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Introduction

ELCOME TO THE WORLD of
WMicrosoft Word 2010. This new Picture

Yourself book from Cengage Learning will
help you use the many and varied features of one

of Microsoft's most popular products—Microsoft
Word, part of the Microsoft Office Suite.

Microsoft Word 2010 is a powerful word processing
program that will take your documents far beyond
what you can produce with a typewriter. Whether
you want to create a simple letter to a friend, pro-
duce a newsletter for a professional organization,
or even write a complicated, multiple-page report
containing graphics and tables with numerical
data, you will find the information that you need
to quickly and easily get the job done in Picture
Yourself Learning Microsoft Word 2010.

This book uses a detailed approach with illustra-
tions of what you will see on your screen, linked
with instructions for the next mouse movements
or keyboard operations to complete your task.
Computer terms and phrases are clearly explained
in non-technical language, and expert tips and
shortcuts help you produce professional-quality
documents.

Picture Yourself Learning Microsoft Word 2010 pro-
vides the tools you need to successfully tackle the
potentially overwhelming challenge of learning to
use Microsoft Word. Whether you are a novice user
or an experienced professional, you will be able to
quickly tap into the program's user-friendly inte-
grated design and feature-rich environment.

Through this book you will learn how to create
documents; however, what you create is totally up
to you—your imagination is the only limit! This
book cannot begin to teach you everything you can
do with Microsoft Word, nor does it give you all the
different ways to accomplish a task. What I have
tried to do is show you the fastest and easiest way
to get started with this fun and exciting program.

This book is divided into four parts. In Part 1, I
show you how to create a basic document. While
it's not the most exciting section of the book, it's
certainly the most practical. Look out after that—
things start to be lots of fun! In Part 2, you work
with longer documents, and in Part 3, you learn
how to enhance the appearance your documents
with columns, tables, and graphics. Part 4 helps
you to improve the quality of your documents and
save you lots of time with Word tools.

Who Should Read This Book?

This book can be used as a learning tool or as a
task reference. The easy-to-follow, highly visual
nature of this book makes it the perfect learning
tool for a beginning computer user as well as those
seasoned computer users who might be new to
Microsoft Word 2010. The only prerequisites are
that you, the reader, know how to log onto
Windows and how to use your mouse.
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In addition, anyone using a software application
always needs an occasional reminder about the
details required to perform a particular task. By
using Picture Yourself Learning Microsoft Word
2010, any level of user can quickly look up instruc-
tions for a task without having to plow through
pages of descriptions.

Added Advice to Make You
a Pro

You'll notice that this book keeps explanations to a
minimum to help you learn faster. Included in the
book are a couple of elements that provide some
additional comments to help you master the pro-
gram, without encumbering your progress through
the steps:

P Tips often offer shortcuts when performing
an action, or a hint about a feature that
might make your work in Word quicker and
easier.

P Notes give you a bit of background or addi-
tional information about a feature, or
advice about how to use the feature in your
day-to-day activities.

I hope you enjoy this book. Picture yourself learn-
ing the fastest and easiest way to use Microsoft
Word 2010.

—Diane Koers
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Part 1

Just the Basics

You are about to embark on a journey into the world of
Microsoft Word 2010. In this life, there are a number of
essential things we need. Air and water certainly fit the
bill, and many of us consider chocolate and true love
right at the top. If you are using a computer, a good
word processing program is essential—and you have it.
Microsoft Word is the most popular word processing
program in the world. It's abundance of features and
ease of use leaves it unmatched. Whether you're making
a grocery list or writing the great American novel, Word
is the program for you. This part of the book explains
the fundamentals of working with Word, and even if you
have worked with other word processing programs, I am
sure you will find Word's ease of use enriching.







Getting Started with

Word

: lICTURE YOURSELF AS A SMALL CHILD looking through a
glass door. The world looks huge when viewed through the perspec-
tive of a toddler, but generally children aren't afraid to explore the
world around them. That's how they learn. In this chapter, you'll begin
exploring the world of Microsoft Word.

Microsoft Word is a powerful word processing program that takes your
documents far beyond what you can produce with a typewriter. Whether
you want to write a simple letter to a friend, produce a newsletter for a
professional organization, or even write a complicated, multiple-page
report containing graphics and tables with numerical data, you can create
it in Word.

If this is your first opportunity to use Microsoft Word, you may be a little
overwhelmed by all the buttons and items on the screen. Just remember
that although Word is a powerful program, it's also very easy to use,
which is why most businesses have adopted it as a company standard.
Don't worry. You'll be creating your first document after just a couple of
mouse clicks.




Opening Word

HOOSE START > All Programs > Whenever you finish working with a specific appli-
‘ Microsoft Office > Microsoft Word 2010. A cation, you exit the program to release the pro-

blank document appears on your screen gram from your computer's memory. Click the File
ready for you to begin entering your data. tab and choose Exit or click the Close button in the

upper right corner of the application window. You
may be prompted to save your file. Click Yes or No
if prompted to save your file.

Create a Desktop Shortcut

To place a Word application icon on your
Windows desktop, right-click the Word icon Ti P
(under the Start > All Programs > Microsoft
Office menu) and choose Send To > Desktop
(create shortcut).

Optionally, click the File tab and choose
Close. The current file closes, but the cur-
rent program remains open.

Exploring the Word Window

ESIGNED TO ADJUST to the way you take a stroll through a Word window and review

work, instead of the traditional Windows some of its elements. These elements are com-

menu bar and standard toolbars, Word mon not only to Word, but also to most Office
uses a Ribbon. Take a look at Figure 1-1, and let's applications.



Chapter 1
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The Ribbon is designed to provide the right tool at the right time.

P Title bar: Across the top you see a title bar
that shows the program title and the docu-
ment title. If you are working with a docu-
ment created in an earlier version of Word,
you may see the words Compatibility Mode
displayed. You'll learn about Compatibility
Mode later in this chapter.

P File tab: Pause your mouse over the icon
on the top-left screen corner. Microsoft calls
this icon the File tab. As you stop your
mouse over it, a description of the File tab

functions appears. The File tab is where you
see the Backstage view and access many
common file functions, such as Open, Save,
and Print.

» Quick Access Toolbar: The Word Quick
Access Toolbar (QAT), which is the only tool-
bar, provides fast and easy access to basic
file functions. Hover your mouse over any
of the four icons above the File tab. By
default, the Quick Access Toolbar functions
include Save, Undo, and Redo. You can click
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the arrow next to the QAT and customize it
to better meet your needs.

» Ribbon: If you hover your mouse over the
Ribbon area containing tabs, which are task-
orientated screens, a description of the fea-
ture appears in an Enhanced ScreenTip. The
tabs are also broken down into subsections
called groups, which break the tasks into
smaller areas. Figure 1-2 shows the Page
Layout tab, which includes the Themes, Page

Tabs Groups

Setup, Page Background, Paragraph, and
Arrange groups. As you click a different tab,
the Ribbon changes to reflect options per-
taining to the selected tab.

Tip

Beginning with Word 2010, you can now
customize the Ribbon. See Chapter 17 for
more information.

File Home Insert Page Layout Reference! Mailings Review Wiew
E- Iy Orientation = ¥= Breaks = ) Watermark = Indent Spacing 3 = -y Bring Forward = |2 Align =
= [a] 13 size = ¥ Line Numbers = | ¥ Page Color = EE Lem:  0* s 32 Before: 0pt . | O Send Backward ~ T3] Group
Themes Margins . Posit Wirag
. - ? EE Columns = b Hyphenation = | [] Page Borders £3 Right: 0" = :: After: 10 pt . s Te _:_u E{; Selection Pane ) Rotate
Themes Page Setup s | Page Background Paragraph Arrange
[F=:s : ! '. : : : : : : C——
|
= (]
b 4
+
(=]
- s
4 | ] | »
Page:10f1 | Words: 0 | [Ene2 e 9m C—0—G
Figure 1-2

Related items appear in groups.
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P Dialog Box Launcher: Many options related dialog box. In Figure 1-3, clicking the
include an icon at the bottom-right edge of Page Layout > Paragraph Dialog Box
the group option. Microsoft calls this the Launcher, displays the Paragraph dialog box.

Dialog Box Launcher, and clicking it opens a

Page Layout References Mailings Review Wiew
Entation ~ *5 Breaks v A) Watermark = Indent Spacing il
v SR v v =l 0° - 4= : - .
£Line Numbers ~ 4 Page Color = leftt 0 v | 4= Before: Dpt * || po L Dlalog Box Launcher
mns * b Hyphenation ~ | (] Page Borders | 2 Right: 0” 3| IS after [10pt =
age Setup «  Page Background Paragraph F
1 . . ¥ 1 ] P T 2 5 P , 1 m " P 3 § & P 1 y
Paragraph ]—- _X

Indents and Spacing | Line and Page Breaks |

opt Line spacing: a:
After: l1opt | Multiple [z] 115 ]
] bon't add space between paragraphs of the same style

a
-

Preview

Figure 1-3
See additional options through
a traditional dialog box.

Tip

Click the Cancel button to close a dialog box without making any changes.



» Galleries: Some Ribbon buttons display a
down arrow, which means there are more
choices available such as on the Insert >
Illustrations > Shapes button. Click the
arrow to display a shapes gallery. See
Figure 1-4. (Click the arrow again to close

the gallery.)

Recently Used Shapes
B\\NOooA1LL>Y6
2N > %

Lines

NN L L2 e g
Rectangles
Oochooonhoo

Basic Shapes
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OO0OANOV ARG (B
5 e

Block Arrows

D RTSELPRIT
€ dvnoD D[R AN
GHa

Equation Shapes

F=R =g

Flowchart
O0<OOoofSeoayu
CUCNRDB X 6 AVED
QBOO

Stars and Banners

gl it S SIS ROROROROR R
RTEW TP

Callouts

DQOOOA@ LA d /5,
¢ ADAD dD

4} News Drawing Canvas

Figure 1-4
A gallery
example.

» Status bar: Along the bottom of the Word
application window you see a status bar
that tells what page of your document you
are on and how many words are in the doc-
ument. You can customize what displays in
the status bar by right-clicking anywhere on
the status bar. The application displays a list
of options in the Customize Status Bar
menu, similar to the one shown in Figure
1-5. Click any option without a checkmark
next to it to activate the feature, or click
any option with a checkmark to deactivate
the feature.

Status bar

|

Customize Status Bar
Formatted Page Number

-

Section
v | Page Number s §
Wertical Page Position

Line Number

o
=9
™

Lolumn

S ke oR

Word Count

Number of Authors Editing
Spelling and Grammar Check
Language

Signatures
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Off
Information Management Policy Off
Permissions Off
Track Changes Off
2| Caps Lock Off
Onvertype Insert
Selection Mode

Macro Recording Mot Recording
Upload Status

Document Updates Available No

Zoom 190%

Zoom Slider

v
v
V| \iew Shorteuts
v
v

Figure 1-5
Display helpful information on the status bar.
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Working with Word Elements includes many items that you'll see only in Word.

. . Let's take a look at Figure 1-6.
In the previous section, you saw elements common

to most Office applications; however, Word

Rulers Insertion point View controls

Qocurment - Microsoft Word

File Home Inse Page Layout References Mailings i ew Wiew o iy
5] coerPage - == ol Bl (S 3 = ] ';'“ B\ Hyperlink ] Header - A 3l Quick Parts = | & Signature Line = JT Equation =
) Blank Page j lﬁ‘ o Ll—‘l) )g “ € A Gookmark o Footer - aﬂWordAn.* 33,0.\& & Time €2 symbol ~
Tabl Picture Clip Shapes SmartArt Chart Screenshot Tt | _ . -
v=f, Pagd Break - Art - . (H) CNyss-reference | (5] Page Number = | poy~ 25 Drop Cap - g Object =
Pagks Tablfs Dlustrations inks Header & Footer Text Symbols
Lu..,/:.,,!...:..,-‘:,‘.‘\....?.,.:,,.1...1,,.5.E
] / \ :
"
E 3
(=]
> ¥
4 | W | |3
Page:1of1 | Words: 0 | |I@M B2 e 190% (=) e —
Figure 1-6
Word screen elements.

» Mouse pointer: The shape of the mouse » Ruler: Use the rulers to measure the docu-
pointer changes as you move it to different ment settings within the page margins.
areas on the screen. (See Chapter 4 for information on setting

margins.)



Display Rulers

Show or hide the rulers by choosing View >
Show > Ruler.

» Document screen: The white area of the
screen is where your typed text appears.

» Insertion point: The blinking vertical line
in the document screen indicates where
text will appear when you begin typing.

» View controls: Buttons on the status bar

show you your document from various per-

spectives. (See Chapter 6 for more about
changing views.)

Selecting Commands with the
Keyboard

Sometimes you don't want to take your hands off
the keyboard to make a choice from the Ribbon.
Fortunately, Word provides easy ways to select

commands using the keyboard instead of the
mouse. Follow these steps to make a keyboard
command selection:

1. If appropriate for the command you intend to
use, place the insertion point in the proper
word, paragraph, or cell.

2. Press Alt on the keyboard. Shortcut letters
and numbers appear on the Ribbon. The let-
ters control Ribbon commands, and the
numbers control Quick Access Toolbar com-
mands. See Figure 1-7.

3. Press a letter to select a tab on the Ribbon;
for example, press N and you see options for
the Insert tab. The application displays the
appropriate (in this example the Insert) tab
and letters for each command on that tab.

4. Press a letter or letters to select a command.
The application displays options for the com-
mand you selected.

Docurmentl - Microsoft Word_-—- E=alon

e | Pag Ref M;mngs 4. - 0
F E‘;
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_) Blank Page L—J e A Bookmark = Footer - Al wordart - [5) Date & Time €2 symbol =
_| 'I'ahle Picture (Iup Shapes SmartArt (hm Sueenshot Ted _
= Page Break f) Cross-reference | [v] Page Number~ | oy~ 25 Drop Cap bgd Object =
Pages Tables Nlustrations Header & Footer Text Symbols
[ ———— 3 | e A ) i R ]
-
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Figure 1-7
Make command selections using the keyboard.
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Exploring the Backstage View

New to Word 2010 is the Backstage view. In older
programs, you might have referred to this as the
File menu in that it contains many file-related
choices, such as Save, Open, or Print. But the
Backstage view is more than just a menu. It's a full

Take a Step Backward

Press the Escape key to revert the keyboard
controls back one step.

information center.
5. Press a letter or use the arrow keys on the key-
board to select an option. If you use the arrow
keys, press the Enter key after making a selec-
tion. The application performs the command
you selected, applying the option you chose.

Take a look at Figure 1-8. With a document open,
in this example a Word file called Surviving a
Recession, you see three columns of information.
The first column is where you see the file com-
mands and represents actions you can select. The
second column currently displays tasks relative to,
Ti p in this case, the file Surviving a Recession. As you
make selections from the first column, the choices
in the second column change. The third column
contains information about the current document,
including the author, the file creation and modifica-
tion dates, file size, and other document properties.

Press F6 to change the focus of the pro-
gram, switching between the document,
the status bar, and the Ribbon.

O EE 7 “Suninang a Receasion - Mi —_— = ﬁﬁl
Home  Dnset  Pageluyout  References  Malings  Review  View (7]

e e . v :
- Information about Surviving a Recession
Swve A5 ¥
CAlser\Daane\Documents\ Surviving a Recessson.docx
5 open
§ o
iz = Permissions
_y;' Ariyane can open, copy, and change any part of this docurnent
Protect o
Recent Document = Froperies
144K
Hew
Prepare for Sharing
Print :j Bedoen shasing this fibe, be pwae that i cantaing:
Check Docurnent properses and authar's name
eck for
Save & Send Tk
Help Related Dates
S i Vark blodif
[ 8] %] There are no previous versions of this file. ate Toda
J L
B et 2 Pr
Mansge " .
Versions =
PRotlated Prople
Lt Modited 8
Fotlated Documents

Figure 1-8
The File Information window.
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Now click the Print option from the first column.
As you see in Figure 1-9, the second column
changes and now displays options related to print-
ing. If you click the Recent option, you see a list of
documents you recently worked with. You can click

any document to open it. See “Opening an Existing
File" file later in this chapter.

Click the File tab to close the Backstage view and
return to your open file.

v
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Figure 1-9
Viewing File Print options.
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th Files

Working w

HENEVER YOU WORK with Word,

Word is creating a file, called a document

file. You can create the file and just throw
it away when you're finished, or you can save it on
a disk drive for future reference.

Saving a File

The first time you save your file, Word prompts you
for a name and a folder in which to save it. Click

the File tab and choose Save or click the Save but-
ton on the Quick Access Toolbar. The Save As dia-
log box appears, as shown in Figure 1-10.

Tip

Optionally, press Ctrl+S to save your file.

=

(W] Microsoft Word | Documents library

Includes: 2 locations

I Favorites

Save As .
j —— Save in folder
O(_)? < » Libraries » Documents » 1ts
= =S
Organize New folder = - @

— Favorite links

Arrange by:  Folder ~

Name Date modified Type g .
B Desktop | ) |~ File name
8 Downloads d J microsoft File folder 4
) Recent Places | | - Monthly Workbooks File folder
| My Stuff : (1 My Data Sources Fill fol A
| My Kindle Content pile folder - File type
4 Libraries | : Outlook Files 3/25, File folder
S Documents . PowerPoints File folder
o) Music PresentationCD
) Pictures @_] 2009 Toyota Camry Vehicle Oyer?
a Videos 9] ABC Time Studies
6] Addresses jprGrd /010741 PM  Microsoft Word D...
& Homegroup partio 2/19/201010:53PM  Microsoft Word D...
¢
File pame: S50 =

Save as type: | Word Document

Authors: Diane s: Add a tag

[7] Save Thumbnail

Figure 1-10

“ Hide Folders Tools

Saving a file for future

Cancel

reference.
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From the Save As dialog box, you enter the follow-
ing information:

» Location: By default, Word saves your files
in your Documents folder. If you want to
save your file in a different folder, use the
Favorite Links pane to navigate to the folder
or disk drive where you want to save the file.

» Name: In the File Name text box, type a
descriptive name for the file. File names can
contain any characters except an asterisk,
slash, backslash, or question mark.

» Type: Word has a specific file type it uses as
a default. Word 2010 and Word 2007 docu-
ments use a .docx file type. Most of the
time you'll want to use the default file type,
but if not, click the Save As Type down
arrow and select a different file type. If
someone who doesn't have Word 2010 or

Word 2007 will be opening your file, you
might consider saving your file in a format
that more closely matches their version,
such as Word 97-2003. Older Word versions
use a .doc file extension.

Click the Save button. Word saves the file in the
location and with the name you specified. After
assigning the file a name and a location, each time
you click the Save button, the saved file is updated
with any changes.

Depending on the file type you chose, Word may
prompt you for additional information. In Figure
1-11, for example, you see a dialog box warning
you of your document features used with Word
2010 that aren't available when saving a file in a
Word XP or 2003 format.

file in one of the new file formats.

Summary

MVicrosof: Word Cornaitan) Checker‘ [ 2 ||

The following features in this document are not supported by earlier
versions of Word, These features may be lost or degraded when you
save this document in an eatlier file format. Click Continue to save the
document. To keep all of your features, click Cancel, and then save the

Occurrences

Effects on text will be removed.

6 A

Check compatibility when saving documents

Figure 1-11
Some Word 2010 features are

[ Continue ] [ Cancel

not available in earlier Word
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Save Often!

Don’t wait until a project is finished to save
it. A good rule of thumb is to save your work
at least every 10 minutes.

Perhaps you want to make some changes to your

file, but you're not sure if you will like the changes.

Or maybe you wrote a proposal to a company, and
you need a similar one for a different company.
One way to work around the changes is to save the

file with a different name or in a different location.

Word then keeps the old version with the original
name or location and keeps the modified file with
a different name or in a different location.

Unique File Names

No two files can have the exact same name
in the exact same folder. You can place
them in different folders, save them as dif-
ferent file types, or vary the name by at
least one character.

To save a revised file without overwriting the origi-
nal file, click the File tab and choose Save As, which
displays the Save As dialog box. From the Save As
dialog box you can enter a new file name, select a
different folder, or choose a different file type.

Creating a New File

As mentioned earlier in this chapter, when you
open Word, a blank document appears. You can
also generate a new document at any time by click-
ing the File tab and choosing New. The application
then displays the New Backstage view, prompting
you for more information. See Figure 1-12. You
click the template you want to use, and then click
the Create button. (Chapter 17 discusses tem-
plates.) By default, Word temporarily names each
new file by the next numerical increment, such as
Document2 or Document3.

Create button

Figure 1-12
Create any number of new files.

Tip

Optionally, press Ctrl+N to create a new
file without opening the Available
Templates window.

15



1. Click the File tab and choose Open. An Open
dialog box similar to the one seen in Figure
1-13 appears.

Opening an Existing File
When you've worked on and saved a file previously,

you can reopen it to review or modify the file.
Following are several ways to open an existing file.

File type arrow

(@9 E I T ) E T

=2

Organize = New folder =+ Al @
(W] Microsoft Word Documents library
Includes: 2 locations
T Favorites Name . Date modified Type Size =
: gmads L PowerPoints 3/13/2010 241 PM  File folder
S Recent Places ). PresentationCD 3/25/2010 8:99 PM  File folder
1 My Stuff () 2009 Toyota Camiry Vehicle Overview 7/3/2009 9:36 AM Microsoft Word D... 15KB
&) ABC Time Studies 2/23/2010801 PM  Microsoft Werd D... 28 KB
=3 Libraries @ Addresses in Word 2/23/2010 741 PM  Microsoft Word D... 14 KB
B D AT B_] Albertsons Letter 2/18/201010:53 PM  Microsoft Word D... 14 KB
o Music 18 Atlantis Water Park 7/23/2008 4:55PM  Microsoft Word 9... 27KB =
) Pictures @ Backstage View 8/15/2009 4:05PM  Microsoft Word D... 470 KB
8 Videos @ Bingo 12/11/200911:00 ...  Microsoft Word D... 68 KB
] Bio 3/18/200911:24 PM  Microsoft Word 9... 24K8
& Fioiriago BMLEASE 3/25/19984:04 PM  Microsoft Word 9... KB
) Braille Course 3/16/20098:48 PM  Microsoft Word 9... 24 KB
Y — ] Business Plan 4/2/201011:31 AM  Microsoft Word D... 29K8
ﬁ 05(C) E] butterflies 8/17/20091:14 PM  Microsoft Word D... 14 KB
(P DVD RW Drive (D:) Megas @ Canadian Geese 2/23/201012:01 PM  Microsoft Word D... 15KB|
g @] Cashew Chicken 2/20/2010 704 PM  Microsoft Word D... 16 KB
@ Network ] CD Labels 5/19/200310:19 AM  Microsoft Word 9... 39K8
1 DIANE @] confidentiality agreement 5/5/20031213PM  Microsoft Word 9... 22KB
1 LOANER [4) CRATE TRAINING 5/25/2008 7:51 PM  Microsoft Werd 9... 20 KB
8] Credit appl 3/25/1998 4:03PM  Microsoft Word 0... 2K8
R PeceEETA ] Declaration of Independence 221/2000 316 PM  Microsoft Word D... 20KB
) Dessert personality test 6/27/20034:14 PM  Microsoft Word9... 26 KB
) Emergency Supplies 27142003141 PM  Microsoft Word 9... 46 KB
) Extreme Home Makeover 6/27/2008 6:04 PM  Microsoft Word 9... 26 KB -
File name: Canadian Geese - |A|I Word Documents b |

Teols - i Open |vl|

Figure 1-13
Open a previously saved file.
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Chapter 1

Getting Started with Word

Tip

Optionally, press Ctrl+O to display the
Open dialog box.

2. If needed, select the appropriate folder from
the Folders pane.

3. Select the file you want to open.

Display Other File Formats

Click the file type arrow to display files saved
in other formats.

4. Click the Open button. The document
appears, ready for you to edit.

Compatibility Mode

If the file you open was created in a previous version of Word, the words Compatibility Mode appear on
the title bar, next to the document name (see Figure 1-14).

Compatibility Mode

[El H9-0|= butterflies [Compaﬁhil&yMude]?_Micmsoﬂ“Tor_trl—
Home Insert Page Layout References Mailings Review View
2 v 2 | . PR — =
L) D Colbriody a1 v AT AT Aav %) 2 UE-CE EE M T | asppcen | assbceoe AaBb
Pa'ste j B[Z|u - abe x, x* w.-A-|EE== = & || TNomal |TNoSpaci. Heading
Clipboard 1% Font Paragraph Styles
@_E B T i e

Figure 1-14
Some Word 2010 functions are not available when working in Compatibility Mode.

17



Converting a Prior Version File
to Word 2010

If you originally created a file in a prior than 2007
version of Microsoft Word, you may find you want
to convert it to a Word 2010 file so you can take
advantage of the great new features provided by
Word 2010. Begin by opening a file created in the
earlier Word version. The application title bar indi-

cates the document is in Compatibility mode. Click

converted version,

["] Do not ask me again about converting documents

the File tab and from the Backstage view Info
screen, choose Convert. Word displays a message
indicating you are about to convert the current
document. (See Figure 1-15.) Click OK. Word
replaces the older version of the document, using
the same name you used for the older version of
the document. If the older version was a Word 97-
2003 or earlier document, Word 2010 changes the
file extension to .docx.

wovos . e

This action will convert the document to the newest file format, The layout of the document may change.

Converting allows you to use all the new Features of Word, This document will be replaced by the

Figure 1-15

Renaming a File

When you first save your file, you're prompted to
name it. But perhaps you didn't give it a name
intuitive enough to know what the file represents.
If you click the File tab, choose the Save As com-
mand, and then save your file with a different
name, you will have both the original file and the
new file. If you just want to rename the existing
file, you can use the Open or Save As dialog boxes.
Follow these steps:

1. With the Word application open, but not the
file you want to rename, click the File tab
and choose Open. The Open dialog box
appears.

18
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Tip

Optionally, click the File tab, choose Save
As, and then proceed using the Save As
dialog box.

2. Locate and click once on the file you want to
rename. Do not double-click the file, as dou-
ble-clicking the file will open it.

3. Choose Organize > Rename (see Figure 1-16).
The original file name becomes highlighted.
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Organize

Organize v New folder

Chapter 1

4 o nents library
= Copy 2 locations
[7] Paste
Unde
Redo soft
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Select all L
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Layout ndle Content
Folder and search options pk Files
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Date modified
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3/25/2010 8:04 PM
3/13/2010 2:41 PM
3/25/2010 8:49 PM

oyota Camry Vehicle Overview 7/3/2009 9:36 AM

2/23/2010 8:01 PM
2/23/2010 7:41 PM
2/19/2010 10:53 PM

Arrange by:  Folder ¥

Type

File folder
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File folder
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File folder

Microsoft Word D...
Microsoft Word D...
Microsoft Word D...
Microsoft Word D...

- A

File name: ABC Time Studies

Save as type: lWord Document

Authors: Diane Koers

Maintain
compatibility with
previous versions of
Word

~ Hide Folders

Tags: Add a tag

[7] Save Thumbnail

Cancel

Figure 1-16
Choose a new file name.

4. Type the new file name and press Enter
when you are finished typing. Word renames
the file.

] 38

5. Click the Cancel button, or press the Escape
key, to close the Open (or Save As) dialog box.
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Deleting a File

Similar to renaming files, you can also use the Open Ti p

or Save As dialog boxes to delete unwanted files.

With Word open, but not the file you want to delete, Alternatively, from the Open or Save As
click the File tab and choose Open or Save As. Either dialog box, click the file you want deleted
the Open or Save As dialog box appears. Locate the and press the Delete key.

file you want to delete and choose Organize >
Delete. A confirmation dialog box appears like the
one shown in Figure 1-17. Choose Yes to delete
the file, and then click the Cancel button (or press
the Escape key) to close the dialog box.

Y 2

"n: Are you sure you want to move this file to the Recycle Bin?
‘3
e ABC Time Studies

= Type: Microsoft Word Document
w L Authors: Diane
< Ah Size: 27.6 KB

Date modified: 2/23/2010 8:01 PM

J [ No Figure 1-17
Delete unwanted files.

Previewing with Live Preview

called Live Preview where you can see effect on your document. If you want a different
how formatting choices look in your doc- look, you simply move your mouse to a different

ument before you actually apply them to the docu- option to view it; effect. Additionally, you can use
ment. By pointing to formatting options with your Live Preview to view tables, shapes, and graphics.

WORD 2010 INCLUDES a feature mouse, such as fonts or styles, you can see the
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Take a look at Figure 1-18, where you see the effect the effect, just click the mouse on the font to actu-
of selecting a different font immediately display on ally apply it to the text.
the Word document heading. If you decide you like

n Home Insert Page Layout References Mailings Review View
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SME 1) Frankin Gothic Medium Cond
© FrankRuehl TN Figure 1-18

Impg :?':;Uzw = Preview how font changes will
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Creating a Word

Document

ICTURE YOURSELF WITH AN IDEA. Ideas begin with an
intention and then progress into a plan. Whether you extend the
idea verbally or though another medium, such as an e-mail or doc-
ument, the plan typically involves developing a topic, transmitting the
idea to a recipient, letting them comprehend and digest the information,
and finally for the recipient to respond.

One of the most popular ways to transmit information is through
Microsoft Word. You begin with a blank document, and then typically
create a piece of writing containing the point you're making about a
topic. And in that writing document, generally, each paragraph is a
group of sentences dealing with one idea related to that topic.

You begin this chapter getting more acquainted with the Word screen,
and then you begin your creation. Along the way, you'll probably make
some mistakes. That's okay because you can edit your document. Editing
and correcting documents are a snap with Word.



Moving Around the Screen

document (see Chapter 1 for a refresher),

you begin typing in a document at the
location of the blinking insertion point (cursor). As
you type a few lines of text, you'll notice that you
don't need to press the Enter key at the end of
each line. The program automatically moves down
(or “wraps”) to the next line for you. Word calls this

O NCE YOU HAVE CREATED a new Word

feature word wrap. You need only to press the
Enter key to start a new paragraph. In Figure 2-1,
you see the text wrapped around to the next line.

To make changes to your document, you'll need to
move the insertion point. Take a look at several
methods Word provides for moving around the
screen.

wait until the situation improves.

Mow is the time for you to tighten up the controls on all your expenses, especially those that are not
crucial to keeping your business going. It certainly is not a good time to indulge in luxury items; that can

Figure 2-1
Word wrap takes care of
adjusting the line for you.

Using Click and Type

You can position the insertion point anywhere on
the document using the Click and Type feature.
Double-click your mouse pointer where you want to
type. Word determines and sets any necessary para-
graph formatting based on where you double-click.
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Tip

The Click and Type feature works only if
you are using Print Layout or the Web
Layout view. Chapter 6 covers the different
Word views.
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Before double-clicking the mouse, pay close atten-
tion to the appearance of the mouse pointer. If
there are lines to the right of the I-beam pointer,
the text you type will flow to the right of the
insertion point. If the lines are to the left, the text
will flow to the left of the insertion point, and if
the lines are below the I-beam, the text will be
centered at the insertion point (see Figure 2-2).

Click and Type insertion point
/

Norw s thee tima for you to Sghten up the controbs on all your ‘wspacially those that are nat
orudial to keeping your business going. It certainly Is not a good time £o indulge in kowury Items; that can
walt until the situation improves.

i

Using the Scroll Bars

The Word document screen includes two scroll
bars; a vertical scroll bar and a horizontal scroll
bar; however, depending on the current view and
the document zoom amount, you may not see the
horizontal scroll bar. Figure 2-3 illustrates a docu-
ment with both scroll bars visible.

Click the arrow at either end of the scroll bar to
move the document up or down in the window, or
click the arrow at either end of the horizontal scroll
bar to move the document left or right. Displaying
text by using the scroll bars does not move the inser-
tion point. You still need to click the mouse wherever
you want to locate the insertion point.

Optionally, drag the scroll box up or down
to quickly move through a document.

|h!m
" Hyphenation = | [] Page Borders 5 Right: 0
Th Page Setup « | Page Background Parsgraph

Aminge

Figure 2-2 P
Using Click and Type.
Wik 0" —— Survnang a ecession - Microsoft word || =& -%
Home Insert Page Layout References Mailings Review View =] E
—} E- Lty Orbentation * =5 Brests = U Watesmark = Indent Spacing 12 asign +
I - EQtine Mumbers = S Page Color = ERLe: 0 a3 Before: 0pt Yy B
i '_‘ MW ™ W columns - : iSamec wpt 22, Selection Fane

Now would be a good time to build on your knowledge and learn new skills regarding
financial aspects of your business. Your customers should be impressed with your prc

This not only will enhance your reputation as an expert, but will also ensure that they
they run into difficulties.

Control Your Expenses

Now is the time for you to tighten up the controls on all your expenses, especmll
crucial to keeping your business going. It certainly is not a good time tlge in lux
wait until the situation improves.

You should also split large expenses int: er ones so that they become more mar

when purchasing inventory, get longer credit periods or better rates by compar

by different suppli

4 v

Page: 1ef2 | Woedi 573 | B HUE 3 m 9% (=

of
=

/ Scroll box
7

/ Horizontal scroll bar

|_— Vertical scroll bar

Figure 2-3

+]

Word document scroll bars.
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Using the Keyboard

As you've seen, you can work on any part of the
document that appears on your screen simply by
clicking the mouse pointer where you want to
work. You can also move around in a Word docu-
ment by pressing the Up, Down, Right, or Left
arrow keys on the keyboard. Each press of the key
moves the insertion point one character or one
line at a time.

There are also a number of shortcut keys designed
to speed up the process of moving around in a
Word document. Table 2-1 illustrates these short-
cut keys.

Using the Go To Command

If you have a lengthy document, use the Go To

command to jump to a specific location in the doc-

ument. Follow these steps:

1. Choose Home > Editing and click the Find
button drop-down arrow.

2. Choose Go To. The Find and Replace dialog
box appears with the Go To tab in front (see
Figure 2-4).

Table 2-1 Shortcut Keys

To Move...

Do This

A word at a time

A paragraph at a time

A full screen up at
a time

A full screen down at
a time

To the beginning of
aline

To the end of a line

To the top of the
document

To the bottom of
the document

To a specified page
number

-9

Enter page number:
11
move forward four items.

| Comment
[Footrote

1| Enter + and - to move relative to the current location, Example: +4 will

26

Press Ctrl+Right arrow
or Ctrl+Left arrow

Press Ctrl+Up arrow
or Ctrl+Down arrow

Press PageUp
Press PageDown

Press Home

Press End

Press Ctrl+Home

Press Ctrl+End

Press Ctrl+G, and
then enter the page
number

Figure 2-4
Quickly locate specific pages
in your document.
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Tip

Two optional methods for displaying the
Go To option are to press the F5 key or
press Ctrl+G.

Editing Text

3. Type the page number you'd like to display
and then click Next, or press the Enter key.
Word displays the specified page with the
insertion point located at the beginning of
the specified page.

you'll probably make a few mistakes in

your document. Or maybe you'll change
your mind about some of the text in the docu-
ment. In a word processing application such as
Word, corrections and changes are easy to make,

U NLESS YOURE A PERFECT TYPIST,

and in some instances, typing errors are even auto-

matically corrected for you.

Adding New Text

When you want to add new text in the document,
place the insertion point where you want to locate
the new text and then begin typing. As you type,
Word inserts the characters and pushes the existing
characters to the right or to the next line if neces-
sary. Notice in the bottom example of Figure 2-5
how the added word “business” is inserted after the
phrase “on all your,” which makes some of the
words in the top line drop down to the second line.

wait until the situation improves.

that can wait until the situation improves.

Mow is the time for you to tighten up the controls on all your expenses, especially those that are not
crucial to keeping your business going. It certainly is not a good time to indulge in luxury items; that can

Mow is the time for you to tighten up the controls on all yourbl.nsinesslemenses, especially those that
are not crucial to keeping your business going. Itcertainly is not a good time to indulge in luxury items;

Figure 2-5
Insert additional text wherever

you want.
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Overstrike Mode

If you notice the existing text doesn't move
over, but seems to disappear, you may have
accidentally pressed the Insert key, which
takes you out of Insert mode and into
Overtype mode. Press the Insert key to return
to Insert mode.

Which Key Is the Backspace?

On most keyboards, the Backspace key shows
a left-pointing arrow, which makes it an easy
way to remember which direction the
Backspace key deletes.

Deleting Existing Text

You can delete unwanted text one character, word,
or paragraph at a time. Two common keys used to
delete text are the Backspace and Delete keys.
Pressing the Backspace key deletes one character at

a time to the left of the insertion point, while press-

ing the Delete key deletes one character at a time
to the right of the insertion point. In Figure 2-6, in
the bottom example, the word “non-essential” was
deleted by pressing the Delete key repeatedly until
the word disappeared.

Optionally, make a selection in your document and
press either the Backspace or Delete key to delete
the selection. See the next section for more on
selecting text.

Selecting Text

Before you can move, copy, delete, or change the
formatting or placement of existing text, you must
first select the text you want to edit. When text is
selected, or highlighted, it appears on your screen
showing through a colored (typically blue) shad-
ing. Word allows you to select contiguous or non-
contiguous text for editing. The following list
shows different selection techniques:

luxury items that can wait until the situation improves.

that can wait until the situation improves.

Now is the time for you to tighten up the controls on all your business expenses, espedially those that
are not crucial to keeping your business going. It certainly is not a good time to indulge in non-essential

Now is the time for you to tighten up the controls on all your business expenses, especially those that
are not crucial to keeping your business going. Itcertainly is not a good time to indulge idhmxyitems

Figure 2-6
Deleting unwanted characters.
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P To select a single word, double-click the

word. Ti p

» To select a sentence, hold down the Ctrl

key and click anywhere in the sentence Another way to select the entire docu-
(see Figure 2-7). ment is choose Home > Editing >

Select > Select All.

| Selected word

—

Surviving a Recession

Here are a few things that you can do to stay ah —_ Selected sentence

small business.

arecession and maintain the success of your

Improve Customer Service. Make sure that each and er gets special treatment and leaves
your store or office satisfied elivered much more than what was expected. Your
employees should also understand that tough times require a gentler touch and your customers need to
be treated as VIPs nowmore than ever. Since all your competitors may be selling the same products
that you are, it will be your satisfied customers who will not only bring in repeat business, but also new
customers. .
Figure 2-7
Improve Your Knowledge and Skills. Now would be a good time to build on your knowledge and learn .
new skills regarding the technical and financial aspects of your business. Your customers should be SeleCtlng text to make

impressed with your product knowledge. additional Changes.
P To select an entire paragraph, triple-click
anywhere in the paragraph (see Figure 2-8).

» To select an entire document, hold down
the Ctrl key and press the letter A.

Surviving a Recession

Here are a few things that you can do to stay ahead during a recession and maintain the success of your
small business.

Improve Customer Service. Make sure that each and every cust gets special t and leaves
your store or office satisfied that you have delivered much more than what was expected. Your
employees should also understand that tough times require a gentler touch and your customers need to
be treated as VIPs now more than ever. Since all your competitors may be selling the same products
that you are, it will be your satisfied customers who will not only bring in repeat business, but also new
customers.

Improve Your Knowledge and Skills. Now would be a good time to build on your knowledge and learn F. 2 8
new skills regarding the technical and financial aspects of your business. Your customers should be lgure

impressed with your product knowledge. Select an entire paragraph or
This not only will enhance your reputation as an expert, but will also ensure that they come to you if the entire document.
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» To select a single line of text, click once in » To select non-contiguous text areas, select

the left margin with the mouse arrow
pointing to the line you want selected.

» To select a contiguous text area, click at the
beginning of the text you want selected,
and then hold down the Shift key and click
at the end of the text you want selected.

Optionally, click and drag the mouse over Tip

the first area you want selected, then hold
down the Ctrl key and use the preceding
techniques for each additional text area you
want included (see Figure 2-9).

the text you want to select.

To deselect text, click once anywhere in
the document.

Surviving a Recession

Here are a few things that you can do to stay ahead during a recession and maintain the success of your
small business.

Improve Customer Service. Make sure that each and every customer gets special treatment and leaves
your store or office satisfied that you have delivered much more than what was expected. Your
employees should also understand that tough times require a gentler touch and your customers need to
be treated as VIPs nowmore than ever. Since all your competitors may be selling the same products
that you are, it will be your satisfied customers who will not only bring in repeat business, but also new
customers.

Improve Your Knowledge and Skills. Now would be a good time to build on your knowledge and learn
new skills regarding the technical and financial aspects of your business. Your customers should be
impressed with your product knowledge.

This not only will enhance your reputation as an expert, but will also ensure that they come to you if

Figure 2-9

Selecting non-contiguous
areas in which to make
changes.

Discovering AutoCorrect To take full advantage of the automatic correction

Word includes a fabulous feature that makes us
look like better typists than we really are! The fea-
ture is called AutoCorrect, and, in many cases, if
you mistype a word or forget to capitalize a sen-

feature, you have to understand how it works and
how to customize it to better fit your needs. Follow
these steps to review the AutoCorrect options:

tence, Word automatically corrects it. Or if you type 1. Click the File tab and choose Options, which

something like “(c),” Word automatically under-
stands that what you really want is a copyright
symbol, and it changes the (c) to ©.

displays the Word Options dialog box shown
in Figure 2-10.

2. On the left side, choose Proofing.
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General Agcl
2:, Change how Word corrects and formats your text.
Display '
l Procfing | AutoCorrect options
Save Change how Word corrects and formats text a3 you type: | AutoComect Options...
Language
Wh spelling in Office programs
Advanced
[¥] Ignore words in LIPPERCASE
Customize Ribbon [¥] lgnore words that contain numbers
Quick Access Toolbar I% Ignore Internet and file addresses
[#] Flag repeated words
Add-Ins [ Enforce accented uppercase in French
Trust Center [7] Suggest from main dictionary only

Gustom Dictionaries...

French modes: "I'radiunnal and new !D:IIHS;E
Spanish modes: | Tuteo verb forms only lz'

Wh ing spelling and gr in Word

[¥] Check spelling 35 you type

[¥] Use coptextual speliing

[¥] Mark grammar errors as you type
[¥] Check grammar with spelling
[¥] show readability statistics

‘Wiriting Style: | Grammar Only E

Exceptionsfor: | ] Sunviving 3 Recession E

[ Hide spelling errors in this document only

Figure 2-10
Setting Word options.

Tip

. . (7] Show AutoCorrect Options buttons
See Chap?er 17 for information on other Rt T i Ok
Word options. Capitalize first letter of sentences
Capitalize first letter of table cells
[V] Capitalize names of days
[V] Correct accidental usage of cAPS LOCK key
3. Click AutoCorrect Options. The AutoCorrect FiopHai Lt e VOU i
Options dialog box opens (see Figure 2-11). Boplace:  Whh: @Plaintext © Formatted text
On the AutoCorrect tab, you see the options fiwye
Word automatically corrects for you. [ Isboratory

| learning
| let’s
lets him

But Wait! There’s More!

[V] Automatically use suggestions from the spelling checker

Scroll down the list to see hundreds of prede-
fined AutoCorrect words and symbols.

Figure 2-11
Create your own AutoCorrect items.

31



4. If you want to add your own common mis-
spellings to the list, type your common mis-
take in the Replace text box and then type
the correction in the With box. Click the Add
button to add the correction to the list.

Create Custom Entries

If you frequently use a lot of complex words,
such as chemical names or medical terms,
enter an abbreviation for the term in the
Replace box and put the complete term in
the With box. After adding the term, when
you need to add the term in your document,
you need only type the abbreviation followed
by a space, a period, or other character. For
example, enter hctz to have Word replace it
with Hydrochlorothiazide.

5. Click OK twice to close both the AutoCorrect
and the Word Options dialog boxes.

Changing Text Case

As you just discovered, Word automatically corrects
many text case errors. For example, if you type
“SPringtime,” Word automatically changes it to
“Springtime.” If, however, you type the entire word
in uppercase (“SPRINGTIME"), you can quickly
change it to “Springtime” or “springtime.” You can
apply a text case change to a word, a phrase, or any
amount of selected text. Just follow these steps:

1. Select the text you want to change. The text
becomes highlighted.

2. Click Home > Font > Change Case. A drop-

down list of options appears, as shown in
Figure 2-12.
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“ Home Insert Page Layout References Mailings

N ®  Caibrigody) - 11~ A A" [Aac] @ ==
X3 =
Paste Sentence case.

g B 7 U-aex x

Clipboard Font lowercase |

e UPPERCASE
] s : : ; i
Lapitalize Each Word

"‘ tOGGLE cASE

Figure 2-12
Quickly switch from lower- to uppercase lettering.

3. Select an option from the drop-down list.

Tip

Optionally, make a text selection and
press Shift+F3. Each time you press
Shift+F3, a different case option applies.

Adding Special Symbols

You may think the only characters you can type
into a Word document are those that appear on
your keyboard. That's just not the case. You can
add many different special characters, such as the
trademark symbol, diacritical marks, Greek letters,
smiley faces, or foreign currency symbols.

Choose Insert > Symbols > Symbol. A list of 20 dif-
ferent symbols appears. If you want to use one of
those symbols, just click it and Word inserts it into
your document. But those 20 symbols are not the
only ones you can insert. From the Symbol menu,
choose More Symbols and the Symbol dialog box
shown in Figure 2-13 appears.
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<tk
@ &
2P

%[ d|=|D
FEIEE)
RIRIGIE
elon [
ABREER
® % EE

Y -

Becertly used symbols: S o .
(e|e|¥[ofo|™|t]]<|2|+[x]|=|u|alp]
Wingdngs: 32 Character code: |32 from: | Symbal (decimal) [ ]
utoCorect... | [ ShortcutKey... | Shesteut key:

oo ]

Figure 2-13
Insert special characters into your document.

Different fonts display different symbols. If you
don't see the symbol you want, select a different
font from the Font drop-down list. For a large vari-
ety of unusual characters, look at the Wingdings
fonts. Additional special characters are available on
the Special Characters tab.

When you find the symbol you want, click Insert.
Word inserts the symbol into the document. Click
the Close button when you are finished.

Creating Equations

If you write technical papers or scientific journals
that need the use of equations, Word has a built-in
support tool for writing and editing equations. The
tool is designed so that when you type the basic
equation, Word automatically converts it into a
professionally formatted equation.

Not all equations require the use of the equation
tool. For example, to show the makeup of water,
you would simply type H20, but then format the 2
as subscript by selecting it, and choosing Home >
Font > Subscript, making the formula read H,0.
Another example of using regular text formatting
is E = mc2. But what if you wanted to insert the
quadratic formula?

You would simply choose Insert > Symbol >
Equation which displays a gallery of predefined
equations. Hover your mouse over each formula to
see its description, then choose the predefined
equation you want, which in this example, is for
the quadratic formula shown in Figure 2-14. Word
inserts the equation as an object in your docu-
ment. If you need to change a variable in the equa-
tion, simply click inside the equation box and
make the necessary change.
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Taylor Expansion

x a2 xB
9”=1+E+§+E+'", —w<x<w
d Trig Identity 1
N . 1 1
sing + sinf = 2sin(a + ) cos (@ F 6) -

2 40 More Equations from Office.com
TU  Insert New Equation

Figure 2-14
Using a predefined equation.

Tip

To delete an equation, select the entire equation and press the Delete key.

That's easy if you happen to be lucky enough to 1. Choose Insert > Symbol > Equation > Insert
need one of the predefined equations. That's New Equation. An equation box with the
probably not going to happen though. . .. So for words “Type equation here” appears on the
those times when the formula is more complex, screen. You also see the Equation Tools >
such as for Newton's Law of Universal Gravitation, Design tab, which contains a number of tools
r,- ™22 follow these steps to use the Word for creating equations. (See Figure 2-15.)

Equation Editor:
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Equation Tools

References Mailings Review | Design

s e L, 2

Home Insert Page Layout
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E uatuon i Fraction Script Radical Integral Large  Bracket Function Accent Limit and Operator Matric
aton L omuires | <) 2] B E]EFIE][R][E] V]3] | Fracton st madiat gt tage _orces runchon acen i ana operaa

(O 0 g Jfim

Tools Symbaols Struckures
”_1_2 -|---1---|---z---|---3‘--|---4---|‘--s---|---s---A--»?--»|@
£ T T T T g T g T g v g T
-

|I']

A I Type equation here. ‘ ' |

Figure 2-15
The Equation Tools > Design tab.

in the equation. Type the characters you need
in the appropriate box. In Figure 2-16, I need
to type the letter “F” in the first box and the
g" in the smaller subscript box.

2. Begin by choosing the equation element you
need first. In this example, I need a character
with a subscript, so I choose Equation Tools >
Design > Structures > Script > Subscript. letter
Word places a small, dotted placeholder box

Equation Tools.

Home Insert Page Layout References Mallings Review Design

[ Y s 4
Grawint =] FEMEEMEE - ,—‘5 el I % oy e G ojm A [i]
Equtﬂon abe Normal Test E . E . . - . El . Fradlons Sulpl: Radla! Integral Llarge  Bracket Function Accent Limit and Operahnr Mal.rlx

- Log~

- Operator> - v

Tools

Symbols

and

i

[

T

J il i il Ho

Common Subscripts and Superscripts

Xyt g-iue %2 '1\}'

E[%_
|

Figure 2-16
Beginning the equation.
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3. Continue adding symbols, text, or structures
as needed. For this example, I'll need to type
an equals sign symbol, then a character (the
letter G) followed by the fraction symbol. (I
need a Stacked Fraction.) On the top of the
fraction, I need two subscript structures, and
on the denominator portion, I need a super-
script structure. Now my formula structure
looks as you see in Figure 2-17.

F ! ation Tools - .

2 View Design

X X n J-x n, i as
y ex . & (O w6 g
Fraction Script Radical Integral Large  Bracket Function Accent|

s Operator- - - -
Structures

B T S | A T N |

4. Finally, type the desired characters in the
placeholder boxes. See Figure 2-18 for the
finished equation.

1] m m,
E

g=G 7]

Figure 2-18
The finished equation.

Save Your Equations

You can add your own equations to the
Equation Gallery. Select the equation you
want to add, then choose Equation Tools >
Design > Tools > Save Selection to Equation
Gallery. In the Create New Building Block dia-
log box, enter a name for the equation and
click OK. When you exit Word, choose Save to
keep the Equation.

Figure 2-17
Placeholders in the equation.
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Moving and Copying Text

RD PROVIDES A NUMBER of differ-
Weont methods with which you can copy and
move text. Moving or copying text usually

involves the Windows Clipboard, which temporarily
holds text you place on it. You use the Clipboard fea-
ture to move or copy text from one place to another,

thereby avoiding the need to retype it.

Moving Text

When you want to remove text from one place and
put it into another location, you cut and paste the
text. With Cut and Paste, Word deletes the selected
text, holds it, and then places it into a new loca-
tion. Just follow these steps:

1. Select to highlight the text you want to move.

2. Choose Home > Clipboard > Cut. The text
disappears from the document, but Word
stores it on the Windows Clipboard.

Tip

Optionally, press Ctrl+X or right-click and
choose Cut, which also moves the selected
text to the Clipboard.

3. Click the mouse where you want to place the
text. The blinking insertion point appears at
the new location.

4. Choose Home > Clipboard > Paste, or press
Ctrl+V. Word places the text at the new loca-
tion. In Figure 2-19, the highlighted para-
graph was originally the first paragraph, but
through cutting and pasting, it is now the
second paragraph.

37



Paste Cut Copy

Surviving a Recession - chmsoﬂw
Page Layout References Mailings Review Wiew o i

= m v || == .hm A 24 Find ~
% B AN A D ECECE FEN T | sebced| assbeede AaBbCi AaBbCe % e
— _ ac
P‘_"e ) B T U-abe x, x| -%-A-~ EEEE 15 | &~ - TNormal | %Mo Spaci.. Headingl Heading2 _ g:‘;:‘,ﬂf R Select~
Clipboard = Font M Paragraph T Styles ) Editing
. S O T O T, e R S O . =
-

Surviving a Recession

Improve Customer Service. Make sure that each and every customer gets special treatment and leaves
your store or office satisfied that you have delivered much more than what was expected. Your
employees should also understand that tough times require a gentler touch and your customers need to
be treated as VIPs nowmore than ever. Since all your competitors may be selling the same products

: that you are, it will be your satisfied customers who will not only bring in repeat business, but also new
il customers.

Here are a few things that you can do to stay ahead during a recession and maintain the success of your

small business.
B (Cty ~

Improve Your Knowledge and Skills. Now would be a good time to build on your knowledge and learn
new skills regarding the technical and financial aspects of your business. Your customers should be

g impressed with your product knowledge. hd
: This not only will enhance your reputation as an expert, but will also ensure that they come to you if :
14 { m ] »

Page:10f2 | Words: 23/573 | <& | |EnE 2 = 130% (=) J {+)

Figure 2-19
Save typing and editing time with Cut and Paste.

Source: Microsoft Word Document

Paste Without Formatting iy
. Ofuts:  [woltvodbocmet bt +| L1owln eskon
If you want to paste the text without the for- Y o —
matting, instead of clicking the Paste button Unfcrmatied Unicode Text
directly, click the arrow beneath the Paste i
button and choose Paste Special. From the o
Paste Special dialog box (see Figure 2-20), 2 Insertsthe contents of the Clpboard as text wihout any formatting.
(e ]

Figure 2-20
Paste without any formatting included.
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Copymg Text 3. Click the mouse where you want to place the
text. The blinking insertion point appears at

The Copy and Paste features leave the selected text the new location.

at its existing location and duplicate it into a new

location. Working similarly to the Cut and Paste 4
functions, Copy and Paste use the Windows

Clipboard to temporarily store the text. Use the fol-

lowing steps to copy text to a new location:

. Choose Home > Clipboard > Paste, or press
Ctrl+V. Word places the text at the new loca-
tion (see Figure 2-21). Notice that the second
paragraph is repeated as the fourth paragraph.

1. Select to highlight the text you want to
duplicate.

Tip

2. Choose Home > Clipboard > Copy or right-
click and choose Copy. The text remains in
the document, but Word also stores it on the
Windows Clipboard.

When you paste text, you may see a small
icon, called a Paste Options button, appear
to the right of the pasted or moved text.
See the section “Understanding Paste
Options” later in this chapter.

Tip

Optionally, press Ctrl+C to copy selected
text to the Clipboard.
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small business.

= Improve Customer Service. Make sure that each and every gets special and leaves

2 your store or office satisfied that you have delivered much more than what was expected. Your
employees should also understand that tough times require a gentler touch and your customers need to
be treated as VIPs now more than ever, Since all your competitors may be selling the same products
that you are, it will be your satisfied customers who will not only bring in repeat business, but also new
Customers.

Improve Your Knowledge and Skills. Now would be a good time to build on your knowledge and learn
new skills regarding the technical and fi ial aspects of your business. Your customers should be
impressed with your product knowledge.

Improve Customer Service. Make sure that each and every gets special and leaves
your store or office satisfied that you have delivered much more than what was expected. Your
ployees should also unds i that tough times require a gentler touch and your customers need to

be treated as VIPs nowmore than ever. Since all your competitors may be selling the same products
that you are, it will be your satisfied customers who will not only bring in repeat business, but also new
customers.

8 (cety -
This not only will enhance your reputation as an expert, but will also ensure that they come to you if

they run into difficulties.

-4

Figure 2-21
Duplicate text without
retyping.
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Using Drag and Drop

Another, sometimes faster, method to move text
from one location to another is to use the drag-
and-drop editing function. The drag-and-drop fea-
ture works best for moving a relatively small
amount of text a short distance. The following
steps show you how to use drag and drop.

1. Select the text you want to move.

2. Position the mouse pointer on top of the

highlighted text. The mouse arrow should
point to the left.

. Hold down the mouse button and drag the

mouse pointer to the desired location. As
you drag, a small box appears at the bottom
of the mouse arrow and a gray line indicates
the text position (see Figure 2-22).

Tip

To copy text instead of moving it, hold
down the Ctrl key before dragging the
selected text. Then release the mouse but-
ton before releasing the Ctrl key.

Copy Between Documents

If you want to move text from one document
to another, open both documents and dis-
play them side by side by choosing View >
Window > View Side by Side. Then highlight
and drag the desired text from one docu-
ment window to another (see Figure 2-23).
Hold down the Ctrl key if you want to copy

4. Release the mouse button to finish the text

the text to the second document.

move.

Surviving a Recession

Here are a few things that you can do to st a recession and maintain the success of your

small business.

' prove Customer Service. Make sure that each and every customer gets special treatment and leaves
v%lr store or office satisfied that you have delivered much more than what was expected. Your
employees should also understand that tough times require a gentler touch and your customers need to
be treated as VIPs now more than ever. Since all your competitors may be selling the same products
that you are, it will be your satisfied customers who will not only bring in repeat business, but also new
customers.

Improve Your Knowledge and Skills. Now would be a good time to build on your knowledge and learn
new skills regarding the technical and financial aspects of your business. Your customers should be
impressed with your product knowledge.

Improve Customer Service. Make sure that each and every customer gets special treatment and leaves
wour store or office satisfied that vou have delivered much more than what was exnected. Your

| New position for text

Figure 2-22
Select and drag text to a new

location.
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Figure 2-23
Move or copy text easily
between documents.

« 0.4

Understanding Paste Options

By default, when you paste text, Word includes any
formatting contained in the original text along
with the text. For example, if the original text is
underlined, the pasted text is underlined as well.

If the pasted text is a different font, size, or style
than the text near where you pasted, you'll see the
Paste Options button, which provides the option to
paste text with or without formatting. (You'll learn
more about formatting in Chapter 3.) Click the
arrow next to the Paste Options button, as shown
in Figure 2-24, which displays the Paste Option
Gallery and choose from the available choices:

» Keep Source Formatting: Leaves the pasted
text formatted the same as the original text.

P Match Destination Formatting: Modifies
the pasted text so it's formatted to match
the closest existing text.

P Keep Text Only: Modifies the pasted text
with the default document font.

Surviving a Recession

Here are a few things that you can do to stay ahead during a recession
small business.

Surviving a Recession

% (cor)
Improve Customer Service. Mak: paste :

your store or office satisfied thal 75/ + A much more than
employees should also understa require a gentler
be treated as VIPs nowmore than ever. Since all your competitors may|
that you are, it will be your satisfied customers who will not only bring

every customer gy

Set Default Paste...

customers.
Figure 2-24
Select paste options.
Display Paste Options

After using the Ctrl+V shortcut to paste your
text, just press the Ctrl key one more time to
drop the new Paste Options gallery and
change to a different Paste option.
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Using Undo and Repeat

you really don't want to make that change after

all, use Word'’s Undo function. You can use
Undo to restore text that you deleted, to delete
text you just typed, or to reverse a recently taken
action. Word keeps track of several steps you've
recently taken, so you can also undo your actions
back several steps if you prefer.

I F YOU MAKE A CHANGE and then decide

Cannot Undo a Save Command

Be aware that once you save your docu-
ment, you cannot use Undo to “unsave” it.
Also, if you close the document, when you
reopen it, you cannot undo changes made
in your previous editing session.

» To reverse the last action you took, click the
Undo button on the Quick Access Toolbar.

» To repeat a previous action, click the Repeat
button on the Quick Access Toolbar. If you
just used the Undo button, the repeat but-
ton allows you to undo the previous Undo
action.

» To undo multiple actions at once, click the
arrow next to the Undo button and choose
how far back you want to reverse your
actions (see Figure 2-25).
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Figure 2-25
If you make a mis-
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Creating a Word Document

Displaying Non-Printing Symbols

O ASSIST YOU IN EDITING a document,

Word can display hidden symbols it uses to

indicate spaces, tabs, and hard returns, which
are those created when you press the Enter key.
These symbols do not print, but you can display
them on your screen.

Choose Home > Paragraph > Show/Hide. As shown
in Figure 2-26, you see the paragraph symbol
where a paragraph ends, and you see dots that rep-
resent spaces and arrows that represent tabs. To
turn off the display of hidden characters, click the
Show/Hide button again.

Wl id 7~ 0 [® — Survning s Recession - McrosoftWord — [N
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|| Surviving-a-Recessiond -
Here-are-a-few-things-thatyou-can-do-to-stay-ahead-during-a-recession-and thesuccess of-your

smallbusiness.

5 * -+ Improve-Customer-Servicey
* = Imp yourk ledge-and-skills§
* + ControlYourExpenses
* = Start-Accepting Payments: by-Credit-Card
* = Lower Your-Profit-Margins¥
* =+ Use'the-Power of the-Internet
* =+ Motivate Your-Staffy

Improve-Customer-Service.- Y

Make-sure-that-each-and-every customer-gets-special- treatment-and-leaves-your store-or-office-satisfied-
thatyou-have delivered -much: more-thanwhat-was expected.- Youremployees-should-alsorunderstand-
thattough-times-require-a-gentler-touch-and-your-customers-need-to-be-treated-as-VIPs- now-more-than-
ever.-Since-allyour-competitors-may-be-sellingthe-same- products-that-you-are, itwill- be-your-satisfied-

Figure 2-26

swhowilknotonlebringinrepeat-t but-alsonew 1 :
; P O G WY T . Viewing non-printing Word
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symbols.

Tip

Press Ctrl+Shift+* (asterisk) to display or hide the non-printing symbols.
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Making a Word Document

Look Good

ICTURE YOURSELF GOING for an important job interview. You
need to make a good impression, so you want to look your best. You
make sure your clothes are clean and coordinated, your hair is
combed, and your shoes are shined. You put on your best smile, assemble
your thoughts, and go forward into the interview.

When you create a Word document, especially one that others review, you
want it to look its best. Besides making sure you've dotted all the Is and
crossed all the Ts, the document should have a clean, consistent, well-
defined appearance. You use Word's formatting features when modifying
your document's appearance.



Selecting Text Attributes

HEN YOU SPEAK, the tone of your
Wvoice conveys how you feel. You can con-

vey your enthusiasm (or lack of it), be
friendly, or be sarcastic. In a similar way, fonts,
which are families of design styles for the num-
bers, letters, and symbols that make up text, can
provide additional information to the reader. Fonts
can, for example, make your document appear
mature and businesslike or young and casual.

Choosing a suitable font size can make a document
easier to read. Other text attributes you might use
to set the document tone include style settings,
such as bold, underline, italics, or even color.

For many text attributes, Word offers a chance to
“try before you buy” with its Live Preview feature.
By pointing to various formatting choices, you can
see the effect the option has on your document
before you actually choose the format option. If
you like it, you can simply click your mouse to
choose the option. For example, if you pause your
mouse over a font choice, the text appears dese-
lected (it isn't) and displays with the font you are
pointing to. Live Preview works with most font and
paragraph formatting choices as well as styles and
picture formatting changes.

Tip

If you don't like the Live Preview option,
you can turn it off. Click the File tab and
choose Options. Click General and remove
the check mark from Enable Live Preview.
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Choosing a Font

In addition to the many fonts you already have on
your machine, Word comes with additional fonts.
The default font used with Word 2010 is called
Calibri. Fonts generally fall into two different cate-
gories: serif and sans serif. Serif fonts usually have
details on the ends of some of the strokes that
make up letters and symbols. A font that has serifs
is called a serif font and a font without serifs is
called sans-serif, from the French word sans,
meaning “without.”

Changing fonts is a very simple process. Select the
text you want to modify and choose Home > Font,
and from the Font drop-down list select the font
you want to use (see Figure 3-1).
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Chapter 3

Start Typing the Font Name

If you know the font name you want, you
can quickly jump to that font by typing the
first few characters of the font name. For
example, if you want a Tahoma font, from
the font list, type Ta, or for Arial, type Ari.

Selecting a Font Size

You can use any size for any font. Font sizes are
measured in points, where a point is approximately
1/72 of an inch tall. Therefore, a 72-point font is
approximately 1 inch tall.

Select the text you want to format and then choose
Home > Font. Click the Font Size drop-down list
arrow. You see a drop-down list of available sizes
similar to those shown in Figure 3-2. Choose the
size you want from the drop-down list, or type
your own measurement in the Font Size box. While
you can enter a value between 1 and 1638, don't
expect to be able to read a 1-point font, and a
character as large as 1638 points won't even begin
to fit on a standard page!

Optionally, you can click the Grow Font or Shrink

Font button to increase or decrease your font size.
Figure 3-2 illustrates a document with a title font
size of 24 points.

Tip

The keyboard shortcut for Grow Font is
Ctrl+> and for Shrink Font it's Ctrl+<.
(Hold down the Shift key to access the
> or < key.)

Applying Formatting Attributes

Applying formatting attributes such as bold, italic, or
underline calls attention to particular parts of your
text. Additionally, you can assign a superscript or
subscript notation to any text that makes it appear
above or below the standard text, such as a copyright
or trademark symbol. You can easily access these
choices and others with the Home tab of the Ribbon.

Select the text you want modified and from the
Home tab (see the Font group shown in Figure 3-3)
choose the attribute you want to apply.

iew

—=@— Shrink font

small business.

Improve Customer Service

ThHormal | THo Spaci.

e W AT | apnconc| assboe AaBbC: AaBbCc .

Heading 1

VIVING A RECESSION

Here are a few things that you can do to stay ahead during a recession and maintain the success of your

% ¥ Find =
25 Replace

Change
® Shes- | g Selets

=—— Grow font

~— Font size

Figure 3-2
Changing font sizes.
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Bold Italic Underline Strikethrough

.

Superscript

Clipboard & Font

Figure 3-3
Applying special text attributes.

Formatting Shortcut Keys

Some formatting shortcuts include Ctrl+B for
bold, Ctrl+I for italic, and Ctrl+U for a single
underline.

If you want your text underlined, you can click the
down arrow next to the Underline button and
select an underline style and color from the drop-
down list shown in Figure 3-4.

) “ Calibri(Body) ~* 11 ~ A A"  Aav &
> =3

Page Layout References
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] S : 2

i More Underlines...
il & Underline Color >

Figure 3-4
Choosing an underline style.
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Tip

Choosing More Underlines displays the
Font dialog box where you can select even
more underline styles.

Adding Color

Another way to add impact to your document is by
adding color to your text. Color becomes very
effective when printing to a color printer or view-
ing your document on screen. Follow these steps
to apply color to your text:

1. Select the text you want formatted.

2. Choose Home > Font > Font Color, or if you
want to select a specific color, click the
down arrow next to Font Color and make a
choice from the resulting gallery, as shown
in Figure 3-5.
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Here are a few things that you can do to stay ahead during a recession and ma

Figure 3-5
Add WOW to a document with
color.

Polish Your Documents

Do you notice how the gallery colors are
grouped together in themes? Office docu-
ment themes, available in Word, Excel, and
PowerPoint, contain colors, fonts, and other
formatting options, all designed to give
your documents a polished, professional
appearance. See “Working with Themes”
later in this chapter.

Highlighting Text

You can highlight text in your document in the
same manner you highlight text with a marker in a
book. You can even choose the color of highlighter
you want to use. While on a monitor or with a
color printer, you see the highlight color, on a
black and white printer, highlighting prints as gray
shading over the text. Highlighting calls attention
to specific areas of your document.

Select the text you want to format with highlighting
and then choose Home > Font > Text Highlight
Color, or if you want to select a specific color, click
the down arrow next to Text Highlight Color and

make a choice from the resulting gallery. Word
deselects the text and applies the highlighting.
Figure 3-6 shows text with pink highlighting.
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Improve Your Knowledge a
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"|  impressed with your product knowledge.
Make sure that each and every customer gets spe
that vou have delivered much more than what w:

Figure 3-6
Call attention to special areas with highlighting.

Tip

To remove highlighting, choose
No Color from the available highlight
color selections.
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Adding Text Effects

New to Word 2010, you find the ability to add
spectacular special effects to your text. With just a
few mouse clicks, your text can illustrate shadows,
glows, reflections, bevels and many other great for-
matting features.

Select the text you want to work with, and then
choose Home > Font > Text Effects. A gallery of
text effects appears as you see in Figure 3-7. Select
the effect you want, or click one of the options at
the bottom for even more text enhancements.

Tip

Using the Mini Toolbar

Word (along with Excel and PowerPoint) contains a
semitransparent Mini Toolbar designed to provide
quick access to many text and paragraph formatting
features so you don't have to move your mouse so
far to select the commands from the Ribbon.

The Mini Toolbar appears whenever you select some
text. As your mouse points to the selected text, the
transparent toolbar appears. As you move your
mouse pointer so it rests on top of the toolbar, the
Mini Toolbar appears in full opacity (see Figure 3-8).

If you are working in Compatibility Mode, the Text Effects option is not available.
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Imlarcwe Customer Service. .
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Make sure that each and every customer gets special treatment a
that you have delivered much more than what was expected. You

that tough times require a gentler touch and your customers need

ever. Since all your competitors may be selling the same products

Using the Font Dialog Box

Another way to apply formatting to your selected
text is through the Font dialog box, where you
can make all your font choices via a single box.
Also, you'll find that the Font dialog box offers

Figure 3-8
Save mouse movement by using the Mini Toolbar.

Available choices on the Mini Toolbar include the

following: additional attribute options not available on the
Ribbon. Use the following steps to work with the
» Font Font dialog box:
» Font Size
1. Select th f .
> Grow Text Select the text you want formatted
» Shrink Text 2. From the Home tab, click the Fonts group

Dialog Box Launcher or press Ctrl+Shift+F.

You see the Font dialog box displayed in
» Decrease Indent Figure 3-9.

» Bold

> Italic

» Underline
» Center

» Increase Indent

» Text Highlight Color
» Font Color

» Format Painter
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choose Home > Font > Clear Formatting. (See
Figure 3-10.) All text and paragraph formatting
choices return to the default setting with the
exception of highlighting. Any applied highlight-
ing remains on the selected text.

Clear Formatting
\
Home | Insert  Page layout Refere\ces

Figure 3-9
The Font dialog box.

3. Make any desired text attribute changes. The
preview box at the bottom of the dialog box
illustrates your choices. Live Preview isn't
available from the Font dialog box.

4. Click the OK button.

Removing Formatting

If you decide you really liked the original format-
ting in your document, you can easily return it to
the default document settings. After selecting the
text from which you want to remove formatting,
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Easily remove unwanted formatting.

Changing the Default Font

As mentioned earlier in this chapter, Word 2010
begins with an 11-point Calibri font. If your company
has a different font as its company standard, or you
just prefer a different font for most documents,

you can change the default font for any new Word
documents that you create. Changing the default
font does not affect any existing documents.

Tip

The document body font is actually deter-
mined by the theme you use. See “Working
with Themes” later in this chapter.
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You can set the default font from any blank docu-

ment, or any currently open document. Just follow
these steps:

1. From the Home tab, click the Fonts group
Dialog Box Launcher or press Ctrl+Shift+F.

2. Select the font and size you want as your
default.

3. Click the Default button. A confirmation
message like the one shown in Figure 3-11
appears.

4. Click All Documents Based on the Normal
Template, and then click OK.

Formatting Paragraphs

—

| Font | Adyanced |
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Arial
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Microsoft Word

Do you wank to set the default font to (Default) Arial, 12 pt for:
(@ This document only?
() Al documents based on the Normal template?

ok ][ conce

Improve Customner Service

This is a TrueType font., This Fonk will be used on both printer and screen,

[[set as Defaut | [ TextEffects... |

Figure 3-11
Confirm the Default font change.

ORD INCLUDES MANY FEATURES
Wdesigned to assist you in placing text on

the page just the way you want it. You can
align text left to right using tabs or alignment
options, or you can adjust your text vertically using

line spacing options. Following are some of the
available paragraph formatting choices.

Aligning Text

Alignment arranges the text to line up at one or
both margins, or centers it between the margins.
Alignment applies to entire paragraphs. In other
words, you can't center align part of a paragraph
and left align another part of the same paragraph.
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You can align text to the left, right, or center, or
you can justify your text, which means that the text
becomes evenly spaced across the page from the
left margin to the right margin. Apply alignment
options by selecting the text you want to align,
then choosing Home > Paragraph and clicking one
of the following alignment buttons:

» Align Text Left: The text aligns evenly at
the left margin. This is the default choice.

» Center: The text centers evenly between
the left and right margins.

Figure 3-12 illustrates a document with text
matching each alignment option.

Adding Paragraph Borders

Word includes borders that you can apply to any
size block of text, which draw the reader’s eye to
specific areas for a “quick read.” Use a border to
place a frame around a word, phrase, paragraph, or
group of paragraphs to frame the text and call spe-
cific attention to the areas. A border can encase
the entire area or be any combination of lines
around the text, such as above and/or below the

text. Select the text you want bordered and choose
Home > Paragraph. Click the drop-down arrow
next to the Borders button, which displays a list of
options like the one you see in Figure 3-13. Choose
the border option you want.

» Align Text Right: The text aligns along the
right document margin.

» Justify: The text fills with micro spaces so it
aligns evenly on both the left and right

margins.
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Figure 3-13
Adding borders around text.

You may be wondering what the difference is
Automatic Borders between shading and highlighting. Highlighting

only covers the selected text and not the entire
Word automatically adds a thin single-line paragraph. Also, you typically use a light color for
border if you type three dashes in a row and highlighting so you can still see the black text
then press the Enter key. Typing three under- through it. When you add shading, the shading
score characters in a row and pressing Enter covers the entire paragraph, and if you choose a
automatically creates a thicker border line. darker color, Word automatically changes the text

color to one that coordinates so you can still effec-

tively read the text.

Shading Text

Shading helps you distinguish headlines and .
important passages, such as sidebars, by creating a Ti P
screen, which is typically light gray shading against
the standard black text. Screens can add contrast to
and enhance the readability of your document.
Shading especially looks good when used in combi-
nation with a border.

A great way to add enhancement is to use
black or dark gray shading with white text.
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Click anywhere in the paragraph you want shaded
and choose Home > Paragraph > Shading. Choose

a color from the resulting Shading gallery, as to white.

shown in Figure 3-14. In this figure, adding dark
blue shading caused Word to change the font color

“ Home Insert Fage Layout References Mailings Review View
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cipbourd Font Paagnon_| Teme cors o Paragraph Shading
S ————————— e LT L] e
Improue Your Knuwledge and Skllls Now would be ag I your knowledge and
|- new skills regarding the technical and financial aspect i I IIII I)ur customers should
impressed with your product knowledge. ""“"“ T
= uocolor
Al 'MPROVE CUSTOMER SERVICE - FAwesT T
| Make sure that each and every customer gets special treatment and leaves your store or office Flgure 3-14
.| thatyou have delivered much more than what was expected. Your employees should also unde Addlng shadlng to your
||| that tough times require a gentler touch and your customers need to be treated as VIPs now m paragraphs_
Optionally, if you want to add a shading pattern lndenting Text

ranging from a light 5% shade to patterns, such as
diagonal stripes or polka dots, you can choose
Home > Paragraph, and then click the Borders
drop-down arrow. From the list, select Borders and
Shading, which then displays the Borders and
Shading dialog box. Click the Shading tab then
click the Fill drop-down arrow to select a fill color.
Choices are available in themes or standard colors.
You can then click the Style drop-down list to
select a pattern.

Tip

Use caution with patterns. Using a busy
pattern can be distracting or make your
text very difficult to read.
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Typically, text runs between the left and right mar-
gins, but you may want to indent particular para-
graphs. Surprise! Word contains a tool for indent-
ing. Click anywhere in the paragraph you want to
indent, and then choose Home > Paragraph >
Increase Indent. Each click of the Increase Indent
button indents the text one-half inch from the left
margin. Click the Decrease Indent button to move
the text back one-half inch.

If you want to indent from the right margin or you
want to manually set how much indentation Word
applies, you can use the Format Paragraph dialog
box. Click the Paragraph Dialog Box Launcher,
which displays the Paragraph dialog box shown in
Figure 3-15.
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Figure 3-15
Set text apart by using indentation.

Click the spinner arrows for the Left or the Right
text boxes to specify the number of inches to
indent the left and right edge of the paragraph.
The Preview box at the bottom shows the effects of
your settings. Optionally, click the Special drop-
down list and select an indenting option:

P First line: This option indents only the first
line of the paragraph and leaves the rest of
the paragraph even with the left margin.

P Hanging: This option indents all lines
except the first line of the paragraph.

Click OK after you finish making selections. Word
applies the paragraph indentation settings you
selected.

Another way to control indention is by dragging
the indentation icons on the ruler:

Tip

If you don't see the ruler, choose View >
Show > Ruler.
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Tip

You can also change indentation by choos-
ing Page Layout > Paragraph > Indent.

Working with Tabs

By default, each time you press the Tab key, Word
moves the insertion point a half inch to the right.
However, you can set tab stops at desired points
along the ruler so that when you press the Tab key,
the insertion point moves to that point automati-
cally, instead of stopping every half inch.

Do not try to line up text by pressing the space
bar. Even if the text looks evenly aligned on the
screen, it won't be lined up when printed. Use tabs
instead.

The following steps show you how to set your own
tab settings:

1. Click the mouse pointer at the location you
want to create a tabbed paragraph.
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Tip

If you want to set tabs for multiple previ-
ously typed paragraphs, select the para-
graphs before proceeding to Step 2.

2. Make sure the ruler display is turned on. If
you don't see your rulers, choose View >
Show > Ruler.

3. Click the Tab button located at the left end
of the horizontal ruler as often as needed
until you see your desired tab alignment icon
(see Figure 3-16). Some tab choices include:

> Left: The Tab button defaults to
the left tab symbol, which looks like an
“L.” When using a left tab, text appears
with the left edge of the text at the tab.

| 2 Center: When you select a center
tab symbol, the Tab button looks like
an upside-down “T.” When using a cen-
tered tab, text centers at the tab stop.

> @ Right: When you select the right
tab symbol, the tab button looks like a
backward “L." When using a right tab,
text appears with the right edge of the
text at the tab stop.

| 2 Decimal: If you display the deci-
mal tab, the Tab button appears as an
upside-down “T” with a dot on the
right. When writing out dollar and cent
amounts, for example, decimal points
align to the tab.

| 2 @ Bar: Bar tabs are very different
from the previous four tabs. Text
doesn't position around bar tabs.
Instead, Word inserts a vertical bar at
the top position and runs through the
depth of the paragraph.
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Tab button Indent markers

e e e T

Figure 3-16
Setting manual tabs.

. Click on the horizontal ruler to set the tab

for the current paragraph or the currently
selected paragraphs. Depending on the tab
type you selected, a left, right, center, deci-
mal, or bar tab symbol appears where you
clicked the ruler.

. Click in the paragraph and press the Tab key.

Notice how the insertion point moves to the
tab setting you created.

. Type some text. The text you type appears on

the page. In Figure 3-17, you see examples of
left, right, center, and decimal align tabs as
you might use them in a document. (To
make the tabs easier to see, I've also dis-
played the hidden characters.)

Tip

Pressing Enter continues the tab settings
to the next paragraph.

Moving a Tab

If you're not happy with the position of your tab
stop, you can easily move it. Select to highlight the
paragraphs that have a tab you want moved, and
then drag the tab to a new location on the ruler
bar. As you drag the tab, a vertical dotted line like
the one shown in Figure 3-18 illustrates the new
tab position. When you release the mouse button,
the text moves to the new tab position.

S : I i —
—— Decimal tab
™ Right tab
- LEFT - CENTER - RIG DECIMALY
. ™~ Center tab
-+ Product + SalessRep -+  Quantity
+Red -~  Smith - 35 625.499 ™ Left tab
-+ Blue - Williamson - 164 984.379 Figure 3-17
+ Green -  lones - 6 97.439 Line up text with tabs—not
spaces.
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] LEFT CENTER RIGHT DECIMAL
i Product Sales Rep Quantity Price
| Red Smith 35 625.49
] Blue Williamson 164 984.37 .
Figure 3-18
Green ones 2 A3 Easily move manual tabs to a
different area.
Deleting a Tab

Like moving a tab, using the ruler makes deleting a
tab a very simple process. Select the paragraphs
that have a tab you want to delete and then drag
the current tab setting off the ruler, into the body
of the document. A vertical dotted line appears.
When you release the mouse button, the tab disap-
pears from the ruler and text realigns according to
your new tab settings. If there is no previous man-
ual tab stop, the default tab settings take effect.

Using the Tabs Dialog Box

If you want your tab stops at more precise posi-
tions than you get by clicking the ruler, or if you
want a dot leader before the tab, use the Tabs dia-
log box. Select the text where you want to set the
tab. From the Home tab, click the Paragraph
Dialog Box Launcher. Click the Tabs button, which
displays the Tabs dialog box shown in Figure 3-19.

Tip

Double-click any manual tab stop on the
ruler to open the Tabs dialog box.
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Default tab stops:
0 . SII

Tab stops to be cleared:

Alignment
@ Left
() Decimal
Leader
@ 1 None
©4__
Clear ] [ Clear all ]
[ OK ] [ Cancel l
Figure 3-19
The Tabs dialog box.

In the Tab Stop Position text box, type the location
you want for the new tab and choose an Alignment
and optional Leader style for the tab. Click the Set
button. Repeat this action for each tab you want
set. Click OK to close the Tabs dialog box.
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Tip

Alternatively, use the Tabs dialog box to
change the Default Tab Stops setting from
0.5" to any desired amount.

Changing Line Spacing

Line spacing is the amount of vertical space between
each line of text. You might want to change line spac-
ing when you want to make a document easier to
read, such as a contract, or to make room for changes
when writing a document draft. Like text alignment,
line spacing applies to complete paragraphs. Use the
following steps to change line spacing:

Default Line Spacing

Word 2010 and 2007 use a default line spac-
ing of 1.15. Earlier versions of Microsoft Word
used single spacing (1.0) as the default setting.

1. Select the text you want to change.

2. Choose Home > Paragraph > Line Spacing. A
list of options appears (see Figure 3-20).

3. Select a line spacing option. Word applies the
spacing you select to the highlighted text.

Tip

Shortcut keys for setting line spacing are
Ctrl+1 for single spacing, Ctrl+2 for double
spacing, and Ctrl+5 for 1.5 line spacing.

Adjusting Spacing Between
Paragraphs

Paragraph spacing is the amount of vertical space
between each paragraph of text. Remember that
whenever you press the Enter key, you start a new
paragraph. In early versions of Word, the default
was no spacing between paragraphs, so, tradition-
ally, you would press the Enter key a second time
to leave space between two paragraphs. Word 2010
and Word 2007 use a different default setting. The
default setting allows for 10 points of blank space
at the bottom of every paragraph, thereby elimi-
nating the need to press the extra Enter key.

However, you have complete control over how
much spacing, if any, you want between two para-
graphs. Similar to indentation, paragraph spacing
is controlled through the Paragraph dialog box.
From the Home tab, click the Paragraph Dialog
Box Launcher, which displays the Paragraph dialog
box (see Figure 3-21).
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Figure 3-20
Choosing a line spacing option.
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Paragraph spacing
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Figure 3-21
Manually setting the desired amount of
spacing between paragraphs.

Copying Formatting

The Spacing section is where you determine the
amount of space you want before or after each
paragraph. Settings are measured in points and
range from —1 to 1584.

Tip

You can also change paragraph spacing
by choosing Page Layout > Paragraph >
Spacing.

the right text and paragraph formatting, and

you know you'll need the same formatting sev-
eral more times in your document, you don’t want
to have to remember all your settings and repeat

I F YOU SPEND several minutes setting up just
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them over and over again. Instead, you can copy
formatting from one area to others by using the
Format Painter tool. Follow these easy steps to
copy formatting:
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1. Select some of the text containing the for-
matting you want to use elsewhere. Your
selection could include just a few characters

4. Release the mouse button. Notice, as shown in
Figure 3-22, how the next heading takes on
the formatting attributes of the first heading.

or an entire paragraph.

2. Choose Home > Clipboard > Format Painter. Tlp
Your mouse pointer changes to the shape of
a paintbrush. To keep the Format Painter function active
for repeated use, double-click the Format
3. Press and hold the mouse button and drag Painter button. When you finish using the

Format Painter function, click the Format
Painter button again, which turns it off.

over the text you want formatted.

Format Painter

Surviving a Recession - MicrosoftWord
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that tough times require a gentler touch and your customers need to be treated as VIPs now more than
ever. Since all your competitors may be selling the same products that you are, it will be your satisfied
customers who will not only bring in repeat business, but also new customers.
This not only will enhance your reputation as an expert, but will also ensure that they come to you if
they run into difficulties. =
CONTROL YOUR EXPENSZES
Now is the time for you to tighten up the controls on all your expenses, especially those that are not
crucial to keeping your business going. It certainly is not a good time to indulge in luxury items; thatcan
wait until the situation improves.
You should also split large expenses into smaller ones so that they become more manageable. Even
when purchasing inventory, try to get longer credit periods or better rates by comparing prices offered
by different suppliers.
o
¥
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Figure 3-22
Save formatting time by using the Format Painter tool.
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Working with Lists

OU CAN USE BULLETS or numbers to call )
Yattention to lists in your documents. Bullets vs. Numberlng

Traditionally, you use bullets when the list
items do not follow any particular order (such as a If you choose bullets and then decide you
list of options), and you use numbers when you want numbering, or vice versa, select the
want the items to follow each other in numerical text, and then choose the other option. If you
order (such as the steps in this book). Select the text decide you don’t want a bulleted or num-
for which you want to add bullets or numbers. Then bered list, select the text and click the Bullets
choose Home > Paragraph and click either the or Numbering button again, which removes
Bullets button or the Numbering button. Both items the selected option.
have a drop-down arrow from which you can select

a bullet or number style (see Figure 3-23). You can
preview the options with Live Preview by hovering
your mouse over any option before selecting.
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i small business. Document Bullets
A > Improve your knowledge an¢
| et
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| Define Mew Bullet...
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: » Lower your profit margins
» Use the power of the Internet .
] > tp ot Figure 3-23
otivate your sta .
1 v Grab readers’ attention by
[ s P ~ using bullets or numbering.
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If you have not already typed your list, Word moni-

tors your keystrokes and, depending on what you
type, automatically converts a list to a bulleted or
numbered list. If you type a 1 followed by a period
and then either a space or tab, Word automatically
converts the item to a numbered list. If you type
an asterisk (*) followed by a space or a tab, Word
automatically changes the asterisk into a bullet.
When you finish typing and press the Enter key,
Word creates the next numbered item or adds
another bullet.

Tip

Other features Word monitors and auto-
matically changes include changing frac-
tions to fractional characters like 1/2 to
1/2 or applying ordinals, such as changing
1st to 1st.

Tip

See Chapter 8 for information on creating
a multi-level list.

When Word formats the entry as a list, you see an
AutoCorrect Options button next to the bullet or
number (see Figure 3-24). If you don’t want Word
to change the list formatting, click the AutoCorrect
Options button and choose Undo Automatic
Numbering or Undo Automatic Bullets.

# e Apples
¥) Undo Automatic Bullets
%op Automatically Creating Bulleted Lists

% Control AutoFormat Options...

Figure 3-24
Word's AutoFormat as You Type feature.

Disable Automatic Settings

To permanently turn off the automatic num-
bering or bullet formatting, choose File tab >
Word Options. In the Proofing section, click
AutoCorrect Options. Click the AutoFormat
As You Type tab and turn off Automatic
Bulleted Lists and Automatic Numbering.
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Working with Themes

the content in your documents, making sure

you are getting your point across to the
recipient clearly. Throughout this chapter, you've
seen how you can add a little extra “oomph” to
your document by adding formatting.

YOU SPEND A LOT OF TIME preparing

All Microsoft applications include a feature that

saves you boatloads of time by providing expertly
designed themes, which can give all of your Office
documents a unified and professional appearance.

Themes include a set of colors, fonts, and other for-

matting details that coordinate together, and since
the themes are shared across all the Office pro-
grams, all your Office documents can now have the
same look.

By default, when you create a new Word (or Excel,
PowerPoint, and so forth) document, Office begins
with the Office theme. As you've already seen, it
starts with the Calibri 11 point font, and you've

also seen the default paragraph settings. Microsoft
Office includes 43 other themes with names such
as Apey, Civic, or Metro. You can also download
additional themes from Microsoft Office Online.

All of the document content links to the theme, so
if you change the theme, a complete set of new
colors, fonts, and effects is applied to your entire
document. You can still, however, make any indi-
vidual formatting changes to the document.
Themes also save time when it comes to adding
tables, charts, or diagrams to your documents
because those elements can also include the
matching theme settings.

To apply a different theme to your document, click
Page Layout > Themes > Themes. A gallery appears
of the different themes, as shown in Figure 3-25. As
you pause your mouse over any theme, you can
immediately see how the fonts and colors change
in your document. Click the theme you want to use.

Theme Color Strategy

ble and still look good.

Theme colors have 12 color positions. The first four colors are for text and backgrounds. The next six are
accent colors, and the last two colors are used for hyperlinks. The folks at Microsoft built visibility rules
into the themes so that usually you can switch colors at any time, and all your content will remain legi-
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themes.

Working with Styles

your document look good by using Word's

many formatting tools. You've already worked
with direct formatting, which is where you apply
the formatting directly, such as bold, underline, or
a different font.

THIS ENTIRE CHAPTER is about making

In the previous section, you discovered themes.
You discovered that themes change the overall
colors, fonts, and effects used in your document.
However, there is a faster way to quickly apply
formatting: working with styles. Styles are a saved

collection of formatting steps. You can apply styles
to characters, paragraphs, lists, and tables.

Using Quick Styles

Quick Styles are predefined sets of font and para-
graph formatting settings, each designed to coordi-
nate with each other. For example, a Quick Style
might include styles for headings, titles, body text
or even quotations. Some include color changes
and some do not. Quick Styles change how the dif-
ferent colors, fonts, and effects are combined and
which color, font, and effect is dominant.
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Quick Styles are tied to themes and help maintain

design and consistency in your document without

actually changing the entire document theme. Use
the following steps to work with Quick Styles:

1. Select the text to which you want to apply
formatting.

2. Choose Home > Styles and click the More
button next to the Styles scroll bar. A gallery
of style options appears, as shown in Figure

3. Asyou position your mouse over the styles,
Live Preview shows you the effect on your
selected text. Select the option that best suits
your text.

Tip

Optionally, choose Home > Styles >
Change Styles > Style Set to view addition-
al style options, which are named after
and originate from the different themes.

(See Figure 3-27.)
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Working in the Styles Task Pane

Every new Word document includes styles; however,
the exact styles the document includes vary with
the document template you use. (See Chapter 17
for more information about templates.) The Quick
Styles you worked with in the previous section are
the ones available with the standard blank Word
document.

Many companies have a complete series of styles
they use to standardize the look of company doc-
uments. In the next section, you discover how to
create your own styles. You can use the Styles
task pane for easy access to the standard and
your custom styles.

From the Home tab, click the Styles group Dialog
Box Launcher. On the right side of your screen, the
Styles task pane appears like the one you see in
Figure 3-28. The styles that have a paragraph mark
(9) next to them are paragraph styles, and the ones
that have an “a” next to them indicate they are
character styles, and there are some that are
marked with both. Word calls these linked styles.
Paragraph styles apply to entire paragraphs (such as
alignment, spacing, or tab settings), and character
styles can apply to the text itself (such as bold, ital-
ics, or font). Paragraph styles also include every-
thing that a character style contains. You mostly use
paragraph and character styles in your documents.
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Figure 3-28
The Styles task pane.

Linked styles work as either a character style or a
paragraph style, depending on your selection. For
example, if you simply click in a paragraph or select a
paragraph and then apply a linked style, Word
applies the style as a paragraph style. However, if you
select specific words in the paragraph and then apply
a linked style, Word applies the style as a character
style with no effect on the overall paragraph. Word
also has table styles, which you apply to tables. (See
Chapter 12.) From here you can click in or select
your text and apply a style by clicking the desired
style from the Styles task pane.
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Tip

Click the Close button (x) when you are
finished with the Styles task pane.

Creating Customized Styles

If your company has a standard format it likes to
use for document areas, you can create your own
Quick Style and quickly apply it whenever you
need it. For example, suppose your company likes
proposals to have a heading in a 24-point bold
Harrington font with the Gradient Fill — Blue,
Accent 1 text effect and a shadow.

You can save all that formatting in a style and save
it for use in future documents. Follow these steps
to save the formatting to a Quick Style.

1. Format and select some text the way you
want it.

2. Choose Home > Styles and click the More
button.

3. Choose Save Selection as a New Quick Style,
as shown in Figure 3-29. The Create New
Style from Formatting dialog box appears.
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Figure 3-29
Create your own quick style.



Making a Word Document Look Good

Chapter 3

4. Enter a name for your style, “Proposal,” for
example.

5. Click Modify. The dialog box expands. See

Figure 3-30.
New documents based on this template
Create New Style from Formjatting R
Properties
Iame: Proposal
Style type: Unked (persgraph and charscter) =]
Style based on: o Normal =]
Style for Following r T Froposal E
Formatting
Harrington [+] 24 [+] Ty Automatic ||
EEEE|== = |2 2| & F
Proposal
Fonk: Harrington, 24 pt, Bpld, Test Outine, Text Fill, Shadow, Centered, Style: Quick Style
Based on: Normal
(7] Add to Quick style st ] Automatically update

Only in this document @) New documents based on this template
(ramat- ] (e ]

Figure 3-30
The expanded Create New Style from
Formatting dialog box.

6. Select New Documents Based on This
Template.

7. Click OK. The new Quick Style appears in the
Quick Style box. See Figure 3-31.

Managing Styles

Sometimes the styles you already have, whether
standard or custom styles, aren't quite right for the
current document. For example, say the Heading 1
style is a 14-point bold Veranda font, but for this
document, you want it as an 18-point font.

You could select every occurrence of the Heading 1
style and change them individually to an 18-point
size, or you can modify the style. When you modify a
style, you decide if you want it changed for only the
current document, or if you want to change it also
for future documents based on the same template.

Fortunately, Word has a Manage Styles box you can
use for quick, efficient style management. Just fol-
low these steps:

1. Display the Styles task pane by clicking the
Home > Styles Dialog Box Launcher.

2. Along the bottom of the Styles task pane are
three small icons, the third of which is the
Manage Styles icon.

3. Click Manage Styles. The Manage Styles dia-
log box appears, as shown in Figure 3-32.

New Quick Style
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Figure 3-31
The newly saved Quick Style.
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The Manage Styles dialog box.

4. From the Manage Styles dialog box, select
the style you want to modify.

5. Select whether the change you are planning
should apply to the current document or to
any new documents based on the template.

6. Click the Modify button and make changes
to the style.

7. Click OK when you are finished.

Deleting Styles

In the previous section, you worked with the
Manage Styles dialog box where you discovered
how you can modify a style. You may have noticed
a Delete button on the Manage Styles dialog. If you
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click the Delete button, you are only temporarily
deleting the style—not permanently.

If you want to permanently delete a customized
style, you must do so through the Style Organizer
window. For whatever the reason, Microsoft made
the Style Organizer window a little difficult to get
to, but the following steps show you the way:

1. Click the File tab and choose Options. The
Word Options dialog box appears.

2. On the left side, choose Add-Ins. The right
side displays options related to Add-Ins.

3. Click the Manage drop-down list and choose
Word Add-ins. See Figure 3-33.
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Choosing Word Add-ins.

4. Click the Go button. The Templates and Add-
Ins dialog box appears.

5. Click the Organizer button located in the
lower-left corner. The Organizer dialog box
appears, as shown in Figure 3-34.

sﬁes'uwopromm

6. From the right column (In Normal:) select
the style you want to delete.

7. Click the Delete button. A confirmation box
appears.

8. Click Yes, and then when you are finished,
click the Close button.

Delete button

Tg Document5:

Default Paragraph Font -
Mo List

Fonk: Harrington, 24 pt, Bold, Text Outiine, Text Fill, Shadow, Centered, Style: Linked, Quick Style
Based on: Normal

Selected style

Figure 3-34

Deleting unwanted styles.
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Revealing Formatting

Word has a really cool feature that lets you quickly
see all formatting applied to selected text. Called
Reveal Formatting, you can review the font format-
ting, paragraph formatting, and section formatting
all at once.

To see the text formatting, first select the text you
want to inspect, then open the Style task pane by
clicking the Home > Styles Dialog Box Launcher.

Reveal Formatting icon

From the bottom of the Styles task pane, click the
Style Inspector icon, which is the middle icon. The
Style Inspector pane shown in Figure 3-35 appears.

From the bottom of the Style Inspector pane, click
the Reveal Formatting icon (the one on the left).
The Reveal Formatting pane appears on the right
side of your Word window. See Figure 3-36. From
here you can see all formatting applied to the
selected text.

Style Inspector icon
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Figure 3-35
The Style Inspector.
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Figure 3-36
The Reveal
Formatting

task pane.
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If you want to change any of the options, click the
applicable underlined link. A dialog box relative to
that option appears where you can change the set-
tings for the selected text.

When you are finished, click the Close box (x) on
the Reveal Formatting task pane, the Styles task
pane, and the Style Inspector task pane.
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Managing Word

ICTURE YOURSELF TAKING YOUR FAMILY to an
-amusement park. The older children want to go this way,
and the younger children want to go another way.
Grandpa just wants to sit and rest and watch. How will you
manage everything?

=i

Balancing a document's white space—the amount of blank space
on a page—is an important aspect of designing professional-
looking pages. You can increase or decrease white space by
adjusting margins and the amount of text you place on a page.
Additionally, Word provides the ability to work with multiple
documents at the same time, as well as methods for quickly
comparing information between two documents. When multiple
windows are active, you'll need a way to manage them all. That's
what this chapter is about—managing a Word document.



Creating Page Breaks

ORD AUTOMATICALLY INSERTS a
Wpage break when text fills the page. This

page break sometimes doesn't fall where
you want it to. You can override Word's automatic
page break by creating your own page break. You

can make a page break at a shorter position than
Word chooses, but you cannot make a page longer.

A manual page break is sometimes called a hard
page break because, unlike the page breaks that
Word inserts, a manual page break doesn't move if
you delete text above it, adjust the margins, or oth-
erwise change the amount of text on the page.
Insert a manual page break by positioning the
insertion point where you want the new page to
begin and choosing one of the following methods:

» Choose Insert > Pages > Page Break

» Choose Page Layout > Page Setup > Breaks
> Page

» Press Ctrl+Enter

If you are in the default Print Layout view, you see
the text below the insertion point move down to
the next page of the document. However, if you
have the Show/Hide characters active, you see the
words "Page Break," along with a dotted line, where
the new page begins, as shown in Figure 4-1.
(Document views are discussed in Chapter 6.)

Tip

You can show or hide the hidden characters
by choosing Home > Paragraph >
Show/Hide 9.

You cannot delete Word's automatic page breaks,
but you can delete the manually inserted hard
page breaks at any time. Simply click the mouse
pointer at the beginning of the text after the page
break indication, and then press the Backspace key.
Word deletes the manual page break, and the doc-
ument text readjusts to fit on the pages correctly.
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Figure 4-1
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Using Section Breaks

HEN YOU NEED TO APPLY different
Wpage formatting options to only a portion

of the document, you need to break the
document into sections. For example, when page 1
requires different margin settings from the rest of
the document, you must break page 1 into its own
section. If only pages 16—18 need to be printed in
landscape orientation, you can break pages 16, 17,
and 18 into a section. Other uses for section breaks
are when you need a different header or footer for
a section of your document or you want to separate
the chapters in your document so that the page
numbering for each chapter begins at 1.

Most section breaks involve entire pages; however, if
you need different columns, they don't necessarily
have to be on different pages. Word allows for four
different types of section breaks:

P Next Page: Inserts a section break and
starts the new section on the next page.

» Continuous: Inserts a section break and
starts the new section on the same page.

P 0dd Page: Inserts a section break and starts
the new section on the next odd-numbered
page.

P Even Page: Inserts a section break and
starts the new section on the next even-
numbered page.

Section formatting options include the following,
many of which are covered in this chapter:

P Margins: The amount of space between the
text and the paper edge.

P Paper Size: The paper size you intend to
use when printing.

P Paper Orientation: The direction the text
prints on the paper edge.

» Paper Source: When printing, which paper
tray the printer should pull paper from.

P Page Borders: Bordered lines that appear
around the entire document page.

P Vertical Alignment: The placement of text
between the top and bottom margins.

» Headers and Footers: Text that appears at
the top or bottom of every document page.

» Columns: How text in newsletter-style
columns flows from one column to the next
on the same page.

P Page Numbering: Sequential numbering
for each document page.

» Line Numbering: How Word automatically
counts the lines in a document and displays
the appropriate number beside each line of
text.

» Footnotes and Endnotes: A note of text
placed at the bottom of a page or at the
end of the document typically citing a refer-
ence used in the document.

To insert a section break, position the mouse
where you want the new section to begin, choose
Page Layout > Page Setup > Breaks, and select the
desired section break type from the drop-down list
as shown in Figure 4-2. A section break controls
the formatting of the text that precedes it.
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you have the Show/Hide characters active, you see

Depending on the type of section break you
choose, from the default Print Layout view, you see
the text below the insertion point remain at the
same location or move down to the next page of
the document. However, if you are in Draft view or

the words "Section Break” and the type of section
break in action, along with a dotted line, where the
previous section ends (see Figure 4-3). Chapter 6
covers the different Word views.
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Managing Page Layouts

document can feel a bit overwhelming.

Fortunately, Word contains many features
designed to assist you, such as those that allow
you to set the page size and layout, mixing and
matching them as needed.

SOMETIMES WORKING WITH a long

Setting Margins

Margins are the space between the edges of the

paper and where the text actually begins to appear.

Word allows you to set margins for any of the four
sides of the document and also allows you to mix
and match margins for different pages. Word sets
the default margins as 1 inch on each of the top,
bottom, left, and right sides. You can set the docu-
ment margins before you begin entering text into

a document, after you've completed the entire doc-

ument, or at any time in between.

Choose Page Layout > Page Setup > Margins and
select from the choices you see in Figure 4-4, or
click Custom Margins, which displays the Page
Setup dialog box where you can set your own
choices. By default, Word applies the new settings
to the entire document.
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Figure 4-4
Choosing from standard margin options.

If you want to change margins for only part of the
document, select the portion you want to change.
From Page Layout > Page Setup > Margins, choose
Custom Margins. Set the margins you want and,
from the Apply To drop-down list, choose Selected
Text (see Figure 4-5). Word creates section breaks
and applies the new margin settings.
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Orientation
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Pages
Multiple pages: Normal
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Figure 4-5
Applying margin settings to only
part of a document.

Changing Document
Orientation

Webster’s dictionary describes orientation as a
position in relation to a specific place or object. In
word processing, orientation refers to how the text
is positioned in relation to the top of a page. Two
orientations exist: Portrait, the default orientation,
prints the text beginning along the short edge of
the paper, and Landscape orientation prints along
the long edge of the page.
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Choose Page Layout > Page Setup > Orientation
and choose Portrait or Landscape, as shown in
Figure 4-6.

m Home Insert

Page Layout References
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""" [l = [ | Line Numbers ~
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[ S R Y A S N e L S A AYAYES

Figure 4-6
Choosing a document orientation.

Sections Required

Similar to margin settings, if you want to
change the orientation for only part of the
document, select the portion you want to
change and, from the Page Setup dialog box,
choose your orientation and from the Apply
To section, choose Selected Text. Word
creates section breaks and applies the new
settings to the selected section.

Setting the Paper Size

Word assumes you want your document printed on
standard paper 8.5 inches wide by 11 inches long,
but you may want some or all of your document
printed on a different paper size. Although Word
can work with many different sizes of paper, often
the selections available to you depend on the
printer you have. In many situations, you can even
create your own custom paper size.
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Word provides a number of different ways to man-
age document paper sizes:

» To change the paper size for the entire doc-
ument, choose Page Layout > Page Setup >
Size and select a size from the resulting
drop-down list (see Figure 4-7).
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Figure 4-7

Selecting the desired paper size.

P To change the paper size from a certain
location through the rest of the document,
position the insertion point where you

want the new paper size to take effect, and
then choose Page Layout > Page Setup >
Size and select More Paper Sizes. From the
Paper tab of the Page Setup dialog box,
select the paper size you want and then, in
the Apply To drop-down list, choose This
Point Forward.

P To change the paper size for a particular
section, create the section breaks where
needed and click anywhere inside the sec-
tion you want to change, or select the text
area. Choose Page Layout > Page Setup >
Size and select More Paper Sizes. From the
Paper tab of the Page Setup dialog box,
select the paper size you want and then,
from the Apply To drop-down list, choose
This Section or Selected Sections.

Adding Line Numbering

Sometimes, especially with legal documents, you
need to place line numbering. Word has a feature
that can automatically count the lines in a docu-
ment and display the appropriate number beside
each line of text. Word gives you a number of dif-
ferent line numbering options. For example, you
can number every line in a document, number
every line in only a part of the document, or dis-
play line numbering at specific intervals such as 2,
4,6, 8 or 10, 20, 30, 40, and so forth.

Word also has a few rules about how it counts
special items:

P Blank lines are included. Paragraph spacing
is not included.

P A table counts as one line. (See Chapter 12
for information about tables.)

P Graphics count as one line. (See Chapter 13
for information about graphics.)
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» A text box counts as one line if it is posi-
tioned in-line with the text on the page. If
text on the page wraps around the text box,
the lines of text on the page are counted.
Lines of text inside a text box are not
counted. (See Chapter 13 for information
about text boxes.)

» Footnotes, endnotes, headers, and footers
are not included.

To add line numbering, choose Page Layout > Page
Setup > Line Numbers. You see the menu as shown
in Figure 4-8.
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Figure 4-8
Line numbering choices.

Line Numbering Sections

If your document has sections, and you want
to number the entire document, before
applying line numbering, you must select the
entire document by pressing Ctrl+A.
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By default, Word numbers every line in a docu-
ment as 1, 2, 3, 4, and so on. You can choose to
number continuously through the entire docu-
ment, or you can have the numbers restart at each
page or section.

Line numbering does not show up on your screen
document. It appears only in the printed docu-
ment or in Word's Print Preview window. To see
how the line numbering looks, click the File tab
and choose Print. You see the document with its
line numbering on the left side of the screen.
Figure 4-9 illustrates a document numbered con-
tinuously throughout the entire document.
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Figure 4-9
A document with line numbering.
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If you want a different numbering scheme than Check the Add Line Numbering option, and then
the default sequential 1, 2, 3, 4, choose Page select any other desired options. Click OK twice.
Layout > Page Setup > Line Numbers > Line

Numbering Options. The Page Setup dialog box

appears. Click the Line Numbers button on the .

Page Setup dialog box. You see the Line Numbers Tlp

dialog box shown in Figure 4-10.

To remove line numbering, choose Page
Line Numbers button Layout > Page Setup > Line Numbers >
None.

Section start: Continuous
Suppress endnotes
Headers and footers
[C] Different 0d{ | ine Numbers
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[¥] Add line numbefi
From edge: Start at: 2

From text: Al

Countby: 2

Numbering:
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() Restart
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Page
Yertical alignmer

<|> _<|) 1_|b

Figure 4-10
Setting the line number pattern.
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Adding Headers and Footers

EADERS AND FOOTERS are features
H used for placing information at the top or

bottom of every page of a document. As
you'd expect, a header prints at the top of every
page, and a footer prints at the bottom. You can
place any information in headers and footers, such
as a company logo, the document title, page num-
bering, and so forth.

Using Header and Footer Styles

In keeping with the themed concept of Office 2010,
the predefined headers and footers contain ele-
ments designed to make your document more visu-
ally appealing. Choose Insert > Header & Footer >
Headers (or Footers) which displays a gallery of 27
unique header (or footer) styles, as shown in Figure
4-11. If you were not already in Print Layout view,
Word automatically switches you to it.

From the Header or Footer gallery, select the style
you want. The document header area becomes visi-
ble, the body of the document fades, and Word dis-

plays one or more additional tabs on the ribbon. You
can now use the Header & Footer Tools > Design tab

for creating your personalized header or footer.

In the header example shown in Figure 4-12, Word

inserts a placeholder for the document title. Click
the placeholder and enter the desired text. Also in
the same figure, you see a placeholder that says
Pick the Date. If you click the down arrow, Word
displays a calendar from which you can select the
date you want in the header. Optionally, you can

just type a date in the date field. The actual choices

you see depend on which header or footer style
you select.
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Figure 4-11
Creating a header or footer.
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Figure 4-12
Working with text placeholders.

Now take a brief look at some of the tool groups
Tip on the Header & Footer Tools > Design tab, as
shown in Figure 4-13.

If you don't want the predefined place-
holder, click the small tab above the
placeholder and press the Delete key.

Wid9-0( Business Plan - Microsoft Word

File Home Insert Page Layout References Mailings Review Wiew Design
[ ] L [ ;-__I ] t a . [E = [ H 5" =
j Q | aj: 58 | LJ EI"‘ Previous [] Different First Page 34 Header from Top: 0.5 :
e o e 5’{, Mext [7] Different Odd & Even Pages g- Footer from Bottom: 0.5 b
Header Footer Page Date  Quick Picture Clip Goto Goto a3 = 1 Close Header
- *  Number+ &Time Parts~ Art | Header Footer % Link to Previous | [¥] Show Document Text + Insert Alignment Tab and Foater
Header & Footer Insert Mavigation Options Position Close

Figure 4-13
The Header & Footer Tools > Design tab.
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» Header & Footer: Use this group to change
the header or footer style, or to insert the
page number in the header or footer.

» Insert: From this group you can insert the
current date or time, a picture, or a piece of
clip art. You can also select from Quick Parts
and choose one of the document properties
shown in Figure 4-14.

w9~ 0= Business Plan = Microsoft Word

» Position: This group contains settings for
exact header and footer placement in rela-
tion to the top or bottom of the document
paper edges.

» Close: Use this button to close the header or
footer and return to the document body. You
can also double-click anywhere in the docu-
ment body to close the header or footer.
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» Navigation: Use the tools in this group to
move between the document headers and
footers.

» Options: The Options group allows you to
choose whether the first page of your docu-
ment should have a different header or
footer from the rest of the document. You
can also choose different headers for the
odd or even numbered pages.
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Adding document Quick Parts.

Every page of the document displays the header
and/or footer you created (see Figure 4-15).
Remember, however, that documents displayed in
Outline or Draft view do not reveal any headers
or footers.
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Changing the Header or Footer

If you don't like the header or footer you selected, double-click the header or footer, and then from
the Header & Footer Tools > Design tab, click the Header or Footer button and choose a different

header or footer.
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Figure 4-15
Viewing a document header.

To further edit the header or footer, either double-click in the header or footer area, or choose Insert
> Header & Footer > Header (or Footer) > Edit Header (or Footer). To remove the header or footer,
choose Remove Header (or Footer) from the same menu.
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Creating a Custom Header or
Footer

If none of the predefined headers or footers suits
your needs, you can certainly create your own. You
can add text, fields (such as date, time, or author), or
page numbers, and you can add graphics (such as
logos, lines, and other art). Just follow these steps:

1. Choose View > Document Views > Print
Layout.

Tip

If you want to work on the footer instead
of the header, click Go To Footer to jump
to the footer area.

2. Double-click in any desired header or footer
section and type the text you want for the
header (or footer). As you see in Figure 4-16,
you can format the header and footer text
just as you would any cell data.

wWid9-~-0|= Business Plan - Microsoft Word
File Home Insert Page Layout References Mailings

3. Insert any other options from the Header &
Footer Tools > Design tab:

» Page Number: Insert a code that indi-
cates the page number.

» Date & Time: Insert the print date or
time of day.

» Picture: Insert a graphic image such as
a company logo.

» Clip Art: Insert a clip art image.

4. Click in the document body, outside of the
header (or footer) area, to close the header or
footer.

Adding Page Numbering

Although Word automatically numbers your pages
as you type them, it doesn't print the page num-
bers; it simply displays them in the screen status
bar. You can easily tell Word you want to print
them. Typically, the page numbers appear in the
header or footer area, but they don't have to. You
can place them wherever you want. What you do
need to remember, though, is to use the Page
Number feature provided by Word—don't try to

: Footer
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Figure 4-16
Creating your own header or footer.
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type the page numbering yourself. If you type Page
1 of 6 in the footer, every page will say Page 1 of 6.
If you use one of Word's Page Number features, the
page numbering will change as needed, such as
Page 2 of 6 or Page 3 of 6.

To insert a page number, choose Insert > Header &
Footer > Page Number. A menu of placement
options appears. You can put the page number at
the top of the page in the header, at the bottom of

the page in the footer, in the page margins outside
of the header or footer, in the margin area, or you
can put the page numbering at the current docu-
ment position of your cursor.

Choose the position you want, and then a gallery
of prefabricated page number styles appears (see
Figure 4-17). Select the page numbering style you
want to use. Word adds the page numbering to
your document, as shown in Figure 4-18.
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Figure 4-18
Page numbering added to the document.
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Understanding Security

and Printing

. ICTURE YOURSELF WORKING AWAY on an employee evalua-
tion. You don’t want anyone to see it, and people are constantly
coming in and out of your office, even when you're not there. How

can you protect your work from those of whom you don't want to see it?

And if you decide to pass the file on to others, is there any way you can

lock the contents to keep others from changing it? The answer is yes.

Word contains a number of ways to keep your files safe.

This chapter is about security. It's also about printing. When you want to
share the document in a printed form, you have quite a few choices as to
what to print. In this chapter you'll learn how to keep your documents
secure and how to share them when you want to.




Keeping Documents Secure

ANY DOCUMENTS CONTAIN data
M that is confidential in nature, such as

business plans or personal diaries. In
today's world of electronic snooping, it's up to you
to protect your work against prying eyes. Even if
you allow others to view your documents, you may
want to prevent accidental or intentional changes.
Fortunately, Word provides several security tools,
including password protection.

Making Backups

Prepare yourself. I'm going to nag at you here.
Okay, this section doesn't really have anything to
do with Microsoft Word. It's more of a personal
plea. Back up your files. I repeat: Back up your files.
You know the silly, but popular, little saying, “Stuff
happens.” (That's not exactly how it goes, but you
get the idea.) Well, it's true. Things happen. Now, I
don’t mean to sound pessimistic, but computers
do fail, files get deleted or corrupted, and disasters
(such as fire or theft) can occur.

Well, you can always get another computer and
reload your Microsoft Word program. But even
millions of dollars can't buy back all the docu-
ments and the hundreds of work hours you

have in them and that you have stored on your
computer. That's why backing up your files on a
regular basis is important. Then, if disaster strikes,
you can restore them.

Whether you copy your images using Windows
Explorer to a flash drive, a CD, or a DVD, or you use
a special backup program, don't procrastinate. Do it!
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Officially, Microsoft Word doesn’t have any specific
function for backing up your files, but refer to the
Windows Help system on how you can copy files
from your Documents folder (or wherever you
store your documents) to your backup flash drive,
CD, or DVD. Trust me—you won't regret it.

Inspecting for Personal
Information

Many Word documents contain metadata, which is
somewhat hidden information that others could
see—data such as the names of people who have
previously edited the document, file locations, and
even e-mail addresses. You may not want others to
have access to this information. Fortunately, you
can eliminate the metadata by using the
Document Inspector.

If you are collaborating with others using features
like comments or tracked changes, you may not
want to remove the metadata until the collaboration
is complete. Typically, you run the Document
Inspector just prior to publication. (You'll discover
comments and tracked changes in Chapter 16.)

First save your file and then click the File tab. From
the document Information panel, choose Check for
Issues and then choose Inspect Document. You see
the Document Inspector dialog box shown in
Figure 5-1.
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Figure 5-1
Inspecting your document for
personal information.
Deselect any options you do not want to check information. When the inspection is complete, the
and click the Inspect button. Word inspects the Document Inspector reappears with information,
document for various types of potential personal as shown in Figure 5-2.

@ Comments, Revisions, Yersions, and Annotations
Mo ikems were found.

Document Properties and Personal Information
The Following document information was Found:

* Document properties

* Author

Custom XML Data
Mo custom XML data was found.

Headers, Footers, and Watermarks
Mo headers, footers, or watermarks were found.

Invisible Content
No invisible objects found,

Hidden Text
No hidden text was found.

Figure 5-2
The Document Inspector
reveals potential problem areas.
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/iy Note: Some changes cannot be undone.




Click the Remove All button next to any option
you want removed. Word removes the selected
information and the Remove All button next to the
option disappears. Repeat this for any additional
items you want to remove. When finished, click the
Close button and resave your file.

Restricting Formatting
Changes

If you apply a file password (which you'll see how
to do later in this chapter), with the right password
you or others can open or modify the document. If
you can modify a document, you can modify any
portion of it—content or formatting. One method
of protection you can apply is to protect the docu-
ment against formatting changes. Then before
someone can change the document appearance,
they must first enter a password. Follow these
steps to lock-in document formatting:
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1. Choose Review > Protect > Restrict Editing. A
Restrict Formatting and Editing task pane
opens on the right side of the screen, as
shown in Figure 5-3.

2. Click the Limit Formatting to a Selection of
Styles check box.

3. Click the Settings link. The Formatting
Restrictions dialog box appears (shown in
Figure 5-4). By default, changes to any styles
are allowed.

- Settings

2. Editing restrictioes
Allow oy Ehis bype of edting i
the document

e tharges (Raad oy

3. Stark enforcement

e you rmady th apcly thess
‘setings? (Yo cam burn Hhem off
later)

‘Yo, Rart Enforong Protection |

W | Restrict permission

Figure 5-3
Crr e :l  Stop unwanted formatting changes.
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[¥] Limit Formatting to a selection of styles

By restricting Formatting to the styles you select, you prevent the ability to
modify styles and the ability to apply direct formatting to the document.
Select the styles you want to allow to be used in this document.,

Checked styles are currently allowed:
T
14 a]‘ i | |
| article | Section B
| Balloon Text (recommended)
|| Bibliography (recommended)

|| Block Text (recommended)
|| Body Text (recommended)

| |Body Text 2 (recormnsmlsd)
|| Body Text 3 (rece

Al

[7] Allows AutoFormat ko override Formakting restrictions
["] Block Theme or Scheme switching
[ Block Quick Style Set switching

Figure 5-4
Setting formatting restrictions.

4. Click the None button. All choices are dese-
lected; however, if you do want to allow for-
matting changes to a particular style, you can
recheck that style name.

5. Click the OK button. Click No if you get a
message box saying, “This document may
contain formatting or styles that aren't
allowed. Do you want to remove them?”

6. From the Restrict Formatting and Editing
task pane, click the third option: Yes, Start
Enforcing Protection. The Start Enforcing
Protection dialog box appears.

7. Enter an optional password, and then reenter
the password to confirm it. The password you
type appears as a series of black dots.

8. Click OK. Notice in Figure 5-5 how any
Ribbon option that affects formatting,
including Quick Styles, becomes unavailable.

If you want to make any formatting changes, you
must first click the Stop Protection button at the
bottom of the Restrict Formatting and Editing task
pane. If you don't see the Restrict Formatting and
Editing task pane, choose Review > Protect > Restrict
Editing. You must then enter the password to stop
the protection and allow formatting changes.

Wl - 0= Business Plan - Microsoft Wo (=
Home Insert Page Layout References Mailings Review Wiew & 0
T E— 24 Find ~
& Cu = =z A
[ ! VA A B T | aapbceoe % 2
A Cop: 3¢ Replace
Paste % - B I U~-asx x - A - 1 Normal ~ Change
- ¥ Format Painter — - L | T Styles~ | W Select~
Clipboard Font Paragraph Styles Editing
Figure 5-5

The Word Ribbon with formatting restricted.
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Marking a Document as Final

To protect your document against accidental b sove

changes, Word includes a feature called Mark as Bl sma &0

Final. After choosing the option, the document can- s

not be changed unless you choose the Mark as Final G Gose

option again, which then allows document changes. _
Recent

Click the File tab and from the document e

Information panel, in the first section, click the
Protect Document button and choose Mark as Final Print
(shown in Figure 5-6). A confirmation message

) > Save & Send
appears. Click OK. Next, another confirmation mes-
sage appears. Click OK to that message also, and HeD
then click the File tab to return to the document. ] options
£ Eit

Marking a document as final disables every option

Information about Business Pl

C\Users\Diane\Documents\Business Plan.docx

Permissions
@}J Anyone can open, copy, and cha

Protect
Document -

e Mark as Final
Let readers know the document is final
and make it read-onhy.

((T <) Emcrypt with Password
1 Require a password to open this
document.

& Restrict Editing
1] Control what types of changes people
can make to this document,
‘-\ Restrict Permission by People
_Q Grant people access while removing r
their ability to edit, copy, or print.
I Add a Digital Signature

Ensure the integrity of the document
by adding an invisible digital signature,

in the Ribbon that could change the document in
any way. A bar appears across the top of the win-
dow (see Figure 5-7) indicating the document is
marked as final; if you attempt to make any
changes, Word simply ignores you. The document
title bar also shows the document as (Read-Only).

Figure 5-6

Disable editing by marking a document as final.

Edit Anyway button

Wl 9~ 05 Business Plan [Agad-Only] -'MicmsoftWon__m
Home Insert Page Layout References Mallings Review Wiew 2 0

o Marked as Final  An author has marked this document as final to discourage editing. _Edrt_Anyway ] x
L 3 2 I ;|
- -

Rucinoace Plan
Figure 5-7

Opening a document marked as final.
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This feature is easily bypassed. Suppose you need
to change a date in the document, or you forgot to
list a particular item. You can “unmark” the docu-
ment from being final by simply clicking the Edit
Anyway button.

Saving a File as Read-Only

If your goal is to prevent accidental changes, either
by you or others, one of the easiest methods is to
save the file with a read-only recommendation.
When a file is read-only, you can still make changes
to the document, but the only way you can save
those changes is to save the file to a different file
name or folder.

1. Click the File tab and choose Save As.

Organize « Mew folder
: - General Options
IE Microsoft Word
File encryption options for this document
W Favorites Passwordto open:
Bl Desktop File sharing options For this document
& Downloads Password to modify:
= Recent Places ] Read-onty ,
R Wy Suft Brotect Document...
L Macro security
4 Libraries
= Adjust the security level for opening files that might
| | Decuments 3 contain macro viruses and specify the names of Hacro Seoehy,
J‘ = trusted macro developers.,
Music
=) Pictures
B Videos
QQ Homegroup
- 4
File name: Business
s i o) [foma )
Authors: Diane i

[F] Save Thumbnail

. Optionally, select a different folder in which

to save the file.

Enter a file name if you haven't already
assigned a name.

Choose Tools > General Options (see Figure
5-8).

. From the General Options dialog box, click

the Read-Only Recommended check box.

Click the OK button, which returns you to
the Save As dialog box.

Click the Save button.

Tools button

Tools

= Hide Folders

7 |

Figure 5-8

Choosing general file options.
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When you or another user attempts to open the
file, the message shown in Figure 5-9 is displayed.
Click Yes to open the document as a Read-Only file.
If you choose No, Word again recommends you

@ Business Plan should be opened as read-only unless changes to it need to be saved. Open as read-only? |

[ ves ] [ mo | [ cancel | [ Hep |

Assigning a File Password

Another method to protect your documents, and
probably one of the safest methods, is to assign a
password. When you assign a file password, the
application uses a key to encrypt the document'’s
contents. Word, Excel, and PowerPoint all allow
you to assign passwords. There are two levels of
password protection you can use. One forces any-
one who attempts to even open the file to supply a
password. Of course, if they cannot open the file,
they cannot view it or modify it. The second level is
where you could allow others (with or without
password protection) to open the file and view it,
but not allow them to edit the file in any way with-
out first providing another password.

INOTICE]|

AUTHORIZED

PERSONNEL
ONLY
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open the file as Read-Only, but if you click No
again, the file finally opens as a standard file where
changes can be made.

Figure 5-9
The read-only recommendation
box.

To create file passwords, click the File tab and
choose Save As. Select a folder for your file and
enter a file name. Choose Tools > General Options.
The General Options dialog box appears. Type a
password in the Password to Open text box if you
want users to enter a password before they can
open and view the document. Word displays pass-
words with a black dot for each character, like
those shown in Figure 5-10.

File encryption options for this document
Password to open: guessess

File sharing options for this document
Password to modify: |

| Read-only recommended

Macro security
Miusttl'besewﬁvlwdforopemqfiesthatnﬂw
contain macro viruses and specify the names of
trusted macro developers.

Macro Security...

t OK_EICmd

Figure 5-10
Assigning a file password.
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The Perfect Password

Good passwords should be at least eight
characters and should contain a mixture of
numbers as well as upper- and lowercase
letters. Passwords are case sensitive. Don't,
however, make your passwords so difficult
you can't remember them. If you lose the
password to your Word, Excel, or PowerPoint
document, it cannot be recovered!

Optionally, you can leave the Password to Open box
empty and enter a password in the Password to
Modify text box. Using this option allows others to
open the file, but they cannot make any changes
without keying in the password. Click OK, and a
message box appears prompting you to reenter the
password just in case you typed it incorrectly the
first time. Reenter the password as prompted and
click OK; then, click the Save button to save the
password security.

Tip

If you want to use both a password to
open and a password to modify, it's a
good idea to use different passwords for
each function.

When you or anyone opens the file, Word prompts
you for the password (see Figure 5-11).

f Password E&M1

e,

Enter password to open file
C:\...\Diane\DocumentsBusiness Plan.docx

] I Cancel ] .
LLL——_HJ’
Figure 5-11
Enter the required password to open the file.

Tip

To remove file passwords, from the
General Options dialog box, delete the
characters from the Password to Open or
Password to Modify text box and resave
the file.

Understanding Protected View

In today’s world, we must be very careful when we
open documents created by others. It's too easy to
open a virus along with the document, and we all
know by now what havoc a virus can cause.

If you have an up-to-date anti-virus program on
your computer, you shouldn’t have too much of a
problem. However, not everyone has an up-to-date
anti-virus, and we have to face it—the bad guys are
out there everywhere. To lessen the worry, Word
now comes with an extra security feature called
Protected View.
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Protected View is a way for Microsoft to show Word
(and other Office applications) files to you, but
without all of the worry about those files being
dangerous. When a file is detected to originate
from the Internet, Word opens the file in a read-
only view, which has minimal access to your sys-
tem, and no access to your other files and informa-
tion. Even if the file is malicious, it can't get out
and do harm to your computer or data.

Tip

Occasionally, Word also opens files that
originated on a network server in
Protected View.

Once you indicate that you trust the file, the next
time you open the file, Word remembers when you
chose to trust it, so you don't have to re-trust it
next time. That's Word's way of making security
strong, but still smart enough to get out of the way
when its job is done.

When you open a potentially dangerous file, Word
displays the file in read-only mode (look, but don't
touch) with a yellow bar across the Ribbon indicat-
ing the file is in Protected View. (See Figure 5-12.)
If you trust the file origin, click the Enable Editing
button, and you can then work on the document.
If you don't click Enable Editing, Word ignores any
action you take to alter the document.

d9- 0= — .;er-:reﬁt-dispuhe-hner@mumd View) - Microsoft Word
Home Insert

Page Layout References Mailings Review View

——

E_ -'1—__.'_':(:}:%.3.

0 Protected View  This file originated from an Internet location and might be unsafe. Click for more details. Enable Editing —_—

SO

— Enable Editing button

A A e

Figure 5-12
A document in Protected
View.

Saturday, Apnl 03,2
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Printing and Sharing

nd now it's time to use it. With the adop- right to enlarge'or reduce Fhe view, or

tion of e-mail within most corporations and click anyyvhere in the Preview window
homes, many documents today might never be to zoom 1n or out.
printed on paper—they may only ever exist in an
electronic form; however, there may still be times Page number box Next Page Zoom controls
when you need a paper copy. This section shows | / |
you how to distribute your document both elec-
tronically and on paper.

YOU DID IT! You created a great document, P Use the Zoom controls at the lower
a

Busfhess Flan

Using Print Preview e
Before you print your document, you should pre- ———— o
view it on the screen so you can look at how docu- e ?g;'*“?*““mmm
ment layout settings (such as the margins) will e e T T B
look in the printed document. In Print Preview, o o s v s o
although you can only view the document and can- P R e ——
not edit it, you can tell quite a bit about it from a e o P s e gl
different perspective. The following steps walk you ey
through the Print Preview process: i #":“m‘mxam;;ﬁ?:’“""““”
vl oves e v oo g
1. Click the File tab and, from the Backstage m _1/ it o b hosplty sy, sk, o
view that appears, choose Print. A Print
Settings section appears on the left and a pre-
view of the worksheet appears on the right. i hlih P om

Figure 5-13

2. From the Preview area (shown in Figure 5- o o
Previewing your document before printing it.

13), select from the following options:

P If you have multiple pages, click in the
page number box, then click the Next
Page or Previous Page buttons to view
additional pages.

3. If you're ready to print your document, con-
tinue to the next section, but if you want to
return to the document, click the File tab.
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Printing a Document

When your document is complete and you've
reviewed it for any changes, you may want to make
a hard copy of it to file away or to share with oth-
ers. Click the File tab and, from the Backstage view
that appears, choose Print. A Print Settings section
appears on the left and a preview of the worksheet
appears on the right. The Print Settings section
shown in Figure 5-14 illustrates the many printing
options. Take a look at a few of them:

» Copies: Select the number of copies you
want to print.

» Printer: If you are connected to more than
one printer, you can select which printer
you want to use from the drop-down list.

P Settings: Determine which pages you want
to print. If you highlight a document area
before you display the Print dialog box, you
can choose Selection to print only that
area. If you want to print only selected
pages, enter into the Pages text box the
page numbers separated by a comma or a
dash. For example, to print only the first
three document pages, enter 1, 2, 3 or 1-3.
Other settings include options such as mar-
gins, paper size, or collating options. The
last option (Page Per Sheet) determines
how many document pages you want to
print on a single sheet of paper. The for-
matting and document page layouts do not
change; Word simply reduces the size of
each printed page to fit the number of
pages that you select. This feature is help-
ful as an overview or handout document.

Choose any desired options and then click the
Print button to begin printing.
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L~ Print button

Print
=
Print

Printer
/ Send To OneMote 2010 -
% Ready
Printer Properties
Settings

4 Print All Pages

4 Print the entire document
Pages:

| Print One Sided =
I} Only print on one side of the p...

‘_]l_] Collated =

123 123 123
j Portrait Orientation -

Letter
85" x 11"

Normal Margins
i— Left: 1" Right 1"

J 1Page Per Sheet M Figure 5-14

Bage Setup Print settings.

E-Mailing a Document

If you have e-mail access, you can send a document
directly to another person. Word copies the content
of the document as an attachment to an e-mail
message. While many e-mail applications work fine
with this feature, Office works best with Outlook
and Outlook Express.
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With the document open and ready to send, click
the File tab and choose Save & Send > Send Using
E-Mail. Then click the Send as Attachment button
shown in Figure 5-15.

i ness Plan + Miceosoft Word
Mome  bset  Pagelmuut  Refeences  Mulings  Redew  View
: fe Save & Send Send Using E-mail
5 ooen (LY samimgEmi ) | * ok soran i
o cose e &;, Changes and feedback need to be incorporsted manually Send as Attachment
o 0 A Agtachment.
et u Save to SharePoant Create an e-mail thak containg a link to this dotument
i Eviryore works on the same copy of this docurent
N - R i e
Print File Types [y Document must be saved in » thared location
R W
» !.; Creste PDF/XPS Document Sendas ::;:ximr‘m"?h:::“!“
2] Cethons POF
e Py Airnch 3205 copy of this docuenent b an e-ml
“ Pt e
Sand 03305 Content cannct be easily changed
Send v Iternet Fax
Send » fax without using » fax machane
ﬁ‘ PRaquires  fa senvice Di’whm-
Inkerreet Fax
Figure 5-15
The Save & Send screen.
Word launches your e-mail application with the file document name as the subject, but you can click
listed as an attachment. Type the recipient’s e-mail the Subject text box and change the subject.
address or click the To button to select from your Optlopally, type a message in the message body
Outlook Contact List. Word automatically adds the (see Figure 5-16). Click the Send button when you

are finished.

usiness Plan - Message (HTML)

Message | Insert  Options  FormatTedt  Review a @

= ® ﬂ:‘l@j g 8 z ¥ Follow Up - ".:2

1 High Importance

= . .
_] ¥ CalibrifBoch - 11 - AT a7 | IS
b a

Faste . B I #7. A [BE|ZT F iEGE Address Check  Attach Attach Signature Zoom
Y z A ] (G el # towimportance
Clipboard & Basic Text ] Names Include Tags =| Zoom
To.. madonnadoeeomeast.net
J Ceu
Sen
Subject: Business Plan
Attached: | E] gusiness Plan doce (4 KB
&
Hi Madonna, g

Please take alook at my business plan and let me know if you see any errors,

‘I'I.wnks!

e Figure 5-16

E-mailing a Word document as
an attachment.
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Part 2

Longer Documents

There's more to Word than short letters and memos.
Now that you are more comfortable with the basics of
Word, I'll show you how you can view your documents
from different perspectives and generally work with
longer documents. In this part, you'll discover outlines,
mass mailings, and adding referencing information such
as bibliographies, footnotes, tables of contents, and
indexes. Using features like these makes creating legal
briefs, annual reports, catalogs, and other complex doc-
uments much easier.







Working with Document

Views

ICTURE YOURSELF GOING OUTSIDE on a beautiful spring
day. If you look up, you see the sky and the birds. If you look down,
you see the grass and pavement, and if you look around, you see
flowers, shrubs, cars, and people. The general view is of the outside, but
as you move around, your perspective changes.

Word provides several different view perspectives to use when displaying
a document, each having its own purpose. There is Print Layout view
where you can see all elements in your document up close. Full Screen
Reading view limits the distractions, and you can focus strictly on reading
the document content. Web Layout view shows you how your document
might appear on a website. Draft view hides margins, graphics, headers
and footers, so you can concentrate on editing the document content.

Viewing your document from different angles is what this chapter is
about. You'll discover when and how to use each of the views, as well as
how to zoom in for a closer look or zoom out for an overall look.



Viewing a Document

ORD PROVIDES SEVERAL different Print Layout View

view perspectives to use when displaying

a document, each having its own pur-
pose. For each of the following views (except Print
Preview), choose View > Document Views and
select an option.

Print Layout (the default view), allows you to see
how text, pictures, graphics, and other elements
will be positioned on the printed page. This view is
especially helpful if you are working with text
columns. In Print Layout view, you'll see the docu-
ment's top and bottom margins, as well as the
headers and footers. The top and bottom margins
Ti appear, and page breaks between pages are indicat-

P

ed by a darker area.

Word also displays icons along the status
bar that allow you to choose most of the
view options.

EIN you are not already in Print Layout view,
you can easily switch to it by clicking View >
Document Views > Print Layout or click the Print
Layout icon on the status bar. In Figure 6-1, you
see a document in Print Layout view.

W90 Dedaration of Independence - Microsoft Word = & =
Home Insert Page Layout References Madlings Review Wiew a g

| 3 Ruer %] [llone Page ] 9 = p = B

A ol - 1 ] L

| 0 | e Gredines v oL 4l Two Pages — 3 i 2

Prink |Full Soreen Web  Owtline Draft Toom  100% Hew  Aminge  Spit Sweitch Macros
ading  Layout Nwdgation Pane W Page WA | indow il : Windews -

rq ROt BRI BT SOSCICR SCRCICN SO NORCRCN SR, 77

Py

Declavation of Jndependence

. When in the Course of human events, it becomes necessary for one people to
2 dissolve the political bands which have connected them with another, and to
assume among the powers of the earth, the separate and equal station to which the
Laws of Nature and of Nature's God entitle them, a decent respect to the opinions
of mankind requires that they should declare the causes which impel them to the
separation.

We hold these truths to be self-evident, that all men are created equal, that they are
endowed by their Creator with certain Unalienable Rights, that among these are
Life, Liberty, and the pursuit of Happiness. That to secure these rights,
Govemments are instituted among Men, deriving their just powers from the

consent of the govemed.
Figure 6-1 L
. . . 2 | .- -
View document pictures in : ] 2
. . s [ :
Print Layout view. Paguitors | oD B O W Yo ——
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Full Screen Reading View If your document has multiple pages, you see the
document in two-page view, similar to reading a

book. However, if you have trouble reading the doc-
ument, you can adjust the reading font size without
actually affecting the document itself. Choose View
Options > Increase Text Size or hold down the Ctrl
key and roll your mouse scroll wheel forward until
the font is large enough for you to read.

Using the Full Screen Reading view hides most of
the Ribbon and other screen elements and displays
your document two pages at a time, usually in a
larger font size, scaling the contents of your docu-
ment to pages that fit comfortably on your screen,
making it easy to read. When in Full Screen Reading
view, the page breaks are not necessarily the same
page breaks as those in the printed document,

although you can change the settings so you are Word prgvides several methods to move from page
reading the document as it appears when printed. to page in a document:

EA To switch to Full Screen Reading view, choose P Click the navigation arrows at the top cen-
View > Document Views > Full Screen Reading or ter of the screen

click the Eull Screen Reading icon on the status » Click the arrows in the lower corners of the
bar. See Figure 6-2 for an example of a document pages.

in Full Screen Reading view.

i L e Toou -0} [%7 - L Seeenllatd - b i View Options = X Close

\ Close button

= genesl \
mseresz View options

Declavation

When in the Course of human events, it b
necessary for one people to dissolve the politica
bands which have connected them with another, and to
assume among the powers of the earth, the separate
and equal station to which the Laws of Nature and of
Mature's God entitle them, a decent respect to the +
opinions of mankind requires that they should declare os
the causes which impel them to the separation. o ¥ \ . .
Navigation arrows

We hold these truths to be self-evident, that all men That whenever any Form of Governmein

are created equal, that they are endowed by their destructive of these ends, it is the Right of the Pea

Creator with certain Unalienable Rights, that among to alter or to abolish it, and to institute new

these are Life, Liberty, and the pursuit of Happiness. Government, laying its foundation on such principles s

That to secure these rights, Governments are instituted and organizing its powers in such form, as to them Toolbar
among Men, deriving their just powers from the shall seem most likely to effect their Safety and

consent of the governed. Happiness. Prudence, indeed, will dictate that

Governments long established should not be changed
for light and transient causes; and accordingly all
experience has shewn, that mankind are more

disposed to suffer, while evils are sufferable, than to
right themselves by abolishing the forms to which they
are accustomed. But when a long train of abuses and
usurpations, pursuing invariably the same Object,
evinces a design to reduce them under absolute
Despotism, it is their right, it is their duty, to throw off

Figure 6-2
View document pictures in
Full Screen Reading view.




» Press the left or right arrow keys to view the
next or previous pages.

» Press the Page Down key or the spacebar to
view the next pages.

» Press the Page Up key or backspace to view
the previous pages.

Jump to a Screen

To quickly display the last screen of the docu-
ment, press the End key or press the Home
key to quickly display the first document
screen.

The Full Screen Reading view has a toolbar along
the top left of the screen. (See Figure 6-3.) From
here you can save, print, highlight document
areas, or add comments to the document. There is
also a tool to translate selected words or phrases
from your document into a different language.
The Tools arrow on the toolbar provides options to
research document selections, choose a text high-
light color, add a comment, or locate document
words or phrases.

= 3 %Tuuls'[glﬂ' 2

Figure 6-3
Full Screen Reading view toolbar.

At the top right of your screen, you see a View
Options button. Clicking the View Options button
displays a menu. From the View Options menu
(shown in Figure 6-4), you can select from a num-
ber of choices. Let's take a look at a few of them:

» Don’t Open Attachments in Full Screen:
If you are using Microsoft SharePoint
Services, you can view your e-mail in a Word
document. When selected, this item blocks
the attachments to protect your document
security. This option is active by default.

Tip

Active menu items have a border around
them.

» Increase Text Size or Decrease Text Size:
As mentioned earlier, you can choose one
of these options to zoom in or out on your
document.

» Show One Page or Show Two Pages:
Select one to determine how many screen
document pages you want to see at a time.
Two pages is the default option.

» Show Printed Page: Choose this if you
want to see your document as it will look
when printed.
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P Margin Settings: Allows you to see the
document margins. This feature only
becomes available if you have Show Printed
Page activated.

» Allow Typing: By default, you cannot edit
your document while in Full Screen
Reading view, but click this feature and you
can then add or remove text from your doc-
ument. You cannot access Ribbon tools for
formatting features, but you can use key-
board shortcuts. For example, select your
text and press Ctrl+B to add bolding to the
selected text.

» Track Changes, Show Comments and
Changes, and Show Original/Final
Document: All three of these changes per-
tain to using Word's document tracking fea-
ture. See Chapter 16 for more information.

f:lj\fiew Options '] X Clos

Don't Open Attachments in Full Screen
J Don't open e-mail attachments and documents from a
Microsoft SharePoint Foundation site in full screen view,

Increase Text Size

a
A Make the text larger for reading. Temporarily changes
how much text fits on a page.

» Decrease Text Size

Show One Page
Read one page at a time.

| Show Two Pages
View two pages at a time,

Show Printed Page
Show pages as they will look if printed.

Margin Settings

- Allow Typing
Allow typing while reading. Set this if you like to edit
your documents as you read them,

[= Track Changes
Track changes made to the document.

= Show Comments and Changes »
Q; Show OriginalfFinal Document »
Figure 6-4

View Options menu.

X Close (Click the Close button to return to the
previously used view.
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Web Layout View

If you are designing a document you plan on pub-
lishing to the Web, the Web Layout view is very
helpful because it imitates how you see the docu-
ment if it were viewed in a Web browser. Web
Layout view hides page breaks and displays the
document as if it were one long page.

5 Choose View > Document Views > Web
Layout. Figure 6-5 shows a document in Web
Layout view.

HT -0 Dedaration of hdependence - Micrascit Word
Home  sert  Pagelmoat  References  Mallings  Review | View

Declarvation of Jndependence
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‘When in the Course of human events, it becomes necessary for one people to dissolve the political bands which have connected
them with another, and to assume among the powers of the earth, the separate and equal station to which the Laws of Nature and of
Nature's God entitle them, a decent respect to the opinions of mankind requires that they should declare the causes which impel

‘We hold these truths to be self-evident, that all men are created equal, that they are endowed by their Creator with certain Unalienable
Rights, that among these are Life, Liberty, and the pursuit of Happiness. That to secure these rights, Govemments are instituted
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Figure 6-5
Web Layout view.
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Outline View

Outline view displays your text in an expandable
and collapsible view by heading levels. It includes
an outlining tab from which you can display levels
as well as promote and demote headings. (See
Chapter 8 for information on outlines.)

= Choose View > Document Views > Outline or
click the Outline icon on the status bar. Figure 6-6
shows a document in Outline view. Notice that
when switching to Outline view, Word displays an
additional Ribbon tab. From the Ribbon tab, you
can make outlining modifications. In order for you
to use Outline view effectively, your document
must contain heading styles. Refer to Chapter 3 for
a refresher on using Word styles.
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© Surviving a Recession
Here are a few things that you can do to stay shesd during a recession and ..,
> Improve your knawledge and skills
Improve Customer Service
Control your expanses
Start accapting payments by credit card
Lower your profit marngins
Use the power of the Internet
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Improve Your Knowledge and Skills.
© Now would be a good build on your ige and | sills ..
Improve Customer Service
© Make sure that each and every customer gets special trestment snd leaves ...
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@ This nat only will enhance your reputation as an expert, but will also ensure ...
© Control Your Expenses

® Nowisth fior ghten upth i5 on all your expenses, ...

® You should also split large expenses into smaller ones so that they become ...

© Start Accepting Payments by Credit Card
® If you are dealing in consumer goods, then you probably already havea ...
© Lower Your Profit Margins
L] g it will only porary, this is g o lower ...
© Use the Power of the Internet
® Usethe Internet to advertise your products. In compasison to traditional ...
© Motivate Your Staff
® Your staff should be made aware of your business’ situation in the current ...
_ ® Usethese ideas and seek others on your own £o your small business will ...
. Figure 6-6
4 1
Puge 1012 | Words 636 | <5 | @R E wm =) V) i Outline view.
When you are finished using the Outline view, page breaks or section breaks by a dotted line.
choose Outlining > Close > Close Outline View or Headers, footers, page margins, backgrounds, and
click a different view button from the View con- some other objects do not appear in Draft view. It's
trols on the status bar. my personal favorite.

Draft View = Change your document to Draft view by
choosing Views > Document Views > Draft or by
clicking the Draft view icon on the status bar.
Figure 6-7 shows you a document in Draft view.

Draft view is a general purpose (mostly) text-only
view used for typing, editing, and formatting text.
It simplifies the layout of the page so that you can
type and edit quickly. In Draft view, Word indicates
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‘When in the Course of human events, it becomes necessary for one people to
dissolve the political bands which have connected them with another, and to
assume among the powers of the earth, the separate and equal station to which the
Laws of Nature and of Nature's God entitle them, a decent respect to the opinions
of mankind requires that they should declare the causes which impe them to the
separation.

We hold these truths to be self-evident, that all men are created equal, that they are
endowed by their Creator with certain Unalienable Rights, that among these are Life,
Liberty, and the pursuit of Happiness. That to secure these rights, Governments
are instituted among Men, deriving their just powers from the consent of the
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govemned.
i Figure 6-7
4 1
Page: Lot5 | Woros 1072 | B FEERIOE I 0 + Draft view.
Tip

One other perspective you will find helpful is Print Preview. See Chapter 5 for more information.

Using the Zoom Feature

SING WORD'S ABILITY to zoom in on a

document allows you to examine your doc-

ument more closely or in greater detail
through a close-up view of your text. You can also
zoom out to see more of the page at a reduced
size. Zoom settings do not affect the arrangement
of text when you print the document.
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Choose View > Zoom, and you see that Word pro-
vides a number of different ways you can zoom in
or out of your document:
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) 200% () Page width (©) Many pages:
Using the Zoom feature does not alter the ©{100%} ©) Text width ﬂa
size at which the document will print. ) 75% ) Whole page =
Percent: 100% |+
Preview
AaBbCcDdEeXxYyZ
100%  CJ i =
> Cllgk the Zoom but.ton to display AaBbCcDAEeXXYYZ
the Zoom dialog box (see Figure 6-8) where z
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icon on the status bar.
. . OK Cancel
P Choose View > Zoom > One Page to view [ J { ]
the entire page (see Figure 6-9). .
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The Zoom dialog box.
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» Choose View > Zoom > Two Pages to view » Choose 100% to return to the normal zoom
two pages side by side. Use the scroll bar to rate of 100%.
scroll down through the document two

tati » Drag the Zoom slider located on the status
pages at a time.

bar to zoom in and out as desired. The cur-

» Choose Page Width to view the page by rent zoom rate appears next to the Zoom
page width. slider.
Zoom In Tip

Setting the Zoom to Page Width can be very
helpful if your document page orientation is
set to landscape.

If your mouse has a scroll button on top,
you can use it to zoom in and out. Hold
down the Ctrl key and move the scroll
button forward to zoom in or backward to
zoom out.

Working with Split Windows

F YOU WANT TO SEE two parts of a docu- arrow appears at the mouse pointer. Click the
I ment, but you can't get them on the screen at mouse where you want the window divided, which
the same time, you can split a window. Doing then locks in the split. The yvindow div.ides into
so enables you to view part of a long document in two sections with each section havmg its own
the upper window while you view another part of scroll bar and rulers. Take a look at Figure 6-10,
the document in the lower window. which shows page 1 in the top section and page 5

in the bottom section.

When you split a window, each window panel con-
tains its own scroll bar. Choose View > Window >
Split. A horizontal line with a double-headed
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Declavation of Jndependence

| When in the Course of human events, it becomes necessary for one people to
|-l dissolve the political bands which have connected them with another, and to
| assume among the powers of the earth, the separate and equal station to which the
2 Laws of Nature and of Nature's God entitle them, a decent respect to the opinions e
of mankind requires that they should declare the causes which impel them to the
separation.

I

i
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and Independent States, they have full Power to levy War, conclude Peace,

| contract Alliances, establish Commerce, and to doall other Acts and Things which
- Independent States may of right do. And for the support of this Declaration, with a
. firm reliance on the protection of divine Providence, we mutually pledge to each
other our Lives, our Fortunes and our sacred Honor.

|

NOTE: This text of the Declaration of Independence is taken from the reprint in

the Revised Statutes of the United States, corrected by comparison with the version

in the journal of the Continental Congress. The original manuscript can be seen in

the National Archives, Washington, D.C.
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Figure 6-10
Splitting the window.
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When you want to remove the window split,
Resize Spli’[ Windows choose View > Window > Remove Split. Your docu-
ment reappears in a single window.

To resize the windows, position the mouse at
the top, bottom, or side of the either window
until the mouse pointer becomes a double-
headed arrow, and then drag the line until
the windows are the desired size.
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Comparing Documents Side by Side

two documents side by side, perhaps to

compare one version to another. Word pro-
vides the ability to view any two open windows
next to each other.

O CCASIONALLY, YOU MAY want to view

Choose View > Window > View Side by Side. If you
have more than two Word documents open, Word
first requests which window you want to compare
to the top current window (see Figure 6-11). If you
have only two open Word documents, you do not
see this Compare Side by Side dialog box.

Compare Side by Side
Compare Side by Side with:
butterflies [Compatibility Mode] i
Surviving a Recession
[ ok ][ cancel |
Figure 6-11

Which documents do you want to compare?

Tip

To edit a document, click anywhere in the
document window.
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By default, the two windows are synchronized so
that, as you scroll through one window, the other
one scrolls with it. If you want to scroll through the
windows independently, you need to turn off
Synchronous Scrolling. From either window,
choose View > Window > Synchronous Scrolling.
See Figure 6-12.

Synchronous Scrolling button

When i the Course of buman evests, it becomes pecessuy for ane people 1o
dhssabve the political bands which have connected them with ssather, and 1o
earth,

mong the p -  equal stasion 1o which the
Laws of Nature and of Nature's God enfitle them, a decent respect to the opinions
af mamkind requires that they should declare the causes whach smpel then to the
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eparation |
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T
2 E sstroe samocece | papn| | A 8, i
A ] Rk B E-A BEEE I B teems T | sy | B

Surviving a Recession

Figure 6-12
Viewing multiple document windows.

To return to a single document window, deactivate
the feature by choosing View > Window > View
Side by Side.



Chapter 6

Working with Document Views

Using the Navigation Pane

F YOUR DOCUMENT is quite lengthy, it can be

difficult and time consuming to navigate through

the document. However, if your document con-
tains heading styles, you can use the Navigation pane
feature to ease navigation. The Navigation pane also
allows you to examine the document flow for com-
pleteness and ensure that formatting is consistent.
Think of a Navigation pane as a simple table of con-
tents. Choose View > Show > Navigation Pane. A
Navigation pane, like the one shown in Figure 6-13,
appears on the left side of the screen.

Each item in the Navigation pane represents a
heading in your document; you can click any item
to move the insertion point to that place in the
document. You can click the plus sign (+) to
expand a heading or click the minus sign (-) to
hide subheadings.

To hide the Navigation pane, choose View > Show
> Navigation Pane, which removes the checkmark
from the Navigation pane option and closes the
Navigation pane.

Blank Navigation Pane

If the document does not contain any heading sty

les, the Navigation pane will be blank.
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Adding Supplementary

Flements

' ICTURE YOURSELF ORGANIZING antiques and collectibles to
= prepare for an auction. You create a tag for each item to identify it.

| ' You also take a photo and write a brief description—including the
provenance—so that you can create a listing for each item in the auction
catalog. You need to be really organized to pull it all together in time and
make it easy for buyers to find the items they want.

Longer documents, such as sales proposals, annual reports, and catalogs,
usually include pictures or illustrations that need to be identified, infor-
mation from other sources, references to legal statutes, and key terms or
jargon. Packing more content into a document gives the reader much
more to navigate. That's why learning about Word's tools for referencing
information will pay off. You'll be able to create documents that not only
meet professional or academic standards for referencing sources, but also
enable readers to find and jump to key information with ease.




Working with Pages

manual page breaks in a document. Manual

page breaks can come in particularly handy for
long documents, for example, when you want to
move a heading or picture to the top of the next
page. You can use additional page-oriented fea-
tures to add necessary or decorative information to
any document, long or short. This section shows
you what some of those features are and how to
use them in Word.

I N CHAPTER 4, you learned about creating

Creating a Cover Page

Most formal documents like reports and proposals
do not launch right into the text. Instead they
include a title page or cover page that provides
basic information about the document. The infor-
mation contained on a cover page can include the
document title, a subtitle, a brief summary of the
document (called an abstract), the year or date it
was created, the author’s name, a company name
and address, or even an image that illustrates the
document’s contents.

Word 2010’s Building Blocks Organizer offers 19
preformatted cover pages that you can add to any
document. Each cover page has preformatted
placeholders that prompt you to add applicable
text. The more simple cover page designs include
design elements like rules and blocks of color,
while the more advanced designs include other
graphic elements like photos and drawn objects.
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To add a cover page to the current document,
choose Insert > Text > Quick Parts > Building
Blocks Organizer. In the Building Blocks Organizer
dialog box, scroll down the Building Blocks list and
click one of the choices with Cover Pages in the
Gallery column. As shown in Figure 7-1, a preview
of the selected cover page appears at the right side
of the dialog box. When you've found the cover
page you like, click Insert.

Word inserts the cover page as the first page in the
document. You can go there and replace the place-
holder information in the square brackets. Of
course, you can substitute information other than
that suggested by a placeholder. You also can
delete a placeholder by clicking it, then clicking
the tab that appears, and then pressing Delete to
remove it.

Tip

Clicking a date placeholder displays a
drop-down list arrow. Click it to open a
calendar from which you can select a date.
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[ Building Blocks Organizer = = &2
Building blocks: Click 2 building block to see its preview
Name Gallery Category Template o &
Works Cited  Bibliograp...  Built-In Built-In Buil... |; — -
Austin CoverPages  Built-In Built-In Buil... —
Contrast Cover Pages  Built-In Built-In Buil...
Exposure CoverPages  Built-In Built-In Buil...
Transcend  Cover Pages Built-In Built-In Buil...
Sideline Cover Pages  Built-In Built-In Buil...
Stacks CoverPages  Built-In Built-In Buil...
Puzzle CoverPages  Built-In Built-In Buil... [Typ e th e
Conservative Cover Pages Built-In Built-In Buil... v
Austere CoverPages Built-In Built-In Buil... document tltle] ¢
Tiles Cover Pages  Built-In Built-In Buil... ok e St aatiiend
Perspective  Cover Pages  Built-In Built-In Buil... ! -
Annual CoverPages  Built-In Built-In Buil... B
Pinstripes Cover Pages  Built-In Built-In Buil...
Cover Pages Built-In Buil...
| | Alphabet Cover Pages  Built-In Built-In Buil...
| | Med CoverPages  Built-In Built-InBuil... | (§ .l
Cubicles CoverPages  Built-In Built-In Buil...
Grid CoverPages  Built-In Built-In Buil...
Motion Cover Pages  Built-In Built-In Buil... =
Trig Identit... Equations Built-In Built-In Buil... =
Adbnmmsns  Faisbins . T P temn | Newsprint
4 ] » Tithe with abstract and a paper texture with a large block of
[ EdtPropertes... | [ pelete | [ nsert color at the top.

Figure 7-1

Chapter 7

Selecting a cover page design.

Displaying a Watermark

Paper with a watermark has a semi-transparent
imprint that's visible only when you hold the docu-
ment up to the light. For some types of docu-
ments, such as checks, the watermark provides a
way to verify a document's legitimacy. In Word
2010, a watermark is a lightly printed background
image, often used to signal a document's status,
such as CONFIDENTIAL or COPY. Word includes a
few predefined watermarks that you can add to a
document by choosing Page Layout > Page
Background > Watermark, and then clicking one of
the choices at the top of the menu that appears,
shown in Figure 7-2.

Confidential e

CONFIDENTIAL 1 CONFIDENTIAL 2 DO NOT COPY1

DO NOT COPY 2 -
59 More Watermarks from Office.com »
4] Custom Watermark...
18 Remove Watermark
a

Figure 7-2

Predefined watermarks.
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However, Word doesn’t limit you to using its water-
marks. You can create a picture watermark, such as
if you want to include a logo behind the text on
every page. Choose Page Layout > Page Background
> Watermark > Custom Watermark. In the Printed
Watermark dialog box, click the Picture Watermark
option button, and then click the Select Picture
button. Select the desired picture in the Insert
Picture dialog box, click Insert, and then click OK.

You also can create your own text watermark that
uses the word or phrase that you want and format-
ting that you specify. Choose Page Layout > Page
Background > Watermark > Custom Watermark,
and this time click the Text Watermark option but-
ton. You choose one of the predefined words from
the Text drop-down list in the Printed Watermark
dialog box, or type your own word or phrase into
the text box, as shown in Figure 7-3. If needed, you
can choose an alternate Font, Size, and Color in the
dialog box, and change the layout between
Diagonal and Horizontal. You also can use the
Semitransparent check box to control the water-
mark's opacity. When you finish making your
choices, click OK.

Custom text entry

Printed Watermark / M
~) No watermark
Picture watermark
Scale: Auto | Washout
@) Text watermark
Lenguage: | Engish U.s) | [~]
Text: Prepared by Diane E]
Font: Century Schoolbook [+]
Size: Auto [+]
Color: E] V] Semitransparent
Layout: @) Diagonal () Horizontal
oy J[ ok ][ concel |
Figure 7-3

Custom text watermark settings.
126

To remove a watermark, choose Page Layout > Page
Background > Watermark > Remove Watermark.

Different Page, Different Watermark

Any watermark you apply appears on every
page of the document and is anchored to the
header area. If you need a watermark to
appear on limited pages in the document,
create a new section and apply the water-
mark in that section. Then, edit the header
for the new section, choosing Header &
Footer Tools > Design > Navigation > Link to
Previous to unlink the header. You can then
add and remove a watermark in the new sec-
tion. See Chapter 4 for more on section
breaks and footers.

Changing Page Color

If you plan to publish a document as a Web page
or a document's recipient will be viewing it
onscreen, you can add a page background to all
the pages in the document. (By default, page back-
grounds do not print.) You can see the page back-
ground when you view the document in Print
Layout, Full Screen Reading, and Web Layout
views. To apply one of the current theme colors or
a standard color as the page background, choose
Page Layout > Page Background > Page Color, and
then click a color in the gallery that appears, as
shown in Figure 7-4. The No Color choice removes
any previously applied page background.
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Chapter 7

Tip

To print your Page background, choose
File > Options. From the Display section
(under Printing options), check Print
Background Colors and Images, and then
click OK. Many printers do not print to
the edge of the paper, so you may still see
a white border around the page.

Theme Colors

Standard Colors
[ § |  HEEEN

No Color

More Colors...

Fill Effects...

Figure 7-4
Page colors.

If a plain color doesn't provide the look you want,

you can instead fill the page background with a gra-

dient, texture, pattern, or picture. Choose Page
Layout > Page Background > Page Color, and then
click Fill Effects at the bottom of the gallery. In the
Fill Effects dialog box that appears, click the tab for
the type of background you want to create, use the

tab's settings to select the desired fill (such as gradi-

ent colors or a texture), and then click OK. To
remove a page background fill effect, choose Page

Layout > Page Background > Page Color > No Color.

Adding Page Borders

A page border surrounds all of the text and other
contents on a document page. In the Borders and
Shading dialog box, you can select a line style,
color, and width for the border, or even select dec-
orative art to serve as the border. You also can use
the choices in the Apply To drop-down list to con-
trol where the page border appears:

» Whole Document: Adds the page border
to all pages in the document.

P This Section: Adds the page border only to
pages in the current section.

P This Section — First Page Only: Adds the
page border only to the first page in the
section.

» This Section — All Except First Page: Adds
the page border to all pages except the first
page in the section.

To add a page border, choose Page Layout > Page
Background > Page Borders. In the Borders and
Shading dialog box (shown in Figure 7-5), first
choose Style, Color, and Width settings in the cen-
ter area of the Page Border tab. Alternately, choose
a decorative border style from the Art drop-down
list. Then click one of the Setting choices on the
left, such as Box or Shadow, to apply the border.
Finally, make a choice from the Apply To drop-
down list to control which pages in the document
show the border. Then click OK.
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/ Border format choices

/ Apply To list

Borders and Shading
Page Border | Shading
Setting: Styje: Preview
_-i— None Click on diagram below or use
Box e
Shadow R
= Color
E| e | Automatic
= Width:
=|| custom | [12pt
LA}
_N;t: E
IITTI0
e o ][ conce

J Figure 7-5

/ Page border settings.

Tip

If Word's predefined cover pages are too elaborate for you, you can create your own cover page by
adding a border to the first page of the first section of the document and type the needed informa-

tion on that
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Creating Footnotes and Endnotes

HEN YOU QUOTE or heavily refer-
Wence information from another source,

as when writing an article or report, you
should indicate the source of the information.
Word enables you to identify sources using either
footnotes or endnotes. Each footnote appears at
the bottom of the page holding the cited infor-
mation, while endnotes appear together at the
end of the document.

Know Your Footnote Style

The information and punctuation used in a
footnote or endnote is defined by its style.
Teachers, instructors, publishers, and some
other organizations often require you to use a
particular style, such as the MLA style estab-
lished by the Modern Language Association.

Back in the typewriter era, you had to change the
carriage position to create the superscript footnote
number, and then leave room at the bottom of the

page for the footnote itself. If you planned wrong
and didn't leave room for a subsequent footnote on
the page, you would have to retype the entire page.

That's what makes Word's automated footnote and
endnote capabilities so beneficial. Word properly
numbers and formats footnotes and endnotes,
adjusts the page break based on the number of
footnotes on the page, and compiles endnotes in
the correct order for you.

Creating a Footnote or Endnote

It takes mere moments to create a footnote or end-
note. Start by typing in the quoted or paraphrased
text from the source. With the insertion point
directly to the right of the last character in the
information or closing quotation mark, choose
References > Footnotes > Insert Footnote or
References > Footnotes > Insert Endnote. Word
inserts the number for the footnote or endnote in
the text, and then moves the insertion point to the
location for the corresponding footnote or end-
note. Type the text for the note in the proper style.
Figure 7-6 shows an example footnote.

Number inserted in text —|

Corresponding footnote with
text entered

w era of building with straw and grassesbegan in the late 18005 with the

“In the Unf e
development of the stationary horse 3 owered baler, which made it possible to compress

hay and straw into string- or wire-tied units called bales.”* Straw bales then began to replace sod as the
preferred building material in the massive plains of the United States.

Company, 1994) 3.

Figure 7-6
Footnote example.

1 Athena Swesell Steen et al,, The Strow Bole House (White River Junction, VT: Chelsea Green Publishing
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Copying Notes

If a source is really good, you might quote or para-
phrase its contents multiple times in the same doc-
ument. Word saves you the need to retype the same
footnote or endnote information by enabling you
to reuse an existing note. To do so, you copy and
paste the note number that's placed just after the
sourced text (not the footnote or endnote itself).

Drag over the note number to select it, and then
copy it with either Ctrl+C or Home > Clipboard >
Copy. Then click just to the right of the next quota-
tion or paraphrased material, and paste using
Ctrl+V or Home > Clipboard > Paste. That's it. Word
automatically assigns the correct number to the
pasted note both in the text and in the note itself.

Moving Notes

If you move text marked with a footnote or end-
note in the document, the note “travels” with the
text. That means Word automatically renumbers all
notes as needed to reflect the new location of the
sourced text relative to other sourced text.

Look Up | »

Additional Acti L4
! athena Swentzell Steen et al, The Strow B! S pdotitiokd

Company, 1994)3.
CalibriE~ 10 ~ A" A" iE £E

B[Zjlu=Ew-A-¢

If you inserted a footnote or endnote at the
wrong location, a simple cut and paste solves the
problem. Drag over the note number to select it,
and then cut it with either Ctrl+X or Home >
Clipboard > Cut. Then click in the correct location
for the note and paste using Ctrl+V or Home >
Clipboard > Paste.

Converting Between Note
Types

Back in the typewriter era, it was extremely impor-
tant to understand whether footnotes or endnotes
were required for a particular document. If you used
the wrong type of note, you would have to retype
the entire document. Word's reference capabilities
don't lock you in to one note type or the other. You
can convert a footnote to an endnote and vice versa
at any time. To do so, right-click anywhere in the
footnote or endnote itself. In the shortcut menu
that appears (see the example in Figure 7-7), and
click Convert to Endnote (or Footnote).

42
- ({4, Paste Options:
l B
A Font..
S0 Paragraph...
Style...
“In the United States, a new era of build Go to Footnote began in the late 1800s with the
development of the stationary horse an¢ MNote Options... , which made it possible to compress
hay and straw into string- or wire-tied u| Conyert to Endnote les then beganto replace sod as the
preferred building material in the massiy B Hyperink.. Bs,

n, VT: Chelsea Green Publishing

Figure 7-7
Converting a note.
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Creating a Table of Contents

(TOC) at the beginning of a long document
provides a nice roadmap to the document’s
contents. The reader can identify a topic of interest
and go right to the page that discusses the topic. If

the document includes a title page or cover page,
in most cases you should insert the table of con-
tents on the page directly after the title or cover
page. In many cases, you should also insert a hard
page break after the table of contents to separate it
from the following text. This ensures that the first
page of information in the document starts at the
top of a new page.

INCLUDING A TABLE OF CONTENTS

Word offers both a gallery of built-in table of con-
tents styles and a dialog box where you can choose
more specific settings for your table of contents.
No matter which of these methods you use, you
need to start by formatting the headings in the
document using the appropriate Quick Styles. (The
section called “Using Quick Styles” in Chapter 3
introduced how to apply styles in Word.) The Table
of Contents feature in Word identifies which items
to list based on the style applied. Text formatted
with the Heading 1 and Heading 2 Quick Styles
become the top-level and second-level entries in
the table of contents.

Tip

Word actually offers nine heading level
styles, and three of them are used in a
TOC by default. To find the other styles,
click the Dialog Box Launcher in the
Styles group of the Home tab. Then click
the Manage Styles button at the bottom.

After you have applied the heading styles to the
headings in your document and have created the
page where you want to insert the TOC, use one of
these methods to generate the TOC:

» Choose References > Table of Contents >
Table of Contents. Then click one of the two
Automatic Table choices at the top of the
gallery shown in Figure 7-8.
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Built-In
Automatic Table 1

Contents
Heading 1 1
Heading 2 1
Heading 3 1

Automatic Table 2

Table of Contents
Heading 1 1
Heading 2 1

Heading 3 1

Manual Table

Table of Contents
Type chapter tithe (level 1)
Type chapter title (leved 2)
L 3)

& W N e

CQ More Table of Contents from Office.com
5] Insert Table of Contents...

3.; Remove Table of Contents
i T

Figure 7-8
Generating an automatic TOC.

» Choose References > Table of Contents >
Table of Contents > Insert Table of Contents
to display the Table of Contents dialog box
shown in Figure 7-9. Among the settings you
can change here are whether or not to Show
Page Numbers or Right Align Page Numbers.
If your document has more than three head-
ing levels that you'd like to include in the
TOC, change the Show Levels value. You can
use the Formats drop-down list to choose an
alternate style for the TOC. If you plan to
publish the document to the Web, leaving a
check in the Use Hyperlinks Instead of Page
Numbers box changes the TOC to a hyper-
linked format in Web Layout view. Click OK
to finish adding the table of contents.
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Table of Contents.

Index_| [ Table of Contents | | Table of Figures | Table of Authoribes |

Print Preyiew \Web Preview

11 [ 5 R——— Heading 1 -

| :
HERORE T icimisniniissimiion 3 Heading 2

| Heading 3......ccmmessmcrrnses 5 Heading 3
[
g - -

[¥] show page numbers (] Use hyperiinks instead of page numbers

1| | (] Right align page numbers

: Tableader: ... [~]
General
Formats: From template EI
Show levels: |3

Figure 7-9
Selecting TOC settings.

If the text of the document changes, if you add or
delete headings, or if you create a separate page to
hold the table of contents after creating it, you'll
need to update the table of contents. You can
update just the page numbers of the table of con-
tents, but the safest choice is usually updating the
entire table, which ensures that the TOC reflects
any heading changes made since you generated it.

To update a table of contents, click within it. Then
click Update Table in the tab above the table. As
shown in Figure 7-10, the Update Table of
Contents dialog box appears. Choose either Update
Page Numbers Only or Update Entire Table, and
then click OK.
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Update Table of Conten

i )~ L3 Update Table..c——— |

Contents

Uni i 3 Rdale QAgE Numbers onty)
EENAb Lo

—— Click to update table

Figure 7-10
Updating the TOC.

Figure Captions

look at how to use pictures, clip art,

SmartArt diagrams, and more to illustrate
the information in a document. Let’s just say for
this discussion that you've already mastered those
techniques. When you include graphics of any type
in a document, adding captions explains exactly
what each illustration shows. Word's References
tab includes a tool for adding a caption to any
graphic that you select. Word automatically num-
bers the captions so that you can refer to them by
number in the text. This helps the reader
immensely if you need to refer back to a graphic
on a much earlier page in the document, because
the reader can identify the correct figure according
to its number.

CHAPTER 13 WILL GIVE YOU a detailed

Follow these steps to add a caption:

1. Select the picture or other graphic by click-

ing it.

. Choose References > Captions > Insert

Caption. The Caption dialog box appears.

. If you want to change the label that appears

with the caption number, make another
choice from the Label drop-down list or click
the New Label button, enter another label,
and click OK to create the alternate label. It is
important to use the same label for all cap-
tions in the document, not only for style rea-
sons, but also for reasons you'll learn more
about in the next section.
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4. You can click the Numbering button, choose
another Format list option in the Caption
Numbering dialog box, and then click OK to
change the caption’s numbering style. 6. Click OK. Figure 7-11 shows a caption and

the Caption dialog box settings used to cre-
ate it.

5. Click back in the Caption text box at the top of
the Caption dialog box and type the caption.

Caption — ==
| |Figurc2R-w1uesgrdDh. |
)| Options

Label: Figure |Z|

Posiion: |Below selected item

A | 7 Exchude label from caption

1| | autocaption... | [ ok ][ cona |

S | Example caption

R-Value

WR=Value by Exterior Wall Ty

Figure 2 R-values graph. Figure 7-11

Adding a caption.

Consistency Counts

Try to use consistent structure and punctuation for captions. For example, use all complete sentences,
or only one- or two-word labels. Either use a period at the end of all captions, or none at all. As always,
check the standards for the course, school, or organization to learn the proper caption style.
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Adding a Table of Figures

the document page number on which each

graphic for which you've added a caption
appears. Some academic and technical environ-
ments prefer or require a table of figures to identify
all illustrations in a document. Generally, a table of
figures appears at the end of the document, along
with other resources, such as the bibliography and
endnotes; although in some circumstances, placing
the table immediately after the table of contents
makes the figures easier to find and reference.

Q TABLE OF FIGURES is a list identifying

Follow these steps to create a table of figures:

1. First create a separate page for the table, if
needed, and then position the insertion
point at the top of the page.

2. Choose References > Captions > Insert Table
of Figures. The Table of Figures dialog box
shown in Figure 7-12 appears. The settings it
offers are similar to those for the Table of
Contents dialog box shown in Figure 7-9.
One important difference is the Caption
Label drop-down list. The setting you choose
there must correspond to the Label option
you selected in the Caption dialog box when
creating captions. Only captions using the
selected caption label will be listed in the fin-
ished table of figures. You can clear the
Include Label and Number check box if you
prefer to identify captions by their text alone.

Caption label

Table of Figures / 19 i
[ 1ndex | Tab!coFCm'.:msE Table of E_Twieofiumm |

Print Preview Web Preview

271170 T [ s ASn— Figure 1: Text -

Figure 2: Text.. Figure 2: Text

Figure 3: Text..

Figure 4: Text..

Figure 5: Text. e fns

| Use hyperiinks instead of page numbers

[¥] show page numbers
| Right align page numbers

(o) (o)

Figure 7-12
Creating a table of figures.

3. Click OK to tell Word to generate the table of
figures.

4. You can finish the table by adding a heading
above it, if desired.

If you left Use Hyperlinks Instead of Page Numbers
checked in the Table of Figures dialog box, each
item in the table of figures list is a hyperlink that
you can use to move to the referenced graphic.
Ctrl+click on any listed figure to jump to that fig-
ure in the document.
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As for a table of contents, if the contents of your
document change—such as if you move, delete, or
add more graphics with captions—you'll need to
update the table. To do so, click in the table, and

then choose References > Captions > Update Table.
Choose either Update Page Numbers Only or
Update Entire Table in the Update Table of Figures
dialog box, and then click OK.

A Table of Tables?

Some styles also require you to list tables in the document. To include both graphics and tables in a
single table of figures list, assign them all the same Label in the Caption dialog box (such as Figure
or a custom label). Then choose that caption label in the Table of Figures dialog box. Or to list differ-
ent elements separately, use different caption label choices (such as Figure versus Table), and then
generate separate tables of figures by changing the caption Label setting.

Creating a Bibliography

indirectly in a document (that is, sources

you do not directly quote or paraphrase but
from which you have drawn key conclusions, ideas,
or concepts). You first must insert each citation, or
reference, to the sources in the text where appro-
priate. Like footnotes and endnotes, citations fol-
low a particular style, such as MLA or the Chicago
Manual of Style, so you need to find out which
style to use for your class, school, professional dis-
cipline, or organization. Word formats each citation
you add according to the selected style. For exam-
ple, a citation in the MLA style might have just the
author last name or author last name and cited
page number in parentheses, as in (Smith) or
(Smith 235).

Q BIBLIOGRAPHY LISTS SOURCES cited
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To also include other sources that you've drawn on
even more indirectly in the bibliography, you have
to add those sources separately. Note that you
should also check on the style of your school or
organization with regard to including
footnoted/endnoted sources in the bibliography.
Most styles call for you to also include
footnoted/endnoted sources in the bibliography,
in which case you must add the sources manually,
while some instructors may consider
footnotes/endnotes and a bibliography separate
elements. Some styles frown on using both foot-
notes/endnotes and parenthetical citations, so you
should use citations and a bibliography only in
that instance.

Once you've completed all the citations and
sources, you can compile the bibliography.
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Adding Citations

Start by selecting the citation style and inserting
citations in the document, like this:

1. Choose References > Citations & Bibliography
> Style, and then click the style you want in
the list, as shown in Figure 7-13.

|5f) Insert Tak
=¥ Updat

!

ﬁ ::’j Manage Sources
= 0 style: | MILASHE| - |

Insert P—
Citation ~ @ Bibliot APA Fifth Edition

Citations & Bibli¢ Chicago Fifteenth Edition

GB7714 2005
GOST - Name Sort
GOST - Title Sort
ISO 690 - First Element and Date
ISO 690 - Numerical Reference
MLA Sixth Edition
SISTO2
Turabian Sixth Edition

sl

Figure 7-13
Citation styles.

2. Click to position the insertion point where
you want the citation to appear in the
document.

Choose References > Citations &
Bibliography > Insert Citation > Add New
Source. The Create Source dialog box
appears.

Select the type of publication or source that
you're citing from the Type of Source list.
Then, fill in the rest of the text boxes with
the information about the source. The dialog
box will automatically adjust to prompt you
for different information based on the cita-
tion style you selected in Step 1 and the Type
of Source choice. For example, Figure 7-14
shows information for a book using the MLA
Sixth Edition citation style.

. Click OK to finish adding the source and cre-
ating the citation.

—
Create Source

Type of Source |Book
Bibliography Fields for MLA Sixth Edition

Year 1993

[7] show all Bibliography Fields
Tag name

Figure 7-14 Gwya3

A new citation source.

Author | Gwynn, Kate; Sloan, Annie;
["] Corporate Author
Title | Classic Paints and Faux Finishes

City Pleasantville
Publisher Readers Digest

Enter or edit names.

| e —

]
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Making the Right Entries

When the insertion point is in a text box in
the Create Source dialog box, an Example
field at the bottom of the dialog box shows
you how to type the information for that text
box. For help entering multiple authors, click
the Edit button. Enter the name for each
author as prompted in the Edit Name dialog
box, and then click Add. Click OK to finish
adding authors and return to the Create
Source dialog box.

6. To add a page number for the citation, right-

click it and click Edit Citation. In the Edit
Citation dialog box, type a page number or
range in the Pages text box, as shown in
Figure 7-15. To suppress information from
appearing in the citation, click the appropri-
ate check box under Suppress. Click OK to
finish editing the citation.

BRPRE)

~
Edit Citation

Add
Pages: 78

Suppress
[T Author []Year [ ]Title

o) o)

Figure 7-15
Adding a page number.
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7. Repeat Steps 2 through 6 to add citations
from new sources. Or, if you've already added
the source, choose References > Citations &
Bibliography > Insert Citation, and then click
the source name in the menu, as shown in
the example in Figure 7-16. You can then add
a page number to the subsequent citation as
described in Step 6.

: (3 Manage Sources

= (@ Style: MLA Sixt ~ 1
Insert Insert
Citation » ﬂi Bibliography ~ Caption L) Cross-refere
Gwynn, Kate, Sloan, Annie
Classic Paints and Faux Finishes, (1993)

ﬂ 2] Insert Table
¥ Update Tab

Lstiburek, Josephn, Carmody, John
Moisture Control Handbook: Principles for
Residential and Small Commercial Buildings, (1996)

& Add New Source...
:)) Add New Placeholder...

Figure 7-16
Using an existing source.

Adding a Source

You also can include sources in the bibliography
that you haven't directly cited. Doing this is a good
practice, as it both ensures you've given proper
credit to other authors whose ideas you've drawn
upon, as well as providing your peers and readers a
comprehensive reading list so they can verify the
information you presented or learn more about a
particular topic.
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Use these steps to create additional sources for the
bibliography:

1. Choose References > Citations &
Bibliography > Manage Sources. The Source
Manager dialog box appears.

2. Click the New button to open the Create
Source dialog box. It looks and works just
like the Create Source dialog box shown in
Figure 7-14.

3. Select the type of publication or source that
you're citing from the Type of Source list.
Then fill in the rest of the text boxes with the
information about the source and click OK.

4. Repeat Steps 2 and 3 to create additional
sources. They will be added to the Current
List area at the right (see Figure 7-17). Note
that you also can click a source in the
Current List area and use the Delete or Edit
buttons to remove or change it.

Tip

Sources you cited in other documents
appear in the Master List area at the left
side of the Source Manager dialog box. To
add a source to the current document so
that you can use it in citations, click the
source in the Master List at the left, and
then click the Copy button.

5. Click Close to finish working with sources.

Generating the Bibliography

Once you've added and edited all the citations and
have included additional sources that you did not
specifically cite, you can create the finished bibliogra-
phy. Once again, Word properly formats the bibliog-
raphy based on the style you selected in the Citations
& Bibliography group of the References tab.

| Lsthurek, Josephn, Carmody, Johe:
Steen. Athena Swentzel. Steen, Bl

Moisture Control Handbock:

+  oited source.

Preview (MLA Sorth Ediion):

Scurce Manager 15 e
Search: Sort by Author [
Sources available in: | prem—

Master List (Bomen| Curent Lst
| Gorynn, Kate, Sloan, Annie; Classic Paints and Faux Finishes (1993) - Copy -> | ¥ Gueynn, Kate, Sloan, Annie; Classic Paints and Fauix Finishes (1993) .
| Lacnskd, Pau, Bergeron, Michel; Serious Straw Bale: A Home Constru

b Lacnski, Paul, Bergeron, Michel; Sericus Straw Bale: A Home Consh
Pring [ | |+ Lstiburek, Josephn, Carmody, John; Moisture Control Handbook: Pr
0 Delete Steen, Athena Swentzel, Steen, B, Barbridge, David, Essrberg,

7 placeholder source

Citation: (Steen, Steen and Bainbridge)

Bibliography Entry:

Steen, Athena Swentzell, etal. The Straw Bale House, White River Junction: Chelsea Green Publishing Company, 1994, ‘

Figure 7-17

= Managing sources.
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Follow these steps to finish creating the bibliog-
raphy:

1. Press Ctrl+End to go to the end of the docu-
ment (assuming you haven't already created
the index, in which case you should insert
the bibliography on a new page before the
index).

2. Press Ctrl+Enter to insert a hard page break.

3. Choose References > Citations &
Bibliography > Bibliography, and click the
Bibliography choice under Built-In. (See
Figure 7-18.) The Bibliography immediately
appears in the document.

) Manage Sources j J Insert Table of Figures j J Insg|

1= (3 style: MLA sixt -

Insert Mark
Kitation = []JJ Bibliography ~ caphqn _‘\j Cross-reference Entry
Citatid Byilt-In x|
Bibliography
Bibliography
Chen, lacky. Citations w Yo 2003,
MHaas, Jonathan. Creating - : .., 2005.

Kramar, larmes Drvid. How 1o Wiite Bbliopraphies. Chicago: Adventure Works Press, 2006,

Works Cited
Works Cited
Chen, lacky. Citation Bew Yorle 2003
Haas, Jonathan. Croating : P =, Irec., 2005,

Kramar, lames David. How o Winte Bblographies. Chicago: Adwentune Works Press, 2006,

ﬂ) Insert Bibliography

Figure 7-18
Adding the bibliography.
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To update a bibliography after you change sources,
click in the bibliography, then click Update
Citations and Bibliography in the tab above it, as
shown in Figure 7-19.

i gfte L3 Update Citation: and Bibliagraphy

Bibliography

Gwynn, Kate and Annie Sloan. and Faux 1993,

Lacinskl, Paul and Serious A Home G shde for ANl Climates.
White River Junction: Chelsea Green Publishing Company, 2000.

Lstiburek, Josephn and lohn Carmiody. Moisture Control Handbook: Principles for Residential and Small

Commercial Bulldings. New York: John Wiley & Sons, 1956

Steen, Athena Swentzel, et al The Straw Bale House. White River Junction: Chelsea Green Publishing
Company, 1954

Figure 7-19
Updating the bibliography.

Ditching the Underlining

Notice that Word uses underlining for book
titles in the bibliography. Most styles have
migrated to using italics for book titles in
footnotes and a bibliography. You can simply
reformat each book title in the bibliography
as needed by dragging over the title and
pressing Ctrl+U to remove the underlining
and Ctrl+l to add italics.
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Adding a Table of Authorities

table of authorities, which is a list of all of the

LEGAL DOCUMENTS OFTEN REQUIRE a
cases, statutes, rules, treatises, regulations,

constitutional provisions, and other types of authori-

ties cited in the text. Creating a table of authorities
works much like creating a bibliography, except that
you type the citation into the text using the appro-
priate format for the type of citation and citation
style that you're following. For example, you might
type in (James v. Jones, 48 Wn. 3d 405 (1963)) for a
legal case citation or (NCGS § 131A-247(6)) for a
statute citation. You then select and mark all the
citations, and create the table of authorities.

Use this process to mark citations and create the
table of authorities:

1. Type in and select the citation to mark. If the
style that you are using calls for parentheses
surrounding the full citation, do not select
the outermost pair of parentheses.

2. Choose References > Table of Authorities >
Mark Citation. The Mark Citation dialog box
opens.

3. Choose the proper Category for the citation,
as shown in Figure 7-20.

A=

Mark Citation

Selected text:
NCGS §131A-247(6) 7

Next Citation

Tl

Long ditation:

%

Figure 7-20
Marking a legal citation.

4. If there is a shorter version of the citation
that appears elsewhere in the document, edit
the Short Citation text box entry to match
the shorter version.

5. Click Mark to mark only the current instance
of the citation, or click Mark All to mark all
instances in the document. Word inserts a
field code that identifies the citation and turns
on the display of nonprinting characters.

6. Click Close.

7. Repeat Steps 1 through 6 to create and mark
additional citations.

8. Click to position the insertion point where
you want the table of authorities to appear
in the document, creating a new page first, if
desired.



9. Choose References > Table of Authorities >
Insert Table of Authorities. The Table of
Authorities dialog box appears, as shown in

Figure 7-21.
Table of Authorities =)
[Tindex. | Table of Contents | Tabie of igures. | | Tabie of gutharities] |
Print Preview Category:
[ -
Cases | Cases |
Baldwin v. Alberti, Statutes =
58 Wi 2d 243 (1961).....5, 6 Bt
Dravo Corp. v. Metro. Seattle, Trantons
79 Wi 2d 214 (1971). passim R ioveisss
F v, Craddock * |8 =)
[ Use passim
7] Keep original formatting
Tableader: |....... []
Formats: From template B
Mok Otaton... | [ body... ]
(o J [ coea ]

Figure 7-21
Choosing table of authority contents.

10. If you need to limit the table to a particular
type of citation, click it in the Category list.
(The All option includes all citations in the
table.) Also change other formatting set-
tings as desired until the Print Preview area
appears as you'd like.

11. Click OK to insert the table of authorities.

12. Choose Home > Paragraph > Show/Hide to
turn off the nonprinting characters.

Generating Cross References

item or location in the document, such as a

particular heading, item in an automatically
numbered list, a bookmarked location, footnote or
endnote, numbered figure, or a table or equation.
(Chapter 15 provides more information about creat-
ing bookmarks.) Inserting items as an automated

Q CROSS-REFERENCE points to another
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cross-reference provides two advantages. First, the
cross-reference is created as a hyperlink by default,
so the reader can use it to navigate in the docu-
ment when viewing it in Word. Additionally, if you
move content around in the document, the cross-
references update automatically to reflect the
changed locations of the cross-references.
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Use these steps to insert any type of cross-reference: Cross-reference [0 [t
Reference type: Insert reference to:
. Heading -
1. If you want to enclose the cross references in : . [*] [-]
|| Insert as hyperlink Indude above fbelow

quotation marks (as when referencing a head- Separats ik bers vt

ing) or parentheses, position the insertion For which heading:
point at the desired location and type the e e

Benefits of Straw Bale Construction
opening quotation mark or left parenthesis.

Steps in Straw Bale Construction

Bibliography

2. Choose References > Captions > Cross
Reference. The Cross-Reference dialog box
opens.

(Lipsert ] [ conce

3. Make a choice from the Reference Type drop-
down list. As shown in Figure 7-22, the list of
items matching that reference type appears
in the For Which <type> list at the bottom of

Figure 7-22
Creating a cross-reference.

the dialog box.
5. If you would like the cross-reference to display
4. Click the desired item to cross-reference in as something other than the text being refer-
the For Which <type> list. enced, such as the page number where the ref-

erenced material is located, make the appropri-
ate choice from the Insert Reference To list.

6. Click Insert to create the cross-reference.

Indexing Content

N INDEX LISTS THE PAGE NUMBERS generally appears at the very end of a document,
A where important terms appear in a docu- starting at the top of a new page.
ment. While indexes are most common for

lengthy publications, such as books, you may need
to include an index for a shorter work if it contains
a lot of jargon and technical explanations. An index

As for the other reference features you've already
learned about, creating an index is a two-step
process. First mark the entries to index throughout
the document, and then insert the index.
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If an index entry is about a general topic that
spans multiple pages, such as the “Creating a
Bibliography” section earlier in this chapter, you
would first need to select the entire section, and
then create a bookmark for it as described in
Chapter 15. For standard entries, select the text to
mark for the index, and then choose References >
Index > Mark Entry. In the Mark Index Entry dialog
box that appears (see Figure 7-23), type any suben-
try that you want to create for the entry in the
Subentry text box. If you are creating only a cross-
reference, click the Cross-Reference option button
and type the term to cross-reference to the right of
See in the accompanying text box. Or, if you previ-
ously created a bookmark that will serve as the
cross-reference, click the Page Range option and
select the bookmarked location from the
Bookmark drop-down list. Enable options under
Page Number Format as desired, and then click
Mark to mark only the current selection or book-
mark, or click Mark All to have Word find and mark
all matching instances of the term for the index.
Then click Close.

After you have marked all the items to index, press
Ctrl+End to go to the end of the document, and
then press Ctrl+Enter to start a new page. Choose
References > Index > Insert Index. The Index dia-
log box appears, as shown in Figure 7-24. In the
case of an index, the From Template choice in the
Formats list results in a very bland index. If your
index is lengthy, consider choosing one of the
other Format choices, all of which add a divider to
start each new letter of entries. For a brief index,
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Mark Index Entry m

Index

Main entry: [foundation planning |

Subentry: lfoundation |

'| Options

(©) Cross-reference: [See l

@ Current page
() Page range
Bookmark:
Page number format
("] Bold
[] 1talic

This dialog box stays open so that you can mark multiple
index entries.

| Mark

J [ Markar ] [ conce

Figure 7-23
Marking an index item.

consider reducing the columns setting from 2 to 1.
When you have made those and other choices,
click OK. Note that Word does not include a head-
ing for the index, so you should probably insert a
top-level (Heading 1 style) heading that reads
Index, and update the table of contents to reflect
the index location. If you need to update the index
itself after marking or deleting terms, choose
References > Index > Update Index or press F9.
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exosphere, 4

‘ Earth

" 1 -

Index %
[ ndex |aBEoFCoORRE | Table of Figwres | Table of Authoribes | | ‘
| | Print Preview
Aristotle, 2 | «  Type: @ Indented Runn |
| Asteroid belt. See Jupiter Columns: |2 |
|| |atmosphere tanguee: [Engleh .50 B
|
|

Right align page numbers

|
‘ Formats: E|
|
|
|

[ markEntry... | [ Ayomsark... | [ modify... |

|

Figure 7-24
Index settings.

Tip

To delete an index entry, choose Home >
Paragraph > Show/Hide. Then select the
entry field and its braces, and press Delete.
Finally, click in the index and choose
References > Index > Update Index.
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Working with

Outlines

B ICTURE YOURSELF PLAYING FRISBEE with your dog. Your
dyard has a fence around it so your dog doesn’t go outside of its

L. confined area. The protective border also keeps the dog focused on
the Frisbee and not the bicyclist riding down the street. In this chapter,
you'll work with outlines. By working within the confines of an outline,
you stay on track. Outlines contain major topics and subtopics and possi-
ble detail information about each.

Also in this chapter, you'll discover master documents and its sub-
documents. A master document is the container that includes links to
any number of smaller documents, such as a book and all its individual
chapters. Think of a master document as the glue that holds a longer
document together.

Finally, you'll discover outline numbering, which is far different from an
outline. In Chapter 3, you worked with bulleted lists and numbered lists.
Outline numbering is similar to a numbered list, but with greater detail.
Outline numbering is frequently used in legal documents.



Creating a Standard Outline

outlines assist you by using major topics

(called headings) and subtopics to categorize
a task and its subtasks. Most of us work with mental
outlines every day. If you were to plan your basic
day, you might plan it like this: The major topics
would be the places you go that day (work, grocery,
dinner), and the subtopics might be what you plan
to do at each place. For example, while at work you
might write a report that is due, make a few phone
calls, or attend a meeting. Those would be subtopics
of the Work major topic.

Q GREAT ORGANIZATIONAL TOOL, Word

The easiest way to create an outline is by begin-
ning in Outline view. Choose View > Document
Views > Outline or just click the Outline view icon
located on the status bar. While in Outline view,
you see a new tab at the beginning of the Ribbon.
The Outlining tab is designed to assist you in creat-
ing your outline (see Figure 8-1). The Outlining tab
also allows you to display different outline detail
levels and reorganize your outline. More about
those topics later in this chapter.

Printing an Outline

When you print an outline, Word prints the
outline in its entirety as it displays in Print
Layout view. The indentation and levels made
in Outline view do not appear.

Generating Headings

On a blank document screen in Outline view, you
see a small circle with a minus sign. Next to the cir-
cle is your blinking insertion point where you
begin entering your headings.

Word considers the first line of text you type in an
outline to be a Level 1 heading, the top-most level.
Word uses styles to track outline headings and sub-
headings, and a Level 1 heading is a style. Type the
first line of your outline and then press the Enter
key, which moves the insertion point to the next
line. Type the second line of your outline. Notice
from the Outlining tab that the text still appears as

W - 0s Documentd - Microsoft Word o @
Qutlining Home Insert Page Layout References Mailings Review WView [}
a2 Show Level: Level 8
® o llowin 7| o gy 5 mowient iew %

[¥] Show Text Formatting
o A = e Show
Ll Show First Line Only

Document Subdocume
Outline Tools Master Document

Close
Outline View

Close

Figure 8-1
The Outlining tab on the Ribbon.
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a Level 1 heading. Continue entering your main
topic headings as needed. Level 1 headings are for-
matted with the Heading 1 Quick Style. (Refer to
Chapter 3 for a refresher on Quick Styles.)

When you want to create subheadings, use the Tab
key to indent the text. Word automatically assigns
a Level 2 heading. Each time you press the Tab key,
Word creates a lower level subheading. A Word

outline can contain up to nine different heading
levels. Again, Word automatically assigns a Quick
Style to your subheadings. Word uses Heading 2
styles for a Level 2 heading, Heading 3 for a Level 3
heading, and so forth.

When you need to return to a higher level, press the
Shift+Tab keys. Figure 8-2 illustrates a sample docu-
ment outline with two different heading levels.

H9-0r Docimentd - Microsalt Word
Outhining Home Insert Page Layout References Mailings Review Wiew

prape : - by
et «| @ gy | ¥ Showlenk B
¥ Shetvw Text Foamatting —
aw 4= Show Gose
Show Firit Line Ondy Dowmment Outine View

Outine Tools aster Document
© Jonesville's Cardholders increase sales & loyalty!
@ Key Selling Points
@ For the Associates and Managers

@ For the Sales Associate

© For the Store Manager

© For the District Manager
© Pocket Tool
©@ Overcoming Customer Objections

@ Common Customer Objections

© Make their "No" a“ Sure! Why Not”
el

M
[Page: 1041 | Wordidé | D |

HUE3E 0% (=

= & B
~@

Figure 8-2
A sample outline.

+

Creating Body Text

If you want to add text to your outline that isn't
really an outline heading, you create body text.
Typically, body text elaborates more on the outline

level heading directly above it. You create body text

by using the Outlining tab.

Type the text you want as body text and click the
Demote to Body Text button. See Figure 8-3 for an
example of body text.
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© 2010 Field Sales Pilot
@ Jonesville's Cardholders increase sales & loyalty!
© Key Selling Points
© For the Associates and Managers

© For the Sales Associate
@ For the Store Manager
@ For the District Manager
Pocket Tool
Overcoming Customer Objections
©@ Common Customer Objections
©  “I have too many credit cards in my wallet”
®  This is definitely not just a regular credit card like the ones in your wallet, The
Jonesville’s card acts as a rewards program and pays you to shop with us. | can
save you 10% today just for opening an account and send you another $10 in the
mail for every $150 that you spend. You will receive a special invitation to shop
with us on the last Tuesday of the month and save an additional 10% off of your
entire purchase. The application process is quick and simple. I
© Make their “No” a“ Sure! Why Not”

o0

|0

4
Page: 1of 1 | Words: 184 | B |

EuaEe oo

| Figure 8-3
An outline with body text.

[+

If you enter your text in Outline view and switch to
Draft or Print Layout view, the text retains its
Heading styles unless you switch it to body text
which uses a Normal style. If you type text in Draft
or Print Layout view, and then switch to Outline
view, Word assigns a Body Text level to the text you
typed in the other views.

Viewing the Outline

While in Outline view, you can expand or collapse
the various levels to view only the portions you want
to see. For example, you can view upper-level head-
ings only to get an overview of the entire document,
thereby helping you further organize your thoughts.
Additionally, you can turn the formatting display on
or off. Word includes several areas on the Outlining
tab to assist you with viewing your outline.
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» On the outline body, double-click a Heading
button that looks like a circle with a plus
sign in it (called an Expand and Collapse
icon). If the Heading button has a minus
sign, there are no subheadings or body text
under that heading; however, a plus sign
indicates additional items. Word collapses
the body text and subheadings of the first
level below the currently selected heading,
or, if the heading is already collapsed, Word
expands the first heading level below the
currently selected heading. Each double-click
will collapse or expand additional headings.

Tip

Optionally, double-click an Expand and
Collapse icon to fully open the selected
heading.
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» From the Outline Tools group on the
Outlining tab, click the Show Level down
arrow, which displays a drop-down list of
heading options. Select a level, and Word
displays only the headings at the level you

chose and those that are higher. For exam-
ple, as shown in Figure 8-4, if you select
Show Level 2, both Level 1 and Level 2
headings appear but not body text or any
Level 3 headings.

H9-0r Docimentd - Microsaft Word e & B
Outhining Home Insert Page Layout Referemces Mailings Review Wiew =]
o
W & BonTer < 9 gy T Showleat L2

N %]
[ Show Text Foematting — z
- v § = Sy Close
L 3 + ew
. I Aaster Dorument lose

__— Expand and Collapse icons

-]
[&]
=]
L+]

@ For the Store Manager
© For the District Manager
Pocket Tool
Overcoming Customer Objections
© Commeon Customer Objections
© Make their "No"” a* Sure! Why Not”

o0

4
Page: 1ol | Wordi: 184 | B |

EuaEe o c

Figure 8-4
Displaying only the levels you
want to view.

G

Tip

Click Show All Levels to view the entire outline.

» Choose Outlining > Outline Tools > Show
First Line Only. The outline display toggles
between displaying all the body text or only
the first line of each body text paragraph.
(See Figure 8-5.) In lengthier documents,

you don't have to scroll through pages of
text to keep your overall perspective. Show
First Line Only applies only to body text. If
your headings have multiple lines, Word
still displays them in their entirety.
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@ Never sound rehearsed or practiced. Casually offer the card to the customer. Ask ..
@ |f the customer is not interested in the lonesville's card by the end of the sale, be sure ..
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@ For the District Manager
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Figure 8-5
Show only the first line of
each paragraph.
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» Choose Outlining > Outline Tools > Show
Text Formatting. The Outline view toggles
between displaying the outline with or
without character formatting. When

viewed without character formatting, you
can see more of your document on a page.
Figure 8-6 illustrates the outline without
text formatting.
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Viewing an unformatted
outline.
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Tip

Choose Outlining > Close > Close Outline
View to close the outline and return to
Print Layout view.

Reorganizing the Outline

Most of us, when typing the main points we want to
relay in a document, will change our minds several
times. You determine you should point out Topic B
before you mention Topic A. That's okay because it's
very quick and easy to reorganize your outline.

Promoting or Demoting Headings

A Level 1 heading is the highest level in an outline,
and a Level 9 heading is the lowest. You have a

choice of using the click-and-drag method of mov-
ing headings (and body text) or using the buttons
on the Outlining tab. Use any of the following
methods to promote or demote your headings:

P Place the insertion point anywhere in the
line you want to promote and click the
Promote button or press Shift+Tab. You
either click the Promote button or press
Shift+Tab for each level you want to pro-
mote the text. If you want to demote the
heading to a lower level, place the insertion
point anywhere in the line and click the
Demote button or press the Tab key.

» Click anywhere in the line you want to
change and click the Current Outline Level
drop-down list and choose from the result-
ing list shown in Figure 8-7.
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5 Figure 8-7
Choosing a new level.
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» Click the Expand and Collapse icon for the
level you want to move. Word highlights
the text. Drag the Expand and Collapse icon
left or right in the outline. As you drag the

mouse, a gray line appears, as shown in
Figure 8-8. Release the mouse when the
line indicates the level to which you want
the text moved.

Jonesvile Outline - Microseft Werd
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Move line
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|2010 Field Sales Pilot
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Overcoming Customer Objections
© Commeon Customer Objections
© Make their “No” a “ Sure! Why Not”

10

4
Page: 1042 | Wordi 585 | OB |

Selected line

—— New level

Figure 8-8
Dragging text to a new level.
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Promote to Heading 1

The Outlining tab on the Ribbon also contains a button with double arrowheads pointing right. Click
that button to quickly promote the current line to a Heading 1, the highest level.

Moving Levels Up or Down

As you organize your thoughts and ideas in an out-
line, you might change your mind and want to
cover a topic earlier than originally planned. You
can move selected headings along with any associ-
ated subheadings and body text up or down to any
location in your outline. Click the Heading icon of
the section you want to move and either click the
Move Up button or click the Move Down button.
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The selected section moves up or down one line
with each click of the button.

Optionally, click the Expand and Collapse icon for the
level you want to move. Word highlights the text.
Drag the Expand and Collapse icon up or down the
outline. As you drag the mouse, a gray line appears,
as shown in Figure 8-9. Release the mouse when the
line indicates where you want the text moved.
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= Jonesvile Outline - Microsoft Word
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Figure 8-9
Moving text up or down the
outline.
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Working with Master Documents

kitchen spoil the soup” can also apply when

you have too many people trying to put
together a single document. You may have some
people doing the same job, making ineffective use
of time. Perhaps some of the related documents
become lost and you have to start over, or maybe
while delegating areas, an important topic gets lost
in the diversion.

THE OLD PHRASE “too many cooks in the

It doesn't have to work that way. Word's Master
Document feature offers a system of organization
for larger documents. A master document works as
a container for smaller subdocuments. A book is a

good example for using a master document. Think
of the book title as the master document, and each
book chapter is a subdocument. Working with the
Master Document feature makes the longer docu-
ment much more manageable.

Creating a Master Document

The basic principal behind a master document
begins with a master document outline. The major
headings become the subdocuments, which Word
creates and saves into its own document and
places hyperlinks in the master document. You, or
someone else, then enters the chapter content into
each individual subdocument.
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1. Choose View > Document Views > Outline,
which switches you to Outline view and dis-

2. Choose Outlining > Master Document > Show
Document. The Outlining tab expands with

plays the Outlining tab. additional choices, as shown in Figure 8-10.
W9~ 0= Introduction to Peachtree Accounting - Microsoft Word = &
Outlining Home Insert Page Layout References Mailings Review Wiew &
w25 Show Level: - = ) Create ] Merge
e @ Lewel3 M A (e 3 -
[V] Show Text Formatting J - dPRmset = spiit E
A v = Show o Close

[¥] Show First Line Only Document| subd OQutline View

Master Document Close

Figure 8-10
Master Document options on the Outlining tab.

Outline Tools

Create Auxiliary Items

You can create a table of contents, index, and cross-references for all of the subdocuments in a master
document. See Chapter 7 for more information on tables of contents, indexes, and cross-references.

3. At the document beginning, type the first
heading or the document title and then press
Enter. Word creates the first heading and
applies a Heading 1 style.

Tip

For best results, use the Level 1 heading
for the document title and Level 2 head-
ings for subdocuments.

4. Press the Tab key, which shifts the second
line to a Level 2 heading, and type the first
document major topic.

5. Press Enter and continue typing document
topics. If desired, you can use the Demote
and Promote buttons to organize your topics
into major topics and minor topics. See
Figure 8-11 for an example.
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© Introduction to Peachtree Accounting
New Company

Default Options

Accounts Payable

Accounts Receivable

Inventory

Job Cost

Payroll

0000000

Figure 8-11
Creating the Master Document outline.

Working with Subdocuments

Now that you have the basic structure defined, it's
time to assign which headings are subdocuments.
You can create the subdocuments from the head-
ings in your outline, or you can indicate existing
documents.
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Creating Subdocuments

By creating the outline and specifying it's a Master
Document, you're only a mouse click away from
creating the subdocument. Click anywhere in the
first topic you want as a subdocument, and then
click Outlining > Master Document > Create. Word
puts a border around the topic and places a sub-
document icon to the left. (See Figure 8-12.)

=l Click the Save icon on the Quick Access
Toolbar or press Ctrl+S to save the master docu-
ment. Word also then saves the subtopic as its own
Word document. This step is very important, as it
creates the connections between the master and
any subdocuments.

W b 9-0l=
Qutlining

1 Show First Line Only
Outline Tools

© Introduction to Peachtree Accounting
L]

Introduction to Peachtree Accounting - Microsoft Word

Document |Subdocuments| ‘4] Uniink ] Lok Document  cuttine View
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- v § o= Show Collapse Close Create

Close

Subdocument link icon

[+]

New Company

)

Default Options
Accounts Payable
Accounts Receivable
Inventory

Job Cost

Payroll

000000

Figure 8-12

Creating a subdocument.

File Locations

Word stores all subdocuments in the same folder as the master document. When you first save the mas-
ter document, it's a good idea to save it in its own folder so all related documents are kept together.

The subdocument icon, which looks like a small
piece of paper, represents the link to the subdocu-
ment. Double-click the icon, and Word opens the
subdocument shown in Figure 8-13. Notice the

document title is the same as the text in the docu-
ment, which is also the heading you used in the
master document.
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Figure 8-13
Viewing a subdocument.

Any detail or text that needs to be entered should
be entered and saved in the subdocument. See
Figure 8-14 for an example.
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Text that you entered in the subdocument shows up the plus sign (+) next to the heading. Continue creat-
as body text in the master document, as shown in ing subdocuments as needed. Be sure to frequently
Figure 8-15. You can hide the body text by clicking save the master document.
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Copy settings from an existing Peachtree accounting company: This choice ...
Converta company program: ct sption if ...

Build your 5@ this if your has supplied you ...
Alist of sample charts of atcounts appears. ...
Selecting Company Options
One feature Peachtree has that many other sccounting software products ...
However, two of the options you select when setting up your company are ...
Actounting Basis: Accrual or Cash?
During the setup process, Peachtree asks youto select an sccounting ... .

pessd bl omnt It norah 50t z Figure 8-15
A cosh-bosed busingss dedares income in the month you recaive the ...

Say, for example, that you sell a $20,000 product to Smith and Sons an... ? Subdocument text ln the
master document.

19000 000000000000 0000000000D

4 ¥
Page: Lod 7 | Words: 2,766 | <D oG =

o

Tip

When you create subdocuments, Word automatically creates a section break between the subdocu-
ments. (See Chapter 4 for more information on section breaks.)

Inserting Subdocuments

If you have already created some or all of the docu- Subdocument Heading

ments you want as subdocuments, you can easily

insert them into the master document. For exam- For best and easiest results, make sure the
ple, perhaps you're writing a book and your biogra- already created subdocument has a level

phy information is already saved. You don’t need to heading at the beginning. So if you are work-
recreate and retype the biographical information. ing with Level 1 headings, the first line in the
You simply tell the master document where you've subdocument should be a Level 1 heading.
saved the biography. You don't actually insert the

document; you insert a link to the subdocument.
Follow these steps:
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1. From the Outline view, click the insertion
point in a blank line where you want the
already created subdocument.

2. Click Outlining > Master Document > Insert.
The Insert Subdocument dialog box shown in
Figure 8-16 appears.

(W] Microsoft word Documents library

Includes: 2 locations

(W] Insert Subdocument
L )L ) |[5 » Libraries » Documents » v | 4 || search Documents ol
Organize Mew folder =~ [l @

Arrange by: Folder »

i Favorites N - P dified &
ame ate moditie
Desktol
= P ] pro-collection-letterl 2/19/2010 8:29 P
& Downloads e ) ;
%] Recent Places pro-sales-followup-letter 2/1972010 :30 P
| My Stuff | ] pro-thankyou-letter 2/19/2010 8:29 P
| -!1] ritz Charles Payroll Notes 10/1/2006 11:33
4 libraries | ‘E_] Small Business Liability Insurance 4/2/2010 11:31 2
_ifl Documents |!_€|_] Surviving a Recession 4/2/2010 10:47 P
o) Music (1] tab exercise 2/20/2010 10:12
=/ Pictures 1] The Butterfly 2/25/2010 1:33 P
H videos 1] Understanding the COA 4/17/2010 4:38 F|=
(1] Using Default Information 4/17/2010 431P =
*y Homegroup
- 4 m L
File name: Understanding the COA - [Ni Word Documents V]
Tools = [ Open Iv] [ Cancel ] Figure 8-16

Inserting existing documents.

3. Locate and select the document you want and
click the Open button. You may see a message
about style formatting. Click Yes to All.

4. Save the master document. Word saves the
link between the master and subdocument.

5. Continue inserting additional subdocuments

if needed. Be sure to frequently save the mas-
ter document.
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Expanding and Collapsing
Subdocuments

In the master document, when subdocuments dis-
play in expanded mode, you see the text expanded
from the subdocuments. If you double-click the
plus sign next to the subdocument heading, you
can collapse the subheading. From there, you see
the subdocument link icon and the heading itself,
but no body text.

However, if you choose Outlining > Master
Document > Collapse Subheadings, you see the
actual links to the subdocuments. When you click
the Collapse Subheadings button, Word may
prompt you to save the master document. Click Yes.



Chapter 8

Working with Outlines

Your document then looks similar to the one
shown in Figure 8-17, in that the Collapse
Subdocuments button turns into the Expand
Subdocuments button. Instead of the headings,
you see the link to the subdocuments including
the drive and folder location. You also have the
subdocument icon on the left side. You can still
access the subdocuments by double-clicking the
subdocument icon or by holding down the Ctrl key
and clicking on the actual file link.

Irtroduction to Peachtree Acosunting - Microsoft Word

Fagelayout  References  Mailegs  Redew  View

™ R ENCNE )
Outiining | Home  Insert
> - . 3
7 St Tet Fomatting =

* -

o Expand
L1 Show First Line Only Dotument Subdocuments

Outline Tools Mastes Document

@ Introduction to Peachtree Accounting
[ ]

CAUsers\Diane\Documents\New Company.doc

a3 ©8

CAUsers\Diane\Documents\Understanding the COA docx

L]

CAUsers\Diane\Documents\Accounts Payable.docx

ChUsers\Diane\DocumentsiAccounts Receivable docx

L]

CAUsers\Diane\Documents\inventory.doc

CAUsers\Diane\Documentshlob Cost.docx

CAUsers\Diane\Documents\Payroll.docx
e

Ll
Page: 1of1 | Woeds:19 | o |

Close
| Outline View

= & B
a

. Figure 8-17
Collapsing the subdocuments.

HU33m 0% =

[+

To expand the master document back to where you
see the headings, choose Outlining > Master
Document > Expand Subdocuments.

Rearranging Subdocuments

Earlier in this chapter, you learned how you can
move outline heading levels up or down. You use
a very similar method if you need to rearrange
your subdocuments. For example, perhaps you
want the heading “Company History” before
“Company Future.”

You select the subdocument you want to move by
clicking its subdocument icon. If you want to move
multiple adjacent subdocuments, click the first
icon, and then hold down the Shift key as you click
the last icon in the group you want to move.

Drag the subdocument icon up or down the mas-
ter document outline. As you drag the mouse, a
gray line appears as shown in Figure 8-18. Release
the mouse when the line indicates where you want
the subdocument moved.
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Fagei 1011 | Words 9 | <X |

] Figure 8-18

Merging Subdocuments

As you work on a larger document, you may dis-
cover two or more topics you want to combine
into a single topic. For this, you need to use the
Master Document Merge feature.

First of all, the two topics you want to combine
must be located together. If the subdocuments are
not listed together, you must rearrange one of them.
(See the previous section for rearranging topics.)

Select the first topic's subdocument icon, which
highlights the entire topic, then hold down the
Shift key and click the second topic. Both topics
are now highlighted. (See Figure 8-19.)
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Figure 8-19
Selecting multiple subdocuments.
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Working with Outlines

Finally, click Outlining > Master Document >
Merge. The two topics combine into one, as shown
in Figure 8-20. When you combine subdocuments,
the first one that you selected before merging
them is the file into which Word inserts the con-
tents of the second document. The second subdoc-
ument file is still stored on your disk drive, but you
can safely delete it if you want to. (See Chapter 1
for information on deleting a file.)

© Introduction to Peachtree Accounting
.

© New Company

© Understanding the Chart o Accoun ts

@ Default Option

Choose Outlining > Master Document > Split.
Word moves the selected text into its own section.
In Figure 8-21, [ want to split the subdocument
Payroll into “Payroll” and “Tax Setup.” In the sub-
document, the newly created heading and any text
below it are moved and saved into a separate file,
just like all the other subdocuments.

1
Bogec 806 10 | i 413 BEE3E

Figure 8-20
Merging subdocuments.

Splitting Subdocuments

On the reverse side of merging subdocuments, you
may find you need to split the subdocuments up
even more. Perhaps you decided that a particular
topic was just too long. As easily as you can merge
subdocuments, you can split them.

Open the subtopic document you want to split by
double-clicking the subdocument icon. In the doc-
ument, place a comparable heading level (usually a
Level 2) as the other subtopic headings and then
save and close the subdocument.

In the master document, select the new heading.
The heading and all text below it is highlighted.

Figure 8-21
Splitting subdocuments.

Deleting Subdocuments

If you decide you don’t want to include a subdocu-
ment in the master document, you can easily
delete it. When you delete a subdocument, you're
not deleting the original document, only the con-
nection between the documents is deleted. The
original file remains on your disk drive.

To delete a subdocument, from the master docu-
ment, click anywhere in the subdocument heading
and choose Outlining > Master Document >
Unlink. The heading remains in the document, but
the connection to the saved file is eliminated.
Since the deleted file is still stored on your disk
drive, you can safely delete it if you want to. (See
Chapter 1 for information on deleting a file.)
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Creating a Multilevel List

N CHAPTER 3, you worked with a single- 1. Click your mouse where you want to begin
I level numbered list, such as Item 1, Item 2, and your list.

Item 3. A multilevel list shows the list items at ]
different levels rather than at one level. 2. Choose Home > Paragraph and click the

arrow next to Multilevel List. A gallery of

styles appears. (See Figure 8-22.)
By default, Word provides you with seven unique

multilevel lists styles. Choose the one you want by
following these steps:

wHd9-0is Document3 - Microsoft Word
Home Insert Page Layout References Mailings Review Wiew

) 7 calbriosy) v 11 v AT A Aac ®, i=-i=-fE] EE 49 -‘-\aBchD:;d.aBb

Paste B 7 v abe g B
- 7 u Ze i Z a4 [EE W Al
Eb_”"" &l Font o |1
—
List Library
~ 1)- 1.
- None a) 11.
. ] 114
- L] Article I Headi | | 1 Heading 1-
> Section1.01 1| | 1.1 Heading 2
.- - | | (a)veading3- | |1.4.4

Lists in Current Documents

1 -1 [1)
11. a)
144, Dl

Define MNew Multilevel List...

: C— Figure 8-22
X efine MNew List Style...
. Multilevel List options.
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Working with Outlines [JESLEINI&:

3. Click the style you want. Word assigns the
first level.

4. Type the text you want and press Enter.
Word drops to the next line down, and the
next number in the same level appears.
Figure 8-23 illustrates a multilevel list.

ﬁ Home Insert Page Layout References Mailings Feview View
1 F cobiomg -1 v A A A B E=CENE EE T
e o B J U-aexx A-¥-A-[EEINE i H-T

Clipboard s Font 0 Faragraph

— o _ = -
L |'—. T T A R T T, T T D
g = v T T v T ¥ T

1) Identifying Subjects and Verbs
a) Subjects
i) Single
i) Multiple
b) Verbs
Knowing The Differences
a) Prepositions
b) Subjects
3) Other Verbs
a) Main Verbs
b) Helping Verbs
4) Pronouns
a) Subject
b) Object
i) Comparison
(1) Singular
(2) Plural
ii) Agreement

£l o |

2

—

Figure 8-23
A multilevel list.
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Creating Form Letters with

Mail Merge

at

\ @ Y CTURE YOURSELF OPENING THE MAIL. On the front of the
envelope it says in big bold letters that “You have won TEN MILLION
EEDOLLARS.” Then, of course, in teeny tiny print it says “if you are the
lucky winner.” It has your name printed in big letters right there on the cer-
tificate! The funny thing is that each of your neighbors got exactly the same
letter with their name on the envelope and certificate. Probably millions of

exactly the same letter arrived in mailboxes all around the country.

Although our society has become a little more paperless than just a few
years ago, realistically we still use snail mail for lots of things. We still rely
on the postal service for delivery of our bills, catalogs, Christmas cards,
and lots of other types of correspondence. And let's not forget the hard-
working trash collectors. They might be out of work if it weren't for all
the junk mail we receive!

When you plan on sending a group of recipients the same basic letter, that
letter is called a form letter. A form letter results from merging together a
standard generic letter and personalized information. To create form letters
in Word, you use the Mail Merge function. This chapter is all about mail.




Creating the Main Document

OU NEED TWO THINGS to create a per- of the information that will vary from recipient to
Ysonalized mailing with a mail merge: a let- recipient, such as addresses, meeting dates, and such.
ter, which is called the main document and
contains the information that doesn’t change, and The following steps show you how to begin the

codes, called merge fields, that act as placeholders mail merge process:
for the variable information. This variable informa-
tion is usually a list of names and addresses, called
the data source, and contains the information that
does change for each letter. When you merge the
two, the result is an individualized form letter,
called the merge document.

1. Open or type the letter you want as the main
document.

2. Choose Mailings > Start Mail Merge > Start
Mail Merge > Letters. If you were not already
in Print Layout view, Word switches to Print

For the main document, you can use a letter that Layout view (see Figure 9-1).

you've previously created, or you can create a letter

from scratch. Type your letter without filling in any

ABC TIME STUDIES
123 WEST MAIN
INDIANAPOLIS, IN ATAZ3
(317) 555-1234

7o )

July 18, 2010

Dear :

Please acceptmy compliments for the supportive role you played when our firm held
the initial Person-to-Person training session at your company. I've had high-level
executives in our sessions before, and it's rare that they can resist the temptation to
dominate.

You allowed your managers to express doubts, raise questions, and honestly participate

in a frank discussion covering numerous sensitive topics. Flgure 9_1
vous L ha luaddarshin cida that athac avac Hisss racahs Ao oue udl A mail merge main document.
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Creating Form Letters with Mail Merge

Specifying Data for Your Mail Merge

NCE YOU CREATE your main document,

you need to link the document to a file that

contains your data. The data source could
be in the form of a comma-separated value Word
document, or it could be in an Excel worksheet or
an Access database. See Figure 9-2 for an example
of each document type—Excel, Access, and Word.

Two terms commonly used with merge data files
are fields and records. A field is an individual piece
of information about someone or something, such
as a zip code, first name, or product description. A
record is the complete picture of information with
all the fields put together.

Selecting a Data Source

For the data source, you can select from a preexist-
ing list or you can create a new one using Word. If
you want to choose from an existing file, choose
Mailings > Start Mail Merge > Select Recipients >
Use Existing List (see Figure 9-3). The Select Data
Source dialog box opens. Locate your data file and
choose Open.
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Figure 9-2
Possible data sources.
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Write & Insert Fields

Documenté - Microsoft Word

Wiew

2P Rules ~

93 Match Fields

| E&j Use Existing List...
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Ty, pe

83 Selectfrom Outlook Contacts..,

Figure 9-3
Selecting an existing data
source.

If you have not already created a data source, you
can create it with Word. Following are the steps for
creating a data source in Word:

1. Choose Mailings > Start Mail Merge > Select
Recipients > Type New List. The New Address
List dialog box appears. Word tries to antici-
pate your needs by providing the most com-
monly used data fields. (You'll soon see how
you can add extra fields.)

2. Enter the data for the first recipient. You do
not need to enter data into every field, as
you see in Figure 9-4.

| New Address List

e
Type recipient in the table. To add mare entries, cick New Entry.
Tite v |FistName  « [LastMame | Compary Name w | Address Line 1 |
- Pauline HNewman Hud Studios P.O.Box 120
L Daoris Daytona Que Sera Sera P.OBox 1090
= Fred Flintstone Bedrock Excavat.. 6302E Co.Rd. L.
| Clint Westwood Make MyDays 1612 N Baldwin ...
i v
[ petste Entry | [ Customige Cokms... | [ o ][ concel )
Figure 9-4
Adding records.
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Tip

Use the Tab key to move from one field to
the next, or press Shift+Tab to return to a
previous field.

3. Click the New Entry button, which creates a
blank line for the next recipient. Optionally, as
you press Tab after the last field, Word auto-
matically adds a line for the next recipient.

4. Repeat steps 2 and 3 for each additional
recipient.

Although Word includes commonly used data
fields, you may need to add your own fields or
remove the predefined fields you don’t want. Click
the Customize Columns button in the New
Address List dialog box. The Customize Address
List dialog box appears, like the one shown in
Figure 9-5. Make any desired changes and then
click OK.
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Eield Names
Title -
First Name

| Add...
e e ]
Company Name

Address Line 1
Address Line 2
City

State

ZIP Code

Country or Region
Home Phone
Work Phone
Mol

[ ok || cancel

| Customize Address List (7)==

Figure 9-5
Customizing data fields.

Here are the options available in the Customize
Address List dialog box:

» Add: To add additional fields, click the Add
button. As shown in Figure 9-6, Word
prompts you for a name for the new field.
Type the name and click OK.

Add Field (IS

Type a name for your field
Course Name|

[ OK ][ Cancel ]

Figure 9-6
Adding an additional data field.

» Delete: To delete an unwanted field, click a
field name and then click the Delete but-
ton. A confirmation message appears. Click
Yes to confirm the deletion.

» Rename: To rename a field, click the field
name and then click the Rename button.
Enter the new name in the resulting dialog
box and click OK.

» Move up: To move a field farther up in the
list, click the field name and click the Move
Up button until the field is located where
you want it.

» Move down: To move a field farther down
in the list, click the field name and click the
Move Down button until the field is located
where you want it.

Tip

If you want to delete a record, click any-
where in the record and click the Delete
Entry button. Click Yes to the resulting
confirmation message.

When you have all your entries in the New Address
List dialog box, click the OK button. Word prompts
you to save your address list. By default, Word
attempts to save the file in the Documents > My
Data Sources folder. Select a different folder if
desired. Enter a file name and then click Save.

Tip

Word saves the data file as an MDB file,
which is an Access database file.

171



Selecting Recipients

You may have a number of names in your data file,
but perhaps you don’t want to send the merged

2. Click the check box to the left of the name
for any recipient to whom you don’t want to
send the form letter. The checkmark will be

; ] removed.

letter to everyone in the file. By default, Word

assumes you want everyone in the data file, but

you can pick and choose which recipients you .

want to use. Just follow these steps: Ti P

1. Choose Mailings > Start Mail Merge > Edit To edit recipient information, click the

Recipient List. You see a Mail Merge data source name, then click the Edit but-
Recipients list similar to the one displayed in ton. The Edit Data Source dialog box
Figure 9-7. appears, from which you can make any

desired changes.

Tip

3. After determining that the desired recipients

Click any column heading to sort the are checked, click the OK button.

records by the selected column.

This is the list of recipients that will be used in your merge. Use the options below to add to or change your list. Use the
checkboxes to add or remove recipients from the merge. When your listis ready, click OK.

| Mail Merge Recipients |

_} Yalidate addresses. ..

Source ||7 |C|mne| w | Contact w | Address Line 1 v!l:iy -
esand Addre... [¥  Adams County Animal F... Lisa Doolittle P.0. Box 688 Anderson |=
esand Addre... |¥  Hud Studios Pauline Newman P.0.Box 120 Bloomer |
&5 and Addre... [ Que Sera Sera Doris Daytona P.O.Box 1090 Briston
&5 and Addre.. [ Quackery Bulletin Donald Duck P.O. Box 62 Coatesville
es and Addre... [V Bedrock Excavation Fred Flintstone 6302 E Co. Rd. 100 N. Decatur
es and Addre... Il seven Guns | James Whitemare | 605 Kesco | Flushing
es and Addre... |7 Harry Hunker Realtors Harry Hunker 5830 State Hwy 614 Glenview
esand Addre.. [¥ Deuce Batty Consulting  Deuce Batty 5190 Oster Road Jackson
es and Addre... |7 Colt Development USA Peyton Manning I 502 5 Nebraska Kalamazoo -

] m | »

Data Source Refine recipient list
Names and Addresses.dsx .+ | 4] sort...
T3 Filter...
E‘,_;;j Find duplicates...
- é;’J Find recipient. ..
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Figure 9-7
Deselect any recipient you
don't want to include.
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Inserting Merge Fields

document and have selected a data source,

the next step is to enter the merge fields
(also called merge codes) into the main document,
thereby instructing Word exactly where you want
those data fields placed.

N OW THAT YOU'VE CREATED the main

You have the option of placing a group of fields
together or choosing the individual fields you want
to enter. The field groups come in the two differ-
ent forms. The first group is for an Address Block,
which consists of the following fields: Title, First
Name, Last Name, Company Name, Address Line 1,
Address Line 2, City, State, and ZIP Code. The sec-
ond group is for the Greeting Line, which includes
a greeting such as “Dear” or “To,” followed by the
First Name and Last Name, and then a punctuation
choice, such as a comma.

Adding an Address Block

Begin by adding an Address Block. In the main doc-
ument, click the insertion point where you want
the recipient name and address. Choose Mailings >
Write & Insert Fields > Address Block. The Insert
Address Block dialog box appears, as shown in
Figure 9-8.

Since Word recognizes the individual fields—includ-
ing name, address, city, state, and ZIP—as part of
the Address Block, using the Address Block saves
you the steps of inserting each of those fields indi-
vidually. You can, however, choose the style of
Address Block you prefer. Click on the various
address formats and review in the Preview panel
just how your data looks with each format.

Insert Address Block

Match Fields button

@) Only include the country/region if different than:

United States
[¥] Format address according to the destination country/region

Specify address elements Preview
(V] Insert recipient's name in this Format: Here is a preview From your recipient list:
[Josh | 1 ]
Josh Randall Jr.
Joth Q. Raruial.x. 3 Lisa Doolktle
Jachua Randal . Adams County Animal Farms
Joshua Q. Randall . ([ Jl| PO Bax 662
— Anderson, WI 76722
| Insert company name
[¥] Insert postal address:
Never inchude the countryfregion in the address
Always include the country fregion in the address CorractPr

If items in your address block are missing or out of order, use
Match Fields to identify the correct address elements from your

_ Figure 9-8
Match Fiekds... ) )
Setting options for an Address

x ) om ) Block.
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Match Fields

If the fields in your Address Block don't
match your data, you can manually pair
them together. For example, if you expect to
see someone’s first name, but instead you
see their country, click the Match Fields but-
ton to identify and match the fields.

Click OK when you've decided on the format you
want. Word returns to the main document and
inserts a field <<AddressBlock>> at the insertion
point. This is a hidden code to Microsoft Word.
Don't try to just type <<AddressBlock>>.

Selecting a Greeting Line

Most form letters also include a personalized greet-
ing. Use the Greeting Line field box to assist you.
Begin by positioning the insertion point where you
want the Greeting Line, usually two lines under the
Address Block. Choose Mailings > Write & Insert
Fields > Greeting Line. The Insert Greeting Line
dialog box appears (see Figure 9-9).

Insert Greeting Line =
Greeting line format:

(none) [+ |30shua Randall Ir. [+] [tnone) [+]
Greeting line for invalid recipient names:

Dear Sir or Madam,
Preview
Here is a preview from your recipient list:

b > M

Lisa Doolittle ‘

Correct Problems

If items in your greeting line are missing or out of order, use Match Fields to
identify the correct address elements from your mailing list.

Select a greeting from the first drop-down list.
Choices include Dear, To, or nothing at all. From
the second drop-down list, select the name format
you like best, and then from the third drop-down
list, choose a punctuation mark of comma or a
colon, or choose no punctuation.

In the event that one or more of your recipients
doesn’t have data in the first and last name fields,
the Greeting Line for Invalid Recipient Names
drop-down list provides a couple of alternatives.
Select the one you prefer for your document. Or
you might have to click the Match Fields button
and select the proper field.

Click the OK button, which returns you to the
Word main document where you now see the
<<GreetingLine>> field code.

Adding Individual Fields

If the field information you want to insert into your
document doesn't fall into the Address Block or
Greeting Line groups, you can manually insert fields
into desired document areas. Just click the mouse
pointer where you want the field to appear. Choose
Mailings > Write & Insert Fields > Insert Merge Field
and select the field you want in the letter.

Fields and Forms

It's not necessary to use all fields in a form
letter, and you can use fields multiple times
in the same document.

Figure 9-9
Choosing a Greeting Line format.
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Figure 9-10 illustrates a sample form letter with an
Address Block, Greeting Line, and an individual
data field entered into the letter. To make it easier
for you to see, | highlighted the fields in yellow.
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July 19,2010

«AddressBlock»

Dear «Greetinglines:

Please accept my compliments forthe supportive role you played when our firm held
the initialtraining «Course» session atyour company. 've had high-level executivesin
oursessions before, and it's rare that they can resistthe temptationtodominate.

You allowed your managersto express doubts, raise questions,and honestly participate
in a frank discussion covering numerous sensitive topics.

You demonstrated the leadership style that other executives rarelydo. Your willingness
to participate as a co-equal willmake this top-down program successful at each level.

Thankyou for giving yourtime. It will pay offin a big way.l

Figure 9-10

Sincerely, A sample form letter.

Finishing the Merge

EFORE YOU ACTUALLY PRINT all the Use the Preview Results scroll buttons to browse

records, you should preview them. Choose between the previous and next records or the first

Mailings > Preview Results > Preview and last records. Again, in Figure 9-11, I left the
Results. You see your letter with data filled in from fields highlighted in yellow to make it easier for
one of the records (see Figure 9-11). In the Preview you to see.

mode, you can manually make any formatting or
text changes, and the changes will appear for all
recipients.
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5 erge Fields
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July 19, 2010

Pauline Newman
Hud Studios
P.0.Box 120
Bloomer, OH 11255

Dear Pauline Newman:

Please accept my compliments for the supportive role you played when ourfirm held
the initial training Protect the Client session atyour company. I've had high-level
executives in our sessions before,and it's rare that they can resist the temptation to
dominate.

T~ Preview Results scroll buttons

Figure 9-11

When you are satisfied with the results, you're ready
to finish the merge. Choose Mailings > Finish >
Finish & Merge. A menu of options appears where
you can edit the individual documents, print the doc-
uments, or send the documents via e-mail.

» Edit the Individual Documents: Choose
this option if you want to personalize your

Previewing the merged letter.

letters. This option creates a new Word doc-
ument where each letter is on its own page,
and any changes you make affect the indi-
vidual current record only—not the other
recipients. You have the option to merge all
records, the current record, or a range of
record numbers (see Figure 9-12).

wWid9-0r ABC Time Studhes - Microsoft Word
Home Insert Page Layout References Mailings Review View

= 3 b B

Erwelopes Labeli  StartMadl  Select

= & 8
&

123 WEST MAIN
INDIANAPOLIS, IN A7423
L (317) 555-1284

ABC TIME STUDIES @

July 19, 2010

Hud Studios|
Ms. Pauline Newman
P.0. Box 120
Bloomer,OH 11255

Dear Ms. Newman:

Please accept my compliments for the supportive role you played when our firm held
the initial Person-to-Persontraining ionatyour company. I've had high-level
executives in our sessions before, and it's rare that they can resist the temptationto
dominate.

‘ ,
Pagei Lot | Werdi a3 | B |

[HoE s um i

pliF

Figure 9-12
Displaying the merged letters
in a new Word document.

=0 =d

1153
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Creating Form Letters with Mail Merge

Chapter 9

» Print Documents: Choose this option if you
don't need to make any individual changes
and just want to print the merged docu-
ments. When you choose this option, you
can choose to merge all records, the current
record, or a range of record numbers.

P Send E-Mail Messages: This option sends
the document to the recipient via e-mail. The
e-mail option only works if the individual
record data includes e-mail addresses. When
you choose this option, like the others, you
can merge all records, the current record, or
a range of record numbers. Additionally, as
shown in Figure 9-13, you determine which
field in your data source contains the e-mail
address as well as enter a subject line. Also,
you determine if you want the letter sent as
an attachment to the e-mail, in HTML for-
mat, in the e-mail, or in just a plain text with
no formatting in the e-mail.

Tip

Don't leave the subject line blank. Many
e-mail filters will not display an e-mail
without a subject.

| Merge to E-mail

(7 =)
Message options
To: Email [=]

Subject ine: | Thank you for attending our class|

Mail format; HTML E
Send records

@ all

() Current record

) From: To:

[ OK ] [ Cancel

Figure 9-13
Sending the merged letters via e-mail.
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Printing Envelopes and

Labels

ICTURE YOURSELF DRIVING TO THE POST OFFICE.

There's a sign ahead: a stop sign. Just past the stop sign, you see

another sign. This one tells you how fast you can drive. When
you arrive at the post office, you see another sign; this one tells you
you've reached your destination. Everywhere you go, you see signs
providing directional information.

Envelopes are signs, too. Of course, they are smaller than most signs, but
they are directing the mailman where to deliver your important message.

Now think about labels. They are signs, too. You place labels on a gift

to make sure the gift is given to the right person. You probably don't

want your mom to open the gift containing a tie and your dad to get

the one with the perfume! You label your inventory so you don't send
the wrong item to your customer. We all use labels for many different
things pertaining to daily life.

By using Word's Mail Merge feature in the previous chapter, you discov-
ered how you can create a single letter and easily personalize it to send
to many different people. You can also use the Mail Merge feature with
envelopes—creating a single envelope and sending it to many different
addresses. Or perhaps you only need a single envelope for a letter you
just created in Word. If your Word document contains the recipient
address, you're only a few mouse clicks from printing the envelope.

And just as easily, you can create labels—either a full sheet of labels
with the same information, or a full sheet of labels, each with a differ-
ent address. Are you ready to get started?



Generating a Single Envelope

the post office when sorting mail, it's impor-

tant to make sure the envelope address is
clear and concise. Hand-addressed envelopes can
easily be misread by both man and machine and,
frankly, they often look very unprofessional.

B ECAUSE OF THE AUTOMATION used by

By using Word to address your envelopes, you can
create neat, accurate addresses for both the mail-
ing address and the return address. You can even
add a bar code that can often speed up delivery
time or a graphic image to make your envelope
personalized.

Creating the Envelope

When you generate an envelope, Word displays an
Envelopes and Labels dialog box. Obviously, for the
envelope, you'll need a delivery address. First take
a look at several methods Word uses to obtain a
delivery address:
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» If you have a letter or other document
already open on your screen, you can let
Word automatically find the recipient
address and fill it directly into the Delivery
Address box. By far, this is the fastest and
easiest method! Refer to Figure 10-1 for a
sample letter that contains a recipient
address.

» You can type the address directly into the
Delivery Address box in the Envelopes and
Labels dialog box.

» From the Envelopes and Labels dialog box,
you can choose an address from your
Outlook contact list.

» You can copy the address (Ctrl+C) from
another source and then paste it into the
Delivery Address box. Use the Ctrl+V key-
board shortcut to paste the address.
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Wido-0s ABC Time Stutkes - Microsoft Word = & 8
Home Insert Page Layout References Malings Review View =]
=58 2 B
Ermelopes Labels  Start Mall Select
Merge = Recipients -

» [zl

ABC TIME STUDIES E%]
123 WEST MAIN E?
| INDLANAPOLIS, IN 47423
|| (317) 555-1284

| July 19,2010

Hud Studios|

Ms. Pauline Newman
(| P.0. Box 120
| Bloomer,OH 11255

Dear Ms. Newman:

. Please accept my compliments for the supportive role you played when our firm held Figure 10-1
1] the initial Person-to-Persontraining ion at your company. I've had high-level .
executives in our sessions before, and it's rare that they can resist the temptationto e Word can Ple Up the
dominate. o .
. mailing address from the
4 »
Page: 1001 | Wiords: 136 | <3 | CEEET YO 0 current document.
Choose Mailings > Create > Envelopes. The Envelopes and Labels FIE
Envelopes and Labels dialog box seen in Figure 10-2 Erwelopes | Labels |
appears. If your document contained the mailing sty addresi @~
address, the address already appears in the Delivery [Hud Studios -
Address area. If you don't see the delivery address in - &
the dialog box, you need to enter the address using |Bloomer, OH 11255
one of the previously listed methods. =
|| Add electronic postage
Return address: W~ [ omt
|ABC Time Studies

1123 West Main

| Preview Feed
|Indianapolis, IN 47423 E E}

Werify that an envelope is loaded before printing.
[ et | [ addtooocument | [ gotions.. | [ E-postage Propertes.. |

Figure 10-2
Envelope settings.
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Following are the other choices on the Envelopes

tab:
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» If you subscribe to an electronic postage

service, such as Stamps.com, check the
Add Electronic Postage box. You also
should then click the E-Postage Properties
button to set any desired options for your
e-postage subscription.

» Enter your return address in the Return

Address box, or click the address book icon
above it to extract your address from your
Outlook contact list. When you exit the
Envelopes and Labels dialog box, Word asks
whether you want to save the return
address as the default return address. If you
choose Yes, the next time you open the
Envelopes and Labels dialog box, your
address will already be listed in the Return
Address section. You can change the default
return address at any time.

» Click the Omit check box if you don’t want
Word to add a return address to the envelope.

» Click the Options button to display the

Envelopes Options dialog box. From this
dialog box, you select the envelope size as
well as a default font you want for the
addresses.

» The Printing Options tab (in the Envelopes
Options dialog box) displays options for
feeding envelopes, but | recommend you
leave it at Automatically Select, since
Windows already knows how your current
printer accepts envelope feeds.

Printing Envelopes

Each printer model handles envelopes a little
differently. Review your printer manual for
envelope feed information.

Once you select the envelopes options, you now
can either create or print the envelope. If you click
the Print button, Word sends the printing informa-
tion directly to your default printer. Make sure you
have the printer on and the envelope inserted into
the appropriate location. If you click the Add to
Document button, Word adds a new page to the
top of the document and displays the envelope
(see Figure 10-3).
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ABE Tiaa Sradinn
123 Wien Muis
Indinnapalis BN4T423

Hugd Studios
M3, Pauline Newman
PO Boulin
Blosmer, 04 11255

ASC TIME STUDIES
123 WEST MAIN
INDIANAPOLIS, IN ATARS
(317) s85-1234

July19, 2010

Hug Studics
Ms. Pauline Newrman
PO, Box120
Birnear Db 117955

Figure 10-3
Adding an envelope to your
document.

If you add the envelope to the document, you can,
by using the Word tools you already know, edit the
envelope addresses, change fonts, or even add a
graphic to the envelope. If you want to change the
envelope options, click anywhere inside the enve-
lope area and choose Mailings > Create >
Envelopes again, which redisplays the Envelopes
and Labels dialog box. Make any desired changes
and then click Change Document.

Adding a U.S. Bar Code

The computerized sorting equipment used by the
United States Post Office relies on delivery point
bar codes, which are also known as POSTNET bar
codes. You can easily add a bar code to your enve-
lope. Follow these steps:

Tip

. Add the envelope to your document. (See the

previous section.)

. Click the insertion point where you want the

POSTNET bar code located, which is typically
directly above or below the delivery address.

. Choose Insert > Text > Quick Parts > Field.

The Field dialog box appears.

. In the Field Names list, click once on

BarCode. Bar code options appear on the
right side of the dialog box, as shown in
Figure 10-4.

If you are processing a bulk mailing, you can save money by presorting the envelopes and including
the POSTNET barcodes. Contact your post office for more information on bulk mail postal rates and

requirements.
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Please choose a field | Field properties Field options
Categories: Bookmark name: [] POSTNET bar code
(All)

= I Facing ID Mark (FIM):

AddressBlock :: [V] Bar code is LIS zip code: 11255

|¥] Preserye formatting during updates
Description:
Insert a delivery point bar code

Cox ) [ com ]

Figure 10-4
Generating a bar code.

5. In the Field Options section, click the Bar As you see in Figure 10-5, Word inserts the bar
Code Is US Zip Code option. code at the insertion point.

6. Next to the Bar Code Is US Zip Code option,
type the recipient zip code and then click the
OK button.

ABCTime Studies
123 West Nain
Indianapelis. IN 47423

Hud Studios
Ms. Pauline Newman
P.0.Box 120
Bloomer, OH 11255
[ [ P A P A T
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Figure 10-5
A POSTNET bar code.
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Chapter 10

Creating Labels

that feed easily into both inkjet and laser

printers, making mailing labels easy to pro-
duce using Word's Label function. Labels are espe-
cially useful if you have large quantities of letters to
mail, and, of course, some envelopes are simply too
big or bulky to fit into your printer. You can also use
labels to create hundreds of different items, such as
name tags, product information, file folder labels, or
return address labels.

YOU CAN PURCHASE SHEETS of labels

Like an envelope, if you want Word to pick up the
address automatically, create it in the form of a let-
ter or document before you begin label creation.
Otherwise, start with a blank document, and then
follow these steps:

1. Choose Mailings > Create > Labels. The
Envelopes and Labels dialog box appears
with the Labels tab on top.

. Click the Options button. The Label Options

dialog box shown in Figure 10-6 appears.

. Click the Tray drop-down list and select the

printer tray you plan on using for labels.

. Click the Label Vendor's drop-down list and

select the manufacturer of the labels you
plan on using.

. Click the label Product Number you want to

use. A description of the selected label
appears on the right side in the Label
Information area.

. Click the OK button. You return to the

Envelopes and Labels dialog box.

. Choose the Full Page of the Same Label

option. Select this option even if you want to
enter different information on each label.

Label Options
Printer information

() Continuous-feed printers
@ Page printers Tray: Default tray B
Label infarmation

Label vendors: | Awvery US Letter E

Find updates on Office.com

Easy Peel Address Labels

Prqr:IUfJ_: nyml_:gr: Label information

5155 Easy Peel Return Address Labels - Type:

5159 Mailing Labels Height: 1"

5160 Easy Peel Address Labels @ | wah: "
5161 Easy Peel Address Labels L EWTCK N 2Ot
5162 Easy Peel Address Labels Page size: 8.5" x 11
5163 Shipping Labels el

| Detais.. | | NewlLabel... |

OK

ll Cancel }

Figure 10-6

Choosing a label size.
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8. If you want a full page of the same label,
enter or edit the label information in the
Address section (see Figure 10-7) or click the
Insert Address icon to choose from an
Outlook contact.

Tip

If you want to type individual information
on each label, leave the Address box blank.

Show Me the Gridlines

Word uses tables when creating labels. If you
don't see the gridlines indicating labels, click
Table Tools Layout > Table > View Gridlines.

Emlapu and Labels L7 (=)
[ Enwelopes | Labels
Address: Wi = [ ] use return address
Hud Studios =
|Ms. Pauline Newman r
|P.O. Box 120

|Bloomer, OH 11255

Print Label
© Eull page of the same label Avery LS Letter, 5160 Easy Peel Ad...
) Single label Easy Peel Address Labels

Row: |1 | Column: |1

=

Before printing, insert labels in your printer's manual feeder,

pint | [ Mewpocument | [ gptions... | [ E-postage Properties... |

Figure 10-7
Enter address label information.

9. Click New Document. A screen full of labels
or a label grid appears.

10. You can now optionally edit the individual

labels and print them whenever you're ready
(see Figure 10-8).
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Figure 10-8
A full page of labels.

Tip

If you find that your labels are printing
too close to the left edge of the label,
press Ctrl+A to select all of the labels, and
then drag the left indent mark a little to
the right on the ruler.



Part 3

Word Columns,
Tables, and Graphics

Newspapers, newsletters, magazines, and many Web
sites format information in columns. Doing so allows for
more flexibility in arranging topics within a larger docu-
ment. In Word, using columns makes your information
easy to find and read when creating newsletters and
other documents.

You also have tables, which are a grid of columns and
rows and great for comparing or following information
across several columns. If you have used Microsoft Excel
or another spreadsheet program, you will find working
with tables in Word very similar. In fact, on a very small
scale, Word tables are small spreadsheets.

And finally, in this part of the book, you'll work with
graphics, such as pictures, shapes, or diagrams. Using a
few carefully placed graphics in your document can be
just the enhancement the document needs to keep your
reading audience interested. You’ll learn how to place
them into your document and manipulate their size,
color, arrangement, and more. Working with Word
graphics is fun and easy.







Working with

Columns

ICTURE YOURSELF WORKING in your vegetable garden on a
bright, sunny day. You have several packets of seeds that you want
to plant, so you consult the directions on the back of each packet.
Most of the packets recommend planting the seeds in rows, with a certain
amount of space between rows to allow the plants room to reach their
mature size without crowding one another. Better pick up the hoe and
start making rows!

Columns in a document help you organize text in vertical “rows” for
easier reading. Newspapers, newsletters, magazines, and many Web
sites all format information in columns to allow for more flexibility in
arranging shorter topics within the context of the larger document.
Whether you're creating a meeting summary for colleagues or a news-
letter to send to family and friends, using columns will enable you to
create an attractive look that makes stories easy to find and read.



Adding Columns

EWSPAPERS AND MAGAZINES are
N just a few of the documents that use

columns to break up stories, with the text
flowing from the bottom of one column to the top
of the next. Of course, columns can be used for
many other items, such as creating attractive
newsletters, forms, or marketing materials.

When you format text in columns, you should do so
with the reader in mind. Columns provide a means
of not only arranging information on the page, but
also for making a document more readable. The rule
of thumb is that the smaller the font size applied to
text, the narrower the size of the overall line (also
called line length) should be. The default 11-point
font in Word works fine for a margin-to-margin line,
but at 8 points, a line like that might be hard to
read. When you need to use a smaller font to pack
more information onto a page, using columns will
maintain the text's readability.

Newspaper-Style Columns

The type of columns that Word creates by
default, where the text fills one column
and then starts down the next, are called
newspaper-style columns. To create columns
that flow in another way, use text boxes.

Word applies columns to the entire document
unless you first select the portion you want changed
into columns, or you can create section breaks and
apply the column settings to the current section.
(You first discovered section breaks in Chapter 4.)

Choose Page Layout > Page Setup > Columns. As
shown in Figure 11-1, you see a drop-down list of
preset column options. Click one of them to apply
the columns that you want. Take a look at what
each choice represents:

Home  mnzent

E.I B 2y Orientation = 43 Bresks = @ w L I Asign *
""' [al- 13 size - 2 tine Mumbers = | 8 Pa Pren: o s
s | Murges G 1 piatin~ | E) uge Burds | I8 gt B, Setetion Pane
.J one =
] ™o
] e i O P
readily in a warm water bath. Just place wads of comfrey in a S-gallon bucket, cover
J et 1d cover firmly with a lid. Place the bucket in the sunshine. After 2 weeks or so, your
will be ready. (Be wamed that it also might be quite fragrant!) Dilute and apply to
Tred.
J Fught
. MR More Columns... i vo o Oviars
Figure 11-1 Aie Corry : ;
Some plants are just naturals for early spring and late fall—spinach, various letiuces, beets, kale,
H o and more. These plants just boom in cool weather, but in hot weather? Not so much.
Choosing column settings.
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Chapter 11

Working with Columns

Pute o (Bl U - dex %

Chpboard

» One: Use this choice to transform the docu-

ment (or section) from

multiple columns

back to a single column.

P Two: Select this to divide the page into two
equally spaced columns.

» Three: If you want three equally spaced
columns on the page, choose this option.

P Left: The Left option divides the page into
two columns, but the left column is smaller
than the right (see Figure 11-2).

P Right: The Right option divides the page
into two columns, but the right column is
smaller than the left.

Home | Bnset  Papelaycet  References  Madings

Y FaninGothic = 14+ AT AT Aac # =

Fart

» More Columns: This option displays the
Columns dialog box where you can cus-
tomize your column settings.

Use Section Breaks

Remember that if you want to make column
changes to only a portion of the document,
you must select that portion or click in the
section before choosing options from the
Columns dialog box.

Review  View

e iE® 09 sapnced AaBbeeD | AaBbC | AaBbCe |
oA EEam e

D

EMoemal T No Spaci

Pasagraph Styles

Hesging1 | Heading2 ||

b Selet -

Eting

Compost Capers

Some gardeners shy away
from composting, calling it
ahassleora d eff

Cool Weather Carry Overs
Some plants are just naturals for early springand late fall—
spinach, various lettuces, beets, kale, and more. These plants
just i | weather, but in hot weather? Not so much.

‘While composting does
requine work, planning. and
an appropriate space, there
are altemnate methods that
take less time and effort.

In winter, you can direct

‘You may already be using row covers both to start these plants
earlier in the spring or keep them warm from fall into winter.
But did you know that you also can use a different type of row
«cover to help your cool weather plants stay or start off coolerin
summer? The key is to use a row cover material that shades
the rows and is permeable 5o that heat escapes and the plants

COMpost veg
into the garden. You can
either pile more dense

matter in the garden or

.....

aren't Catalogs for hobby g and
professional growers offer a variety of fabrics suitable forrow
«covers and can help you select the row cover fabric that will be
Ibest for extending the life of cool weather crops in yourzone,

» &

Figure 11-2
The left column is smaller
than the right.
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Figure 11-3 illustrates a newsletter created in Word
using columns, a section break, shading, and a few
graphics.

Pagelayout  References  Malings  Review  View
18 Cover Page = B T Gk (3 Header = A 7| & QuickPurts + [ Signatuse tine =TT Eauation +
) Blank Page : =] U a - A Bookmark & Foster = " Al woraset - (Bl Date & Time £ Symbad =
¥ Page Break B} Crossreterence | s) Page tumber = | gane A¥Drop Cap+  gObject +

Fages Tabies Butrations Links Header & Feoter Teat Symbols

Table Picture O Shapes Smadtart Chat Scoreenshot
. e .

Great =
Gardening

In This Issue Growing Great Garlic
»  Grow Great Garlic ood news if you are reluctant to shell out $3 per pound
« Compost Capers forquality galic at your local market! Garlic is
«  Cool Weather Carry surprisingly easy to grow. Even novice gardeners can
Disees, plunk some garlic in th ground in the fall and have a nice crop
to harvest by summer, i you're a garlic newbie, here are some
tips 1o get you started:

* While it ibleto plant g: B aisle,
investing in bulbs from a quality seed supplier will give
meore reliable results.

«  Know the variety that you are buying. Softneck garlics
ane smaller and can be braided lor storage, while
hardneck varieties may store for longer periods of time,

«  Plant eitherin the fall in cooler climates or early spring

Figure 11-3
A finished newsletter.

elsewhere.
= Plant individual cloves in loose, well composted soil 1-3

Pagtilel2 | Wors 508 | 5 | EEEEN &E}I -D.

| [P

Tip

To create the large first letter shown in the main story in Figure 11-3, called a drop cap, select the
first letter and choose Insert > Text > Drop Cap > Dropped.
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Typing in Columns

S WITH A LOT of other formatting in col.umns at thg top of a new page or at some
Aword' you can apply column formatting pomt on an existing page, such. as after the
either before or after you create the text for title for a newsletter, although it's usually
a document. There are advantages to both methods. not good design to format most of the page
If you've already typed your text, applying the ina smgle column and the end of the page
columns after the fact will give you the opportunity in multiple columns.

to work with column widths and edit the text to fit
the columns. Applying the columns first gives the
advantage of enabling you to see how much text
will fit on the page using the number of columns
and font size that you want to use. This shows you
if you have room for more information or need to
be more concise.

2. Choose Page Layout > Page Setup >
Columns, and then click one of the preset
column options. (You also can use the More
Columns choice, which you'll learn about in
the next section, to set up the columns.)

3. Type your text. When you reach the bottom
of the first column, simply keep typing. As
Follow these steps to apply columns and then type shown in Figure 11-4, the insertion point
text in a document: automatically moves to the top of the next
column, flowing the text to that column,
just as word wrap flows text from one line to
the next.

1. Position the insertion point where you'd like
to start typing in columns. You can start

Compaost Capers of cool weather crops in your zone. For mare
|

¥ dwy

calling it a hassbe or 3 wasted effort. While
COMmposting does requine work, planning and
an appropriate space, there are allemate
methods that take less time and effort

In winter, you can direct cnﬂm\wpu.ue
e ks the it o i it I~ Text typed at top of second column
smadler bits out. After a few months, simply
‘work the decayed material into the soll.

Another method involves creating compost
A, Some vegetable matter—especially
comirey—breaks down readily in 2 warm
water bath. Just place wads of comérey na 5-
galion buclest, cover with water, and cover
Tiernly with & lid. Place the Bucket in the
sunshine. After 2 weeks of 0, your compost
tea will be ready. (Be warned that it also
imight be quite fragrant!) Dilute and apply to
{plants as desired.

Cool Weather Carry Overs : Figure 11-4
Some plants are just naturals for early spring. o
Typing with columns.

and |ate fall-spinach, various [sttuces, beets,
Poge 1eld | Weesssit | o CEEEY WL
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Creating Custom Columns

columns of equal size or two-column docu-

ments with narrow left or right columns. You
can create up to 45 columns, and you can specify a
precise width for each of the columns. For example,
if you are creating your own brochures using legal-
sized paper, you could format the document in the
landscape orientation and set it up to have four
columns of information. Each of the columns would
then appear as a “panel” once you folded the
brochure to its finished size. Or, you might need two
narrower columns at the left side of the document
and one larger column at the right.

YOU AREN'T LIMITED to creating three

The Columns dialog box enables you to create
more than three columns as well as make columns
that are precise in width. Select the text to which
you'd like to apply the columns or position the
insertion point where you'd like to start typing in
columns. Choose Page Layout > Page Setup >
Columns > More Columns. The Columns dialog
box shown in Figure 11-5 appears. Make sure the
Apply To drop-down list has the correct setting
selected. The available choices will depend on
whether you selected text in advance or simply
positioned the insertion point at the location
where you want the columns to start.
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Apply To list Choose number of columns
-
Columns ¢
= == E== =z
= EE is =
One i Two Left Right
Number of dolumns: |1 = Line between
Width and pacing Preview
Col #: Width: Spading:
1t 5
,_ —_—
=
Equal clumn width
Apply to: | Selected text El Start new column
o ][ conel ]
M

Figure 11-5
Creating multiple columns.

If you selected text first, here are the choices:

» Selected Text: Choose this option to apply
the column changes to the selection only.

» Selected Sections: Use this choice to apply
the column changes to the entire section(s)
that contains the text you selected.

» Whole Document: Choose this option if
you realize that you want to format the
whole document in columns.



Working with Columns [EEiEIIEC@]

If you instead positioned the insertion point at the
location where you want the columns to start, the
Apply To choices are as follows:

» This Section: Applies the column changes to
the section holding the insertion point only.

P This Point Forward: Applies the column
settings to the section holding the insertion
point and any subsequent sections in the
document.

» Whole Document: Applies the column set-
tings to the entire document.

Once you've determined where to apply the
columns, move on to indicating the number of
columns to create. You can click one of the choices
in the Presets section and modify settings from
there, or you type an entry in the Number of
Columns text box or use its spinner arrows to indi-
cate how many columns you need. For example,
Figure 11-6 shows 4 columns specified.

Columns &g
Presets
— - EEE mm— 1}
= EE i is =
One Two Three Left Right
Number of comns: |4 |+ [7] Line between
Width and spacing Preview
Col #:  Width: ~ Spadng:
125" B o5 H -

2 | (125" ] [o.5° =] L EEES
EESES
3| L2 = |0.57 H - EEES
[¥] Equal column width

Apply to: | This section E

Start new column

[ oc J[ conce |

Figure 11-6
Adding columns.

Click OK. The document displays with the columns
in place. Figure 11-7 shows a document with four
columns, as specified in Figure 11-6.

To Do List Compost the backet in he sermman heat
=t Cagan oot
-
+ Ot seets be ready. (Be Catabogs bor hobby
and veediogs
+ it kg might b ite pritessional
i o beptpas Iragriti)Giksts growers cftera
S e secquire workk, s
s desired. suitable for ow
remaining :_:_,m s
¥ wpectand there are aitemate
repais Carry Overs rivw cirenr fabekt.
wwuo m'::mm Sorme plants ire thst will b bewt
+ Artersd garden o= [Ura—"— o extencing e
e plst sabes early spring and a-of cool waathar
i winte, you can. late fal—spinach. IO 0 YOUF Fone.
[Favorite direct compost Vi lettuces.
Gardening vegetable aner beets, ale, and
Quotations et the garden. more. Thess plassy
Youcen siherpile  jest boomin cool
fesosrambsponn marn dese westher, et in hot
i matter i the weather? Kot 0
S— Barden cr sgread mesch.
it p———
e Bnbning 108 prisapgbes Youmay already
mane, sirply g
puas 013 | ot 100 {5 | e DEaam we -
.
Figure 11-7

A four-column section.

Tip

Some pros at document design recom-
mend decreasing margin widths if you
add more than two or three columns in a
document to provide more room for text
and column spacing. Refer back to
Chapter 4 to refresh your memory about
setting margins.
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Changing Column Size

FTEN, YOU DON'T WANT all the Width for leftmost columns
O columns in a document to have the same e, 2
width. For example, if a newsletter you're
creating includes a list of articles, you may want s
that list to appear in a very narrow column at the = = i ‘ is = ‘
left or right while having two other larger columns one . Thvee Lot Right
for the articles themselves. Or if you want a lot of Naber of cokkabe: |5 ) Line between
space between columns in a document, you might Width and sphchg Preview
reduce column width to allow for more space. Col #: W:L‘- Spacing:
=] [1z H o5
(2] [z H o5
The Width and Spacing section of Word's Columns [3][ar =
dialog box displays a row of settings for each col- I i coh s vt
umn you created. Choose Page Layout > Page
Setup > Columns > More Columns to open the dia- SNTRR] T seckon [-] P
log box. To be able to customize the columns indi- [ ok ][ cancel |
vidually, click the Equal Column Width option at S e —
the bottom of the section to clear the check box. Figure 11-8
The controls on each row then become active. Custom column width.

You can use the Width controls to specify the cor-
responding column’s width. For example, Figure
11-8 shows the settings for a three-column layout
where the first two columns are 1.2 inches wide.
After you click OK, Word adjusts the column sizes
accordingly. Figure 11-9 shows how the column
width settings applied in Figure 11-8 look in a
newsletter document.
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o Do List Compost e oo By ith 4 6. P the buchtin
v Pantoml Dugaia he sunstire, Ater 2 weeks or 5, your
‘compas iea will e ready. (Be wamed that &
THICOTOR iy gy trom
¥ Ordersods ooy 1oplants i denired
Indiesd®t  culiagRahasle  Cool Weathor Camy Overs

;
i
|

‘Yoo may alsendy be using row covers bath fo.

repairoe spubce, there see +100t hese plants earbe inhe spring o kesp

seplace tols e ‘thaten warrn frsen [l int winiter. But S you

Amend garden  mpthods that

i o Bt you sl can b & BBerest frpe of

Lod ndffon o0 wtart off coobes in sammer? The ley is o use

matesial that shades the sows and
Favorite i winter, you can e
: ™ +6110a et escages and the

Gardening et compost o el
Quotations W Punaes seed probasabonil Jrowars ofiee 8
mane shen you o b you weoc the pow cover fabek that
have s garden. D‘*m;“" wil be B for extending te e of ool
There's sotsing e WLl Crops in yous Bone.
[T i b el

Puge 2otd | e de0 | 5 SEEam e

Smaller Columns, Smaller Font Size

Don't forget that when you make a column
narrower, as a result you have more leeway to
reduce the size of the text in the column.
This means you can add more information
into a small column holding a list of contents
or tips.

Figure 11-9
Two narrow left columns.

Changing Space Between Columns

columns also impacts the look of the docu-

ment and the readability of text. Compare
the examples in Figure 11-10. The top example has
0.5 inches of space between columns, while the

CONTROLLING THE SPACING between

bottom example has only 0.2 inches. This subtle
change reduces some of the excess space in this
example and also better aligns the larger main col-
umn at right with the newsletter title above.
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Reduced spacing Improved alignment with title The row for each column in the Width and Spacing
/ section of the Columns dialog box includes a
G reul. Spacing control that you can use to adjust column
spacing. To be able to customize the columns indi-
vidually, click the Equal Column Width option at

Gﬂ I‘de ng the bottom of the section to clear the check box.

Then, you can adjust not only the width for each

Growing Great Garlic

ood news fyou are ghuctant o shellout 3 per pound column, but also change the spacing that appears
for quality gadic at four local market! Garic is 5 )
isingy easy th grow. vennavice to the right of the column by changing the value
garlicin th in the fall and have a nice crop . . . .
to harvest by summer.  you're  gari newbi, hereare some in the Spacing field on the same row (see Figure
tips to get you stai B .
o S apodbibls i ik gk omniie grocemyelils 11-11). You can change column spacing either
e when you create custom columns or after you've
- i that you are buying. 2
s oo Aot b Dt or S eag e created columns.
wvarieties may store for longer periods of time.
«  Plant fither in the fall in cooler climates or early spring
Follow these steps to change the width between
G eul- columns in text already formatted in columns:
@ . . . .
a rden i ng 1. Click anywhere in the section formatted in
_ columns.
In This lssue Growing Great Garlic
*  Grow Great Garlic ood news if you are reluctant to shell out $3 per pound for
« compostCapers quality galicatyour local market Garic s surprisnglyeasy 2. Choose Page Layout > Page Setup > Columns
»  Cool Weather Carry to grow. i lunk rlic in the .
overs round nthefal and have a nicecrop o harvest by summer. > More Columns. The Columns dialog box
you're a garlic newbie, here are some tips to get you started:
-~ = Whileit's plant g; B aisle, appears'
Investing in bulbs g
reliable results.
46 iy o 3. If it isn't already unchecked, click the Equal
arieties may store forlonger periods of time, !
« Plantetherinthetal o coole cimtes or ey sping Column Width check box to remove the
elsewhere.
*  Plant individual cloves in loose, well composted soil 1.3 checkmark.

Figure 11-10
Changing column spacing.

Tip

When you set custom column widths,
Word recalculates the widths for other
columns but does not recalculate spacing.
You have to change spacing manually
when needed.
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Spacing to the right of columns 4. For each column for which you'd like to
adjust the spacing, use the spinner arrows to

[ cotumns LE i) increase or decrease the Spacing setting.
Presets
= T I T 5. Click OK to apply the column spacing.
i Two Left Rioht Figure 11-12 shows how a newsletter page looks
f| hnber of cokams: |3 B L etrman with the settings shown in Figure 11-11 applied.
wg:":“dw’::‘g el Each of the left columns is 1.2 inches wide, with
S = 0.3 inches of spacing. Word recalculated the width
12 : g
| Z1z__ & giﬁ of the right column to be 3.5 inches based on the
: [3] [35 + ggﬁ reduced spacing.
Il [ Equal column width
/| Apply to: | This section E Start new column

Figure 11-11
Controlling column spacing.

Home Page Layout References Madfings Review View
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Thimes Bl MU o Consmns = " Hyphenation - L] Page Borders | 3 Right: 0 3 iSamer gt 3 P T By Selection Pane L ].Z_inch Columns
Themes Page Setup Paragraph . Amange
[ s T PR, | O MR e rprr T “
_— 0.3-inch spacing
To Do List Compost and cover firmly with a lid. Place the bucket in the /
¥ Plantcool Capers sunshine. After 2 weeks or $0, your compost tea
z wealher criops  gome gardeners
: ¥ Tillincompost 1 .
: 7 Oeaads i | 3.5-inch column
: and seediings yyih P
¥ Use mulching Just naturals for early spring and
mower o Bll-spinach, various lettuces, beets, kale, a
tak cai ot m‘&":’""‘ more. These plants just boom in “utin
remaining work plening, ot weather? Not so
. leaves and an You may already be using row covers both to start
Kopo-t Sl P inthe spring or keep
repair or space, there are from fall into winter. But did you know that you also
= > replacetools  aiemate can use a different type of row cover to help your cool
- ‘:f"dw“ methods that weather plants stay or start off cooler in summer?
3 Sad plant take less time The key is to use a row cover material that shades
sales and etfort. the rows and Is permeable 5o that heat escapes and
3 Favorite 1 winter, you can meplamar!n'lmﬂlemd.htabsslmlnhh_y
5| Gardening direct compost s . Snetyof
- vegetable matter e A
Quotations Itg-the select the row cover fabric that will be best for
Weather means :fo:ms:ilmdm extending the life of cool weather crops in your zone.
more when you -
pile more dense .
: have a garden. iy : Figure 11-12
=) There's nothing 5 of
: ke listeningtoa  Borden orspread _ 1 . .
o013 | Woraseeo [ — I Yo E———o| Custom widths and spacing.
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Inserting Lines Between Columns

a document that you really want to squeeze the

spacing between columns to the smallest possi-
ble size, you can add lines between columns to
help your readers. The lines visually separate the
columns of text, preventing the reader’s eye from
wandering right past that narrow space to the next
column over. As for the other settings for cus-
tomizing columns that you've seen so far, you use
the Columns dialog box to add or remove lines.
You can add or remove the lines while customizing
columns, or at a later time.

I F YOU NEED TO INCLUDE so much text in

Follow these steps to add vertical lines between
columns in text already formatted in columns:

1. Click anywhere in the section formatted in
columns.

2. Choose Page Layout > Page Setup > Columns
> More Columns. The Columns dialog box
appears.

3. Click the Line Between option to check it, as
shown in Figure 11-13. The Preview area in
the Columns dialog box shows you where
the lines will appear.

4. Click OK to apply the line setting.
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Line Between check box

\

Columns \

/| Number of columns: |3

(L7 [t
Pressts
E B W \E
One Two Three Left Right

| Width and spading
Col #:  Width: Spacing:
: 1 1.2° = [0.3"
! 2z | = [0.3"
o[ 3|35 :
|| [[]Equal column width
'| Apply to: | This section El Start new column
Ll
' o J[ coee ] |
——— —

Figure 11-13
Adding lines between columns.

Figure 11-14 shows the example newsletter with
lines between columns. You may have noted that
the Columns dialog box doesn't present any
options for formatting the lines between columns.
If you need more flexibility in the appearance of
the lines, you can manually insert line shapes and
format them individually. (Chapter 13 explains
how to add and format shapes.) Another approach
would be to create a table rather than columns,
and display and format only vertical borders
between cells. (Chapter 12 shows how to create
and format tables.)
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Lines separating columns.

Adding and Deleting Column Breaks

Y DEFAULT, TEXT WILL FLOW down one

column, then over to the next column. If you

want the column to break at a particular point,
you can insert a manual column break. Column
breaks are similar to page breaks in that you cannot
create a manual column break to make the column
longer than the page margins, but you can make a
column shorter. Here are a few examples of when
you might add column breaks in a document:

P Insert a column break just before a column
heading to force the column heading to the
top of the next column.

P Similarly, insert a column break before a
paragraph to shift the entire paragraph to
the next column so that you avoid an awk-
ward split in the paragraph.

P Insert a column break to balance columns.
For example, if a two-column document has
a full left column but little text in the right
column, use a column break to shift more
text to the right-hand column for a more
attractive appearance.
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To create a manual column break, position the
insertion point where you'd like the break to
begin. That is, click immediately to the left of the
text that you want to shift to the top of the next
column. Choose Page Layout > Page Setup >
Breaks > Column.

Removing a column break works just as easily. You
can click in the same position that you clicked to
create the column break (such as immediately to
the left of a heading), and press the Backspace key.
Another method is to choose View > Document
Views > Draft. The column break appears as a dot-
ted line with the text “Column Break” at the center.
Double-click on the Column Break line to select it,

as shown in Figure 11-15, and then press the Delete
key to remove the break. Choose View > Document
Views > Print Layout to leave Draft view.

Headings and Columns

If a column heading lines up at the top of a
column, check its position. Most heading
styles include extra space before the heading,
preventing the heading from aligning prop-
erly. See “Adjusting Spacing Between
Paragraphs” in Chapter 3 to learn how to
remove the space.

v Attend

garden and

plant sales.
oty Break
Favor]%e
Gardening
Quotations
Weather means
maore when you

Figure 11-15
Removing a column break in
Draft view.

Deleting Columns

if you apply multiple columns and don't like

the result you get, or if you're working with
a copy of a document file and need to remove the
columns to reformat the text for another audience

YOU MAY WANT TO REMOVE columns
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or document type. The simplest way to remove the
columns is to click in the section formatted in
columns, and then choose Page Layout > Page
Setup > Columns > One, as shown in Figure 11-16.



Working with Columns [EEiEIIEC@]

me Insert Page Layout

— [ Size~
Mar.gms EE Columns ~

One

Al
ll

= Two
Three
== Left

=:| Right

(23 Orientation v %= Break

¥ Linen
be™ Hyph

== |
£ More Columns... |

Figure 11-16

Removing columns in a section.

Tip

If you inserted column breaks, they will
function as page breaks when you return
the document to one column. Delete the
column breaks as described in the previ-
ous section.

If you want to delete the columns in a section as
well as all other section formatting, delete the sec-
tion break that follows the column. Choose View >
Document Views > Draft. The column break
appears as a double dotted line with the text
“Section Break” and the name of the break type at
the center. Click on the Section Break line to select
it, and then press the Delete key to remove the
break. Choose View > Document Views > Print
Layout to leave Draft view.

1 'rlll
Wl
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Working with

ICTURE YOURSELF CRAWLING out of your warm

bed after a good night's sleep. A luxurious aroma wafts

p |
through the house and you anticipate your first cup of

hot coffee. You sit at the table and begin reading the morning
paper, scanning the headlines and reading some articles in their
entirety. You look at the financial section to check your stocks,
and you review the weather forecast for the next few days.

When you look at the financial page or the weather forecast,
you're usually looking at a table. Tables are great for organizing
information. A table is a grid of columns and rows, and the inter-
section of a column and row is called a cell. When you need to
compare data or follow information across several columns, it's
easier if the information is displayed in a table. You can use
tables to place pieces of data side by side in a document—for
example, in the various sections of an invoice or address list.

If you have used Microsoft Excel or another spreadsheet program,
you will find working with tables in Word very similar. In fact, on
a very small scale, Word tables are small spreadsheets.

That's what this chapter is all about—creating the type of docu-
ment designed for reading large amounts of information quickly
and easily.




Creating a Simple Table

HEN YOU CREATE A TABLE, all you

need to do is estimate the number of

rows and columns you need. Notice |
said estimate. You'll find it easy to add or delete
rows or columns after you create the table. Use the
following steps to create a table:

1. Position the insertion point where you would
like the table to begin.

2. Choose Insert > Tables > Table, which dis-
plays a table grid like the one you see in
Figure 12-1.

3. Drag the mouse across the squares that repre-
sent the number of rows and columns you
want in your table. Word's Live Preview feature
draws a sample of the table in your document.

Tip

If you don’t want to drag across the table
grid to set the table size, choose Insert >
Table > Insert Table. The Insert Table dia-
log box appears, in which you can type
how many rows and columns you want in
your table.
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The table grid.
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Working with Tables

Chapter 12

4. Click the square that represents the lower
right corner of your table. Word places the
table into your document.

Notice in Figure 12-2 that the blinking insertion
point is in the first table cell and that the Ribbon
now contains two Table Tools tabs: Design and
Layout.
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2010 Sales Report

will find a table representing our four country regions.

- [ Boedersl=] Wt

Each year we present to you a two year sales comparison. During the fiscal year ending June 31, 2010,
ABC Production saw a large increase in widget sales, particularly in our new Metallica line. Below you
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Figure 12-2
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Tip

Creating a table.

A table cell is a box that appears at the intersection of a row and column. Although the names don't
display, each column takes an alphabetic letter, A, B, C, and so forth. Each row is indicated by num-
ber. A cell, then, is referred to by both the column and row, such as A2 or B5. This is especially
important if you create a formula in your table. (See “Creating Table Formulas” later in this chapter.)
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Entering Text

NCE YOU HAVE YOUR TABLE in the text. You can press the Tab key to move to the next
document, you can start adding text to it. cell or press Shift+Tab to move to the previous cell.

Click in the cell where you want to enter You can also use the up and d.own arrow keys to
information and begin typing, as shown in Figure Mmove up or down a row at a time, and of course
12-3. If needed, Word automatically wraps the text you can click your mouse in any cell.
and expands the row height to accommodate the

(W id9-0 = Dacumestl - Micrasoft Word
Home Insert Page Layout References Maslings Review Wiew Diesign Layout
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Total Riow Last Calumn %

| Banded Rows ] Banded Columns
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2010 Sales Report

Each year we present to you a two year sales comparison. During the fiscal year ending June 31, 2010,
ABC Production saw a large increase in widget sales, particularly in our new Metallica line. Below you
will find a table representing our four country regions.

Widget Sales by Territory FYE: 2009 FYE: 2010
East 156341 193784
West 142987 178362
North 98741 132668
H i Figure 12-3
4 »
P 1001 | Wersn65 | S Hoasm wni : Entering text into table cells.
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Chapter 12

Working with Tables

Converting Tables

NOTHER METHOD YOU CAN USE to

insert a Word table is by using existing text. If

you already have a list where each column is
separated by a tab, a comma, or other consistent
character, you can easily convert that list to a table so
you won't have to create the table and retype all the
text. (See Figure 12-4). Conversely, if you put text
into a table and then decide you would prefer it in
tabular columns, you can convert the table into a list.

Be Consistent

In order for the conversion feature to work
correctly, you must be consistent with the
character you use to separate the items.

To convert a text list into a Word table, select the
list and choose Insert > Tables > Table > Convert
Text to Table. The Convert Text to Table dialog box
shown in Figure 12-5 appears.
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Other separation character

\

Table size
Mumber of columns:
Number of rows:
AutoFit behavior
@) Fixed column width:

(") AutoFit to contents

(") AutoFit to window

Separate text at
() Paragraphs () Commas
@ Tabs () Other: |-

[ OK ] [ Cancel

 Convert Text to Tahle T

Figure 12-5
The Convert Text to Table dialog box.

Based on the data you selected, Word guesses the
number of columns you want. If you did not sepa-
rate your columns with commas or tabs, in the
Separate Text At section, choose Other and type

the character you used, such as an asterisk or dash.

Click OK, and Word converts the list into a table.
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If your text is already in a table, but you would pre-
fer it in a list, click anywhere in the table and
choose Table Tools > Layout > Data > Convert to
Text. You see the Convert Table to Text dialog box,
as shown in Figure 12-6. Choose the printing or
non-printing character you want the text separated
with and then click OK. The table disappears and
the text remains.

" Convert Table To Text | 7 /2%

Separate text with

Convert nested tables

OK ] l Cancel

Figure 12-6
Converting a table to standard text.
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Creating a Quick Table

THIRD METHOD for creating a table is
Ausing one of Word's Quick Tables. Quick

Tables are nine predefined tables that
include sample data and formatting. If you find a
Quick Table close to what you actually need, you
can save time by choosing the Quick Table and
then changing the elements you want changed.
Choose Insert > Tables > Table > Quick Tables and
choose from one of the preformatted templates as
shown in Figure 12-7.

Ingert Page Layout References Mailings Review Miew
j EE [ J } 2 D, “ B, Hyperlink 3 Header - Y
== B U = EF 4 Bockman: 4 Foater - J
Table | Picture Clip Shapes SmartArt Chart Screenshot Text
- At - - %

£H) Cross-reference =) Page Number = | pg;
Insest Table jons LKL Lt i
01 e s

I O

Ooa Ll_ OO
O
]
0000000000
OOO000000L
OO0O0000000
O sertTable...

& DrawTable

[ Excel Spreadsheet
T Quick Tables

peso | £8 |

Figure 12-7
Choosing a Quick Table style.

Save Table Styles

If you create and format a table style you like
and frequently use, select the table and
choose Insert > Tables > Table > Quick Tables
> Save Selection to Quick Tables Gallery. The
next time you need that table, you can select
it from the Quick Tables gallery.

Okay—one more rather fun way to create a Word
table is by simply typing out a string of plus signs
(+) and minus signs (). Word uses its AutoCorrect
feature to interpret your typing and convert it to a
table. Type a plus sign and then type a series of
minus signs until you have the first column width
you want for your table. Type another plus sign,
followed by more minus signs. Repeat these steps,
placing a plus sign at the end of the series of
minus signs (see Figure 12-8). When you press
Enter, Word automatically converts it to a table.
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TYPING THIS:

¥IELDS THIS:

Figure 12-8
Manually typing table boundaries.

No matter which method you used to create your
table, you enter the data as well as format or modify
the table in the following ways.

Working with Table Layout

HEN YOU CREATED your table, Word
Wdisp[ayed two additional Ribbon tabs.

The Layout tab, shown in Figure 12-9,
provides the tools you need to modify the table

properties such as how many rows and columns or
how the data lines up in the individual table cells.
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Changing Table Size

Okay, now you have your table created, but it
doesn't contain the right number of rows or
columns. You can easily change the table size by
adding or deleting rows or columns from your
table. Table 12-1 illustrates some of the different
ways you can change the table size.
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Each year we present to you a two year sales comparison. During the fiscal year ending June 31, 2010,
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Deleting unwanted table
areas.
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Table 12-1 Changing Table Size

To. ..

Do This

Add rows to the table end

Add rows in the table middle

Add columns

Delete a column

Delete a row

Delete an entire table

Click in the last table cell and press the Tab key, or click in the last row
and choose Table Tools > Layout > Rows & Columns > Insert Below.

Click in a cell and choose Table Tools > Layout > Rows & Columns >
Insert Below (or Insert Above).

Click in a cell and choose Table Tools > Layout > Rows & Columns >
Insert Left (or Insert Right).

Click in the column you want to delete and choose Table Tools >
Layout > Rows & Columns > Delete > Delete Columns.

Click in the row you want to delete and choose Table Tools > Layout >
Rows & Columns > Delete > Delete Rows.

Click anywhere in the table and choose Table Tools > Layout > Rows &
Columns > Delete > Delete Table (refer to Figure 12-9).
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Adjusting Column Width

When you begin typing in a cell, as you type, the
text wraps to the next line in the same cell. You
may find that you don't want the data to wrap
around, but the column is not wide enough to
hold your data. You can easily change the width of
columns or the height of rows. You can manage
the task with the mouse or you can choose options
in the ribbon. First, look at the methods you can
use to change column width:

» Position the mouse over the edge of any
cell in the column you want to adjust.
Notice the mouse pointer changes to a bar
with both left and right pointing arrows.
Drag the edge of the cell until the column
is the width you want (see Figure 12-10).

» Drag the column boundary marker on the

» Click in any cell of the column you want to
adjust and choose Table Tools > Layout >
Cell Size > Table Column Width. Use the
up/down arrows to set the desired column
width.

» To force the column width so it's wide
enough to fit the widest entry in the col-
umn, position the mouse pointer over the
left edge of any cell in the column. When
the mouse pointer changes to a bar with
the left and right pointing arrows, double-
click the mouse. Word automatically
expands the column to fit the widest entry.

» To force all columns to the same width,
choose Table Tools > Layout > Cell Size >
Distribute Columns

ruler.
w90 Dacument? - Mirosoft Word
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[ select+ G B ben Beiow Moo  :HF == A=
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Figure 12-10
Drag to resize a column.
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» To adjust the width of all of the table
columns to fit their widest entry, choose
Table Tools > Layout > Cell Size > AutoFit >
AutoFit Contents.

Manipulating Row Height

Sometimes you want a little clearance above and
below the cell contents. You can do that by increas-
ing the row height. The methods for modifying
row height are very similar to those you use to
change column width:

P Position the mouse over the bottom edge of
any cell in the column you want to adjust.
Notice the mouse pointer changes to a bar
with both up and down arrows. Drag the
bottom edge of the cell until the row is the
height you want. (See Figure 12-11.)

P Click in any cell of the row you want to adjust and
choose Table Tools > Layout > Cell Size > Table
Row Height. Use the up/down arrows to set the
desired row height.

» To adjust the height so it's tall enough to fit
the tallest data entry, position the mouse
pointer over the bottom edge of any cell in
the row and double-click the mouse.

» To force each row to the same height,
choose Table Tools > Layout > Cell Size >
Distribute Rows.

Changing Table Dimensions

If you find that your table dimensions don't quite
provide the look you want, besides changing col-
umn widths and row heights, you can easily
change the size of the entire table. Just follow
these steps:

1. While in Print Layout view (View >
Document Views > Print Layout) or Web
Layout view (View > Document Views > Web
Layout), position your mouse anywhere over
the table until you see a sizing handle appear
in the lower right table corner. The sizing
handle is a small white square.

2. Move the mouse pointer over the handle
until the pointer changes to a diagonal
double-headed arrow. (See Figure 12-12.)

2010 Sales Report

will find a table representing our four country regions.
o

Widget Sales by Territory FYE: 2009 FYE: 2010
I e — . 1 156,341 : 193,784
West 142,987 178,362
|~ | North 98,741 132,668
'« | South 181,324 235,746
TOTALS |

Each year we present to you a two year sales comparison. During the fiscal year ending June 31, 2010,
ABC Production saw a large increase in widget sales, particularly in our new Metallica line. Below you

B

4 Figure 12-11
Modifying row height.
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will find a table representing our four country regions.

Widget Sales by Territory FYE: 2009 FYE: 2010
East 156,241 193,784
West 142,987 178,362
North 98,741 132,668
South 181,224 235,746
TOTALS

Each year we present to you a two year sales comparison. During the fiscal year ending June 31, 2010,
ABC Production saw a large increase in widget sales, particularly in our new Metallica line. Below you

P Mouse pointer over sizing handle

Figure 12-12
Resizing a table.

3. Drag the sizing handle, which resizes the
table. As you drag the handle, you see a
dashed line that represents the new table size.

4. Release the mouse button to accept the new
table size.

Moving a Table

The first step when creating a new table was to
position the insertion point where you want the
table. If you didn't have your insertion point in the
right location, or you just decide you want to move
the table, you can easily drag it to a different docu-
ment area.

216

From Print Layout view or Web Layout view, as you
move your mouse over the table, notice the upper-
left table corner has a small box with a four-headed
arrow in it. This is the Table Move handle. Position
your mouse pointer over the Table Move handle
until the mouse pointer also changes to a four-
headed arrow, and then drag the table to a new
location. As you move the table, you see a dashed
line which represents the new table position. See
Figure 12-13 for an example.
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Tip

If you want to copy the table instead of
moving it, hold down the Ctrl key as you
drag the table.

Selecting Table Areas

Often you want to make changes to an entire col-
umn or an entire row. Or perhaps you want to
apply a certain formatting option to the entire
table. While you could make any desired changes
one cell at a time, Word includes several methods
you can use to select portions of the table so you

can quickly apply any changes to the entire selec-
tion. The following list shows you several ways to
select table cells:

P To select sequential cells, click in the first
cell, then hold down the Shift key and
select the last cell you want. Optionally,
drag the mouse over a group of cells to
select a sequential area. All cells in the
selected area are highlighted.

» To select non-sequential cells, hold down
the Ctrl key and click each additional cell
you want to select. Figure 12-14 shows
non-sequential cells selected and high-
lighted in blue.
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Each year we present to you a two year sales comparison. During the fiscal year ending June 31, 2010,
ABC Production saw a large increase in widget sales, particularly in our new Metallica line. Below you

will find a table representing our four country regions.

Widget Sales by Territory FYE: 2009 FYE: 2010
East 156,341 193,784
West 142,987 178,362
North 98,741 132,668
South 181,324 235,746
TOTALS

Figure 12-14

» To select a single entire column, position
the mouse pointer at the top of a column
until the mouse turns into a down-pointing
arrow, and then click.

» To select multiple columns, make sure the
mouse pointer is the down-pointing arrow,
and then drag across multiple columns.

» To select a single entire row, position the
mouse pointer at the left of the row column
until the mouse pointer turns into a white,
right-pointing arrow, and then click.

» To select multiple rows, make sure the
mouse is the right-pointing white arrow
and then drag across multiple rows.

Selecting cells.

» To select the entire table, click the small
box in the upper left table corner.

» To clear any selection, click any non-selected
cell or click outside of the table.

Merging Table Cells

By default, Word creates tables with each cell in a
column the same width as the cell below it.
Sometimes, especially if you are creating a form
with your table, you may find some cells too small.
Fortunately, you can combine adjacent cells to
become larger cells. This is especially useful if you
want to create a table header row, such as the one
shown in Figure 12-15.

Select Non-Sequential Cells

When making non-sequential cell selections,
you can include entire rows and entire
columns along with individual cells or
groups of cells.
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2010 Sales Report

Each year we present to you a two year sales comparison. During the fiscal year ending June 31, 2010,
ABC Production saw a large increase in widget sales, particularly in our new Metallica line. Below you
willfind a table representing our four country regions.

-. Widget Sales by Territory

N FYE: 2009 FYE: 2010
A East 156,341 193,784
F West 142,987 178,362
H North 98,741 132,668
N South 181,324 235,746
= TOTALS

Page: 1661 | Wordi: 63 | 335 | MoE 3 . s (=)
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Figure 12-15
Merging multiple cells into
one larger cell.

o= d

[+

Drag across the two or more cells you want to
merge and then choose Table Tools > Layout >
Merge > Merge Cells. The highlighted cells com-
bine into one larger cell. You can merge cells hori-
zontally or vertically.

Splitting Table Cells

If you want to split a cell into smaller cells, you need
to tell Word how many columns and rows you want
in the cell. Click anywhere in the cell you want to
split and choose Table Tools > Layout > Merge >
Split Cells. The Split Cells dialog box shown in
Figure 12-16 appears. Choose how many columns
and rows you want, and then click the OK button.

' Split Cells
Mumber of columns: 2| H-
Number of rows: |1 5

Merge cells before split

[ OK ] [ Cancel

Figure 12-16
Dividing a cell into multiple cells.
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Using Table Design

F YOU WANT TO CHANGE the appearance
I (formatting) of the table cells, you select the

cells you want to modify and apply any of the
standard formatting choices such as fonts, shading,
and borders.

For example, if you want to set your table headings
apart from the table remainder by making them
bold, larger and with shading, you select the head-
ing cells and choose options from the Home tab, as
shown in Figure 12-17. (See Chapter 3 for more
information about formatting options on the
Home tab.)

However, Word also supplies a quick and easy way to
format your table. By selecting from Word's large
gallery of table styles, you can apply attractive for-
matting with a click of the mouse. If needed, you
then can make any additional adjustments to better
meet your needs.

Take a look at the Design tab, shown in Figure 12-
18. With the insertion point anywhere in your
table, the Design tab displays a number of differ-
ent predefined themed formats. As you hover your
mouse over any design option, Live Preview allows
you to see the formatting as it would look in your
actual document. When you find the style you
want, click the mouse to actually accept the style.
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2010 Sales Report

Each year we present to you a two year sales comparison. During the fiscal year ending June 31, 2010,
ABC Production saw a large increase in widget sales, particularly in our new Metallica line. Below you
will find a table representing our four country regions.

Widget Sales by Territory

il FYE: FYE:
2009 2010
Bl East 156,341 193,784
West 142,987 178,362
North 08,741 132,668
South 181,324 235,746
TOTALS
- Figure 12-18
8 Use the Design tab to apply table
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choices, as shown in Figure 12-19.
LD Sales Repiort - Microsoft Word e You can also easily adjust table formatting

References Mailings

options by experimenting with the choices
in the Table Style Options group.

B Modify Table Style...

B gear

4 NewTable Style...

Figure 12-19
Choose from any of the many themed table styles.
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Creating Table Formulas

lots of calculations, consider using Excel to per-

form the calculations and then insert the
spreadsheet into Word. The next section shows you
how to accomplish that. But if you want a simple
calculation, such as adding a column of values, go
ahead and let Word do the work for you.

l F YOU HAVE A COMPLEX TABLE with

There are two rules you must follow when creating
Word calculations. One is that the entire calcula-
tion must be enclosed in a Word field. Word fields,
which you'll see how to create shortly, are dis-
played with opening and closing braces, { and }.
The second rule is that all calculations must begin
with an equals sign (=).

You create Word arithmetic formulas using opera-
tors to perform the calculation you want. Table
12-2 shows the mathematic operators used in
Word tables along with an example of each.
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Table 12-2
Mathematical Operators Used in Word

Name Operator Example Result
Addition 3 {=6+3) 9
Subtraction - {=6-3} 3
Multiplication * {=6*3} 18
Division / {=6/3} 2
Percentage % {=6%} .06
Exponentiation ~ {=6"3} 216

When creating a calculation, the power comes in
to play in that you typically don't use the actual
values; instead, you create a reference to them.
Suppose cell B2 has a value of 6 and cell B3 has a
value of 3. Now, suppose you want, in cell B4, to
multiply those two values. In cell B4, you won't
enter =6*3; instead, you'll enter =B2*B3. The
advantage is that if you later change the value in
cell B2 from 6 to 8, you won't have to retype the
calculation—you'll simply tell Word to recalculate
it. Look at how this is all accomplished:
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1. First you must realize that calculations in
Word tables are generated from formula
fields. Click the cell in which you want a for-
mula field and choose Table Tools > Layout >
Data > Formula. You see the Formula dialog
box shown in Figure 12-20.

3. Type the rest of your formula, as shown in
Figure 12-21. In this example, [ want to add
cells B3, B4, B5, and B6, which will give us
the total amount.

Formula (7=

Formula:
=5UM({ABOVE)|
Mumber Format:

[=]

Paste bookmark:

[ ok ][ cancet |

Paste function:

Formula (7=
Formula:

=b3+b4+b5+b6

Mumber Format:

#,#40| [+]

Paste bookmark:

[ ok || cancel |

Paste function:

Figure 12-20
The Formula dialog box.

2. Sometimes Word can detect the formula you
want and automatically create instructions.
In the previous figure, Word assumes we
want to add together (SUM) the cells above
the current cell. We do, but to illustrate a for-
mula, we're going to manually enter it.
Highlight the existing text in the Formula
text box and type an equals sign (=).

Figure 12-21
Creating a calculation.

4. Next, choose an option from the Number
Format drop-down list. This option deter-
mines the appearance of your answer, such
as whether to include a dollar sign, a percent
symbol, or two decimal points.

5. Click OK. Word calculates the formula and
displays the results. (See Figure 12-22.)
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will find a table representing our four country regions.

Widget Sales by Territory

FYE: FYE:
2009 2010
East 156,341 193,784
West 142,987 178,362
North 98,741 132,668
South 181,324 235,746
TOTALS 579,30p

ABC Production saw a large increase in widget sales, particularly in our new Metallica line. Below you

Figure 12-22

If you later make a change to any of the table cells
referenced in the formula, Word doesn't automati-
cally update the formula answer. Right-click over the
current answer and choose Update Field. If you need
to modify the formula, right-click over the current
answer and choose Edit Field. You'll see the Field
dialog box. Click the Formula button to redisplay
the Formula dialog box where you can make any
desired changes. Click OK when you are finished.

If you want to see the actual formula instead of the
result, right-click over the answer and choose
Toggle Field Codes. You see the actual formula in
the field, as shown in Figure 12-23. To view the
answer again, repeat the action.

Displaying calculated results.

Word contains a number of predefined calcula-
tions, called functions, that you can plug into your
formula fields. For example, if you simply want to
add adjacent cells, use the SUM function, such as
=SUM(ABOVE) or =SUM(LEFT). The ABOVE refer-
ence tells Word to add all the non-blank cells
directly above the answer cell. The LEFT reference
tells Word to all add the non-blank cells directly to
the left of the answer cell. To use a function choose
Table Tools > Layout > Data > Formula. You can
either accept the suggestion provided by Word, or
click the Paste Function drop-down list and choose
a different function (see Figure 12-24).

will find a table representing our four country regions.

Widget Sales by Territory

FYE: FYE:
2009 2010
East 156,341 193,784
West 142,987 178,362
North 98,741 132 668
South 181,324 235,746
TOTALS { =b3+ba+b5+b6 \#
o]}

Figure 12-23
Viewing the calculation.
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Formula (7)==
Formula:

=SUM({ABOVE)

Number format:

[=]

Paste function: Paste bookmark:

4

ABS
AND
AVERAGE

I OK I[ Cancel ]

Y

—| COUNT
DEFINED
FALSE

IF

INT b

Figure 12-24
Select a function.

Tip

Word cannot use a function to total the
entire column or row if your column or
row contains blank cells or cells with text
instead of values.

Adding an Excel Table to a Word Document

power behind a Word table. As mentioned at the

chapter beginning, a Word table is basically a
small spreadsheet. This book doesn't cover creating
Excel worksheets, but you should also know that
once you create an Excel worksheet, you can insert
it into a Word document. Just follow these steps:

l N THIS CHAPTER, you've seen some of the

1. Position the insertion point where you want
the Excel worksheet placed.

2. Choose Insert > Text > Object > Object. You
see the Object dialog box shown in Figure
12-25.

3. Click the Create from File tab.

4. Click the Browse button. A Browse window
opens.

5. Locate and double-click the file you want to

insert. The Object dialog box reappears with
the file name you selected (see Figure 12-25).
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Object - b -  TE=
File pame:
C:\Users\Diane|Documents|Music Sales by Type.dsi]
[ Link to file
[ Display as icon
Resuk
,  Inserts the conbents of the file into your
EB document 50 that you can edit it later using the
application which created the source file,

Figure 12-25
Select the Excel file you want to include.

6. Click OK. The Excel worksheet along with any
formulas and formatting appears in your
document. See the example in Figure 12-26.

Word considers the table an object in the docu-
ment. To make any changes, double-click the
inserted Excel worksheet where you will see the
Excel worksheet Ribbon and options, as shown in
Figure 12-27. Click outside the table to return to
Word. Changes you make in the Word table do not
affect the saved Excel worksheet.

Wl d 9~ 0+ Docimentd - Microsoft Word = & 8
Home | lasert | Pagelmyout  References  Malings  Redew  View a @
18] Cover Page = (3% ' 1 aud ] ] 1 B, Hyperink 3] Hender = A | 5 QuickParts + [ Signatire tine + T Equation =
1 Biunk Page ; pal mu 0P B2 “ W g sootman 4 Footer - r_J Awordat (5 Date & Time 2 Symbei -
e | O | Pt <:,‘° Sapes SNERAL Chat, Tamor B Crossreterence | () Puge Wumbir = | gere A Dropcap~  YElOM -
Peges Tables ations Linics Hewder & Footer Ti ol
0 o R S s = R ——
Music Sales by Type

2 Year

Blues 210 3 246 627 656 - 2,060

Childrens 674 688 697 703 691 — 3,453

Christian 800 816 833 640 580 T e 3,669
‘| |classical 696 704 694 210 T 3,157
- |Country 650 785 939 720 844 3,938
§ Easy Listening 533 632 648 587 613 S 3,013

Heavy Metal 978 658 421 502 280 T 2,879

Rap 321 584 639 510 378 A 2,432 .

Rock 461 319 571 528 810 . _~—" 2,689 > Figure 12-26

2 An Excel worksheet in a Word

{l »
Page1of1 | Words6 | 5 EwmE 3 m o =0 document.
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EhesXndo:
FEEE
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| -E %] [
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§ il Genre 2006 2007 2008 2009
= Figure 12-27
: _ j g Modifying the Excel
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Paperior | worsns | 5 | [Eoz s ww 0@ worksheet.
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Working with

Graphics

ICTURE YOURSELF APPLYING stage makeup. You're an actor or
Bactress, and if you don't apply some makeup you'll appear lifeless

and dull and perhaps go unnoticed by the audience. But if you
apply too much makeup or apply it sloppily, you'll look clownish and the
audience might not take your role seriously.

Using a few carefully placed graphics in your document can be just the
makeup the document needs to keep your reading audience interested.

Graphics can be many different types, such as pictures, shapes, cartoon
art, or diagrams. This chapter is about working with graphics. From
getting them into your document to manipulating their size, color, or
arrangement, you'll find Word graphics can be fun and easy.

One thing to note about working with any graphics image is that you can
only see them while in Print Layout, Full Screen Reading, or Web Layout
view. Graphics are hidden while in Outline or Draft views.




Working with Pictures

OU CAN INSERT PICTURES from a vari- 2. Locate and select the image you want to
Yety of places, including those stored on your Insert.
computer or perhaps a picture from the

3. Click Insert. Word inserts the image you
selected into the document. (See Figure 13-2.)
You also see a new Picture Tools > Format tab.

Web. Once you have the photograph in your docu-
ment, you can then move it around, resize it, or
perform a number of enhancements to the photo.

Placing Pictures

Besides lots of text in your document, if you have a
digital photograph or other graphics image, such
as a company logo, you can place it in the docu-
ment as well. To insert an existing graphics file into
your document, follow these steps:

1. Click the cursor where you want to place a
picture, and choose Insert > Illustrations >
Picture. The Insert Picture dialog box opens. : :
(See Figure 13-1. s e T T e T e

Lk ol st Butre

Figure 13-2
(6] Insort Pictura = Adding a picture to the document.
@Dv!_ b Llibraries b Pictures » v [ g | [ search Pictures =3
Organize + New folder =~ 0 ©
(] Micosoft word . Pictures library ... SO
Includes: 2 locations .
T Favorites TI
B Desktop p
Downioad: . o'
“ Renem:a:n 1 4 .1.!‘1
My stuft 4 " - i

ey i To delete a picture, make sure it is selected.
e 2 You will see eight small handles around it.

o Music

= ures (@ Press the Delete key.
B vigeos . 27
B butterny.6205 & e:i;‘- Fred Fintstone
File riarme: butterfly-87 » [0 Pictures |

Tools = Cancel J

Figure 13-1
The Insert Picture dialog box.
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Using Picture Tools Word guesses the image background and turns it
) ) . magenta. The image foreground remains visible.
When you place a picture in the Word file, you get

quite a few options to perform some fairly sophis-

ticated tasks. You can adjust the image brightness If you need to adjust the image boundaries so it bet-
and contrast, apply a color accent, give it a frame, ter fits the area you want, drag any of the selection
or rotate it three-dimensionally. You can even crop lines so the selection box contains the image portion
it to get rid of unwanted areas. You accomplish all you want. If you want to be more specific in the

of these picture tasks by using the Picture Tools > areas you want to keep, click Background Removal >
Format tab that appears on the Ribbon when you Refine > Mark Areas to Keep and draw around the
select a picture (see Figure 13-3). areas you want. You can also click the Mark Areas to

Remove button and draw around areas you don't

. . . want. Each time you draw an area, you see a white
Making Picture Adjustments marker. If you erk an area in erron}“l, click the Delete
The Adjust group contains seven different options. Mark button and click the marker you don’t want.
The first option, the Remove Background feature,
is new to Word 2010 and lets you to remove back-
ground detail from an image, allowing only a
selected portion to remain visible. Begin by select-
ing the picture you want to modify, and from the
Picture Tools > Format tab in the Adjust group,
click the Remove Background button. Your screen
changes, similar to the one shown in Figure 13-4.

When you are finished, click Background Removal
> Close > Keep Changes. Word removes the back-
ground. You can then add effects, such as shadows,
reflections, or glows, to the remaining image por-
tion. See Figure 13-5, where [ added, cropped, and
resized the butterfly and added a shadow to it.

Wikd9-0|= butterflies - Microsoft Word Picture Tools = B I
Home Insert Page Layout References Mailings Rewiew Wiew Format | & 0
1 % Comections ~ | (]| el L& Picture Border - ) H’] 4 Bring Forward .I,:." = § ol ees -
L By Color + L+ il il il gl - - PictureEffects - =l & Send Backward - 18]
Remove s - - = Position Wrap : Crop =] 65" -
Background * Artistic Effects ~ g~ ¥ 5% Picture Layout ~ - Text Oy Selection Pane Sk~ - -
Adjust Picture Styles ] Arrange Size

Figure 13-3
The Picture Tools > Format tab.

TR ===y bmrfirs  Mecrmich Werd = @ 0
Seopreasunen | Vew | Poenit -d

|~ Selection border

The Butterfly Documentary

Figure 13-4
N P TR 1 Removing the background area.
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‘ The Butterlly Documentars|

What sre butterilios and mothy?
Buttarfiies and moth are » group of insects called Lepsdopters. Like o ingaot, buefies and maths
Pt 8 head, thorks, sbdenmen, tws arbenss, and s legs. Addnicnally, meths and butedies have fow
wings that are simeat by cclered seales fer n
5 Pl obctas. Lapsoptans 5 denved froem the Liti Tapde™ seabe s “plan” = wing. OF course thes
arm excmpticns; seme meth have winglits addts and sra primitive meothe lack a probetcia

How many differem
Buttarfiies and moths ane found on all continents macept Antarctica, and scientists estimate that thers
e approsimately 12:15,000 spesies of butterflies and 150-50,000 spevies of mothe. There are stil
housands of math and bumadly baen found or wthe
Urited States and Cansds, meore than 750 species of buterflrs and 11,000 species of motha baes Boen

Figure 13-5
After removing the background.

t types of husterflios and maths

Other picture adjustments include the following:

» The Corrections button displays a gallery
where you can adjust the image brightness
and contrast. The original image begins at
0%, and you can make the image up to
40% brighter or darken it by 40%.

» The Color button applies a coloring effect,
such sepia, black and white, or other color

» The Artistic Effects button displays a
gallery (see Figure 13-6) where you can
apply cool effects such as texture, water
sponge or photocopy. Pause your mouse
over any effect to see a preview of the effect
on your picture.

» The Compress Pictures button applies
a compression algorithm to all the docu-
ment pictures in order to reduce the
document size.

» The Change Picture button displays the
Insert Picture dialog box, where you can
replace the current picture.

» The Reset Picture button undoes any edit-
ing and formatting you performed on the
selected picture. Trust me—this button will
become your friend!

variations.

Wid9-0* butterflies - Microsoft Word m o 2
Home et Fagelmout  References  Malings  Review  View Format a
2 Comections = i e & Picture Boraer =« | [Gh Sabeng Ll | —
:1! W:.n,'.w " =7 ; .o ,.:,, E,,:,,. = Y - gl | T
s.tmu | arttic pttects - g - 7| 6B Picture Layout - Fossin Tode Sty Selection Pane SA~ oo ) ey
Amange 54
= g
] The Butterfly Documentar
What are butterflies and moths? = Figure 13-6

| CPT 1) i it e . FTRY ER — wot e PE—T) f L
4 | » . . .
Py | Vs |5 23 [Euesm wwc il Adding artistic effects.
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Working with Graphics

Working with Picture Styles

The Picture Styles group on the Picture Tools >
Format tab offers a gallery of styles with prefor-
matted shapes and three-dimensional effects. Click
the More button to see the complete gallery, as
shown in Figure 13-7. Pause your mouse over any
picture style to see its effect on your picture.

In the same group, you also have options to
change the picture border or to add effects. The
Picture Border option allows you to assign a color
to the frame around your picture. From here you
can also choose if you want a thick or thin border.

The Picture Effects option provides options for
adding shadows, reflections, glows, soft edges, and
other options. (See Figure 13-8.)

The Butterfly Documentary

What are butterflies and moths?

is for drinkine li

butterfies - Microtoft Word o @ B
Pagriamout  Beferencer  Madingi  Bedew  View - @
b § r— — e —— - T 3 e - iR
. | e | Oogt T
B ol e ol el ol e %Wl“ ook o
ackgroun " i ot T Tere Syteesientane St e &
- o~ ] s
7,-EEI24 : : =
R -
a E |
- - S
- = e
ot = = g
=3

Butterflies and moths are a group of insects called Lepidoptera. Like all insects, butterflies and moths v
have a head, thorax, abdomen, two antennae, and six legs. Additionally, moths and butterflies have four

Figure 13-7

i, h

.| wines that are almest alwavs covered by colored scales. and a coiled

3
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Papilof) | Weesnil OB | 7]
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< = -tliauidssuch g

[T
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B rore ot Peimout  Befncs  Mmiegi  Beiew  Mew | foon - @
1 @ Compemans = 3 - __ == g Pt Boesr + 4 [ - Sl 5 asr
= (s 6 |G (0] O O e e B, o
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What are butterflies and moths? ( _j '
Butterflies and moths are a group of insects called Lepidoptera ... and moths -

Figure 13-8
Adding picture effects.

o
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The Picture Layout option lets you use your picture
in a diagram. See “Symbolizing with SmartArt”
later in this chapter.

Cropping the Picture

Sometimes you only want part of what appears in
the picture. With the Word tools, it's easy to cut away
the portions you don't want. Called cropping, the
process removes unwanted portions of an image.

1. Select the picture you want to crop and then
choose Picture Tools > Format > Size > Crop.
(You don't need to click the arrow under the
Crop button.) Your mouse pointer turns into
a cropping tool, and instead of selection han-
dles the picture has cropping handles, as
shown in Figure 13-9.

Cropping handles

Crop button

2. Drag a cropping handle to begin the crop-
ping process. The mouse pointer changes to
a black cross, as shown in Figure 13-10. You
may need to crop from several sides of your
image. As you drag a cropping handle, a line
appears representing the new picture edge.

Mouse pointer

Figure 13-9
Cropping the picture.
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Figure 13-10
Drag from an image edge.

Tip

If you crop too much off the image, drag
the cropping handle the opposite way.
What you cropped reappears.
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3. Click the Crop button again or press the Esc text, the image doesn't move. It remains in the same
key to turn off the cropping feature. position. Square and Tight wrapping are very similar,
except that if your picture has an irregular shape,
the Tight option wraps around the shape as well.

Wrapping Text Around a Picture

In most situations, the picture doesn't appear on a Other choices include placing the image on top of
page by itself. There is related or explanatory text the text; however, that's not typically a good idea
around the picture. You can control how the text because you can't read the text underneath the
appears surrounding the image. By default, Word image. You can have the image under the text, but
places the image in-line with the text, which if the image is dark, you may not be able to easily
means the image appears where you inserted it; if read the text on top of the image.

you move the text on the same line, the image

moves as well You position text around the graphic by first mak-

ing sure you have the picture selected, then choos-

Other choices allow you more flexibility in placing ing Picture Tools > Format > Arrange > Wrap Text
the image. If you choose the Tight text wrapping and making a selection. Figure 13-11 shows you
option, the text wraps around the image and stays the text wrapped tightly around the picture.

pretty close to the image. However, if you move the
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Inserting Clip Art

HILE MOST OFFICE applications

have the ability to insert clip art into a

file, adding clip art to a document brings
both interest and distraction to an otherwise dull
document. Office ships with hundreds of clip art
images and thousands more are available online,
free from Microsoft. Office stores clip art in collec-
tions with keywords so you can easily locate the
image you want. Whatever the topic, you are sure
to find a clip art image that compliments it. Here is
how you can add clip art to a document:

1. Click the cursor where you want a picture,
and choose Insert > Illustrations > Clip Art.
The Clip Art pane appears on the right side
of the screen.

In the Search For box, type a word or short
phrase that best describes the kind of image
you want. For example, typing dairy brings
up a collection of artwork ranging from cows
to cheese to milk cartons.

. Click the Go button. Office displays the avail-
able clip art that matches your request (see
Figure 13-12).

Click the image you want. The image appears
in the document, as shown in Figure 13-13.

Click the Close button to close the Clip Art
pane.
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Butterflies and moths are 5 group of insects called Lepidoptera. Like all insects, butterflies
have a hesd, thorax, abdomen, two antennae, and six legs. Additionally, moths and butter
wings that are almost always covered by colored scales, and a coiled proboscis fer drinking
as flower nactar. Lepidoptera is derived from the Latin lepida"= scale+ "ptera" = wing. O
are exceplions; some moths have wingless adults and some primitive moths lack a probos

How many different types of butterflies and moths?

Butterflies and moths are found on all continents except Antarctica, and scientists estimal
are approximately 12-15,000 species of butterflies and 150-250,000 species of moths, The
thousands of moth and butterfly species that have not been found or described by scienti
Urited States and Canada, more than 750 species of butterflies and 11,000 species of mot
recorded. Many spacies of moths and a few kinds of butterflies are still being discovered.

to be learned|

How does a caterpillar turn into a butterfly?

Thiz s not easy to explain. You can say that inside the chrysalis the caterpillar changes ele
into a butterfly. (An esoteric explanation: Inside the chrysalis the caterpillar structures are
chemically and the adult's new structures are formed).

Why do caterpillars turn into butterflies?

adult butterfly is both the mating and egg-laying stage of the beautiful insect. Also adult b
disperse by flight, sometimes long distances, to either colonize new areas with fresh plant
»

1
Page: 1ef2 | Wordi 98l | <3 | 1

Catarpillars are the eating and growing stage for the butterfly, but they cannot mate and | ”
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Figure 13-12
Click the clip art graphic you
want to use.
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Tip

Using the Picture Tools > Format tab, you can perform most of the same modifications to clip art as
you can to photographs.

Using Shapes

VEN IF YOU DO NOT have an artistic

bone in your body, you can still draw with

the Word drawing features. You can draw
arrows, boxes, stars, circles, callouts, and dozens of
other objects. The Shapes feature is also available
in Excel, PowerPoint, and Publisher.

Follow these steps to draw a shape:

1. Click the cursor where you want a shape to
appear and choose Insert > Illustrations >

Shapes. A gallery of shapes appears, as
shown in Figure 13-14.
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Figure 13-14
Selecting a predefined shape.

2. Choose the shape you want. The gallery
closes, and your mouse pointer turns into
a small black plus sign.

3. Click and drag in the document until the
shape that appears is about the size you
want (see Figure 13-15). When you release
the mouse button, the shape object becomes
selected.
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Figure 13-15
Drawing shapes.

Tip

To constrain the shape so it is equally
sized, such as a perfect circle or a com-
pletely straight line, hold down the Shift
key when drawing.

After you draw the shape, you can apply many dif-
ferent style changes to it. After you select the
object, choose Drawing Tools > Format > Shape
Styles. From there, you can do the following:

» Click the Shape Styles More button and
select from the available styles. The choices
you have depend on any theme you have
assigned to your document (see Figure
13-16).
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How does a caterpillar turn into a butterfly?

H This is not wesrto explain. You can saythat inside the ;hq-;umh. caterpillar changes clothes and tums
into. fl | Inside the ct pillar structures are broken dawn

chemically and Iht adult’s new structures are formed).

Why do caterpillars turn into butterflies?

Catarpillars are the eating and growing stage for the butterfly, but they cannot mate and reproduce. The
adult buttedly is both the mating and egg-laying stage of the beautiful insect. Also adult butterflies can
disparse by flight, somatimes long distances, to either colonize new aneas with frash plants for the
caterillars or even migrate lone distances to escaoe our freering winters. such as Monarchs flving to
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Figure 13-16
Changing a shape style.
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P Click the Shape Fill option to change the » Click the Shape Effects option to add spe-
ObjeCt fill. Choices include solid fl”S, gradi- cial effectsy such as ShadOWS, reﬂectionsy
ents, pictures, and textures. borders, or rotation (see Figure 13-17).

P Click the Shape Outline option to change

the border around the object. You can select
a border color, size, and style.
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Adding Screen Shots

UPPOSE YOURE LOOKING at a Web page,

and you want to insert a picture of it into your

Word document. You can now easily do so with
the new Screenshot function included with Office
2010. You can take a picture of the entire program
window or use the Screen Clipping tool to select
only a part of a window. Follow these steps:

1. Make sure the window you want to capture
is not minimized. The Screenshot feature
doesn't work with windows that are mini-
mized. Use the Alt+Tab keys to easily switch
between your applications.

2. In Word, click the cursor where you want to
insert a screenshot and choose Insert >
[llustrations > Screenshot. The Available
Windows gallery appears, as shown in
Figure 13-18.
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Figure 13-18
Available windows.
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3. Click the application of which you want a
screen shot. The image appears in your Word
document. (See Figure 13-19.)

Figure 13-19
A screenshot in a Word document.

If you only want part of the window for the screen-
shot, first of all, make sure the window you want
to capture is right behind your document. If neces-
sary, close other applications.

Choose Insert > Illustrations > Screenshot and
click Screen Clipping. When the screen turns
translucent and the mouse pointer becomes a
cross, press and drag the mouse button (as shown
in Figure 13-20) until you've selected the area you
want. When you release the mouse button, the
portion you clipped appears in your document.
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/ Mouse pointer

Figure 13-20
Using screen clipping.

Managing Objects

OW THAT YOU HAVE all of these
N objects in your document, you probably

need to manipulate them a little. You can
move them to different locations, adjust their size,
or change their color. If you have multiple objects,
you can align them, group them, or even place one
object on top of or beneath another. In this section
you will discover how to make any of those adjust-
ments to any object, whether a picture, clip art,
screenshot, or shape.

Moving Objects

If an object is not where you want it, you can easily
move it to another place in the document. Click
the image to select it, and then position the mouse
pointer over any part of the selected image except
the selection handles or the green rotation handle.
The mouse pointer has four arrow heads. Drag the
image to the desired position. As you can see in
Figure 13-21, a lightly transparent version of the
object indicates the new position. When you
release the mouse button, the object moves to the
new location.
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If you want to move the object just a little bit, you Resizing ObjECtS

may find it easier to use the keyboard. After select-
ing the object, use the up, down, left, and right
arrow keys to nudge the object into a different
position.

Tip

If you want to move the object to a differ-
ent page, use the cut and paste features.

Deleting Objects

Okay, this process is so simple it really doesn't
deserve its own section, but putting it in one
makes it easier for you to find. To delete an
unwanted object, click the object to select it and
press the Delete key. That's it—end of this section.
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The object may not fit on the page exactly as you
envisioned it. You can easily make the object
smaller or larger. Just follow these steps:

1. Select the object you want to resize. The
selection handles appear around the object.

Position the mouse pointer over one of the
eight handles. (Do not select the green rota-
tion handle.) Your mouse pointer turns into a
white double-headed arrow, as shown in
Figure 13-22.

. Drag a selection handle in one of the follow-
ing manners (as shown in Figure 13-23).



Chapter 13

Working with Graphics

busterflies - Microsaft Word
Pageluyout  References

Wlld 9=
Home Insert

Malings  Review  View

= & 8
o

ageilof3 | WordsdbL | B | T

% Comedtions = i == — &, Picture Border - | B (=8 I = 1
e (e % ([ ) ) B S| [ B 3 B B o 7 Selction handles
Poernee -~ P Podition Wrap o, iy rep (3 gse
Background il Artintic Bfects - g - = R Picture Luyout = v Tet- TySelecionPane She| .
|l Adjust Picture Styles 5y Amange Size

: g
B Mouse pointer

Figure 13-22
Resizing an object.
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Tip

When you begin dragging a handle, the
mouse pointer turns into a plus sign.

P Drag a top or bottom handle to change the
object height.

P Drag a left or right side handle to change
the object width.

P Drag a corner handle to resize both the
height and width at the same time.

4. When the object is the desired size, release
the mouse button.

Rotating Objects

Most graphics objects appear in the document in a
horizontal or vertical pattern. And most of the time,
that's exactly what you want. But in some cases, tilt-
ing the object at a fashionable angle provides just
the right touch to a document. Word objects come
with a rotation handle with which you can rotate
an object clockwise or counterclockwise.

Select the object you want to rotate and position
the mouse pointer over the green rotation handle.
Drag the rotation handle clockwise or counter-
clockwise until the graphics object is at the angle
you want. Notice in Figure 13-23 that the mouse
pointer turns into a circular arrow.
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Flipping Objects

If you want to reverse the direction of a picture or
other object, you can flip it either vertically or hori-
zontally. Take a look at the butterflies in Figure 13-
24. In the picture on the left, the butterfly is facing
right, but on the right side image, which is the
same photograph, the butterfly is facing left. To
flip an object, select the object and choose Picture
Tools > Format (or Drawing Tools > Format) >
Arrange > Rotate and choose Flip Horizontal or
Flip Vertical.

Aligning Objects
If your document contains multiple graphics
objects, like the ones you see in Figure 13-25, you

may want some of them to line up with each other.

Word includes a tool to make aligning objects
quick and easy. Just follow these steps:
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Figure 13-24
Flipping an image.
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Figure 13-25
Multiple objects that need aligning.

1. Select the first object you want to align, then
hold down the Ctrl key and select each addi-
tional object.

2. Choose Picture Tools > Format (or Drawing
Tools > Format) > Arrange > Align. A menu
of alignment options appears.

3. Choose one of the following alignment
options:

P Align Left: Aligns the objects along
their left edges

» Align Center: Centers the objects hori-
zontally along their middles

P Align Right: Aligns the objects along
their right edges

» Align Top: Aligns the objects along
their top edges

P Align Middle: Centers the objects ver-
tically along their middles

» Align Bottom: Aligns the objects along

their bottom edges

Two additional options on the alignment choices
apply when you have three or more objects selected.
Distribute Horizontally calculates the total space
from the left edge of the leftmost object to the right
edge of the rightmost object and evenly divides the
space between the selected objects. Distribute
Vertically calculates the total space from the top
edge of the top object to the bottom edge of the
bottom object and evenly divides the space between
the selected objects.

In Figure 13-26, I aligned the object tops and dis-
tributed the space horizontally.
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Figure 13-26
Selecting an alignment option.

Tip

Optionally, from the Align options, choose
View Gridlines to display a grid that you
can use to manually align the objects.
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Stacking Objects

When you have multiple objects, sometimes you
want them to overlap. Depending on the order in
which the images were created, you may have one
object covering up another object that you don't
want covered. In Figure 13-27, you see a star, a box,
and an arrow, with the arrow being the topmost
object. In this sample, I want the box on the bot-
tom and the star on the top, making the arrow the
middle of the three objects.

Figure 13-27
Incorrectly stacked objects.

When you restack objects, you can send an object
back one object at a time or push it to the lowest
object. Or you can bring an object forward one
object at a time or bring it to the top of the stack.
Follow these steps:

1. Select the object you want to reorder.
2. Choose Drawing Tools > Format > Arrange.
3. Choose one of the Order Objects options:

Bring to Front, Send to Back, Bring Forward,
or Send Backward.
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Now take a look at the objects in Figure 13-28. 1
selected the arrow and chose Drawing Tools >
Format > Arrange > Send Backward.

The Butterfly Documentary

Figure 13-28
After changing the stacking order.

Grouping Objects

You can group multiple objects together to form a
single object, which makes moving, resizing, and
reshaping objects much easier. For example,
instead of resizing each of four objects individually,
you can group them together and resize only one.
A really nice feature about the Group function is
that if you need to, you can easily ungroup the
objects, make any desired individual changes, and
then quickly regroup them.

Select the objects you want grouped together and
choose Drawing Tools > Format > Arrange >
Group. In Figure 13-29, you see three independent
objects on the right and one grouped object on the
left. If you want to ungroup the object, select it
and choose Drawing Tools > Format > Arrange >
Ungroup. To regroup, select any one of the original
objects and choose Drawing Tools > Format >
Arrange > Regroup.
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Grouping objects.
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Symbolizing with SmartArt

in your document is called SmartArt.

SmartArt objects are diagrams that show
relationships, product cycles, workflow processes,
and such. Using a diagram allows your viewers to
better visualize a concept or idea.

ﬁ NOTHER ELEMENT YOU CAN PLACE

Other Office Programs

Diagrams are also available in PowerPoint
and Excel.

First you must select the diagram type, and then
you can customize it to meet your specific needs.
There are seven basic diagram types, although each
type contains quite a few variations. Here are the
different diagram types:

P List: Use this type for describing related
items, usually sequential or showing a pro-
gression.

P Process: Use this type for describing how a
concept or physical process changes over
time. Figure 13-30 is an example of a
process diagram.
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* Phase

. Phase

Figure 13-30
A process diagram.

» Cycle: Use this type to show progress from
one stage to another when the process
repeats itself.

» Hierarchy: Use this type to describe rela-
tionships between items or people, as shown
in Figure 13-31. A company organization
chart is an example of a hierarchy diagram.
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» Relationship: Use this type to describe
how two or more items are connected to
each other.

» Matrix: Use this type for showing the
relationship between the whole and its
components.

» Pyramid: Use this for showing proportional
or interconnected relationships.

Creating SmartArt

Begin by selecting Insert > Illustrations > SmartArt.
The Choose a SmartArt Graphic dialog box shown in
Figure 13-32 appears. Select the diagram type you
want, and then from the List section in the middle,
choose the diagram subtype and click OK. For the
illustrations in this section, [ am using a picture
organization chart which is a hierarchy diagram.
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Figure 13-31
A hierarchy diagram.

Figure 13-32
Choose the type of SmartArt you want to create.

Removing Diagram Shapes

Later in this chapter you will see how you can add
additional shapes to your diagram. If, however,
your diagram has shapes you do not want or need,
you can easily delete them. In Figure 13-32, you
see an organization diagram that automatically
begins with a high level, an assistant level, and
three sublevels. If you don't want the Assistant
box, for example, you can remove it. Simply click
the border edge of the shape you want to remove.
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When the shape is selected, you see eight selection
handles around the box. Press the Delete key to
delete the unwanted shape.

Adding Text to a Diagram

Notice that each box in the diagram has a text place-
holder. To add text to your diagram you could click
each individual placeholder and type the desired
text. A faster way, however, is to use the Text pane
that appears on the left side of the diagram (see
Figure 13-33). Selection handles surrounding the
graphics shape are tied to your insertion point loca-
tion on the Text pane. As you enter text, it automati-
cally resizes to fit in the selected diagram shape.

Working with Hierarchy Levels

In the Text pane, when you press Enter, another
blank line and a corresponding shape appear on
the diagram. Since a hierarchy diagram (such as an
organization chart), usually includes different levels,
called branches, Word by default provides several
higher headings and a few lower headings. You can
promote or demote these headings as needed. In
the Text pane, click anywhere in the line you want
to promote or demote and do one of the following:
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Figure 13-33
Entering text into the Text
pane.
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Tip

To close the Text pane, choose SmartArt
Tools > Design > Create Graphic > Text pane.
Click it again to redisplay the Text pane.

» Press the Tab key to demote to a lower
level. Optionally, choose SmartArt Tools >
Design > Create Graphic > Demote.

» Press the Shift+Tab key to promote to a
higher level. Optionally, choose SmartArt
Tools > Design > Create Graphic > Promote.

As you promote or demote the text, the graphic
immediately reflects the changes (see Figure 13-34).

Adding Diagram Shapes

The SmartArt Tools Design tab contains a button to
add shapes; however, in most situations it is gener-
ally easiest to add shapes using the Text pane.
Simply click at the end of the text in the shape
located before where you want the new shape.
Press Enter and the Text pane provides another
line for typing and a shape to go with it. You can
then add as many shapes as you want.

Unlike the hierarchy-type diagrams, the list,
process, cycle, relationship, and matrix diagrams do
not have branches, which makes them travel in a
single direction. Look at the Text pane and diagram
in Figure 13-35, where you see five shapes forming
a circle. When working with these types of dia-
grams, all the Text pane lines are on the same level.
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Figure 13-35
A single-level Text pane.

When adding shapes to a hierarchy diagram, you
have additional decisions to make, such as at what
level you want the new shape placed. If you are
adding a peer-level shape, you use the Text pane.
Click at the beginning of the line where you want
the new shape and press the Enter key. On the
resulting blank line, type the text for the new shape.

If, however, you want to add an assistant-level
shape, follow these steps:

Add Assistant

The Add Assistant feature is available only if
you are working with an organization chart.

1. In the Text pane, click the line for the shape
to which you want to add an assistant.

Choose SmartArt Tools > Design > Create
Graphic and click the Add Shape arrow. A list
of choices appears.

. Choose Add Assistant. The Assistant box
appears. In the Text pane, instead of a bullet
point like the other shapes, the Assistant
appears at the bottom of the list with a right-
angled arrow (see Figure 13-36).
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Adding an assistant.
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In this sample diagram, there is a picture box for
each box. You can click the picture box, and select
a picture for each one. (See Figure 13-37.)

Click here to add a picture

Fred

red
Flintstone

e

s

Figure 13-37
Adding pictures to the shape.

Changing the SmartArt Layout

If after working on your diagram you decide you
should have chosen a different style, you do not
have to start all over. Choose SmartArt Tools >

Design > Layouts and select from the available lay-

outs. As you pause your mouse over any layout,
Live Preview shows you your chart as it would
appear in the new layout. In Figure 13-38, you see
the original organization chart changed to a hori-
zontal hierarchy.
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Figure 13-38
Select a different layout.

Remember that only an organization chart can
have an assistant, so in this example, choosing a
different layout forces the assistant to a peer level.

Changing Shapes

If you want to call special attention to a certain
area of your diagram, you can change the shape.
Optionally, you can change the shapes for all the
diagram shape objects. For example, you want the
assistant to be in the form of a circle instead of
the square cornered box. Or perhaps you want a
box to have rounded corners instead of the square
corners.

Select the shape you want to change and choose
SmartArt Tools > Format > Shapes > Change
Shape. A gallery of shapes like the one you see in
Figure 13-39 appears. Choose a new shape, and the
diagram reflects the change.
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S Emaasswo— 0 Selecting a new shape.

Tip

Changing shapes may force the text size on all the shapes to change. If your shape size needs modify-
ing, choose SmartArt Tools > Format > Shapes and choose Larger or Smaller.

Changing a Diagram Style If you want to change the diagram colors, choose
SmartArt Tools > Design > SmartArt Styles >

Change Colors. A drop-down gallery similar to
what you see in Figure 13-40 appears. Again, as
you pause your mouse over any choice, Live
Preview shows you how it looks on your diagram.

If you want to add a little style to your diagram,
you can select from a variety of predefined coordi-
nated styles that would look good with your cur-
rent diagram layout. You can also change the col-
ors assigned to the diagram. The color choices
available depend on the Word theme.
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1 ] Adding a little color to your
:mmxllmu_ A1 : Enaam M@—O—’@ diagram.

If you want to change the box styles, such as
adding shadows, embossing, or three-dimensional
angles, choose SmartArt Tools > Design > SmartArt

Styles and click the More button. Select from the
choices you see. Figure 13-41 shows the diagram
with an intense color depth and shadows.
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Working with Graphics [[SiEIMIS@ES

You can also change an individual shape, color, or provided, which include the shape fill color, out-
effects by selecting the shape and choosing line attributes, and shape effects. See the Assistant
SmartArt Tools > Format > Shape Styles and shape in Figure 13-42.

choosing from the number of different options

9~ Dacumentd - Micrasoft Word B 1
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- Figure 13-42

i i« Changing individual shape
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Part 4

Word Tools

Picture Microsoft Word 2010 as the Swiss Army Knife of
word processing. Your main tool, Microsoft Word 2010, is
made up of many smaller tools. We all need the right tool
for the job. In this part of the book, you'll discover Word
tools to enhance the quality of your document and the
speed in which you create them. You'll also discover ways
to collaborate with others on a document and lots of
ways to customize Word to better fit the way you work.







Employing Tools for

Quality

ICTURE YOURSELF AS A SKILLED CRAFTSPERSON-a car-
penter, for example. Whether you're building a bird house or a
beach house, you know you need to use the right tools to get the
job done. So it is with Microsoft Word. Different tasks require different
tools, and it's important to use the right tool for the job.

%

Up to this point, you've used quite a few of the basic Word features. This
chapter is an assortment of some additional tools provided with Word that
can make your word-processing tasks easier and help improve the quality
of your writing.

As you work with Word, you may find you use some of the tools a lot
and other tools very seldom, but as you proceed with your Word docu-
ments, I'm sure you'll find yourself looking at your screen and thinking,
“Aha! I can use the [xxxx| feature to accomplish this.”




Correcting Errors

great American novel, a standard busi- Word cannot provide a suggestion. In those cases,
ness letter, or a résumé, spelling or you need to correct the error yourself.

grammatical errors can ruin the impression you're
trying to create. Not only does Word have spelling

WHETHER YOU ARE WRITING the word is replaced with your selection. Occasionally,

and grammar checkers to correct document errors, Add to Dictionary
it also has a thesaurus to help you find just the
right word to convey your ideas. If Word interprets a word as a misspelling,

but it is a word you use frequently, such as a
name or business term, you can add it to

Word has built-in dictionaries and grammatical - , .
your Dictionary so Word won't see it as a

rule sets that it uses to check your document.

Word can identify possible problems as you type, misspelling.
and it also can run a special spelling and grammar
check that provides you with more information
about the problems and tools for fixing them. And Add to Dictionary
although they have been greatly improved in Word — A\
2010, these features aren't infallible; if you type Ha————\ conflicting R
“To air is human” instead of “To err is human,” Ignore
Word probably won't be able to tell you that you're _' Ignore Al
wrong. However, combined with a good proofread- _ it Dichonmy
ing, these tools are very helpful. ! :ﬂ““"m '
anguage »

i Y Spelling...
Checking Spelling and ] tookup 1
Grammar as You Go : o4 Iy
As you type your dpcument, Word operatgs the' . | Evenin the © P__?’_'e Options: , the ow
spell checker tool in the background and identifies ! ¥ %A
problems. Word tags potential spelling errors with ! con”ffhctjng addtional acions » CUStOME
a red wavy line under them. Right-click on an - .
unrecognized word, and you see a shortcut menu Figure 14-1
appear with possible suggestions for correction Fixing errors as you type.

(see the example in Figure 14-1). Click on the cor-
rect spelling, and the misspelled or unrecognized

260



Employing Tools for Quality EKSiEInia e

As with spelling errors, Word identifies potential
grammatical errors by placing a green wavy line
under the questionable text. Right-click on the
questionable word or phrase to display a shortcut
menu with suggested grammatical corrections.
Click the appropriate option, and Word replaces
the incorrect word or phrase with your selection.
Sometimes, however, Word cannot provide a sug-
gestion; in those cases, you need to correct the
error yourself.

Check for Yourself

Do not rely on Word's spell check and gram-
mar features to catch all your errors. The
tools are very helpful, but they are far from
perfect and can miss many items. They can
also flag items as errors that really are okay
and can suggest wrong ways to fix both real
problems and false errors. You alone are the
one who knows what you want your docu-
ment to say. Proofread it yourself!

Running a Spelling and
Grammar Check

If you don't want to correct items as you type,
Word can run a Spelling and Grammar check at the
same time. Running the Spelling and Grammar
check also provides additional options for dealing
with incorrect items. Use the following steps:

1. Position the insertion point at the beginning
of the document to check the entire docu-
ment. If you only want to check a portion of
the text, select the text first.

2. Choose Review > Proofing > Spelling and
Grammar. If there are no errors in the docu-
ment, a message box appears advising you

that the checks are complete; otherwise,
Word displays the Spelling and Grammar dia-
log box shown in Figure 14-2, referencing
the first error, whether spelling or grammar.

Tip

Optionally, press F7 to launch the Spelling
and Grammar check.

Spelling and Grammar: English (U.S.) [7 =%

Mot in Dictionary;

In suchtimes, assets mus]be carefully protected. - | Ignare Once
S rgnorean |
!

Suggestons: -

I - Change |

|MUsSs [

mush =

) N

|mugs —

V] Check grammar

Options. .. Undo Close |
Figure 14-2

Using the Spelling and Grammar check to
improve your document.

3. If the error is a spelling error, do one of the
following:

» Ignore Once: Click this if you don't want
to correct this instance of the spelling.

» Ignore All: Click this if you don’t want
to correct any instances of the spelling.

» Add to Dictionary: Choose this to add
the word to the Dictionary so that in the
future Word won't flag it as an error.

» Change: Choose a word from the
Suggestions list and then click Change,
which changes just this incident of the
spelling mistake.
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P Change All: After selecting a replace-
ment from the Suggestions list, choose
Change All if you think you could have
made the same mistake more than
once.

P AutoCorrect: After making a selection
from the Suggestions list, click this
option to add the unknown word and
the correction as an AutoCorrect entry.
If you make the same misspelling in a
future document, Word automatically
changes it to the correction.

4. 1f the error is a grammatical error, such as
you see in Figure 14-3, take one of these
actions:

Tip

If you don't want Word to check grammar,
remove the checkmark from the Check
Grammar option.

Check Grammar option
/

Spelling and Grammar: En U.s)
Subject-Verb Agreement;

|Caterpillars is|the eghing and growing stage -~
(for the butterfly, b ey cannot mate and L4
\reproduce.

Suggestions:

(Caterpillars ars -
| OR

|A c&% is

(V] Check grammar

L i

Figure 14-3
Catching grammatical mishaps.
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P Ignore Once: Click this option if you
don’t want to change this instance of
the grammatical problem.

» Ignore Rule: Click this option to ignore
all instances of the same grammatical
problem type.

P> Next Sentence: Click this option to skip
the error and continue the check. All
instances of the same error are ignored.

» Change: Choose an option from the
Suggestions list and then click Change,
which changes just this incident of the
grammatical mistake.

» Explain: Click this option to launch an
article that explains the error and offers
suggestions for avoiding the error.

5. When all potential mistakes are identified,
Word notifies you that the Spelling and
Grammar check is complete. Click the OK
button.

Changing Spelling Options

Word provides quite a few options for both the
spelling and grammar correction features. For
example, if you don't want Word to check your
spelling or your grammar as you type, you can turn
off the feature. Click the File tab and choose
Options. Click the Proofing category.

From the Proofing section, as shown in Figure 14-4,
you can set or turn off any desired proofing
options. Some of the options apply to all Office
2010 applications, and some apply only to
Microsoft Word. There are even a few options that
apply only to the current document.
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(¥ Ignore words in UPPERCASE

Tgnore words that contain numpers
Ignore Internet and file addresses
Flag repeated words

Add-In; . Enforcg accented uppercase In French
. Suggest from main dictionary only

Customize Ribbon

Quick Access Toolbar

HEE

Trust Center

1 Summ Dictionaries...
French mades: | Traditional and new spellings [ |

=

Spanish modes: | Tuteo verb forms only
‘When correcting spelling and grammar

¥ Check spelling as you
¥ use coptextual

< <9 E <
x
=

grammar with spelling
17 show readability statistics

Writing Style: | Grammar Only E]
Check Document ]
Exceptionsfor: & Decument1 E

| Hide zpelling errors in this document only
H_l!! grammar errors in this document Oﬂ’f

| Word Options
ABEC|
Cured ; i Change how Word corrects and formats your text.
Display
[ proafing ||| AutaComect options
Save Change how Word comects and formats tedt 33 you type: | AutoCorrect Options.. |
Language
When correcting spelling in Microsoft Office programs
Advanced

e Show Readability Statistics option

& Figure 14-4

Readability Statistics

From the Word Options dialog box, click the
Show Readability Statistics check box. After
running a Spelling and Grammar check,
Word displays statistics, such as the number
of words, characters, paragraphs, and sen-
tences, as well as average words per sentence
or the readability grade level. See Figure 14-5
for an example.

-- T [ C‘n(‘,&l ] . . .
Setting proofing options.
Readability Statistics =)
Counts
Words 541
Characters 2721
Paragraphs 11
Sentences 29
Averages
Sentences per Paragraph 2.6
Words per Sentence 18.6
Characters per Word 4.8
Readability
Passive Sentences 6%
Flesch Reading Ease 59.7
Flesch-Kincaid Grade Level

Figure 14-5
Viewing document statistics.
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Finding Elusive Words with the Thesaurus

KEY TO GOOD WRITING is using
Awords that add interest and flair. However,

remember that you need words appropriate
for your audience. If you are addressing a group of
grade school children, you'll use simpler words
than if you are writing your college thesis. If you
need a little help finding just the right word, try
using Word'’s thesaurus.

Click anywhere in the word you want replaced and
then choose Review > Proofing > Thesaurus.
Optionally, press Shift+F7 to launch the thesaurus.
A Research pane similar to the one shown in
Figure 14-6 appears on the right side of the screen
and displays various meanings of the current word
and possible replacements. If you don't see the
exact word you want, click a similar word, which
displays its synonyms. Click the Back button to
return to the previous word. When you locate the
word that best fits your document, click the arrow
next to it and choose Insert. Word replaces the cur-
rent word with your selection.

Click the Research Close button (X) to close the
Research pane.
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Research v X
Search for:
beautiful

Thesaurus: English (1U.S.) E

PBack |~ D) |~

4 Thesaurus: English {(U.5.) -~
4 lovely (adj.)

lovely
attractive
good-locking
gorgeous
stunning
striking
fine-looking

m

handsome

ugly {Antonym)
4 lovely (adj.)

lovely

picturesque

SCenic
delightful
charming
wonderful
exquisite
pleasing

&) Get services on Office
Marketplace

{0, Research options...

Figure 14-6

Locating synonyms with the thesaurus.
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Using Find and Replace

ORD’S FIND AND REPLACE fea- Navigation v x
Wtures are real time savers. For example, ——
. . . juvenile hormone X|*
you can quickly find out if you covered a
particular topic in a lengthy report, or you can 3 matches
changes names, dates, and prices throughout docu- SIEE AW

ments with just a few keystrokes.
Caterpillars have a chemical
called juvenile hormone in

their bodies that is made by

USing Find their brain,

Word's Find command is useful when you want to

seek out text that you may have trouble visually a C;tter:r)i}lar Shled; its skin
locating in a docgmgnt. The Find comrqanq doesn't ,aer:fel iseh’:;ei';';ue':'t':?::
change any text; it simply locates and highlights next

the specified text for you. Follow these steps:

to the next caterpillar stage,
. . When the juvenile hormone
1. Choose Home > Editing > Find, or press the level is low the caterpillar

Ctrl+F keys. The Navigation pane appears on wanders to
the left side of the screen (see Figure 14-7).

2. In the text box, type the word or phrase that
you want to search for. As you type, Word
automatically highlights and displays each
occurrence of the word or phrase you're
looking for.

Starting Point

The Find command begins its search at the
location of the insertion point.

Figure 14-7
Finding document text.
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3. The Navigation pane also lists the other
occurrences of the searched text. Click any
occurrence to instantly jump to the text. If
you want to discontinue the search, simply
close the Navigation pane.

Tip

Unless you specify whole words (see the
next section), Word locates any instance
containing the letters you specify. For exam-
ple, if you enter read in the Find box, Word
also locates words like bread or reading.

Extending Search Options

If you need to be a little more specific about what
you're searching for, Word provides a number of
extended options to assist you.

Open the Navigation pane by choosing Home >
Editing > Find (or press the Ctrl+F keys), and in the
search text box, type the word or phrase for which
you want to search. Click the More Options arrow
next to the text box, which displays a menu like the
one you see in Figure 14-8. Choose Options, which
displays the Find Options dialog box (also shown in
Figure 14-8), and then select the options you want.
Click OK when you are finished, and Word contin-
ues the search using the options you selected.

Take a brief look at the most commonly used
options:

» Match Case: Check this to locate instances
that match the upper- and lowercase letters
as you entered them in the Find box. For
example, if you typed Go, Word will not
locate go or GO.

WH?-0|+ The Butterfly - Microsoft Word
“ Home Insert Page Layout References Mallings Review View
= = - - = lEir | 3
) -] AdBog) 11 - AW Aa % E- ST R AT | aagocer| 4aBbCel AaBbC AaBbCe '
Paju 7 BJZ U -dex,x [H-9-A- EEXAN (= H-1- Uhormsl | WMo Spaci.. Headingl Hesding2
Clipboard T Font Paragraph Styles
'Nawga!m ol *]-:"Lj' L TR U BT T S A e e A A O A Y B R W
- T e e i M wM e W W B G MR AR e
LRBtNE ) metabolic waste material left over from metamorphosis. It is not re|
St i Find Options |88 =]
R 3 Acanced Find... >
84 | b Match case Match prefiy.
The chrysalls has spiracles or P 214 [ Find whole wards only Match suffic
brealhing tubes just like the, = GoTo.. s wikdcards Tgnore punctustion characterg
‘(-:‘:!":pllllnrs and soults, 50, | o | Sounds Mee (Englsh) Tanore v thar ater|
il Gphic | Find sl word Forms (Englsh) air d
3 Isvies ) Hatight o
Tt Equations ] tncremertal fird
AF' Footpotes/Endnotes
o Comments »
[sethapsto | o J[Ccm ] Figure 14-8
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» Find Whole Words Only: Check this to
locate instances of the entire word only. For
example, if you enter read in the Find box,
Word will ignore words like bread or reading.

P Use Wildcards: Check this to use the ques-
tion mark (?) or asterisk (*) wildcards in your
search. The ? character matches any single
character, and the * character matches any
number of characters. For example, if you
enter b?d in the Find box, Word finds bad,
bed, or bidding, but not bread. If you enter
b*d Word locates words like bad, bed, abide,
bidding, bread, bored, and so forth.

Tip

Word also recognizes wildcard characters
like the at sign (@) or angle bracket (<).
See the Word Help system for a complete
description.

P Sounds Like: Check this to locate instances
that are phonetically the same as the text in
the Find box. For example, if you entered
foul, Word also locates fowl.

» Find All Word Forms: Check this to locate
all grammatical forms of the search word.
For example, if you enter they, Word also
locates their, theirs, them, and themselves.

» Highlight All: Checked by default, this
option tells Word to highlight all occur-
rences of the found text.

» Incremental Find: Also checked by default,
the Incremental Find option allows Word to
start searching as soon as you start typing
in the Find box.

» Match Prefix: Check this to locate words
that only begin, not contain or end, with
the search word. For example, if you enter
mini, Word also locates minimum or minia-
ture, but not administration.

» Match Suffix: Check this to locate words
that only end, not contain or begin, with
the search word. For example, if you enter
ration, Word also locates demonstration but
not rational.

» Ignore Punctuation Characters: Check
this to ignore punctuation marks, such as

?-“1.;: .and /. For example, if you
entered 7478, Word also locates 1,478 and
14.78.

» Ignore White-Space Characters: Check
this to ignore spaces and tabs. For example,
if you enter lonestar, Word also locates lone
star.

Finding Formatted Text

You can also locate text that contains a specified
type of formatting. For example, you want to
locate the word apple, but only if you underlined
the word. Or perhaps you want to locate all text in
the document in a 14-point Arial font. Follow
these steps:

1. From the Navigation pane, click the down
arrow next to the text box and choose Find
Advanced. The Find and Replace dialog box
opens.
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2. Click the More button which expands the
Find options, as shown in Figure 14-9. The
More button turns into a Less button. Some
of the options here are similar to those you
viewed in the previous section.

Less button

FRTARTTApaE B2
[=]
[Resdngrighicht = | [ Fndin= | [ Endmet | [ cancel
Search Opticns:
search; (W [7]
(7] Match case [ Match prefic
| Find whole words only | Match suffioc
Lse wildcards
Sounds e (English) [7] 1gnore punctustion characters
Find all word Forms (English) [7] 1gnore white-space characters
Find
[spacal~ |

Figure 14-9
Expand the search options.

3. Click the Format button. You see a list of for-
matting options.

4. Click the formatting type you want to locate.
Choices include Font, Paragraph, Tabs,
Language, Frame, Style, and Highlight. A dia-
log box appropriate to your selection
appears. In Figure 14-10 you see the Find
Font dialog box.
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'Find Font (T
Font Advanced |

Font: Font style: Size:
+Headings »~ | |Regular | |8 -
Agency FB —| |Italic —| |9 —
aharoni ) leod Bl [0 L=
algerian Bold Italic 1

Andalus - | [NotBold T | [12 ¥
Font color: Underline style: Underline color:

NoCoor  [v] [ ~| Nocolr  [+]

Effects

[ strikethrough [E] 5mall caps
[ Double strikethrough [ all caps
& superscript & Hidden
&) subscript

Preview

butterflies

[ ok ][ concel

Figure 14-10
Searching for formatting.

5. Select the formatting you want to search for
and then click OK, which returns you to the
Find and Replace dialog box.

Tip

Instead of choosing font options from a
dialog box, you can press a formatting
shortcut key such as Ctrl+B for bold.
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6. In the Find What text box, enter the text you
want to search for. Or if you want to find the
formatting only, regardless of the text, leave
the Find What box empty.

7. Specify any other search options and click

Find Next to begin your search. Click the
Cancel button when you are finished.

Tip

Click the No Formatting button to remove
any formatting specifications.

Finding Special Characters

In Chapter 2, you discovered that Word hides many
characters, such as the dots used for spaces, or an
arrow for tabs, or even the paragraph mark q at the
end of a paragraph. You can have Word search for a
number of special characters.

From the expanded Find and Replace dialog box,
click the Special button. You see a list of format-
ting options, as shown in Figure 14-11. Choose the
special character for which you want to search.
Word places a code for the character in the Find
What text box. Specify any other search options
and click Find Next to begin your search.

%A Paragraph Mark
Tab Character - Shiss
[T Anty Character LA ket s e R S
| AwyDigt
Find and Replac Aryy Letter 7=
[ Find Reglace Caret Character
et [k § Section Character E
T Paragraph Character
Colymn Break
Em Dash
Ep Dash
Endnote Mark
S - _rndin- | [ Endve | [ concel |
Search Options Eootnote Mark
Search Al Graphic
Match case Manual Line Bresk Match prefig
By Manual Page Break -
=] use widcards
1 Sounds e (€1 Nenbreaking Hyphen Tgnore punctuation charscters
| Find o word F Nonbreaking Space | Tgnare white-space characters
Optional Hyphen
Section Break
Find White Spac
Famat+_| '

Figure 14-11
Searching for special characters.

Using Replace

If you want to locate some particular text and
change it to something else, let Word do it for you
with the Replace feature. The Replace feature is
very similar to the Find function you just discov-
ered. You can locate text and replace it with differ-
ent text, or you can locate text and replace it with
the same or different text, but perhaps with differ-
ent formatting. Follow these simple steps:

1. Choose Home > Editing > Replace, or press
the Ctrl+H keys. The Find and Replace dialog
box appears with the Replace tab on top.

2. In the Find What text box, enter the text you
want to search for.

3. Click in the Replace With text box and type

a replacement word or phrase (see Figure
14-12).
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Find and Replace

Find | Replace | GoTo |

A

Find what:  |adult [~]
Options: Search Down

Replace with:  mature] [zl
(e ) (o) (Eoines) (o)

Search Options
Search; Down E]

[ Famat~ | [ specal~ |

|| Match case [ Makch prefix

("] Find whole words only [7] Match suffix

[7] Use wildcards

["] Sounds like (English) ["] 1gnore punctuation characters

|| Find all word Forms (English) || Ignore white-space characters
Replace

Figure 14-12
Entering Find and Replace

text.

Replace with Nothing

To delete the “found” text, leave the Replace
With text box empty. Word will replace the
found text with nothing.

4. Specify any additional search or replace
options, such as matching case or a particu-
lar format.

5. Click Find Next. Word locates the first match.

6. Choose one of the following:

P Click Replace if this is the text you want

to change. Word replaces the text and
locates the next occurrence.

270

» Click Replace All to replace all occur-
rences of the found text with the
replacement text. Word displays a mes-
sage box indicating how many occur-
rences it replaced. (See Figure 14-13.)

Tip

Use the Replace All button cautiously.
Remember that Word takes you very liter-
ally. Make sure the Find and Replace
options are exactly as you want them.
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Microsoft Word

o
@I ‘Word has completed its search of the document and has made 8 replacements. N
4 Figure 14-13

[ ok | [ Hep | Using the Replace All
command.

» Click Find Next to skip making changes

on this occurrence and locate the next
match.

7. Word notifies you when no more occurrences
of the search text exist. Click OK to close the
message box, and click Cancel to close the
Find and Replace dialog box.
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Applying Tools for

Speed

ICTURE YOURSELF RACING TO MEET the April 15th tax dead-
line. You're feverishly filling out forms, performing calculations, and
trying to remember all the details you know you're going to need. In
order to make the process as quick and painless as possible, you have your
tools ready: your calculator, your pencil, your receipts, and lots of caffeine.

Word includes a number of tools that help speed up the process of creating
and editing documents, such as tools that can do your typing for you, and
those that let you quickly make changes in your document. This chapter is
about using Word tools so you can work as efficiently as you can.



Creating Bookmarks

UST AS YOU USE A BOOKMARK to mark
a certain place in a book, electronic bookmarks

identify specified text locations for future refer-

ence. As an example, you might use a bookmark to
help you quickly jump to certain topics in your
document.

Tip

Bookmarks are useful for electronic reading
only and do not affect a printed document.

Place the insertion point where you want to create
a bookmark and choose Insert > Links >
Bookmark. The Bookmark dialog box shown in
Figure 15-1 appears.

Type a name for the bookmark and click Add.
Word saves the bookmark and closes the
Bookmark dialog box.

Tip

Bookmark names cannot include spaces or
special characters except the underscore
character (_).

274

Bookmark 7=

Bookmark name:
Metaboﬁc_Waste]

| -

Sort by: (@ Mame
Location

|| Hidden bookmarks

Figure 15-1
Creating a bookmark.

Now instead of scrolling through the document to
locate the text, you can quickly jump to it. Click
Insert > Links > Bookmark, which displays the
Bookmark dialog box along with a list of all the
bookmarks in your document. Select the bookmark
you want and click Go To.

Optionally, you can get to a bookmark by using the
Go To option, found in the Find and Replace dialog
box. Choose Home > Editing, and then click the
down arrow next to the Find option. Choose Go To.
The Find and Replace dialog box appears with the
Go To tab on top (see Figure 15-2).

Click Bookmark and then from the Enter
Bookmark Name drop-down list, choose the book-
mark you want. Click Go To and Word instantly
jumps to the bookmark location.
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Find and Replace B
T|p [7nd [ regece | coTo |
Gg to what: Enter bookmark name:
;:;m + | [ Metabokc_wastel [+]
Two alternative methods of displaying the i
Go To option are pressing Ctrl+G or the s '
F5 key. [ o= ]
Figure 15-2

Locating a bookmark.

Specifying Hyperlinks

YPERLINKS, SIMILAR TO bookmarks, take P If you want to link to a different file or to a

you to a specific location. However, not only Web site, choose Existing File or Web Page.

can hyperlinks jump to a location in your For a different file, locate and select the file
document, they can also jump to another file on name so when the user clicks the link, the
your computer, on your network, or to a Web page. referencgd file will open. However, if you
Like bookmarks, hyperlinks are useful for electronic want to link to a Web site, enter the Web
reading only and do not affect a printed document. address in the Address text box. When the

user clicks the link, the Web browser will
open to the referenced Web page. Figure

Word automatically creates some hyperlinks for 15-3 illustrates a link to a Web site.
you. For example, if you type a Web address or
e-mail address, as soon as you press Enter or the Trert yperiink £
spacebar, Word underlines the area and creates the e ] |
link. The AutoFormat As You Type function is what b | @ 8@ =
controls the automatic link creation behavior. You o || e i
will learn more about the AutoFormat As You Type o - ‘,"f.’u'i";m
. My
feature later in Chapter 17. 5| iy G
ooty (| P [(§ wrcnee
8 My vdeos -

. . ol Addrgss: | hekpcfwwew.thepeachireelady. com| =]
If you want to manually create a link, first select the Ead e ——
text or graphic you want the reader to click to launch -
the hyperlink. Choose Insert > Links > Hyperlink, Figure 15-3
which displays the Insert Hyperlink dialog box. The Creating a hyperlink to a Web site.

Insert Hyperlink dialog box offers several different
options from which you can select:
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» If you want to link to a different location in
the current document, click the Place in
This Document button, then specify which
heading or bookmark you want to refer-
ence. When users click on this link they will
be redirected to the specified location.

» [f you want to create a new document when
the hyperlink is clicked, choose Create New
Document and then enter a name and folder
for the new document.

» If you want to send an e-mail when the link
is selected, click the E-Mail Address button,
then enter the recipients e-mail address and
a subject. When the user clicks the link, the
user's e-mail program starts. Figure 15-4
illustrates the e-mail link options.

Link to: et to dsplay: metamorphosis [ saeentg... |
e} E-mad address:

et
‘Web Page Sabject:
Fleass send me mora information|

PlgceinThs | Regently used e-mad addresses:
Document

Insert Hyperlink 17 ==

g _
':“’ o) o)

Figure 15-4
Creating an e-mail hyperlink.

Word displays hyperlinks in a different color text
and with an underline. Press Ctrl and click any link
to jump to the specified location. As you hover
your mouse over the link, a tip appears with
instructions for following the link and a notation
to where the link will take you (see Figure 15-5).

pillar stage.

it of a butterfly's abdomen after emergence?

http://fwww.thepeachtreelady.com/
out of the abdomen |Cirl+Click to follow link rgence

ver from metamorpFosis| It is not responsible for the wi

Eles and chemical pigments.

breathing tubes just like the caterpillars and adults. §
he developing butterfly and the air outside the chrysalis

Figure 15-5
Hold down the Ctrl key and click the link.

Generating Text with Building Blocks

over and over when composing letters? Or

Q RE YOU TIRED OF TYPING your address
do you have a standard phrase that you need
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to frequently add to your documents? Word provides
a couple of different methods you can use to quickly
add the text into your document.
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The first method is to use Word's AutoCorrect
function, which you discovered in Chapter 2. Not
only can you add words and symbols, but you
can also generate a text paragraph or even a
graphic with your signature. The only problem is
that the AutoCorrect function limits each entry
to 255 characters.

Office 2010 is designed to be modular, so it uses a
function called building blocks that are divided into
14 different galleries. Think of building blocks as
recycled material. You've already been introduced to
some of the building blocks when you discovered
some of the built-in options in Headers, Footers,
Page Numbering, and Quick Tables. Take a brief
look at some of the different building block gal-
leries and what type of element each gallery holds:

» AutoText: Holds small text entries or
graphics that you want to use again, such as
a standard contract clause or a mission
statement.

P Bibliography: Holds text in the form of a
reference list of works by author, subject, or
other relevant information.

P Cover Pages: Holds preformatted cover
pages, such as those you might use for
reports. Figure 15-6 illustrates one of the
sample Cover Page building blocks.

» Quick Parts: Holds miscellaneous building
blocks that don't fit any other gallery.

» Equations: Holds predefined equations
objects.

» Footers: Holds a number of predefined foot-
ers that appear at the bottom of the page.

» Headers: Holds a number of predefined
headers that appear at the top of the page.

[Type the company name]

[Type the document title]
[Type the document subtitle]

Diane

|
[Year] |

Figure 15-6
The Cubicles cover page.

P Page Numbers: There are four different
page number galleries that hold predefined
page numbers—some at the current loca-
tion, some at the bottom or top of the page,
and some in the margins.

» Table of Contents: Holds predefined tables
of contents that are created based on head-
ing styles in the document.

» Tables: Holds a series of predefined tables,
such as those in the Quick Tables.

» Text Box: Holds predefined text box lay-
outs and formatting.

» Watermarks: Holds several predefined
watermarks, such as Draft, Do Not Copy, or
Confidential. Watermarks are in light gray
shading and appear in the background of a
document, as shown in Figure 15-7.
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Figure 15-7
A Watermark building block.

Inserting Building Blocks

Now that you see all the different types of building
blocks, take a look at how to insert any of the existing
blocks into your document. Just follow these steps:

1. Make sure you are in Print Layout or Web
Layout view. (You can insert a Building Block
while in Draft view, but you will not be able
to see it.)

2. Position the insertion point where you want
to insert the building block.

3. Choose Insert > Text > Quick Parts >
Building Blocks Organizer. The Building
Blocks Organizer appears.

4. Click a building block to display a preview on
the right side, as shown in Figure 15-8.
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Figure 15-8
Click the Building Block Organizer to see a preview.

Tip

Click any building block column heading
to sort the building blocks by that column.

5. Click the Insert button. Word inserts the
building block into your document.

Placeholders

Some building blocks prompt you to insert
text, such as your company name or a docu-
ment title. Click the placeholder and type the
appropriate text.

Creating Custom Building
Blocks

If none of the predefined building blocks suits
your needs, you can create your own custom build-
ing block. Additionally, you can start with one of
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the existing building blocks and customize it to a
better fit and then save it for future use. Just fol-
low these simple steps:

1. Create the text and formatting for the new
building block.

2. Select the area you want to save as a building
block

3. Choose Insert > Text > Quick Parts > Save
Selection to Quick Part Gallery. The Create
New Building Block dialog box appears.

4. Fill in the appropriate information, as shown
in Figure 15-9.

Create New Building Block [P
Name: Closing|
Gallery: Quick Parts

Category:  General

[+]
[-]

Description:
Savein: Building Blocks E
Options: Insert content only El
[ ok || concel |
Figure 15-9

Naming a custom building block.

» Name: By default, Word picks up the first
few characters of the text you selected;
however, you can give the building block
a short, more descriptive name.

» Gallery: Select which of the Gallery
types you want. Most likely, you'll want
to use the Quick Parts gallery.

» Category: You can further differentiate
the items in the gallery by creating and
assigning categories.

P Description: Enter a longer descrip-
tion to help you identify the building
block and its purpose.

P Save In: Select whether to save the new
item under the Building Blocks area,
which makes it available no matter
which template you use, or choose to
save it only if you are using the Normal
template.

P Options: Choices include whether to
insert the building block at the current
cursor position, start a new paragraph
and then insert the building block, or
to start a new page and then insert the
building block.

5. Click OK. Now when you open the Building
Blocks Organizer, you'll see your custom
building block.

When you exit Word, you see the message box shown
in Figure 15-10. Choose Save to save the changes.

Microsoft Word ==
2\
/ ! \5 You have modified styles, building blocks (such as cover
pages or headers), or other content that is stored in
"Building Blocks", Do you want to save changes to
"Building Blocks"?

[ Save l rDDg'tSave ] [ Cancel

Figure 15-10
Saving building blocks for future use.

Tip

If you no longer want a custom building
block, display the Building Blocks
Organizer, select the building block you
want to delete, and click the Delete but-
ton. Click Yes to the confirmation message
that appears.
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Adding Automatic Fields

ORD HAS A FEATURE called fields
Wthat you can use as placeholders in your

document. You typically use fields with
the kind of data that might change such as a date,
numbering, or page numbers. In fact, in Chapter 4,
when you created a header or footer, you probably
used a field to insert the page number. Then in
Chapter 7, you discovered fields when you created
a Table of Contents and then you used fields again
in Chapter 9, when you created form letters using
Word's mail merge feature, such as when you spec-
ified a greeting or address block. Let's take a look
at a few other fields.

Placing a Document Property

One group of Word fields is called Document
Properties. And just like it sounds, document prop-
erties are miscellaneous pieces of information about
your document. Pieces of information such as the
document title, or the author are only a click away.

Before we place a document property into our docu-
ment, let’s take a brief look at where we can find
and modify document properties. You'll find them
on the Document Info screen. Click the File tab.
From the Info screen, such as you see in Figure
15-11, on the right side of the screen, you see the
document properties such as the Title, Comments,
Author and lots of statistical information. If you
click the mouse next to many of the choices, such as
Title or Comments, you can type your own informa-
tion into the text box. Word saves the document
properties with a document, and anyone who opens
the document can view the properties.
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Properties =

Size 36.6KB

Pages 12

Waords 4342

Total Editing Time 133 Minutes
Title My Business Plan
Tags

Comments Plans for starting a Dian...

Related Dates
Last Modified

Created 4/3/2010 11:05 PM

Today, 10:16 PM

Last Printed

Related People

Author Diane

Last Modified By Diane Koers

Related Documents
£l Open File Location

Show All Properties

Figure 15-11
Viewing document properties.

But if you also want a property listed in the docu-
ment body, position the cursor where you want the
field and choose Insert > Text > Quick Parts >
Document Property and choose the property you
want from the list seen in Figure 15-12.
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Figure 15-12
Document property list.

All properties appear as fields with a field code box
surrounding it. As you pause your mouse over the
property, a gray field surrounds it. If you click the
field, you can edit or format the field as desired. If
you want to delete the field, click the (non-printing)
field tab that appears at the top left of the field and
press the Delete key. Figure 15-13 illustrates a docu-
ment with the Comment field displayed.

Wastage is estimated at 15% across all food related product (validated
trials). This will reduce once the ‘Nudle-Rac’ and associated IT systems

Training, Quality M g t Syst and Franchise Operations Man
completed effectively for $220,000 by the end of year 1.

=
Plans for starting a Diane's Noodles franchise in Indiana

Figure 15-13
Displaying a document property.

Some of the document properties pull data from
the properties under File > Info, and others remain
blank so you can enter your own data. Then, if you
want to use the property again, in another docu-
ment location, Word remembers what you entered.
For example, suppose you want your customer’s
company name in the document several times so
you add the property field Company. You then type
your customer company name in the first
Company field box. If you then add the field

Company somewhere else in the document, it will
automatically replicate what you entered in the
first Company field. And, if you need to change the
name, changing it in one field, changes it in all the
Company fields.

Adding Field Codes

There are many other types of fields you can use in
a Word document including statistical information
and automatic numbering. Suppose you want the
document creation date entered into a document.
Using the Create Date field, you can insert the date
and time that the document was first saved with
its current name. Or suppose you have a document
that you always want to display the current date.

When you create a document and you type in a
date, the date is said to be static, meaning it doesn't
change when the date changes. So if you type
September 16, 2010, the document will always read
September 16, 2010. If, however, you want the date
or time to change with the calendar, you need to
insert a dynamic date or time. Word handles these
in the form of a field code. Just follow these steps:

1. Position the insertion point where you want
the date.

2. Choose Insert > Text > Date and Time. The
Date and Time dialog box appears (see Figure
15-14).

3. Click the date format you want to use.

4. Click the “Update automatically” check box
and then click OK.
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Date and Time )
Available Formats: |

.2!;4‘;:[0 -
lednesday, February 24, 2010

February 24, 2010
|2f24/10
|2010-02-24
|24-Feb-10
|2.24.2010
Feb. 24, 10
24 February 2010
|February 10
|Feb-10
|2/24/2010 8:43 PM
|2/24/2010 8:43:19 PM
843 PM

Engish (U.5.) [=]

Set As Default

Figure 15-14
Adding an automatic date in the format you need.

Tip

If you only want the current static date
and not a dynamic date, do not select the
Update Automatically option.

Word inserts the current date field into the docu-
ment. As you hover your mouse over the date, the
field becomes shaded and if you click the field, the
field placeholder appears (see Figure 15-15). Fields
update automatically each time you open the doc-
ument, but if you want to update a field manually,
click the Update button at the top of the field
placeholder.

Eagn - @
o - T Ll T T
i s ) A Dowatme  as
Sttt | [ gt | e et +

o

| Apil 25,2010

Figure 15-15
The field placeholder.
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Using Automatic Numbering

By design, the AutoNum field sequentially num-
bers paragraphs but there are many other practical
uses for it. For example, suppose you have a
lengthy document with a list of similar type ele-
ments; such as headings, tables, or figure refer-
ences (such as this book), or graphics. You can use
the AutoNum field to keep track of them for you.

In Figure 15-16 you see a document with headings.
In front of each Heading, I inserted an AutoNum
command. [ also added the word Question in front of
the AutoNum. So you see each Heading 1 with
Question 1., Question 2., and so forth. The advantage
to using the AutoNum field code is that if I move the
third heading up to the top of the document, Word
automatically renumbers the paragraphs for me.

Automatic Numbering field

Question [l. How does a caterpillar turn into a butterfly?
This is not easy to explain. You can say that inside the chrysalis the caterpillar changes clothes

into a {An esoteric Inside the chrysalis the caterpillar structures are brol
chemically and the adult's new structures are formed).

Question 2. Why do caterpillars turn into butterflies?
Caterpillars are the eating and growing stage for the butterfly, but they cannot mate and reprq
adult butterfly is both the mating and egg-laying stage of the beautiful insect. Also adult butte
disperse by flight, sometimes long distances, to either colonize new areas with fresh plants fo
caterpillars or even migrate long distances to escape our freezing winters, such as Monarchs f
Mexico or coastal California for the winter.

Question 3. How do caterpillars "know" when it is time to turn int

Figure 15-16
Automatic numbering.



Applying Tools for Speed [ESLENI @k

To add automatic numbering to your document,
click the cursor where you want the first number
and choose Insert > Text > Quick Parts > Field. The
Field dialog box seen in Figure 15-17 appears.
Choose AutoNum and click OK. Word inserts the
AutoNum field into the document with the first
number (1) and a period after it. Repeat adding the
AutoNum field for each item you want numbered.
You can use Word's copy and paste functions to
copy the automatic numbering.

AutoNum
properties Fieid optiors
] Separstor character:

L3, ..

abc,

A B, C, .

(1A

5,0, m,

Use Default

[ ][ e

Figure 15-17
The Field dialog box.

Using Office Applications

ICROSOFT DESIGNED THE ENTIRE
Mofﬁce suite so that the applications can be

used within each other. You've already dis-
covered in Chapter 5, how you can e-mail a Word
document using Outlook and in Chapter 12, you
realized how to insert an Excel table into a Word

document. But there’s more you can do. This section
is about integrating more of the Office elements.

Inserting a Word File

In your current document, if you need something
you've already typed into another document,
you could (A) retype the document; (B) open the

document you want to insert, select the entire doc-

ument, copy it, and then paste it into the new doc-

ument; or (C) insert the other file into your existing
file. I vote for C.

Position the insertion point where you want the
file to begin and then choose Insert > Text. Click
the Object arrow and choose Text from File. The
Insert File dialog box seen in Figure 15-18 appears.

Locate and click the file you want and then choose
Insert. The entire file appears in the current docu-
ment. It's quick and easy!
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Figure 15-18
Inserting an existing file.

Using Charts from Excel

Suppose you're doing a report and you want to add
a chart. You have two ways you can do that. One is
to create the Excel chart in Word and the other is
to insert an Excel chart in Word. That probably
sounds a little strange to ‘“create an Excel chart in
Word", but because the Office applications are so
tightly integrated, you can do just that. We'll take a
look at creating a chart first.

Creating an Excel Chart

When you create a chart in Word, it's actually using
the Excel program to do so. So to accomplish this,
you need a very basic knowledge of using the Excel
application. The following steps show you how to
create an Excel chart in Word:

1. Position the cursor where you want the chart
and choose Insert > Text > Object. The Object
dialog box seen in Figure 15-19 appears.

284

Object
[ creste New | Create from File |
| Object type:

Microsoft Equation 3.0 -]
Microsoft Excel 97-2003 Worksheet

Microsoft Excel Binary Workshest
hﬁcrosoft Excel Chart

[m

| |Microsoft PowerPoint 97-2003 Presentation
Resul

~ | [l visplay asicon

Inserts a new Microsoft Excel Chart object into

your document,

Sage ey | v ar 2 oG os g

Figure 15-19
The Object dialog box.

2. From the Create New tab, select Microsoft
Excel Chart and then click OK. A sample
chart appears in your document and Excel
worksheet and chart tabs appear on the
Ribbon. See Figure 15-20.

Sheet1 tab

= |

u Food
B Gas

= Motel

sl Oty Gresti 3

7 FUNDS REQUIRED & USE

Figure 15-20
The sample Excel chart.

3. This chart is created from sample data so you
need to replace the data with your own. Click
the Sheet1 tab and replace the sample data
with your own. See Figure 15-21.
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Figure 15-21
Modify the chart data.

4. Click the Chart1 tab to redisplay the chart.

5. If your data takes more or fewer cells than
the sample, choose Chart Tools > Design >
Data > Select Data. The Select Data Source
dialog box appears and you see the work-
sheet data.

6. Highlight the cell data you want for your
chart and click OK.

7. Optionally, use the other Chart Tools tabs to
change the look of the chart or the chart type.

Tip

Word prints the chart with the rest of the
document.

Inserting an Excel Chart

If you've already created and formatted the chart,
you don't need to create it a second time in Word.
You can simple insert the chart into your docu-
ment. Inserting the chart using this method embeds

the chart into the document so that if the data on
the chart changes, the Word document chart auto-
matically updates when you reopen the Word docu-
ment. Let's take a look at how this is accomplished.

Position the cursor where you want the chart and
choose Insert > Text > Object. The Object dialog box
appears. Click the Create from File tab and then
click the Browse button. From the Browse dialog
box that appears, navigate to and select the Excel
workbook containing the chart you want then click
OK. See Figure 15-22. Click OK to accept the choice.

Object FEE
[ cresteNew | Create from e |

File pame:
CilUsers|Diane\Documentsitest for chart.xlsx

[ Link to File
[ Display as icon
Result
. Inserts the conbents of the file into your
EB document 50 that you can edit it later using the
application which created the source file.
o) (o )

Figure 15-22
Selecting an Excel workbook.

Word displays the first worksheet in the Excel work-
book. If the first worksheet is not the chart you want,
click the worksheet tab that contains the chart. Also,
like the chart you create in Word, the embedded
chart will print with the rest of the document.

Inserting a PowerPoint
Presentation

What about PowerPoint? Can you insert a Power-
Point presentation into your Word document? Yes
you can, and similar to the Excel chart, the presen-
tation is embedded into the document so if the
original presentation changes, you'll see the
changes as well in the Word document.
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What is different is that you don't see the entire
PowerPoint presentation in your document; you
only see the first slide. You can view the
PowerPoint slide show from within your document,
but only the first slide prints.

Use the following steps to insert a PowerPoint
presentation:

1. Position the cursor where you want the icon
located and choose Insert > Text > Object.
The Object dialog box appears.

2. From the Create from File tab, click the
Browse button. The Browse dialog box
appears.

3. Navigate to and select the PowerPoint you
want to reference.

4. Click Insert. The Object dialog box reappears
with the referenced file name.

5. Click OK. The first slide in the presentation
appears in your Word document as you see
in Figure 15-23.

Tip

To view the entire presentation in a slide
show format as shown in Figure 15-24, dou-
ble-click the slide in the Word document.

s
Ego-;f T i
) it i (
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0 - o F
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Page o) | werss T SoEIm e -

Figure 15-23
The PowerPoint slide.
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Figure 15-24
The PowerPoint slide show.

Inserting an Access Link

While you cannot actually insert an Access data-
base into a Word document, like you can an Excel
or PowerPoint element, you can reference it so
your document reader can quickly open and review
the database. Of course, that's only going to work
if your reader is viewing the document on the com-
puter; not in paper form.

If you have an Access database that you want to ref-
erence, you have two ways you can do that. One is
by creating a link to the Access database. To do that,
see “Specifying Hyperlinks” earlier in this chapter.

The other method is to insert an Access icon in the
document. When the reader double clicks the
Access icon, the database will open and the reader
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can peruse through it. The following steps walk
you through the process of inserting an Access
database icon:

1. Position the cursor where you want the icon
located and choose Insert > Text > Object.
The Object dialog box appears.

2. From the Create from File tab, click the Browse
button. The Browse dialog box appears.

3. Navigate to and select the Access database
you want to reference.

4. Click Insert. The Object dialog box reappears
with the referenced file name.

5. Click OK. An Access icon appears in your
Word document as you see in Figure 15-25.

Double-click the Access icon to open the Access
database. (See Figure 15-26.)

Datibaredh () Cacabate (aooess 3987) - WATEOA Acess

Apl 29, 201C

restc ts in Indi polis but grew tired of paying exorbitant rent hopil
would turn up each night. His Diane’s Noodles concept takes the prody

Areference list:
)
. Database?b.accdb

Diane's Noodles has strong financials, and is always cash flow positive.|

et B Wk e B e k. A EA AAA AAA L. Vo e F ..l ERITRA A4

Figure 15-25
The Access database icon.

Figure 15-26
The opened Access database.

287






Collaborating with

Others

ICTURE YOURSELF AT A SATURDAY COOKOUT
with friends. Your host and hostess supplied the basics for
the meal—grilling items, beverages, condiments, and so
on. Each of the guests contributed a dish to round out the
meal—a special appetizer, a favorite side dish, or a stunning
dessert. Together, everyone creates a fantastic meal.

Collaboration features enable everyone on the team to make a
contribution to the finished document. Word's Track Changes
features enable changes to be identified by user, and changes
can be accepted or rejected as needed to finalize the document.
If you prefer that changes not be made to the document, other
users can add their comments so that you can incorporate their
thoughts in your own words and then remove the comments.
Word offers a third collaboration approach, the ability to com-
pare documents edited by different users and decide which
changes to keep. When you're working with a team, using
Word's collaboration features ensures that the finished docu-
ment reflects the best ideas contributed by each team member.




Tracking Changes

tle help, whether it's help with punctuation

and grammar, help with word choice and
phrasing, or help with ideas and the flow of infor-
mation in a document. Circulating a document for
review and correction by others provides the bene-
fit of having input from a variety of team members
with varying professional backgrounds, points of
view, and skill sets. Whereas one person may miss
an error or inaccuracy, it's less likely that four peo-
ple will. And if two heads are better than one, well
chances are that five or six heads will give you a
range of ideas to draw on so that you can best com-
municate your message in any given document.

EVEN THE BEST OF WRITERS needs a lit-

Circulating a document for review used to be a
tricky process, even with early word processing pro-
grams. You typically could not tell what changes
were made and who made them. This left you in
the position of comparing the original file with the
edited version (or versions) line by line, and choos-
ing which changes to type into your final version of
the file. This process could lead to omissions and
miscommunications in the review process.

Some versions ago, a document review feature
called revision marking was built into Word. Word
2007 and now 2010 included a renamed version of
that feature called Track Changes. When enabled,
the Track Changes feature does just what the name
implies. As a particular user makes changes to the
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document, Word marks those changes so that you
can see what has been changed. Even better, Word
by default color-codes the changes according to
the user who made them and uses different kinds
of marks to indicate different types of changes.

Markup formatting for the changes includes the
following:

» Strikethrough marks deletions.

» Underlining marks additions, also called
insertions.

» Vertical lines at the left margin indicate
changed lines.

» Double strikethrough marks in green show
text that has been removed from a location.

» Double underscore marks in green show
the new location for moved text.

» Formatting changes are shown with bal-
loons in a markup area that appears to the
right of the document in Print Layout view.

» Shading in a table shows inserted (light
blue), deleted (pink), merged (light yellow),
and split (light orange) cells.

Figure 16-1 illustrates how the Track Changes fea-
ture marks up a document.
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document.
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Once you've turned on Track Changes and have dis-
tributed the document for review, you can decide
which changes to review and keep. You'll learn
about the ins and outs of tracking and reviewing a
document next.

Turning on Tracking

The Review tab on Word's Ribbon offers a wide
variety of document review tools, including those
for tracking changes. To turn on Track Changes,
choose Review > Tracking > Track Changes (the top

part of the button). When the Track Changes fea-
ture is active, its button is highlighted, as shown in
Figure 16-2. Repeat the command sequence to
turn the Track Changes feature off, such as when
you want to make quick additions or deletions that
you don't want marked as corrections.

After you enable Track Changes, save the document.
Then, when you distribute the document to others
and they open it, the Track Changes feature will
already be enabled. Team members reviewing the
document can read it and make the desired changes.

Home Insert Page Layout References Mallings Review View
y [}, Research aTB %}"" _] ] Delete =2 |22 Final: Show Markup % &) Reject - j o _E W
‘ 3 Thesaurus 3 2 Previous | | | @ Show Markup ~ 3 Previous 5. 5"1
T Brco | ™ 0| S e | B e | A Ber || 2% R |
Proofing Language Comments Tracking Changes Compare Protect OneNote

Figure 16-2
Track Changes feature activated.
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Distributing a Document

Use File > Save & Send > Send Using E-Mail
> Send as Attachment to distribute it for
review via e-mail. For a document file stored
on a shared network drive, choose File > Save
& Send > Send Using E-Mail > Send a Link to
start the e-mail message.

Changing Tracking Options

As you learned earlier, Word uses particular
markup formatting to identify the user making
changes and the types of changes made. The
default settings do a great job of identifying
changes for you, but you may prefer to tweak how
those settings work. For example, you can change
the formatting used to mark insertions or deletions
or opt to use one color for insertions and deletions
rather than color-coding them by author (user).

To change the options for tracking, choose Review >
Tracking > Track Changes arrow > Change Tracking
Options. The Track Changes Options dialog box
shown in Figure 16-3 appears. Make the desired set-
tings changes, and then click OK to apply them.

Tip

You can change tracking options before or
after distributing a document for tracking.

As you can see in Figure 16-3, the Track Changes
Options dialog box offers a wide variety of settings,
some of which apply to comments (a feature you'll
learn about later in this chapter) rather than
change tracking. Here's an overview of the features
for tracking changes that you may want to adjust:
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Track Changes Options
Markup -
Insertons: |~ | Color: Moyotor |7
Deletons: Strikethrough [+] golor: [ [T
Changedlines:  |Outsdeborder || Color: M a0 [=]
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| Formatting
|| Eormattng: | (none) [¢] color: Heyotor |7
Balloons
| Use Balloons (Print and Web Layout): Only for comments/formatting E
I Preferred width: |3° + Measurein: | Inches El
Margin: Right [+]
M [¥] show lines connecting to text
Paper orientation in printing: Preserve ]
(o ][ conce ]
Figure 16-3

Choosing Track Changes formatting.

» Insertions and Color: Choose what attri-
bute to use to mark up inserted text, and
make a color choice other than By Author
to turn off color coding and use one color
for all changes instead.

» Deletions and Color: Choose what attri-
bute to use to mark up inserted text, and
make a color choice other than By Author
to turn off color coding and use one color
for all changes instead.

» Changed Lines and Color: Specify a location
for the vertical lines that indicate changed
lines of text and a color for those markup
lines. The small preview area shows how your
choices for this pair of options will look.
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» Track Moves: Use this check box to specify
whether Track Changes will mark up moved
text.

» Moved From and Color: Choose what
attribute or character to use to mark up
moved text in its original location, as well
as choosing a color.

» Moved To and Color: Choose what attri-
bute or character to use to mark up moved
text in its new location, as well as choosing
a color.

» Inserted Cells, Deleted Cells, Merged
Cells, and Split Cells: Use these drop-
down lists under Table Cell Highlighting to
choose the highlighting colors for marking
up the associated cell changes.

» Track Formatting: Use this check box to
specify whether Track Changes will mark up
formatting changes.

» Formatting and Color: Choose to use an
attribute to mark up formatting changes—
the default setting is (None)—and make a
color choice other than By Author to turn
off color coding and use one color for all
changes instead.

Changes enabled, as you saw earlier in Figure 16-1.
To identify who made a particular change, move
the mouse pointer over the change, either in the
text or in a balloon in the Markup Area at the right
in Print Layout view. As shown in the example in
Figure 16-4, a ScreenTip showing the author’s user
name, the date and the time of the change, and
the change contents appears.

Pointer over change

/

/
Marly/4/19/2010 3:46:00 PM inserted:
Pro/Realtors, Inc.

WePro Realtors[Inc. appreciates your longtime patr

Dear Client:

serving as vour resource for real estate transactions i

Only Text?

I've used “text” in the preceding descriptions
to simplify them. The Track Changes feature
also marks up changes to objects, such as
tables and graphics.

Figure 16-4
Viewing a change’s author.

When you use Track Changes to mark up a docu-
ment, Track Changes pulls your user name as speci-
fied in Word Options. If you need to update your
user settings to make sure Word accurately identifies
which changes you made, you can do so right from
the Track Changes menu. Choose Review > Tracking
> Track Changes arrow > Change User Name to
open the General settings in the Word Options dia-
log box (see Figure 16-5). Update the User Name
and Initials entries as desired, and then click OK.

Name and initials

Changing the User Name

If you leave the default Track Changes settings in
place, you will be able to see at a glance where
each user has made changes in a file with Track

R

Disglay

Opan e-muall attschemnt in Full Sérnen Rpsding v

Figure 16-5
Editing user information.
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Tip

Word uses the initials entry to mark
comments that you make. See “Working
with Comments” later in the chapter to
learn more.

Viewing Tracked Changes

Just as you can change the overall view for a docu-

ment, Word enables you to control which changes
appear and how they look so that you can be as
efficient as possible when completing your review
of the changes.

By default, the Track Changes feature shows you
the final version of the document, with the
changes marked. If that is not how you wish to
preview the document, you can click an alternate
choice in the Display for Review drop-down list
(see Figure 16-6) in the Tracking group of the
Review tab. The Final choice shows the document
with all changes in place and no markup. Original:
Show Markup shows the original version of the

text with changes marked. Original shows the doc-

ument without any of the marked changes.

Review View

J% Final: Show Markup m
= Z) | Final: Show Markup
Track

[ Final
|Changes '.\E . o
Original: Show Markup

! Original

Figure 16-6
Choosing how to view changes.

The Show Markup drop-down list, also found in
the Tracking group of the Review tab, enables you
to turn off the display of particular tracked
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changes. As shown in Figure 16-7, you can open
the drop-down list by clicking Show Markup, and
then click one of several choices to toggle display
of the related markup on and off. A checkmark to
the left of a choice means it is toggled on. So, for
example, you could click the Formatting choice in
the list to hide the markup display for formatting
changes. This can be a handy thing to do if there
are a lot of comments in the document and you're
having trouble viewing all of the information in
balloons in the Markup Area. You could choose
Show Markup > Formatting again to turn the for-
matting markup display back on when you finish
reviewing comments.

Review View

-3¢ |23 Final: Show Markup v
| = l_] Show Markup |

ek ——————————
Changes ~

Comments
v | Ink
v | Insertions and Deletions
v | Formatting
v | Markup Area Highlight
3= Balloons >

Reviewers 4

v | Highlight Updates

Figure 16-7
Choosing markup items to show.

The Show Markup drop-down list enables you to
control display of other items using the Balloons
and Reviewers submenus. On the Balloons sub-
menu, you can choose to do any of the following:

» Show Revisions in Balloons: As shown in
the example in Figure 16-8, choosing this
option shows information removed from the
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document in balloons in the Markup Area.
You must be working in Print Layout view or
Web Layout view to see the balloons.

» Show All Revisions Inline: Choose this
option to see revisions and comment mark-
ers right in the text and comments them-
selves in the Reviewing Pane.

» Show Only Comments and Formatting in
Balloons: This default setting shows text
changes inline and formatting changes and
comments as balloons in the Markup Area.

Pro Realtors, Inc.

ATHENS, GA M1

| s Rsaltons, o spposciane; vour longrine putroruge of sur firm. W huve mjoved serving s | Bt
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Tha comemaraty feasew and acnities mckade:

* Vour chos of o, madnbemasee free paso home. o heury home living

+ Chubhous, Biress conter, and pocd
& Contepe, wirport dranth, and bocal trwvel services

+ Hikingrads.
+ Degpark.

Figure 16-8
Deletions shown in balloons.

The Reviewers submenu of the Show Markup
drop-down list enables you to hide and redisplay
comments by a particular reviewer. For example, if
your boss reviewed a document and you want to
focus on the changes that she made, you can hide
the comments from all other reviewers except
your boss. Choose Review > Tracking > Show
Markup > Reviewers, and then click the name of
the reviewer whose markup you want to hide, or
redisplay if not checked. You can use the All
Reviewers choice to remove the markup from all
reviewers, and then revisit the submenu to check
the names for individual reviewers to selectively
turn their markup back on.

One final review viewing feature found in the
Tracking group also applies to both Track Changes
and comments. Choose Review > Tracking >
Reviewing Pane to toggle the display of the
Reviewing Pane on or off. The Reviewing Pane,
shown in Figure 16-9, appears at the left side of
the Word window by default. It lists each of the
changes made and the reviewer who made it. A
detailed summary of the number and nature of
the changes made appears at the top of the pane.
You can use the Show/Hide Detailed Summary
button to toggle the detailed summary off or back
on. To ensure that the Reviewing Pane calculates
all the latest changes, click the Update Revision
Count button.

Update Revision Count
Detailed summary

\Summam 12 rwi:ions\—c */x

Insertions: 5 Deletions: 4 Moves: 2

Show/Hide De}ailed Summary

Formatting: 1 Comments: 0

No underline

| Deleted Mark |

We

Inserted Mark

Pro Realtors, Inc.

Inserted Mark

s

| Deleted Mark |

50 and older

Inserted Mark

ready to downsize

Deleted Janet |

an exclusive

Inserted Janet |

a private

Deleted Janet

please

Inserted Janet |

accommodate L
Figure 16-9

Changes and their authors listed
in the Reviewing Pane.

295



Tip

Choose Review > Tracking > Reviewing
Pane arrow > Reviewing Pane Horizontal
to display the Reviewing Pane along the
bottom of the Word window rather than
the side.

Reviewing Changes

The Track Changes feature considers all marked
changes as proposed changes. The owner of the
document—you—retains the ability to specify
which changes should be incorporated into the
document and which should be discarded. If one
reviewer changed a statistic to a value that's incor-
rect and another reviewer made a change that you
believe is grammatically incorrect, you can quickly
undo those changes while going on to incorporate
other changes that you believe improve and
enhance the document.

The Changes group of the Review tab in the
Ribbon offers tools to automate the process of
reviewing changes. As shown in Figure 16-10, the
Changes tools are as follows:

» Accept: Implements the change in the doc-
ument, removing the markup formatting.
Click the bottom portion of the button with
the arrow on it to display additional
options. Click Accept and Move to Next to
implement the change and move to the
next change. Choose Accept All Changes
Shown to accept only those changes cur-
rently visible in the document (if you've
hidden certain changes or changes by a par-
ticular reviewer, for example). To implement
all the proposed changes, click Accept All
Changes in Document.
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» Reject: Click this button to remove the pro-
posed change and remove its markup.
Clicking the arrow for the button opens a
list of choices like those for the Accept but-
ton. You can choose Reject and Move to
Next, Reject All Changes Shown, and Reject
All Changes in Document.

» Previous and Next: Use these buttons to
move from change to change without
accepting or rejecting the current change.

?/ &2 Reject ~
@} Previous
Accept

= 92 Next

Changes

Figure 16-10
Tools for handling changes.

You can either work your way through the document
and perform the review, or you can work with partic-
ular areas in the document as needed. For example,
you can select a paragraph in the document, and
then choose Review > Changes > Accept to accept
only the changes proposed within the selection.

If the insertion point isn't in text with a change,
clicking Accept or Reject will select the next
change in the document. Alternately, you can use
the Previous and Next buttons to move around and
evaluate proposed changes.

When you finish working with the document
changes, be sure to save the document to finalize it.

Printing the Markup

If a document contains tracked changes, they
will print by default. Choose File > Print,
click the top option under Settings, and click
the Print Markup choice to toggle printing of
tracked changes off or back on.
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Working with Comments

ANY REVIEWERS of your documents
M may have input that requires explanation

beyond short in-text tweaks or may have
questions that need to be addressed outside of the
content of what you've written. In such cases, you
can encourage reviewers to use Word's Comments
feature. Comments are notes or questions that
reviewers can add to the document. The comments
appear in balloons in the Markup Area by default
in Print Layout and Web Layout views. In Draft
view, you can see comments by displaying the
Reviewing Pane (Review > Tracking > Reviewing
Pane) or by moving the mouse over the comment
marker to display the comment in a ScreenTip, as
shown in Figure 16-11.

Pointer over comment marker

/

]

Linda, 4/20/2010 11:04:00 AM
commenged:

d benefits to ] Should we mention how monthly
mainterfance fees compare to those for
similarfcommunities?

include:

ratio home, or iuxurjlr home ]ivinél];(n.

Figure 16-11
Viewing a comment.

Adding Comments

Unlike when you make changes using Track
Changes, when you want to add a comment, you
need to use a command to do so, as follows:

1. Select the text about which you want to
make the comment. While you can select any
amount of text, your comment will be more
effective if you target it to a specific, limited
portion of text, such as a sentence or phrase.
Writers often find it easier to implement spe-
cific suggestions rather than generic ones.

2. Choose Review > Comments > New Comment.
The insertion point is moved to a new com-
ment balloon. If you are not displaying bal-
loons, the Reviewing Pane opens, and the inser-
tion point moves to a new comment there.

3. Type your comment text. You also can format
text within the comment, insert line breaks
and new paragraphs, and so on, as needed, to
make the comment clear and complete.

4. Click in the document, outside the comment,

to finish the comment. Close the Reviewing
Pane, if desired.

Tip

New comments will appear even if Track
Changes is not enabled. You can use the
features together or separately.
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Reviewing Comments

When you've received a commented document
back from your readers and reviewers, the next
step is to take a look at what they had to say and
consider how to use that feedback in the finished
document. Or if you're a reviewer, you can go back
through the comments you've made and change or
expand on them as needed to finish your commen-
tary for the document'’s author. The Comments
group on the Review tab includes Next and
Previous buttons that you can use to navigate
between the comments.

While you can jump around and work with com-
ments using those buttons in any way you please,
here’s how to start the review from the top:

1. Choose View > Document Views > Print
Layout. You also could change to Web Layout
view if you're creating content for a Web page.

2. Press Ctrl+Home to move the insertion point
to the beginning of the document.

3. Choose Review > Comments > Next. Word
selects the first comment in the document in
the Markup Area. As shown in Figure 16-12,
the balloon outline for the selected comment
changes to bold. The insertion point also
moves within the comment.

4. Edit the comment if desired or click in the

document and make edits according to the
comment's recommendations.
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Figure 16-12
Moving between comments.

5. Choose Review > Comments > Next and
Review > Comments > Previous as needed to
navigate to other comments in the docu-
ment and work with them.

6. Click in the document, outside the current
comment, to finish working with comments.

You also can work with comments in Draft view.
When you use Review > Comments > Next to
select the first comment, Word opens the
Reviewing Pane, scrolls to the comment, and places
the insertion point in it, as shown in Figure 16-13.
You can click in the document to make changes
and view other comments in the Reviewing Pane,
jumping back and forth as needed. When you fin-
ish, you can click the Reviewing Pane’s Close (X)
button to close it.
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Summary: 14 revisions o oAX
Insertions: 5 Deletions: 4 Moves: 2
Formatting: 1 Comments: 2
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[ Moved up [1] Mark |

e Short term rental units
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Comment [LK1 Linda
ould we mention how monthly
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[c t [LK2] Linda |

Should the letter perhaps be closed
and signed by the entire team?

ol

Figure 16-13
Comment in the Reviewing Pane.

Tip

If you've previously used Review >
Tracking > Show Markup to hide all com-
ments or comments by one or more
reviewers, make sure you redisplay those
comments so that you can review or
delete them as needed.

Deleting Comments

A finalized document need not include comments
made by reviewers, unless you want those com-

ments to be available for reference or clarification
in situations where references like footnotes and
endnotes would be too formal. You can use one of
three methods to delete comments:

» In any view, right-click the text that's been
commented on and click Delete Comment,
as shown in Figure 16-14.

» Choose Review > Comments > Next or
Review > Comments > Previous to select
the comment to delete, and then choose
Review > Comments > Delete.

» Choose Review > Comments > Delete arrow
> Delete All Comments in Document. This
deletes all the comments in the document.
Use Delete All Comments Shown, instead, if
some of the comments are hidden.

Right-click commented text

_ﬁ dit Comment
Delete Comme&

ageofourfil A [ font..
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Figure 16-14
Deleting a comment.
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Comparing Documents

OST USERS BECOME comfortable
M with the Track Changes and Comments

features within a work session or two. But
that doesn’t mean all reviewers will want to use
those features or provide edited documents with
their changes conveniently marked. Should you
have flashbacks to your pre-Track Changes days
if you receive a version of your document that has
been edited but not marked up or marked up in
separate copies of the file? Not at all. You can com-
pare documents to sort through all the changes
and combine them in a single finished product.

Word actually offers two methods for comparing
documents. Using the first method, Compare,
works best when you want to see the differences
between an original document and a copy that's
been edited by another person. This method is
considered a legal blackline markup, but it effec-
tively marks up a document just as the Track
Changes feature does.

Follow these steps to compare an original docu-
ment with an edited version:

1. Choose Review > Compare > Compare >
Compare. The Compare Documents dialog
box opens.

2. Use the Open buttons to browse and select
an Original Document and Revised
Document, as shown in Figure 16-15. If
you've opened either document recently, it
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may appear in the applicable drop-down list,
in which case, you won't need to use the cor-
responding Open button.

Click for more settings Open buttons

N

N

Label changes with | Janet

[ox J[ cma ]

Figure 16-15
Comparing documents.

3. (Optional) If you want to use an alternate

name to identify the marked up changes,
enter it in the Label Changes With text box
under the Revised Document list. The name
that appears initially is the user name of the
person who edited and saved the file.

. (Optional) To control which items Word

marks up, click the More button and adjust
the choices under Comparison Settings and
Show Changes, accordingly.

. Click OK. The Compare results appear

onscreen, as shown in Figure 16-16. Note that
by default, Word creates a new file named
Compare Result X, and shows it with the
marked up changes in the center pane. The
Reviewing Pane appears at left with details
about the changes. The panes at the right
show the original and revised documents.
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Figure 16-16
The completed comparison.

6. You can edit and save the Compare Result X
file and manipulate panes as needed.

Managing the Source Document
Display

After you've run the comparison, the Review
> Compare > Compare > Show Source
Documents choice becomes active. Use its
submenu choices to determine whether
either, both, or none of the source docu-
ments appears onscreen.

When you have numerous edited versions of a doc-
ument, combining them ensures all the changes
are reflected in a single document. Word's
Combine process is nearly identical to the process
for comparing documents. Follow the preceding
steps, using the Review > Compare > Compare >
Combine command instead. The Combine
Documents dialog box looks and works identically

to the Compare Documents dialog box shown in
Figure 16-15. The compiled results also look simi-
lar to those for a Compare process, as shown in
Figure 16-17. The key differences are that the
Reviewing Pane and combined document show the
changes by both reviewers (identified by the user
names that were active in their copy of Word when
they edited and changed the file), and the initial
name for the combined file appears as Combine
Result X. Just as for the Compare process, you can
work with the combined results, saving the file and
managing the onscreen panes as needed.
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Figure 16-17
The combined files.

Comparing More Reviewers

Combine and save the documents from the
first two reviewers, and then combine that
document with another document to add the
changes by a third reviewer.
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Customizing

Word

ICTURE YOURSELF AT THE CONTROLS of a Boeing 767 aircraft.
The dashboard and console feature an overwhelming array of gauges,
buttons, knobs, and levers, each with a very particular purpose in
controlling how the plane operates. Used properly together, the controls
enable you to achieve the feat of getting a monster plane off the ground
and into the air.

Like a 767, Word offers dozens of settings and features that enable you to
control its operation. Taking the time to set Word up to work the way you
want it to can make you more efficient, so you can concentrate on your
document'’s content rather than fumbling with commands. This chapter
shows you the key ways in which you may want to customize Word.



Creating and Using Templates

scratch, you generally start with a recipe. The

recipe ensures that you add the right ingredi-
ents in the right proportions at the correct point in
the process, and that you cook the dish as needed.
The recipe enables you to get a consistent result
whenever you want to cook the dish again.
Cooking without a recipe can lead to bad-tasting,
overcooked, or undercooked food.

EVEN WHEN YOU COOK a dish from

For a document that you need to create over and
over—such as a newsletter or memo—a template can
work like a recipe, prompting you to put the right
information in the right place. A template file uses
a special format (with a .dotx file name extension)
so that it can become the basis for a new Word doc-
ument. The template can supply not only format-
ting for the document, but also suggested contents
and images. For example, Figure 17-1 shows a
newsletter document with placeholder information
that is set up to be saved as a template.
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A template saves you time because it guides you in
supplying the content for the document and has the
formatting predefined. Using the template enhances
your professionalism because it helps you create
consistent-looking documents with reduced effort.
For example, creating the example newsletter from
scratch each month would be a time-consuming
operation, and unless you could accurately remem-
ber all of the formatting you used, it wouldn't look
the same from month to month.

Great

Gardening

Story 1 Title
ey 11e3t S0ty L bext, S1ony L e, 3oy L1t Sty 1
feat. Story L bext 53y bext Shory L tend Story 1 fext
"Story 1 text. Story 1 ext Story L text. Stoy Ltext.

Story L 1ext StonL st Stony 1 lext Stery 1 bext Story 1 best,
‘Story 116w, Sory 1 1ewd, Stony 1 fext. Story 2 bext. Story 4 best.
Story 416t Stoy 1 text

‘Story 416wk, Stary 1 lexd, Stoy L fext. Slory 1 bext. Story 4 bext,
Story Liest.

Figure 17-1
Newsletter with placeholder content.

Tip

To save time, you can also modify an exist-
ing template that's installed with Word or
that you download from Office.com.



Customizing Word [E&iETio@V]

Saving Your Template

To create a template, first create a document, add
all the placeholder or suggested content that you
want to include, and apply the formatting you
want. (For example, Figure 17-1 shows that the
newsletter is formatted with two columns.) Then
follow these steps to save the file as a template:

1. Choose File > Save As. The Save As dialog
box appears.

2. Type or edit the name you want to apply to
the template in the File Name text box.

3. Choose Word Template from the Save As
Type drop-down list.

4. Navigate to the C:\Users\User Name\
AppData\Roaming\Microsoft\Templates
folder in the Save As dialog box. Saving to
this location may make it easier to find and
use the template, as you'll learn later. Figure
17-2 shows the Save As dialog box.

5. Click Save. Word Saves the template file.

6. Choose File > Close to close the file.

Smarter Templates

If you get more advanced with your use of
Word, you can display the Developer tab on
the Ribbon and use it to set up automated
controls that will help the user update place-
holders with real content even more quickly.

File type Folder Name
(W] Save &3 !
&)= ke Microsat » Templates » ~ [ | [ fcorch
Organize » | New folder
= Documents * Mame
s :‘”i( Document Themes
E \I:::’ LiveCantent
| Senartart Graphics
% Homegroup
% Computer
i Network
& RICKN
File name: | Great Gardening Template -
Save as type: | Word Ternplate

Authors: Lisa Tags: Add atag

Save Thumbnaid

S o+ e ]

Figure 17-2
Saving a template.

Using Your Template to Make a
New Document

Each time you use a template file, Word creates a
new document based on the template. So unless
you specifically open and edit the template, the
original template file remains intact no matter
how many documents you create from it.

Follow these steps to use a template you've saved
to create a new document:

1. Choose File > New. The Available Templates
list appears in the Backstage view.

2. Click My Templates, as shown in Figure
17-3. The New dialog box opens. It lists
any templates that you've saved in the
C:\Users\User Name\AppData\Roaming\
Microsoft\Templates folder.
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My Templates Select a template 3. Make sure that the Document option is
selected under Create New.

4. Click the template that you want to use.

5. Click OK. Word creates the new document.

6. Edit the document as needed, and then save it.

Figure 17-3
Creating a file from a template.

Determining Word Options

ORD OFFERS DOZENS of options for
Wcustomizing how it operates. I'm not Funny Tabs

going to bore you by listing and describ-
ing every one. The use of Word options probably Some writers call the categories at the left
follows something like the 80-20 rule. Eighty per- side of the Options dialog box “tabs.” They
cent or so of the time, you'll be working with the don’t look like tabs to me, but if you see that
same 20 percent or fewer of the options. This sec- term used, know that it means the categories
tion gives you an overview of where to find the var- at the left.
ious types of options and touches on the ones

you'll use most frequently.

General Options

The General category of options (shown in Figure
17-4) appears by default when you open the Word
Options dialog box. You can change your User

Name and Initials under Personalize Your Copy of

To work with Word Options, choose File > Options.
In the Word Options dialog box that appears, click
a category name in the list at the left to see that
category’s options.
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Microsoft Office. (You learned another way to make
this change in Chapter 16.) The top section, User
Interface Options, enables you to turn the Mini
Toolbar and Live Preview off or back on, as well as
change the Color Scheme and ScreenTip Style. You
can choose Don't Show ScreenTips from the
ScreenTip Style drop-down list to turn off
ScreenTips altogether.

you to control which individual marks appear.
Similarly, the Printing Options choices in the bot-
tom section enable to you print items that wouldn't
otherwise print, such as document properties or
hidden text.

T g General aptions for working weh Word N‘

Praceng Uses Intertace optioms.

sy 7] 5o L Tromar n peiectin
] Enabie Lve Preview

Cotor pinemes [ Saver[w]

SgrenTip e | Show festuse desriptont n Soeenen [

Personasive you cogy of Microsaft Office

D040 £mae sttathments i Eul Sooeen Reading st

L], Change how document content is displayed on the screen and when printed.

[— Page cnpiay optne

[ 4] Snow shvte spate Deteen Dages in Print Layost v
4] Snaw [ghsghon marks
] Show donument baeips oa haver

Abveaps e Brie foematting ks o the scieen

b chasactens -
iosces -
sdain Pacageapn garts 1
Higgdentet M
Optionsl hushen -
Obpect anghens &
St g ot sty

Prnting sptions
| Pried agiwings rested i Weed
Prort B ound dodrs dnd images
Pried @cument grapenies
Pried Rigden tegt
Update fieids Before prnting
Update bnted dals before prntng

Figure 17-4
Word's General options.

Tip

You can resize the Word Options dialog
box by dragging the side or bottom bor-
der, or lower-right corner.

Display Options

Click Display in the list at the left to open the
options shown in Figure 17-5. In the Page Display
Options section, enable or disable features like the
white space between pages for Print Layout view.
The middle section, Always Show These Formatting
Marks on the Screen, is the one you will probably
use most. You can select individual nonprinting
characters here to display them onscreen. Unlike
the Show/Hide button in the Paragraph group of
the Home tab, which turns all nonprinting charac-
ters on or off, the Display options settings enable

Figure 17-5
Word's Display options.

Proofing Options

The next category of options, Proofing, helps you
to modify how the spelling, grammar, and
AutoCorrect features work in Word. Figure 17-6
shows this category.

N — — — E— M__\
e ol
= W] Change haw Word cormects and formats yoer test
Bugtay
Praceng AusaComect optons
tae
Langusge
When (na1ectng g in Maioiof Offe progiams
-
] lgnare wieds in UPPERTASE
© v -
Qb Aazes +Tositar 7] sgnsce Intarmat and {5 sdererser

7| Miag pepented word

trtorcg scsanted upgarcast in Fremen
e~ Supoust hom maie cytionaey oely
[ Custom Dnctionaries_
Frenchmades | Tradtonal and mew spesings = |
Soaigmeder Taroveolomiony v
Wonen conertng Lping and grammas in Werd
7] Cneck 1peming v you type
7] Ust costetus speng
) Mark geagmar o 83 you e
4 ek grammar with spating

Snaw resdatgty st
wisting Stye: | Gramess Oty [=] [ Sepmgn
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[ =]
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Hige geimmar arrars i this dncument oty

Figure 17-6
Word’s Proofing options.
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The options under the second section (When
Correcting Spelling in Microsoft Office Programs)
enable you to set up the spelling check feature to
work faster and more effectively. For example,
make sure Ignore Internet and File Addresses is
checked to prevent the spelling check from stop-
ping on every Web page URL in a document. On
the other hand, if you want to start checking words
in all uppercase or that have numbers, clear the
Ignore Words in UPPERCASE and Ignore Words
That Contain Numbers check boxes.

The When Correcting Spelling and Grammar in
Word section enables you to control some auto-
mated aspects of checking spelling and grammar.
For example, if the squiggly lines that appear
under spelling and grammar errors as you type
bother you, clear the Check Spelling as You Type
and Mark Grammar Errors as You Type check
boxes. Use the Exceptions For section settings at
the bottom to hide those squiggly lines in the
current document only.

Click the AutoCorrect Options button at the top of
the Proofing category to open the AutoCorrect dia-
log box, shown in Figure 17-7. This dialog box has

five tabs of options you can use for automated cor-
rection, typing, and formatting features, as follows:

» AutoCorrect: You learned in Chapter 2
how Word automatically fixes many typos
that you make. The settings on this tab
enable you to control correction for specific
typos, such as having Word Capitalize First
Letter of Sentences if you fail to do so. You
also can add a new correction for your com-
mon typos by typing entries in the Replace
and With text boxes, and then clicking Add.

308

» Math AutoCorrect: Use this tab to learn

about and add shortcuts for inserting math-
ematical symbols. For example, you can
type \Delta to enter the delta symbol (A),
which may take less time than inserting the
symbol manually.

» AutoFormat As You Type: Use the choices

on this tab to control whether Word for-
mats specific characters for you, such as for-
matting fractions (changing 1/4 to 1/4) and
ordinals. You can also control formatting
list items, such as turning automatic num-
bered lists on and off.

» AutoFormat: This tab offers many of the

same settings as the AutoFormat As You
Type tab, but the choices here apply only
when you run the AutoFormat feature. You
need to add a button to the Quick Access
Toolbar or Ribbon to make this command
available. See the final two sections of this
chapter to learn how to customize the
Quick Access Toolbar or the Ribbon with
additional commands.

» Actions: Formerly called SmartTags, the

items checked here add settings to the
shortcut menu when you type certain kinds
of text in the document. For example, if
Telephone Number (XML) is checked on
this tab and you type a phone number into
a document, you can right-click a phone
number, point to the Additional Actions
choice at the bottom of the shortcut menu,
and choose or check for actions.
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AutoCorrect: English (U.S) ?

Autoformat | Actions [
1| mathAutocomect | AutoFormatAs YouType |

[V] show AutoCorrect Options buttons

[¥] Correct TWo Initial CApitals

|| Capitalize first letter of gentences

[¥] Capitalize first letter of table gelis

[¥] Capitalize names of days

Correct accidental usage of cAPS LOCK key

[¥] Replace text as you type
Replace: With: @ Plain text

Formatted text

[¥] Automatically use suggestions from the spelling checker

[ J[ conce

Figure 17-7
Finding AutoCorrect and other options.

Save Options

When you need to work with options for file man-
agement, click the Save category in the list at the
left side of the Word Options dialog box to display
the choices shown in Figure 17-8. The top section
in the dialog box, Save Documents, holds the set-
tings you're likely to use most:

P Save Files in This Format: Choose the
default format in which files will be saved.
It is handy to change the default format
when you often share documents with
users who don't have Word 2007. For exam-
ple, you can save in Word 97-2003
Document (*.doc) format by default. Or for
users who have another word processing
program, you can choose a format such as
Rich Text Format (*.rtf). (Some of the file
types will not preserve all the document
features you can apply in Word, such as cer-
tain types of formatting.)

» Save AutoRecover Information Every X
Minutes: The AutoSave feature saves a ver-
sion of all open files at the specified interval,
so you can recover your files if for some rea-
son Word shuts down or locks up when you
haven't saved your work. Use the spin arrows
or enter a value in the text box to specify how
often Word should save versions of your files.
Leaving Keep the Last Autosaved Version If |
Close Without Saving option checked ensures
that the most recent version will be made
available for you to recover.

Tip

Wond Opiom

Ganarat
kel customize how documents are saved
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ey Sawe files in this format: | Weed Dedumest [ 8000 =
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Figure 17-8
Word's Save options.

Choose File > Info and look under
Versions to view the file versions
AutoRecover has created. From there, you
can click a version or choose Manage
Versions > Recover Unsaved Documents
to recover your work.

P> AutoRecover File Location: Specify where
you would like for the AutoRecover versions
of your files to be stored. For example,
changing to a network location can make
sure you have other versions available in
the event of a hard disk failure.
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» Default File Location: If you'd like Word
to suggest another save location by default
the first time you save a file, choose the
folder you want here.

The middle section of settings (Offline Editing
Options for Document Management Server Files)
only applies if you are working with SharePoint. At
the bottom, the Embed Fonts in the File choice is
important to check when you will be sharing files
with other users who may need to heavily edit and
reformat the document, or if you're sending the
document to a commercial printer or print service
within your organization. Embedding the fonts
ensures the document will retain its formatting
and print and look exactly as you'd expect. If the
fonts aren’t embedded and the computer where
another user is editing or printing the file doesn't
have all the document fonts, Word and Windows
could substitute an alternate font and change the
look of the document.

Scroll down to see more

Cetrut parsgrach e Narmal =
7] Show dutoCompiets 1upgertisns

G, copy, and paste

Fasting wishin the 1ame Soosment Kees Sourt Foemating Detoun [~ |

Fasting petween doiuments Koo Sourt Foemating Detam [~ |

Fastng fram sther grogeamt Keeg Sourte Foematnng Dt [~ |
Psenpate pHtuses 1 1n e witn e [ =]

[

Parlez-Vous Francais?

Use the Language category options to add
and choose alternate languages for editing,
display, and Help.

Advanced Options

The last category of options, Advanced, holds a
mother lode of choices organized in 11 sections. As
shown in Figure 17-9, you can scroll up and down
to navigate to the option you need.
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Figure 17-9
Advanced Word options.

Here's a look at the types of options available in
this category:

» Editing Options: Here you can find options
for turning a number of editing features on
and off, such as Allow Text to Be Dragged
and Dropped and Enable Click and Type.

» Cut, Copy, and Paste: Many of the settings
here deal with how formatting behaves by
default when you move or copy text. You
also can control display of the Paste Options
buttons here and use the Settings button to
changes settings for the Smart Cut and
Paste feature.

» Image Size and Quality: Here you can
choose whether settings apply to the cur-
rent document or All New Documents.
From there, choose whether to Discard
Editing Data or Compress Images, and to set
a default resolution (target output) for
images when printing.
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» Show Document Content: These settings
toggle the display of certain document fea-
tures, such as picture placeholders (in place
of the image itself), bookmark and field
codes, crop marks, and the like. Turning these
settings on and off can affect how quickly
Word performs or can make it easier to iden-
tify document features that you need to edit.
If you're working with a document you
received from another user and there are font
issues, you can use the Font Substitution but-
ton to choose substitute fonts.

P Display: If the options in the overall dis-
play category aren't sufficient for your
needs, you can use the options in this sec-
tion to further fine-tune how Word looks.
You can control the number of recent docu-
ments that appears when you choose File >
Recent, control scroll bar display, control
measurement units (for example, use
Inches or Points), and more.

P Print: This section offers several options for
adjusting printing defaults. For example,
you can choose to enable Use Draft Quality
and Print Field Codes Instead of Their
Values, as well as settings for duplex print-
ing and document scaling.

» When Printing This Document: These set-

tings also can apply to the current docu-
ment or All New Documents. You can
enable Print PostScript Over Text to have

PostScript information from PostScript
fields in a document converted from Word
for the Mac format print above text or Print
Only the Data From a Form to print on pre-
printed form paper.

P Save: These settings supplement those in

the Save category. Allow Background Saves

is enabled by default. You also can enable
Always Create Backup Copy for an additional
means of protecting your data via creating
.bak files, as well as saving settings pertaining
to the Normal template and synchronizing
remotely stored files.

» Preserve Fidelity When Sharing This

Document: The settings here, when
enabled, help form and linguistic data save
more accurately when a file will be shared
or reused.

» General: You can change settings for

sounds and settings for opening files here,
as well as entering a mailing address and
using the File Locations and Web Options
buttons to display even more detailed
default settings for storing files and using
Word with your Web browser.

» Compatibility Options For: Enables you to

set up the displayed layout of the current
document or All New Documents to emu-
late a prior Word version or another word
processing program.
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Adding to the Quick Access Toolbar

default features three of the commands used

most often by Word users: Save, Undo, and
Repeat (redo). However, you're not just any Word
user. You have your own needs, preferences, and
quirks, and so you may work more effectively when
your most used commands are a click away on the
Quick Access Toolbar. You can add a button for any
of the available commands in Word—including
those not offered on the Ribbon—to the Quick
Access Toolbar at any time.

THE Quick AccEess TOOLBAR by

Click the Customize Quick Access Toolbar button
(the down arrow at the right end of the toolbar) to
open the menu shown in Figure 17-10. Click any of
the choices above the divider line to toggle its dis-
play on or off on the Quick Access Toolbar. The
checked items are the ones that currently appear
on the toolbar.

Moving the QAT

The Show Below the Ribbon command on
the Customize Quick Access Toolbar menu
moves the toolbar so that you can reach it
more easily by mouse.
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Click to open menu

Home | Customize Quick Access Toolbar

New

Calil
Open

Paste

J. B | /| Save
Clipboard = E-mail
Quick Print
Print Preview and Print
Spelling & Grammar
v | Undo
v | Redo
Draw Table

Open Recent File

More Commands...

Show Below the Ribbon

Figure 17-10
Customizing the Quick Access Toolbar.

If the command that you want to add doesn’t
appear directly on the menu, follow these steps to
add it to the Quick Access Toolbar:

1. Click the Customize Quick Access Toolbar
button, and then click More Commands near
the bottom of the menu. The Word Options
dialog box opens with the Quick Access
Toolbar settings displayed.
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Click command in this list

2. Open the Choose Commands From drop-down

list above the left-hand list of commands, and
then click the location that likely has the com-
mand you want to add. For example, you can
choose one of the Ribbon tabs, choose
Commands Not in the Ribbon, or choose All
Commands as shown in Figure 17-11.

Added command
\ Select command location  Click to add /

Comomizamons: | Agset =

. Click the Add button between the two lists.

The command moves over to the list at the
right, which represents the list of commands
currently on the Quick Access Toolbar, as
illustrated in Figure 17-11.

. Repeat Steps 2—4 as needed to add other

commands to the right-hand list.

. To change a command'’s position in the right-

hand list, click the command and click either
the Move Up or Move Down buttons (arrow
buttons) at the right side of the list.

. Click OK. Word displays the new command(s)

on the Quick Access Toolbar.

Figure 17-11
Finding and adding commands.

. Scroll the left list of commands, and click the
command you want to add to the Quick
Access Toolbar.

More QAT Tricks

Use the Customize Quick Access Toolbar
drop-down list above the right-hand list to
control whether the QAT changes apply to
the current document or all documents. You
also can use the Reset button near the bot-
tom to undo your customizations.
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Customizing the Ribbon

ORD 2007 D]D NOT OF FER the Type name New tab Cllck to rename
Wability to customize the Ribbon, but \ ,
Word 2010 does. Customizing the Ribbon ch': °:"": et 5]

rather than the Quick Access Toolbar offers greater
flexibility because you can add more commands,
and you can organize them by function on tabs. In
fact, customizing the Ribbon requires first adding
at least one new tab, and then designating the
commands that you want to appear on that tab.

[Main\Tabs
@l

Some of the steps for creating a new Ribbon tab
and adding commands resemble the steps for cus-
tomizing the Quick Access Toolbar. Here are the
specific steps for updating your Ribbon:

1. Right-click any Ribbon tab and click Rename \ 2
Customize the Ribbon. Alternately, you can T e
choose File > Options and then click Co Lo E
Customize Ribbon. Either way, the Word :
Options dialog box displays choices for cus- ]
tomizing the Ribbon, which resemble those .l e e e J.
for customizing the Quick Access Toolbar. R '@ ~

2. Click the New Tab button below the Main eowbpen 7).
Tabs list at the right. The new tab appears Figure 17-12
immediately with a generic name, New Tab Naming the new tab.

(Custom) and a generically named group,

New Group (Custom).
P ) 4. Repeat the process in Step 3 to rename the

3. Click the new group, and click the Rename group for the new tab.

button below the list. Type a name in the
Rename dialog box that appears (as shown in
Figure 17-12), and then click OK.

5. Open the Choose Commands From drop-
down list above the left-hand list of com-
mands, and then click the location that likely
has the command you want to add. For
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example, you can choose one of the Ribbon
tabs, choose Commands Not in the Ribbon,
or choose All Commands.

6. Scroll the left list of commands, and click the
command you want to add to the Quick
Access Toolbar.

7. Make sure that the new group is selected in
the right-hand list, and then click the Add
button between the two lists. The command
moves over to the list at the right, under the
group name.

Tip

The first three commands that you add to
a group will display the largest buttons.

8. Repeat Steps 5-7 as needed to add other
commands to the group in the right-hand
list. You also can drag and drop commands
between the two lists.

9. To change a command’s position in the
group in the right-hand list, click the com-
mand and click either the Move Up or Move
Down buttons (arrow buttons) at the right
side of the list. Figure 17-13 shows some
commands added to a new tab and group.

Home  Gnzet  Fage Layout

E [ 0 Fromn of Test

L Crop to Shage =

New group

Qubth Aacess Toslbar
e

B

= Mosheg

8 7 invert o Post)
v o neatan | [ tewsioss | [ Renage |
. tumemizanons: A |

tepesara shessats | Cuspomise.. S

|oem || conca

Figure 17-13
Commands in new group.

10. Click OK. Word creates the new tab and
group. As shown in the example custom
Ribbon tab in Figure 17-14, Word arranges
and sizes the items within the group for you.

Tip

Click the Developer check box in the Main
Tabs list at right to display and hide the
Developer tab, a special-purpose tab for
working with document controls and
macros.

Tab name

Group name

Figure 17-14

Using a custom Ribbon tab.
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Excel charts, 284-285

files, 13—, 13-20

Font dialog box, 51-52
formatting attributes, 47-48
Go To command, 26-27

A numbering, 83-85
manual page breaks, 78
numbering, 90-91
pictures, 230-235
POSTNET bar codes, 183

Access
adding hyperlinks, 286-287
CSV (comma-separated value) documents,

169
access, QAT (Quick Access Toolbar), 5, PowerPoAmt presentations, 285-286 k'eyboards, 26
312-313 QAT (Quick Access Toolbar), 312-313 lists, 64-65

Quick Parts, 88
rows, 206
screen shots, 240-241

master document outlines, 155-163
Mini Toolbar, 50-51
Navigation pane, 121

Actions, 308
Add Assistant feature, 251
adding

Address Blocks, 173-174
artistic effects, 232
assistants, 251
automatic dates, 282
automatic fields, 280-283
bibliographies, 140
borders, 127-128
borders to paragraphs, 54-55
breaks in columns, 201-202
building blocks, 278
captions, 134
citations, 137, 138
clip art, 236-237
colors

to diagrams, 254

to text, 48—49
columns, 190-192, 195
commands, 313
comments, 297
elements, 123
envelopes, 183
Excel charts, 285
fields, 170

code, 281-282

Mail Merge, 173-175
footers, 86-91
headers, 86-91
hyperlinks, 275-276, 286-287
individual fields, 174-175
lines

between columns, 200-201
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section breaks, 80
shading, 56
shapes to diagrams, 250-252
subdocuments, 159-160
symbols, 32-33
tables
to documents, 225-227
table of authorities, 141-142
table of figures, 135-136
text, 27-28, 50, 249
Word files, 283-284
words to dictionaries, 260
Address Blocks, adding, 173-174
addresses
copying, 180
mailing, 181
adjustments to pictures, 231-232. See also
modifying
Advanced Word options, 310-311
aligning
formatting vertical alignment, 79
objects, 244
options, 245
text, 53-54
allowing typing, 113
applications, Office, 283-287
applying
automatic numbering, 282—283
Click and Type feature, 24-25
columns, 193
elements, 9-10

Office applications, 283-287
outlines, 147-165
pages, 124-128
Picture Tools, 231-235
predefined equations, 34
Quick Styles, 67-69
scroll bars, 25
section breaks, 79-80
shapes, 237-239
styles, 67-75
to pictures, 233-234

Styles task pane, 69-70
subdocuments, 156—-163
tables, 205
tabs, 58-61
Tabs dialog box, 60-61
themes, 66—67

areas
noncontiguous, selecting, 30
selecting tables, 217-218

Artistic Effects button, 232

assigning passwords to documents,

100-101
assistants, adding, 251
attachments

opening, 112

sending, 105
attributes

formatting, 47-48

selecting text, 46-53

authors, viewing Track Changes, 293
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AutoCorrect, 308

navigating, 30-32
AutoFormat, 308
automatic borders, 55
automatic fields, 280-283
automatic numbering, applying, 282-283
automatic settings, disabling, 65
automatic Table of Contents (TOC), 131-133
AutoNum field code, 282
Available Templates window, 15

B

backgrounds
deleting, 231
pages, 127
Backspace key, 28
Backstage view, navigating, 11-12
backups of documents, creating, 94
balancing white space, 77. See also layouts
balloons, showing revisions in, 294
bar codes, POSTNET, 183
bar tab, 58
bibliographies, formatting, 136-140
body text, creating outlines, 149-150
bookmarks, creating, 274-275
borders
adding, 127-128
automatic, 55
formatting, 79
paragraphs, 54-55
Borders and Shading dialog box, 127
branches, 249
breaks
columns
adding, 201-202
deleting, 201-202
formatting pages, 78
sections
applying, 79-80
columns, 191

building blocks, generating text with,
276-279

bulleted lists, 64-65
buttons
Artistic Effects, 232
Cancel,
Change Picture, 232
Close, 113
Colors, 232

Compress Pictures, 232
Corrections, 232
Customize Columns, 170
New Label, 133

Open, 17

Paste Options, 39
Repeat, 42

Reset Picture, 232
Shapes, 8

Tab, 58-61

Underline, 48

Undo, 42-43

Zoom, 117

Cc

calculations. See also formulas
creating, 223
viewing, 224
Cancel button, 7
Caption Numbering dialog box, 134
captions, adding, 134
case sensitivity, modifying text, 32
cells
formatting, 220
tables, 207. See also tables
entering text, 208
merging, 218-219
splitting, 219
centering text, 54
center tabs, 58
Change Picture button, 232
changes. See modifying; tracking changes
characters
deleting, 28
formatting, 152
hiding, 78
special, 269
charts. See also diagrams
Excel, 284-285
modifying, 285
organization, 250
checking spelling and grammar, 260-261
citations
adding, 137, 138
marking legal, 141
Click and Type feature, applying, 24-25
clip art, adding, 236-237
Clipboard, 39
clipping, screens, 241

Close button, 113
closing documents, 4
code, adding to fields, 281-282
collaboration, 288-301
comments, 297-299
comparing documents, 300-301
tracking changes, 290-291
modifying options, 292-293
modifying user names, 293-294
reviewing, 296
viewing, 294-296
turning on Track Changes, 291-292
collapsing subdocuments, 160-161
colors
adding
to diagrams, 254
text, 48—49
modifying pages, 126-127
themes, 66
Colors button, 232
columns, 189
adding, 190-192, 195
between lines, 200-201
applying, 193
breaks
adding, 201-202
deleting, 201-202
customizing, 194-195
deleting, 202-203
formatting, 79
headings, 202
modifying
spacing, 197-199
width, 214-215
newspaper-style, 190
section breaks, 191
sizing, 196-197
typing in, 193
combining files, 301
commands
adding, 313
Find, 265-266
finding, 313
Go To, 2627
grouping, 315
Replace, 269-271
Replace All, 271
Save
selecting with keyboards, 10
comma-separated value (CSV), 169
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comments
adding, 297
collaboration, 297-299
deleting, 299
navigating, 298-299
reviewing, 298-299
comparing documents, 120, 300-301
Compatibility Mode, 17
Compress Pictures button, 232

configuring options, 31. See also formatting;

options

Continuous section break, 79
controls, viewing, 9
converting

files, 18

notes, 130

tables, 209-210
Convert Text to Table dialog box, 210
copying

addresses, 180

between documents, 40

formatting, 62-63

notes, 130

text, 37—-42
correcting errors, 260-263
Corrections button, 232
cover pages, formatting, 124-125
creating. See formatting
cropping pictures, 234-235
cross references, generating, 142-143
CSV (comma-separated value), 169

Customize Address List dialog box, 170

Customize Columns button, 170
Customize Status Bar menu, 8
customizing

AutoCorrect, 31

building blocks, 278-279

columns, 194-195

dialog boxes, 7

fields, 171

footers, 90

headers, 90

QAT (Quick Access Toolbar), 312-313

Ribbon, 6, 314-315

status bars, 8

styles, 70-71

templates, 304-306

watermarks, 125-126
cutting text without formatting, 38
Cycle diagram type, 248
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D

databases

adding hyperlinks, 286-287

CSV (comma-separated value) documents,
169

data for Mail Merge, specifying, 169-172
dates, placeholders, 124

decimal tab, 58

default fonts, modifying, 52

deleting

automatic page breaks, 78
backgrounds, 231

breaks in columns, 201-202
columns, 202-203
comments, 299

diagrams, 248

equations, 34

existing text, 28

fields, 171

files, 20

formatting, 52

highlighting, 49

objects, 242

pictures, 230

rows, 206

styles, 72-73
subdocuments, 163

tables in unwanted areas, 213
tabs, 60

demoting

body text, 150
headings, 153
organization charts, 250

design

equations, 35
selecting cover pages, 125
tables, 220-221

diagrams

adding
colors, 254
shapes, 250-252
text, 249
deleting, 248
modifying styles, 253
types of, 247

dialog boxes

Borders and Shading, 127
Caption, 134
Caption Numbering, 134

Columns, 191

Convert Text to Table, 210

Customize Address List, 170

Envelopes and Labels, 180

Field, 283

Find and Replace, 26

Font, 51-52

Format Paragraph, 56

Formatting Restrictions, 96

Formula, 223

General Options, 100

Insert Hyperlink, 275-276

Insert Picture, 230

Manage Styles, 72

New Address List, 170

Object, 225, 284

Open, 17

opening, 7

Paragraph, 7

Paste Special, 38

Save As, 15

Select Data Source, 169

Tabs, 60-61

Word Options, 30, 307

Zoom, 117
Dialog Box Launcher, 7
dictionaries, adding words, 260
dimensions, modifying tables, 215-216
disabling

automatic settings, 65

editing by making documents as final, 98

Display options, 307
dividing cells in multiple cells, 219
Document Inspector, 94-96
documents
adding
envelopes, 183
Quick Parts, 88
table of authorities, 141-142
tables, 225-227
assigning passwords, 100-101
backups, 94
closing, 4
columns, 190-192. See also columns
comparing, 120, 300-301
creating, 23
editing, 27-36
e-mail, 104-105
finding text, 265
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formatting
bibliographies, 136-140
endnotes, 129-130
footnotes, 129-130
paragraphs, 53-62
restricting changes, 96-97
form letters, creating, 168
generating cross references, 142-143
indexing content, 142-145
layouts, 77. See also layouts
marking as final, 98-99
master, 155-163
merge, 168
metadata, 94-96
navigating, 24-27
Navigation pane, 121
opening, 4
orientation
modifying, 82
selecting, 82
placing properties, 280-281
previewing, 20-21
printing, 104
print security, 94-102
Protected View, 101-102
screen, 10
Table of Contents (TOC), 131-133
table of figures, 135-136
templates, 305-306. See also templates
viewing, 110-116
statistics, 263
views, 109. See also views
Zoom feature, 116-118
Draft view, 115-116
dragging text, 40. See also moving
drawing shapes, 238
drop caps, 192
duplicating text, 39. See also copying

E
editing
citations, 138
documents, 27-36
form letters, 176
proofing options, 307-309
Track Changes user information, 293
tracking changes. See tracking changes

effects
pictures, 233
shapes, 239
text, 50
electronic postage services, 182
elements
adding, 123
applying, 9-10
e-mail

documents, 104-105

formatting hyperlinks, 276

form letters, 177
encryption, 100. See also passwords; security
endnotes, formatting, 79, 129-130
Enhanced ScreenTip, 6
entering

Find and Replace text, 270

passwords, 101

text into columns, 193

text into tables, 208
envelopes, 179

adding, 183

formatting, 180-183

generating single, 180-184
Envelopes and Labels dialog box, 180
equations. See also symbols

deleting, 34

formatting, 33-36

saving, 36
Equations Tools > Design tab, 35
errors, correcting, 260-263
Even Page section break, 79
Excel

charts, 284-285

CSV (comma-separated value) documents,
169

exporting tables, 225-227
existing files, opening, 16-17
existing text, 28. See also text
expanding subdocuments, 160-161
exporting Excel tables, 225-227
extending search options, 266-267

F

Field dialog box, 283
fields
adding, 170
code, 281-282
Mail Merge, 173-175

automatic, 280-283

customizing, 171

merge, 168

previewing, 175-177
figures

captions, 133-134

table of, 135-136
File Information window, 11
files

adding Word, 283-284

applying, 13-20

assigning passwords, 100-101

combining, 301

converting, 18

creating, 15

deleting, 20

locations, 157

naming, 14, 15

opening existing, 16—17

options, 99

previewing, 20-21

renaming, 18-19

saving, 13-15

types, 14
file tabs, 5
Find and Replace dialog box, 26
Find command, 265-266
finding

bookmarks, 275

commands, 313

formatted text, 267-269

special characters, 269
first lines, indenting, 57
flipping objects, 244
folders, 13—15. See also files
Font dialog box, applying, 51-52
fonts. See also text

columns, 196-197

modifying defaults, 52

selecting, 46—47

sizing, 47
footers
adding, 86-91

customizing, 90

formatting, 79

modifying, 89

styles, 86
footnotes, formatting, 79, 129-130
forcing column width, 214
Format Painter function, 63
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Format Paragraph dialog box, 56
formatting
applying attributes, 47-48
bibliographies, 136-140
bookmarks, 274-275
borders, 79
cells, 220
characters, 152
charts in Excel, 284
citations, 137
columns, 79, 190-192
copying, 62-63
cover pages, 124-125
deleting, 52
documents, 23
editing, 27-36
navigating, 24-27
restricting changes, 96-97
drop caps, 192
endnotes, 79, 129-130
envelopes, 180-183
equations, 33-36
figure captions, 133-134
files, 15
footers, 79
footnotes, 79, 129-130
form letters, 168
generating cross references, 142-143
groups, 315
headers, 79
indexing content, 142—145
labels, 185-186
layouts, 77. See also layouts
margins, 79, 81-82
multilevel lists, 164—165
multiple columns, 194
numbering, 79
options, 31, 79
page breaks, 78
paper
orientation, 79
size, 79, 82-83
sources, 79
paragraphs, 53-62
Picture Tools, 231-235
Quick Styles, 67-69
Quick Tables, 211-212
Reveal Formatting, 74-75
shortcuts, 48
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SmartArt, 248

standard outlines, 148-155

subdocuments, 157-159

tables
of authorities, 141-142
creating formulas, 222-224
Table of Contents (TOC), 131-133
table of figures, 135-136
tables, 206—-207

text
finding, 267-269
outlines, 149-150

vertical alignment, 79

viewing outlines, 150-153

Formatting Restrictions dialog box, 96
form letters

creating, 167

fields
adding, 173-175
previewing, 175177
main documents, 168
printing, 177
selecting recipients, 172

specifying data for Mail Merge,
169-172

formulas, creating tables, 222-224
Full Screen Reading view, 111-113
functions. See also commands
Format Painter, 63
selecting, 225

G

galleries, 8, 277

General options, 306-307
General Options dialog box, 100
generating

automatic Table of Contents (TOC),
131-133

bar codes, 184

bibliographies, 139-140

cross references, 142-143

headings, 148-149

single envelopes, 180-184

text with building blocks, 276-279
Go To command, applying, 26-27
grammar

checking, 260-261

running Spelling and Grammar check,
261-262

graphics, 229
adding
clip art, 236-237
screen shots, 240-241
applying shapes, 237-239
managing objects, 241-247
slideshows, adding, 285-286
SmartArt objects, 247-255
greeting lines, selecting, 174
grids, tables, 206. See also tables
groups, 6
commands, 315
objects, 246-247

H
hanging option, 57
Header & Footer Tools, 87
headers
adding, 86-91
customizing, 90
formatting, 79
modifying, 89
styles, 86
viewing, 89
headings
columns, 202
demoting, 153
generating outlines, 148-149
promoting, 153
subdocuments, 159
hiding characters, 78
Hierarchy diagram type, 248
hierarchy levels, SmartArt, 249-250
highlighting
deleting, 49
text, 28-30, 49
hyperlinks
adding to Access databases, 286—287
specifying, 275-276

|

images, 229. See also graphics
figure captions, 133-134
viewing, 110

importing tables, 225-227

indenting text, 56-58

indexing content, 142-145
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individual fields, adding, 174-175
Insert Hyperlink dialog box, 275-276
inserting. See adding

insertion points, 9

Insert Picture dialog box, 230
inspecting documents, 94-96

J

jumping to screens, 112
justifying text, 54. See also aligning

K

keyboards

applying, 26

selecting commands with, 10
keys, Backspace, 28

L

labels, 179
formatting, 185-186
New Label button, 133
layouts
managing, 77, 81-85
applying section breaks, 79-80
creating page breaks, 78
Print Layout view, 110
SmartArt, 252
tables, 212-219
Web Layout view, 114
left tab, 58
legal citations, marking, 141
letters, form, 167-177. See also documents;
pages
levels, moving, 154-155
lines
columns, 200-201
modifying spacing, 61
numbering, 79, 83-85
links. See hyperlinks
List diagram type, 247
lists
applying, 64-65
converting tables, 209
formatting multilevel, 164-165
Show Markup, 294
Live Preview, 20-21, 206

locations
bookmarks, 275
files, 157
locations, saving files, 14

M

mailing addresses, 181
Mail Merge

creating form letters, 167-177. See
also form letters

fields
adding, 173-175
previewing, 175-177
specifying data for, 169-172
main documents, creating form letters, 168
Manage Styles dialog box, 72
managing
layouts, 77, 81-85
applying section breaks, 79-80
creating page breaks, 78
objects, 241-247
outlines, 152-155
sources, 139
styles, 70-71
subdocuments, 161-162
manual page breaks, adding, 78
manual tabs, 60. See also tabs
margins
formatting, 79, 81-82
indenting, 56-58
views, 113
marking
documents as final, 98-99
index items, 144
legal citations, 141
markup, printing, 296

master documents, applying to outlines,
155-163

Math AutoCorrect, 308
mathematical operators, 222
mathematics, formatting equations,
33-36

Matrix diagram type, 248
menus

Customize Status Bar, 8

View Options, 113
merging

documents, 168

fields, 168

subdocuments, 162-163
table cells, 218-219
metadata, documents, 94-96
Mini Toolbar, applying, 50-51
modes
Compatibility Mode, 17
Overstrike mode, 28
modifying. See also formatting
charts, 285
colors in pages, 126-127
columns
spacing, 197-199
width, 214-215
default fonts, 52
Excel worksheets, 227
footers, 89
headers, 89
line spacing, 61
margins, 81-82
orientation, 82
shapes, 252-253
spelling options, 262-263
styles
diagrams, 253
shapes, 239
tables
dimensions, 215-216
row height, 215
sizing, 212-213
text
aligning, 54
case, 32
tracking changes, 113
tracking options, 292-293
user names, 293-294
mouse pointers, 9
moving. See also copying
levels, 154—155
notes, 130
objects, 241-242
QAT (Quick Access Toolbar), 312-313
subdocuments, 162
tables, 216-217
tabs, 59-60
text, 37-42
multilevel lists, creating, 164-165
multiple columns, formatting, 194
multiple subdocuments, selecting, 162

321



N rotating, 243
SmartArt, 247-255

reorganizing, 152-155
viewing, 150-153

nan;m.lgd' o stacking, 246 Outline view, 114-115
f‘ulld ing blocks, 279 0dd Page section break, 79 Overstrike mode, 28
fT s, 171 Office applications, 283-287
! eSle%, 15 Open button, 17
modifying user names, 293-294 . P
opening
tabs, 314
o attachments, 112 pages
navigating dialog boxes, 7 adding

AutoCorrect, 30-32
Backstage view, 11-12
comments, 298-299
documents, 24-27
fields, 171

documents, 4

documents marked as final, 98

existing files, 16-17
operators, mathematical, 222
options. See also customizing

borders, 127-128

numbering, 90-91

table of authorities, 141-142
applying, 124-128

Full Screen Reading view, 111 columns, 190-192

Advanced Word, 310-311 ;
Windows menu bar, 4-8 L forme.lttl'ng )
L aligning, 245 bibliographies, 136-140
Navigation pane, 121 .
dialog boxes, 7 breaks, 78
New Address List dialog box, 170 . '
Display, 307 endnotes, 129-130

New Label button, 133

envelopes, 182 _
newsletters, 192. See also columns P footnotes, 129-130

extending search, 266-267 generating cross references, 142-143

files, 99 indexing content, 142-145
formatting, 31, 79

General, 306-307
line spacing, 61
margins, 81-82
multilevel lists, 164

newspaper-style columns, 190

Next Page section break, 79
layouts. See layouts

modifying colors, 126-127
numbering, 79

selecting orientation, 82

Table of Contents (TOC), 131-133

noncontiguous areas, selecting, 30
non-printing symbols, viewing, 43
notes

converting, 130

copying, 130 .
: pasting, 41 table of figures, 135-136
formatting, 129-130. See also endnotes; . o o
footnotes Picture Effects, 233 viewing, 117. See also viewing

moving, 130 printing, 12 watermarks, 125-126
numbered lists, 64-65 proofing, 307-309 paper
numbering Recent Options, 12 orientation, 79

adding, 90-91 Save, 303-310 size, 79, 82-83

spelling, 262-263 sources, 79

automatic, 282-283

captions, 134 Text Effects, 40

views, 113

Paragraph dialog box, 7
paragraphs

indexes, 143
lines, 79, 8385 WC?rd, .306—311 adding borders, 54-55
pages, 79 or.gamza.tlon charts, 250 formatting, 53-62
orientation modifying line spacing, 61-62
modifying, 82 styles, 69
[0 selecting, 82 passwords, assigning to documents,
) . outlines 100-101
Ob'Ject dialog box, 225, 284 applying, 147-165 Paste Options button, 39
°bJeCFS ' applying master documents, 155-163 Paste Special dialog box, 38
ahgn%ng, 244 formatting pasting
deleting, 242 body text, 149-150 options, 41
flipping, 244

grouping, 246-247
managing, 241-247
moving, 241-242
resizing, 242
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multilevel lists, 164-165
standard, 148—155
generating headings, 148-149

text without formatting, 38
patterns, 56

personal information, inspecting docu-

ments for, 94-96
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Picture Effects option, 233
pictures, 229. See also graphics

adding, 230-235

adjustments, 231-232

cropping, 234-235

deleting, 230

figure captions, 133-134

placing, 230

styles, 233-234

viewing, 110

wrapping text around, 235
Picture Tools, 231-235
placeholders

dates, 124

equations, 36

fields, 283

text, 87

viewing watermarks, 125-126
placing

document properties, 280281

pictures, 230
points, sizing fonts, 47
postage, electronic services, 182
POSTNET bar codes, adding, 183

PowerPoint presentations, adding,
285-286

predefined equations, applying, 34
predefined shapes, selecting, 238
previewing

fields, 175-177

files, 20-21

Live Preview, 206

printing, 103
printing, 179

documents, 104

formatting labels, 185-186

form letters, 177

generating envelopes, 180-184

markup, 296

previewing, 103

security, 93, 94-102

sharing, 103-105
Print Layout view, 110
Print Settings section, 104
Process diagram type, 247
promoting

headings, 153

organization charts, 250
proofing options, 307-309
properties, placing documents, 280-281

Protected View, 101-102
Pyramid diagram type, 248

Q

QAT (Quick Access Toolbar), 5
adding, 312-313

quality tools, 259

Quick Access Toolbar. See QAT

Quick Parts, adding, 88

Quick Styles, applying, 67-69

Quick Tables, formatting, 211-212

R

readability statistics, 263
rearranging subdocuments, 161-162
Recent Options, 12
recipients, selecting form letters, 172
Relationship diagram type, 248
renaming
fields, 171
files, 18-19
reorganizing outlines, 152-155
Repeat button, 42
Replace All command, 271
Replace command, 269-271
Reset Picture button, 232
resizing
columns, 214-215
cropping pictures, 234-235
objects, 242
windows, 119
restricting changes in document format-
ting, 96-97
Reveal Formatting, 74-75
Reviewers submenu, 295
reviewing
comments, 298-299
tracking changes, 296

revisions. See editing; modifying; tracking
changes

Ribbon, 4, 5, 6
customizing, 314-315
Excel worksheets, 224
Outlining tab, 148
switching between status bars, 11
templates, 305
right tab, 58
rotating objects, 243

rows, 198. See also columns
adding, 206
deleting, 206
modifying table height, 215
rulers, 9
viewing, 10
running Spelling and Grammar check,
261-262

S

Save As dialog box, 15
Save command, 42
Save options, 309-310
Save & Send screen, 105
saving
building blocks, 279
equations, 36
files, 13-15
table styles, 211
templates, 304-305
screens
Full Screen Reading view, 111-113
jumping to, 112
screen shots, adding, 240-241
scroll bars, applying, 25
searching. See also finding
bookmarks, 275
extending search options, 266—267
special characters, 269
sections
breaks
applying, 79-80
columns, 191
Print Settings, 104
Spacing, 62
security, printing, 93, 94-102
Select Data Source dialog box, 169
selecting
commands with keyboards, 10
cover page designs, 125
data sources, 169-171
fonts, 46-47
form letter recipients, 172
functions, 225
greeting lines, 174
label sizes, 185
multiple subdocuments, 162
orientation, 82
predefined shapes, 238
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Quick Table styles, 211
shapes, 253
tables
areas, 217-218
table of authorities, 142
text, 28-30, 40, 46-53
workbooks, 285
sending
documents via e-mail, 104—-105
form letters, 177
separating columns, lines, 200-201
services, electronic postage, 182
shading text, 55-56
shapes
applying, 237-239
diagrams
adding, 250-252
deleting, 248
modifying, 252-253
selecting, 253
Shapes button, 8
sharing printing, 103-105
shortcuts
formatting, 48
keyboards, 26
showing characters, 78. See also viewing
Show Markup list, 294
single envelopes, generating, 180-184
sizing
columns, 196-197
cropping pictures, 234-235
fonts, 47
formatting paper size, 79, 82-83
labels, 185
modifying tables, 212-213
text, 112
windows, 119
slideshows, adding, 285-286
SmartArt, 247-255
formatting, 248
layouts, 252
SmartTags. See Actions
sources
adding to bibliographies, 138
selecting data, 169-171
spacing in columns, modifying, 197-199
Spacing section, 62
special characters, finding, 269
Special Characters tab, 33
special symbols, adding, 32-33
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specifying
data for Mail Merge, 169-172
hyperlinks, 275-276
speed, tools for, 273
spelling
checking, 260-261
options
modifying, 262-263
proofing, 307-309

running Spelling and Grammar check,
261-262

splitting

subdocuments, 163

table cells, 219
split windows, viewing, 118-119
stacking objects, 246
Stamps.com, 182
standard outlines, formatting, 148-155
starting Word, 4
statistics, viewing documents, 263
status bars, 8

switching between Ribbon and, 11

stopping unwanted formatting changes, 96

Style Inspector, 74
styles
applying, 67-75
pictures, 233-234
Quick Styles, 67-69
citations, 137
customizing, 70-71
deleting, 72-73
footers, 86
footnotes, 129
headers, 86
managing, 70-71
modifying diagrams, 253
restricting, 96
Reveal Formatting, 74-75
saving, 211
shapes, 238
table of authorities, 141-142
Table of Contents (TOC), 131-133
tables, 220-221
Styles task pane, applying, 69-70
subdocuments. See also documents
adding, 159-160
applying, 156-163
collapsing, 160-161
deleting, 163
expanding, 160-161

formatting, 157-159
headings, 159
merging, 162-163
rearranging, 161-162
splitting, 163
viewing, 158
supplementary elements, adding, 123

switching between status bars and
Ribbon, 11

symbols

adding, 32-33

viewing non-printing, 43
synonyms, thesaurus, 264

T

Tab button, 58-61
tables, 205
adding
documents, 225-227
table of authorities, 141-142
Table of Contents (TOC), 131-133
table of figures, 135-136
table of tables, 135
cells
merging, 218-219
splitting, 219
converting, 209-210
design, 220-221
entering text, 208
formatting, 206—207
formulas, 222-224
Quick Tables, 211-212
layouts, 212-219
modifying, 212-213
dimensions, 215-216
rows, 215
moving, 216-217
saving styles, 211
selecting areas, 217-218
tabs, 6
applying, 58-61
deleting, 60
file, 5
moving, 59-60
naming, 314
Outlining, 148
Special Characters, 33
Tabs dialog box, applying, 60-61
templates
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customizing, 304-306
saving, 304-305
text. See also documents
adding, 27-28
colors, 48—49
diagrams, 249
effects, 50
aligning, 53-54
attributes, 46-53
case, 32
copying, 37-42
editing, 27-36
entering into tables, 208
finding, 265
formatting, 267-269
generating with building blocks, 276-279
highlighting, 49
indenting, 56-58
moving, 37-42, 154-155
paragraphs, 53-62
placeholders, 87
selecting, 28-30, 40
shading, 55-56
sizing, 112
subdocuments, 158
wrapping, 208, 235
Text Effects options, 40
themes
applying, 66-67
tables, 220-221
thesaurus, 264
title bars, 5
toolbars
Mini Toolbar, 50-51
QAT (Quick Access Toolbar), 5, 312-313
tools
automatic fields, 280-283
bookmarks, 274-275
correcting errors, 260-263
Equations Tools > Design tab, 35
Find command, 265-266

generating text with building blocks,
276-279

Header & Footer Tools, 87
Picture Tools, 231-235

quality, 259

Replace command, 269-271
specifying hyperlinks, 275-276
for speed, 273

thesaurus, 264

tracking changes. See tracking changes
tracking changes, 113, 290-291

modifying

options, 292-293
user names, 293-294

reviewing, 296

turning on Track Changes, 291-292

viewing, 294-296
turning on Track Changes, 291-292
types

of building blocks, 277

of diagrams, 247

of files, 14

of fonts, 46

of notes, 130

of section breaks, 79
typing

allowing, 113

in columns, 193

U

Underline button, 48

Undo button, 42-43

unique file names, 15

unwanted characters, deleting, 28
updating bibliographies, 140

user names, modifying, 293-294

|4

vertical alignment, formatting, 79
viewing
calculations, 224
controls, 9
documents, 110-116
properties, 280-281
statistics, 263
form letters, 176
headers, 89
non-printing symbols, 43
outlines, 150-153
printing files, 12
Reveal Formatting, 74-75
rulers, 10
split windows, 118-119
subdocuments, 158

tracking changes, 294-296

watermarks, 125-126

Zoom feature, 116-118
View Options menu, 113
views, 109, 110-116

Backstage, 11-12

Draft, 115-116

Full Screen Reading, 111-113

Outline, 114-115

Print Layout, 110

Protected, 101-102

Web Layout, 114

w

watermarks, viewing, 125-126
Web Layout view, 114
Web sites, specifying hyperlinks, 275-276
white space, balancing, 77. See also layouts
width
formatting columns, 196. See also sizing
modifying columns, 214-215
windows
Available Templates, 15
File Information, 11
resizing, 119
viewing split, 118-119
Windows menu bar, navigating, 4-8
Word. See also documents; files
adding files, 283-284
customizing. See customizing
options, 306-311
starting, 4
Word Options dialog box, 30, 307
words
adding to dictionaries, 260
thesaurus, 264
word wrap, 193
workbooks, selecting, 285
worksheets, 227. See also Excel

CSV (comma-separated value) documents,
169

wrapping text, 208

VA

Zoom feature, 116-118
zooming, 103
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